Nya hårddiskar syns inte i diskhanteraren

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Nya hårddiskar syns inte i diskhanteraren

Hej,
Jag försöker byta ut tre ssd i RAID5 (Intel 320 80 GB) mot 3 större ssd (Crucial M500 240GB), men det går inget vidare. Jag tänkte först lägga till de nya, skapa en RAID5-konfiguration med dessa, klona den gamla RAID-disken på den nya och sedan plocka bort den gamla. Problemet är att diskarna inte syns i Diskhanteraren, så de går inte att initiera, vilket jag antar att man måste göra innan man kan RAIDa dem. Jag har testat med SATA-kablar och strömförsörjning som jag vet fungerar (jag tog kablar från en annan hårddisk), men det funkar inte i alla fall. Det är heller inget fel på de nya kablarna - de funkar med andra hårddiskar. Byter jag däremot SATA-port med en fungerande hårddisk syns båda i diskhanteraren och det går att initiera disken. Hårddisk 1 (Seagate Barracuda 1TB) funkar alltså i port 1 och 7, men en av de nya funkar bara i port 7. Hur kan det bli så? Port 8 funkar inte heller. Port 2, 5 och 6 är upptagna av RAID-diskarna och dessa går inte att flytta, vad jag har hört. Jag gissar att det beror på att positionen i RAIDen är kopplad till porten och inte till disken. Det finns alltså lediga portar till alla nya diskar, men jag får bara en av dem att fungera, trots att de funkar med andra diskar. Vad kan det bero på? Alla tips mottages tacksamt.

Moderkortet syns i signaturen.

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Avstängd
Plats
Stockholm
Registrerad
Jun 2003

Ursäkta, vill inte verka gnällig men det är rätt svårt att läsa vad du skriver

Det första du bör göra är att se om dina nya diskar dyker upp i BIOS/UEFI. Gör dem inte det är de ju döda och du bör lämna tillbaka dem.

Om det är en mjukvaruraid i Windows du kör så kan du faktiskt flytta dina diskar, inte bara mellan portar utan även mellan fysiska maskiner och allt kommer finnas kvar. Är det chipsetraid kan du allt som oftast flytta den så länge det är samma chipset.

Trädvy Permalänk
Medlem
Plats
STHLM
Registrerad
Apr 2008
Skrivet av HåkanH:

Alla tips mottages tacksamt.

Jag misstänker att eftersom du hänvisar till signatur och där står det att du hart Windows 7 64-bit vilket inte stödjer RAID5 via OS så har du alltså RAID5 på moderkortets styrkrets, dessa misstänker jag klarar bara 4 enheter så länge BIOS är i läge RAID. Det kan vara anledningen, är dock inte så bra på AMDs moderkort och styrkretsar. Det är min gissning.

There are two kinds of people: 1. Those that can extrapolate from incomplete data.
Min tråkiga hemsida om mitt bygge och lite annat smått o gott: www.2x3m4u.net

Trädvy Permalänk
Avstängd
Plats
Åbo, Finland
Registrerad
Feb 2004

Du får en free bump, den där wall of text critta mig ganska hårt nämligen, så läsa orkar jag inte
Pro tip: Styckeindelning

Chassi: Coolermaster HAF XB PSU: Silverstone Strider 850W, MB: MSI Z87-G45, CPU: Intel I5-4670K @ 4,2Ghz (Corsair H100i), GPU: MSI GTX 970 Gaming RAM: Kingston HyperX 16Gb DDR3 1600Mhz, HDD: 2x Samsung F3 7200rpm 1TB, SSD: Samsung 830 series 128Gb, OS: Win 8.1, Skärmar: LG 55" FullHD & Dell 23'' UltraSharp U2312HM.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

Om du använder en hårvaruraid så kan du göra på följande 2 sätt för att byta dina diskar; Koppla in en stor disk som tar backup på utnyttjat utrymme eller så byter du ut en disk i taget, då kommer hårvaruraiden att återskapa innehållet automatiskt, du kommer att behöva göra detta tre gånger eftersom du har tre diskar.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 18.3 Cinnamon

Trädvy Permalänk
Medlem
Plats
Framför datorn
Registrerad
Nov 2013
Skrivet av Dr.Mabuse:

Jag misstänker att eftersom du hänvisar till signatur och där står det att du hart Windows 7 64-bit vilket inte stödjer RAID5 via OS så har du alltså RAID5 på moderkortets styrkrets, dessa misstänker jag klarar bara 4 enheter så länge BIOS är i läge RAID. Det kan vara anledningen, är dock inte så bra på AMDs moderkort och styrkretsar. Det är min gissning.

En skrev så här på annat forum

Citat:

I could be wrong but i think windows 7 home premium does not support RAID 5... for hardware supported RAID 5 i think you need enterprise or ultimate and for software RAID 5 (striped) you need a server version.

Det verkar vara Home versionen som inte har stöd för RAID5 men Ultimate och Enterprise (tror han i alla fall)

Coca Cola missbrukare
AMD älskare
Katt älskare

Trädvy Permalänk
Medlem
Plats
STHLM
Registrerad
Apr 2008
Skrivet av AMD-FX:

Det verkar vara Home versionen som inte har stöd för RAID5 men Ultimate och Enterprise (tror han i alla fall)

Det är bara serverversionerna som har stöd för RAID5 via OS. Windows 7 stödjer Spanned (JBOD), Striped (RAID0), och Mirrored (RAID1).

There are two kinds of people: 1. Those that can extrapolate from incomplete data.
Min tråkiga hemsida om mitt bygge och lite annat smått o gott: www.2x3m4u.net

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av Dr.Mabuse:

Jag misstänker att eftersom du hänvisar till signatur och där står det att du hart Windows 7 64-bit vilket inte stödjer RAID5 via OS så har du alltså RAID5 på moderkortets styrkrets, dessa misstänker jag klarar bara 4 enheter så länge BIOS är i läge RAID. Det kan vara anledningen, är dock inte så bra på AMDs moderkort och styrkretsar. Det är min gissning.

Du gissar rätt, jag använder moderkortets RAID controller, men enligt manualen ska den klara av fler än 4 diskar i en RAID konfiguration. Det krävs bara att man ändrar lite i BIOS, vilket jag har gjort. Det skumma är att jag har lyckats göra en RAID-disk av de tre nya Crucial-diskarna i "AMD Option ROM Utility" som man når under POST. Där har jag nu två logiska diskar, men den nya syns fortfarande inte någonstans i Windows (Datorn, Diskhanteraren, Enhetshanteraren). Är det något jag missar här?

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Medlem
Registrerad
Feb 2006

Syns dom inte här heller:
Control Panel\System and Security\Administrative Tools

Sen väljer du "Computer Management" -> "Storage" -> "Disk Management"

MSI z87 MPOWER | Intel i7 4770K | Corsair H100i | Asus GTX 970 Strix | 2+1TB Samsung Spinpoint | 120GB Corsair Force GT SSD | 120GB Kingston SSD | NZXT H440 | Corsair CX 750W | Corsair 8GB 2133MHz DDR3 | Windows7 Ultimate 64-bits | Asus Swift PG278Q

MacBook Pro 15.4" Retina | i7 2.3GHz | 8 GB 1600 MHz | 256 GB SSD

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av kwame:

Syns dom inte här heller:
Control Panel\System and Security\Administrative Tools

Sen väljer du "Computer Management" -> "Storage" -> "Disk Management"

Nej, precis. Det är där man förväntar sig att hitta nya diskar. Men ingenting nu.

Skickades från m.sweclockers.com

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Medlem
Plats
Scania-Earth-Milky way
Registrerad
Nov 2001
Skrivet av HåkanH:

Nej, precis. Det är där man förväntar sig att hitta nya diskar. Men ingenting nu.

Skickades från m.sweclockers.com

Många kikar bara upptil där partitioner listas.

Listan nedanför som grafiskt visar enheterna missar de att scrolla neråt där nya enheterna visas.

Detta är knappast fallet här då raidvolymen inte visas i enhetshanteraren. Har man lyckats få till en raid5:a ligger man dessutom långt över genomsnittsanvändaren som glömmer att scrolla neråt i diskhanteraren.

Vägra fx 3of4 Pi 1M 1.84 s Memory remapping
Minnen har ingen egen hastighet. Märkningen anger bara vilken hastighet minnena uppges klara

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av Hardware guy:

Många kikar bara upptil där partitioner listas.

Listan nedanför som grafiskt visar enheterna missar de att scrolla neråt där nya enheterna visas.

Detta är knappast fallet här då raidvolymen inte visas i enhetshanteraren. Har man lyckats få till en raid5:a ligger man dessutom långt över genomsnittsanvändaren som glömmer att scrolla neråt i diskhanteraren.

Allt syns - jag har en stor skärm Det märkliga är att min nya RAID-volym syns i BIOS. Den finns med i Boot-listan och jag kan välja att boota från den. Men jag kommer inte åt att lägga något på den! Vad kan det bero på??

Efter lite omflyttande har jag sett att två SATA-portar faktiskt fungerar, 7 och 8. Dessa har en annan controller: Asmedia 106x SATA Controller. De andra kallas bara ATA Chanell 0 resp. 1. Jag undrar om det ändå inte finns några begränsningar, trots att det inte står så i manualen.

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Avstängd
Plats
Stockholm
Registrerad
Jun 2003

Skulle precis skriva det. Ofta har man x antal sata portar och y sata per kontroller.
Låter helt enkelt som att du saknar drivrutiner för något.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av Damodred:

Skulle precis skriva det. Ofta har man x antal sata portar och y sata per kontroller.
Låter helt enkelt som att du saknar drivrutiner för något.

OK. Kan jag göra något åt det?

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Avstängd
Plats
Stockholm
Registrerad
Jun 2003

Asus har väl något uppdateringsprogram, antar jag.
Direktlänk, hoppas den funkar

http://www.asus.com/Motherboards/CROSSHAIR_V_FORMULAZ/HelpDes...

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av Damodred:

Asus har väl något uppdateringsprogram, antar jag.
Direktlänk, hoppas den funkar

http://www.asus.com/Motherboards/CROSSHAIR_V_FORMULAZ/HelpDes...

Tack. Jag flashade BIOS och uppdaterade några drivrutiner, tyvärr utan effekt.

Skrivet av OldComputer:

Om du använder en hårvaruraid så kan du göra på följande 2 sätt för att byta dina diskar; Koppla in en stor disk som tar backup på utnyttjat utrymme eller så byter du ut en disk i taget, då kommer hårvaruraiden att återskapa innehållet automatiskt, du kommer att behöva göra detta tre gånger eftersom du har tre diskar.

Tack för tipsen. Tips 1: Jag klonade RAID-disken till en av de nya (kopplad till port 7, som Windows kan se. Tyvärr verkar det inte gå att köra RAID på 7:an och 8:an, de syns inte i moderkortets RAIDprogram). Plockade sen bort de gamla RAID-diskarna och en annan disk och kopplade in de andra två nya. De syns fortfarande inte i Windows. Hade det funkat kunde jag ha lagt dem i RAID 1, klonat den andra disken och migrerat från RAID 1 till RAID 5 (tror det ska gå med RAIDXpert). Det var min plan, men det sket sig alltså av okänd anledning. Kanske måste man radera RAIDen först för att det ska funka, men jag vågar inte göra det innan allt är klart.

Tips 2: Tänker jag pröva nu, men jag misstänker att jag inte kommer att kunna utnyttja de nya diskarna till fullo. Den nya storleken borde bli exakt samma som den gamla när man byter ut diskarna en och en i en existerande RAID. Vad jag hoppas är att när alla byten är klara ska det gå att utvidga partitionen i Windows diskhanterare.

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av OldComputer:

Om du använder en hårvaruraid så kan du göra på följande 2 sätt för att byta dina diskar; Koppla in en stor disk som tar backup på utnyttjat utrymme eller så byter du ut en disk i taget, då kommer hårvaruraiden att återskapa innehållet automatiskt, du kommer att behöva göra detta tre gånger eftersom du har tre diskar.

Tips 2 funkade inte heller tyvärr. När jag plockar bort en disk ur RAIDen och ansluter en av de nya till samma kabel (eller någon annan) hittas inte de nya diskarna. Detta är lite alarmerande eftersom det är det jag skulle göra om en av diskarna kraschade. När jag kopplar in den disk som satt i RAIDen från början, hittar den den och det går att återställa volymen. Jag använder RAIDXpert.

Men VARFÖR går det inte att ansluta några diskar till en port där det har suttit något tidigare??? Jag blir galen! Ska jag behöva köpa ett raidkort bara för att byta diskar?

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2002

Dumpa över alla data på ett annat ställe
ryck diskarna
in med dem nya
flytta tillbaka.

tada

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av Danne:

Dumpa över alla data på ett annat ställe
ryck diskarna
in med dem nya
flytta tillbaka.

tada

Jag har redan testat det. Funkar inte. Windows hittar inte de nya diskarna. Möjligen skulle det funka om jag också raderade RAIDen. Den ligger nämligen kvar i programmet som skapade den, trots att diskarna är borta. Men då gäller det att allt funkar. Det blir svårt att få tillbaka några data när RAIDen är raderad.

Skickades från m.sweclockers.com

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Medlem
Plats
Skåne
Registrerad
Jun 2002

Det var det jag syftade på....
Du får ju tanka över datan som sagt, ta bort raiden.
Koppla in dem nya diskarna, skapa ny raid på dem.
och sedan tillbaka med datan.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av Danne:

Det var det jag syftade på....
Du får ju tanka över datan som sagt, ta bort raiden.
Koppla in dem nya diskarna, skapa ny raid på dem.
och sedan tillbaka med datan.

Det låter ju enkelt, men det funkade tyvärr inte. Windows startar inte ens med SATA-inställningarna på RAID i BIOS. Den startar däremot med inställningarna på AHCI, men då kan man ju inte skapa någon RAID-disk. Med inställningarna på RAID öppnas systemåterställningsfönstret, och man får felmeddelandet "Hittar ingen disk." I kommandotolken hittar man inte heller någon annan drive än X:\ (nån typ av nöd-boot-drive).

Det jag gjorde var att jag klonade raid-disken till en av mina nya diskar. RAID-disken hade jag som systemdisk (borde jag kanske varit tydligare med för att underlätta felsökning). Sen plockade jag bort de gamla diskarna. Jag tog inte bort RAID-disken omedelbart, utan lät den ligga kvar. Några dar senare hade den dock försvunnit av sig själv (!). Kan problemen kanske bero på att raiden inte är ordentligt avinstallerad? Hur gör man i så fall det när den inte syns någonstans? Registret är rensat med CC-cleaner. Med den klonade disken går det iaf att köra datorn utan några som helst problem, så länge som dess port är inställd på AHCI. Och alla diskar syns, vilket de inte gjorde förut.

Grundproblemet är alltså: Windows hittar inte mina diskar när portarna är konfigurerade för RAID. Hur löser man det?

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013

Det är något som inte stämmer här, är din raid verkligen en hårdvaru-raid? Dessutom skulle man behöva veta EXAKT vilka portar som samtliga diskar är kopplade mot samt vilken kontroller dom har och hur det ser ut i Windows diskhanterare.

Om diskarna inte hittas när du installerar Windows i RAID-läge så beror det på att det behövs drivrutiner vilket du får om du klickar på läs in drivrutiner när du installerar Windows och dom drivrutinerna ska finnas på moderkortets CD-skiva/hemsida. Men det antog jag du redan hade koll på.

En möjlighet att fixa detta är att starta från Windows installationsskiva när diskarna är i RAID-läge och antigen välja att reparera eller att installera Windows på nytt och i så fall installera på samma partition utan att formatera och att välja att behålla den gamla Windowsinstallationen sedan tar man och kopierar ut allt man behöver till en annan partion och sedan kan man göra en ren installation av Windows på nytt.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 18.3 Cinnamon

Trädvy Permalänk
Medlem
Registrerad
Jan 2012
Skrivet av OldComputer:

Det är något som inte stämmer här, är din raid verkligen en hårdvaru-raid? Dessutom skulle man behöva veta EXAKT vilka portar som samtliga diskar är kopplade mot samt vilken kontroller dom har och hur det ser ut i Windows diskhanterare.

Om diskarna inte hittas när du installerar Windows i RAID-läge så beror det på att det behövs drivrutiner vilket du får om du klickar på läs in drivrutiner när du installerar Windows och dom drivrutinerna ska finnas på moderkortets CD-skiva/hemsida. Men det antog jag du redan hade koll på.

En möjlighet att fixa detta är att starta från Windows installationsskiva när diskarna är i RAID-läge och antigen välja att reparera eller att installera Windows på nytt och i så fall installera på samma partition utan att formatera och att välja att behålla den gamla Windowsinstallationen sedan tar man och kopierar ut allt man behöver till en annan partion och sedan kan man göra en ren installation av Windows på nytt.

Tack, jag ska fundera på det. Nu åker jag bort i några dar.

AMD FX-8350 @ 4,2 GHz, ASUS Crosshair V Formula-Z, Radeon HD7970 3 Gb, Kingston 1333 MHz 4x4 Gb, 4 x Intel 525 240Gb SSD i RAID 10 och 1 Seagate Constellation 3 1 Tb, Thermalright Silver Arrow, Cooler Master Miditower 690 II Advance, Corsair TX650W, Win 10 64