[Linux] Byter ip adress fast static

Permalänk
Avstängd

[Linux] Byter ip adress fast static

Tjo,

Har haft igång VM i flera år utan några problem men tills föra veckan då börja den byta ip adress fast den är static.

Så jag har fått starta om VM vare gång detta händer, det kan väl inte vara dhcp server som har fått ett utbrott?

NAME="Ubuntu" VERSION="18.04.4 LTS (Bionic Beaver)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04.4 LTS" VERSION_ID="18.04" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-polic..." VERSION_CODENAME=bionic UBUNTU_CODENAME=bionic

Permalänk
Medlem

Nu vet jag inte exakt hur det fungerar eller hur ditt nätverk ser ut, men kan det vara så dumt så att det är en annan enhet på nätverket som har fått tilldelat sig exakt den IP som din VM begär? Är IPn reserverad i DHCP-servern?

Permalänk
Medlem

var/hur har du satt adressen statisk?

Permalänk
Avstängd
Skrivet av Chmat76:

Nu vet jag inte exakt hur det fungerar eller hur ditt nätverk ser ut, men kan det vara så dumt så att det är en annan enhet på nätverket som har fått tilldelat sig exakt den IP som din VM begär? Är IPn reserverad i DHCP-servern?

Ingen av mina andra VM har samma ip adress, det ända som jag har gjort är att installera Win11 på en VM med den har ett annat ip adress, har inte gjort något med mitt system på minst 1-2 år.

Har inte reserverad det på DHCP-server fick problem med att sätta static så jag skit i det, använder pfsense till det jobbet.

Permalänk
Avstängd
Skrivet av Hothep:

var/hur har du satt adressen statisk?

/etc/network/interfaces

# ifupdown has been replaced by netplan(5) on this system. See # /etc/netplan for current configuration. # To re-enable ifupdown on this system, you can run: # sudo apt install ifupdown source /etc/network/interfaces.d/* # The loopback network interface auto lo iface lo inet loopback # The primary network interface auto ens160 iface ens160 inet static address 192.168.0.240 netmask 255.255.255.0 gateway 192.168.0.1 dns-nameservers 8.8.8.8 8.8.4.4 up route add 192.168.0.1 dev ens160 up route add default gw 192.168.0.1 auto ens192 iface ens192 inet static address 10.6.0.100 netmask 255.255.255.0 gateway 10.6.0.1 mtu 9000

Permalänk
Medlem

# ifupdown has been replaced by netplan(5) on this system. See
# /etc/netplan for current configuration.

kanske?

Permalänk
Avstängd
Skrivet av Hothep:

# ifupdown has been replaced by netplan(5) on this system. See
# /etc/netplan for current configuration.

kanske?

Går att använda den gamla, det funkar ju på mina andra 15 VM.

Permalänk
Medlem

"skräp" i /etc/network/interfaces.d/ ?
Den "nya" adressen, är det en från en dhcp-server?

Permalänk
Medlem

Är det internt ip som har ändrats eller pratar vi om externt ip?
Är inte helt insatt i nätverk eller hur ISP hanterar det men
Om det är internt ip berörs det av nätverket hur routern har ändrats.
Är det det externt ip så beror det på belåning av ip och finns det behov att ändras så kan det säkerligen bli tvingat att ändras.

I regel om MAC address ändras så tvingas det att förnyas.

Permalänk
Avstängd
Skrivet av Hothep:

"skräp" i /etc/network/interfaces.d/ ?
Den "nya" adressen, är det en från en dhcp-server?

Tomt där, ja det skulle jag kunna tänka mig att det är från dhcp-server, men det känns som det bugar system för just då kunde jag inte ens skriva "dh -h" utan bara laddar men det funkar efter omstart.

Skrivet av 47:an:

Är det internt ip som har ändrats eller pratar vi om externt ip?
Är inte helt insatt i nätverk eller hur ISP hanterar det men
Om det är internt ip berörs det av nätverket hur routern har ändrats.
Är det det externt ip så beror det på belåning av ip och finns det behov att ändras så kan det säkerligen bli tvingat att ändras.

I regel om MAC address ändras så tvingas det att förnyas.

Lan ip adress, har 5 st publik ip adresser så det är inga problem med.

Känns som det är något fel i OS då visa command inte funkar men funkar efter omstart.

Permalänk
Medlem

Har samma problem sedan någon vecka med Telia 1000/1000, räcker att jag startar om boxen så tar det en bra stund tills den får en ny ip address, aldrig varit såhär tiidagare heller. Har datorn inkopplad direkt i fiberkonverten så du är inte ensam.

Permalänk
Rekordmedlem
Skrivet av wuseman:

Har samma problem sedan någon vecka med Telia 1000/1000, räcker att jag startar om boxen så tar det en bra stund tills den får en ny ip address, aldrig varit såhär tiidagare heller. Har datorn inkopplad direkt i fiberkonverten så du är inte ensam.

Telia tilldelar dig ip via dhcp och det är dessutom publikt ip det handlar om, har du alltså satt ett statiskt publikt ip i datorn ? Det är en dålig ide eftersom du varken äger ipnummret eller kan köpa tjänsten att få ett icke dynamiskt ip om du inte har företagsabonnemang hos Telia.

Permalänk
Medlem
Skrivet av superegg:

Tomt där, ja det skulle jag kunna tänka mig att det är från dhcp-server, men det känns som det bugar system för just då kunde jag inte ens skriva "dh -h" utan bara laddar men det funkar efter omstart.

Lan ip adress, har 5 st publik ip adresser så det är inga problem med.

Känns som det är något fel i OS då visa command inte funkar men funkar efter omstart.

Jag hade först kollat vad det är för adress du får när den statiska lossnar. Är det en från din DHCP-server eller en IPv4LL-adress (169.254.x.x) eller är det något annat "spännande" kanske?

Har du stökat runt i dhclient.conf? Du behöver ingen dhcp-klient om du använder statiska adresser.

https://datatracker.ietf.org/doc/html/rfc3927 Om du vill läsa om IPv4LL ( jag menar, vem gillar inte att läsa rfc:er....? )