Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Okt 2001

gentoo 2005.* bug?

Det är så att min dator brann...
Så nu har jag skaffat en "ny" med spec.
athlon xp 1900+
microstar-6380v3
512ddr
Realtek rtl8139
gentoo-sources-2.6.12-senaste
Eftersom min förra processor brann så ville jag göra om min stage 1 installation av gentoo så den bli optimerad mot athlon xp.

Så jag laddar hem gentoo 2005.1 livecdn, när jag laddar den så säger den att den får en adress från dhcp(sitter på en adsl modem och en router), men enligt ifconfig eth0 så har jag inte blivit tilldelad någon adress.

Det kanske inte är så konstigt....... det konstiga börjar när jag kör livecdn 2004.2, då fungerar nätverket hur bra som helst.

Så jag tänkte att jag skulle vara smart och "installera" med 2004.2 men använda mig av 2005.1 stage 1 profilen och senaste portage.

Allt går som fint till jag ska reboota för att boota från hd, då fungerar inte netmount alls. Har försökt att confa /etc/conf.d/net efter konstens alla regler(ja, emergade dhcpcd medans nätverket fungerade och /etc/init.d/net.eth0 är rc-update till default runlevel.
Jag är 100% säker på att rätt modul är laddad för eth0(testade att kompilera in den i körnan och ha den som modul).
Kan inte ping'a routern, network is unreachble blir det.

Är det någon som har upplevt samma problem och har en lösning på det?

Powered by Gentoo

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Mar 2003

Har du testat net-setup eth0?

Trädvy Permalänk
Medlem
Registrerad
Okt 2004

lspci och dmesg, vad säger dom?
Gissar att du kört dhcpcd eth0 också...

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Okt 2001
Citat:

Ursprungligen inskrivet av ErikHK
lspci och dmesg, vad säger dom?
Gissar att du kört dhcpcd eth0 också...

Ja, har testat att sätta net-setup, blir ingen skillnad, testat även att sätta ip, närmask o gateway manuelt.

dmesg | grep eth0 och lspci hittar Realtek kortet.

Trodde först att det skulle vara något hårdvarukonflikt med microstar kortet, för när jag kör in 2005.1 liveskivan i servern så hittar den nätverket hur bra som helst. Men eftersom nätverket fungerar med gamla liveskivan så måste dom ju gjort något sepe med 2005.*

Powered by Gentoo

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001

Om du inte ska installera färdiga paket från skivan så spelar det ju ingen roll vilken version du har...

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Okt 2001
Citat:

Ursprungligen inskrivet av Sachankara
Om du into ska installera färdiga paket från skivan så spelar det ju ingen roll vilken version du har...

Näe, nog vet jag det.
Men om du läser inlägget igen så blev det ju fel när jag uppdaterade portage och world.

Men håller du inte med mig om att det är konstigt att gamla liveskivan fixar nätverket?

Powered by Gentoo

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av hex
Näe, nog vet jag det.
Men om du läser inlägget igen så blev det ju fel när jag uppdaterade portage och world.

Men håller du inte med mig om att det är konstigt att gamla liveskivan fixar nätverket?

Tja, eftersom 2005.x kör med en ny baselayout så måste du uppdatera alla config-filer med etc-update. Annars kommer det inte att fungera som det ska...

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Okt 2001
Citat:

Ursprungligen inskrivet av Sachankara
Tja, eftersom 2005.x kör med en ny baselayout så måste du uppdatera alla config-filer med etc-update. Annars kommer det inte att fungera som det ska...

Ja, när installationen är färdig ja.
Men nätverket ska ju fungera när jag stoppar i liveskivan.

Har redan grejjat med baselaout'en, testade tom att maska den senaste för att använda en lägre version, utan något resultat.

Powered by Gentoo

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Feb 2004

Är du säker på att eth0 är ditt 8139too-kort? Kan ju vara en firewire-enhet eller ett annat kort.

Hur man installerar program i *nix | There is no Swedish conspiracy

these days you can't use the Web at 2400 baud because the ads are 24KB - Bill Joy

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Okt 2001
Citat:

Ursprungligen inskrivet av Lunke
Är du säker på att eth0 är ditt 8139too-kort? Kan ju vara en firewire-enhet eller ett annat kort.

Jag är säker. Har tom testat ett annat nätverkskort(det som sitter i servern), men funkar inte.
Du är en riktig haxx0r om du kan förklara varför 2005.* skivan inte hittar nätverket men gamla 2004.2 skivor gör det, jag är stensäker på att problemet sitter där.

Jag uppskattar verkligen att ni försöker hjälpa mig.

Powered by Gentoo

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Feb 2004

Ingen aning men om nätverkskortet hittas fast dhcp inte fungar kan du ju skippa dhcp och konfigurera nätverket statiskt och på sätt få igång det.
Ungefär så här: (Du kanske behöver ändra vissa adresser)

ifconfig eth0 192.168.0.50 route add default gw 192.168.0.1 echo "nameserver 192.168.0.1" >> /etc/resolv.conf

Hur man installerar program i *nix | There is no Swedish conspiracy

these days you can't use the Web at 2400 baud because the ads are 24KB - Bill Joy

Trädvy Permalänk
Medlem
Plats
Stockholm, Täby
Registrerad
Jul 2001

Jag förstår liksom inte riktigt vad du försöker åstakomma...

Boota med 2004.2-skivan, tanka ner 2005.1-"stagen", bootstrappa om så behövs (stage 1), installera allt, kör en emerge -DuN system, uppdatera config-filerna med etc-update, konfigurera nätverket under /etc/conf.d/net , fixa eventuella services och starta om datorn...

Det är som sagt väldigt viktigt att man går igenom alla config-filer för de har både bytt plats (en del av dem) och funktionalitet i senaste baselayouten...

Förr skrev man t.ex:

iface_eth0="dhcp"

I /etc/conf.d/net, men nu ser motsvarande ut så här:

config_eth0=( "dhcp" )

Finns mer att läsa under /etc/conf.d/net.example ...

(Och glöm som sagt inte att kopiera /etc/resolv.conf till din rot innan du bootstrappar...)

P.S. Ursäkta om jag låter lite väl "upprörd", men jag har bara inte förstått vad du vill åstakomma.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Okt 2001
Citat:

Ursprungligen inskrivet av Sachankara
Jag förstår liksom inte riktigt vad du försöker åstakomma...

Boota med 2004.2-skivan, tanka ner 2005.1-"stagen", bootstrappa om så behövs (stage 1), installera allt, kör en emerge -DuN system, uppdatera config-filerna med etc-update, konfigurera nätverket under /etc/conf.d/net , fixa eventuella services och starta om datorn...

Det är som sagt väldigt viktigt att man går igenom alla config-filer för de har både bytt plats (en del av dem) och funktionalitet i senaste baselayouten...

Förr skrev man t.ex:

iface_eth0="dhcp"

I /etc/conf.d/net, men nu ser motsvarande ut så här:

config_eth0=( "dhcp" )

Finns mer att läsa under /etc/conf.d/net.example ...

(Och glöm som sagt inte att kopiera /etc/resolv.conf till din rot innan du bootstrappar...)

P.S. Ursäkta om jag låter lite väl "upprörd", men jag har bara inte förstått vad du vill åstakomma.

allt som du jar skrivit har jag gjort 2 gånger utan någon förbättring.

jag har gjort som du sa med 2004 skivan, men det fungerar inte

Powered by Gentoo