Hårdvaruacceleration med GF4 i FreeBSD

Trädvy Permalänk
Medlem
Plats
Härnösand
Registrerad
Jul 2001

Hårdvaruacceleration med GF4 i FreeBSD

Har slängt in FreeBSD på min lilla testmaskin. Verkar vara ett trevligt system.

Nu är det så att jag vill få fart på hårdvaruaccelerationen. Jag använder just nu drivrutinen nv men drivrutinen nvidia är kompilerad.
Jag har testat att ändra till nvidia men då blir det fel. X startar, stänger av sig, startar, stänger av sig osv.

Någon som har några tips?

EDIT: Nu gick den igång! Yay
Ett litet problem. Det är 8 bitars färg.

Section "ServerLayout" Identifier "X.org Configured" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard1" "CoreKeyboard" EndSection Section "Files" RgbPath "/usr/X11R6/lib/X11/rgb" ModulePath "/usr/X11R6/lib/modules" FontPath "/usr/X11R6/lib/X11/fonts/misc/" FontPath "/usr/X11R6/lib/X11/fonts/TTF/" FontPath "/usr/X11R6/lib/X11/fonts/Type1/" FontPath "/usr/X11R6/lib/X11/fonts/CID/" FontPath "/usr/X11R6/lib/X11/fonts/75dpi/" FontPath "/usr/X11R6/lib/X11/fonts/100dpi/" EndSection Section "Module" Load "bitmap" Load "extmod" Load "glx" # Load "dri" Load "dbe" Load "record" Load "xtrap" Load "type1" Load "freetype" EndSection Section "InputDevice" Identifier "Keyboard0" Driver "kbd" EndSection Section "InputDevice" Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/sysmouse" EndSection Section "InputDevice" Identifier "Keyboard1" Driver "keyboard" Option "XkbRules" "xfree86" Option "XkbModel" "pc101" Option "XkbLayout" "se" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Monitor Vendor" ModelName "Monitor Model" ### Uncomment if you don't want to default to DDC: HorizSync 30.0 - 96.0 VertRefresh 50.0 - 160.0 EndSection Section "Device" ### Available Driver options are:- ### Values: <i>: integer, <f>: float, <bool>: "True"/"False", ### <string>: "String", <freq>: "<f> Hz/kHz/MHz" ### [arg]: arg optional #Option "SWcursor" # [<bool>] #Option "HWcursor" # [<bool>] #Option "NoAccel" # [<bool>] #Option "ShadowFB" # [<bool>] #Option "UseFBDev" # [<bool>] #Option "Rotate" # [<str>] #Option "VideoKey" # <i> #Option "FlatPanel" # [<bool>] #Option "FPDither" # [<bool>] #Option "CrtcNumber" # <i> #Option "FPScale" # [<bool>] #Option "FPTweak" # <i> Identifier "Card0" Driver "nvidia" VendorName "nVidia Corporation" BoardName "NV25 [GeForce4 Ti 4200]" BusID "PCI:1:0:0" EndSection Section "Screen" Identifier "Screen0" Device "Card0" Monitor "Monitor0" SubSection "Display" Viewport 0 0 Depth 1 EndSubSection SubSection "Display" Viewport 0 0 Depth 4 EndSubSection SubSection "Display" Viewport 0 0 Depth 8 EndSubSection SubSection "Display" Viewport 0 0 Depth 15 EndSubSection SubSection "Display" Viewport 0 0 Depth 16 Modes "1280x1024" EndSubSection SubSection "Display" Viewport 0 0 Depth 24 Modes "1280x1024" EndSubSection EndSection

Där är min xorg.conf. Ser ni varför jag bara får 8 bitars färg?

*Intel i7 3820, ASUS Sabertooth X79, 32GB RAM, Nvidia GTX660 & GTX660, Samsung SSD 840 Pro & 2 Barracuda 7200.10 i RAID1, ESI Audio ESP1010e
*Amiga 4000D i Elbox Tower. 16 MB FAST Mem & 2 MB Chip Mem. Indivision AGA MK2, FastATA 4000 MK-VI, 16 GB CF & 40 GB IDE

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2002

"DefaultDepth 24" under "Screen" kanske hjälper. Lika bra att ta bort alla modes som är 8-bit också...

Perl - Made by Idiots, Java - Made for Idiots, C++ - Envied by Idiots
Homepage: http://rgba.se
IRC: #code.se at QuakeNet

Trädvy Permalänk
Medlem
Plats
Härnösand
Registrerad
Jul 2001
Citat:

Ursprungligen inskrivet av Sunray
"DefaultDepth 24" under "Screen" kanske hjälper. Lika bra att ta bort alla modes som är 8-bit också...

Stort tack!
Det fungerar perfekt nu!

*Intel i7 3820, ASUS Sabertooth X79, 32GB RAM, Nvidia GTX660 & GTX660, Samsung SSD 840 Pro & 2 Barracuda 7200.10 i RAID1, ESI Audio ESP1010e
*Amiga 4000D i Elbox Tower. 16 MB FAST Mem & 2 MB Chip Mem. Indivision AGA MK2, FastATA 4000 MK-VI, 16 GB CF & 40 GB IDE

Trädvy Permalänk
Medlem
Plats
vänster om atom 276
Registrerad
Jul 2001

Snor tråden lite, jag har lite av samma problem, fast för mig är det TV-out som inte fungerar som det ska. X startar och fönsterhanteraren kommer upp på båda skärmarna för att sen totalkrasha. :/

qw q b

Trädvy Permalänk
Medlem
Plats
/dev/null
Registrerad
Feb 2004

Kolla i ~/.xsession-errors och /var/log/Xorg.0.log

Hur man installerar program i *nix | There is no Swedish conspiracy

these days you can't use the Web at 2400 baud because the ads are 24KB - Bill Joy