Seg disk med linux 16.04 på ESXI 6.5

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Dec 2005

Seg disk med linux 16.04 på ESXI 6.5

Hej

Har kommit fram till att jag får otroligt dålig läs prestanda i Linux 16.04 på min ESXI 6.5 server.

Har testat hastigheten med #sudo hdparm -Tt /dev/sda

16.04 ca 20MB/sec
18.04 ca 200MB/sec

Båda använder samma datastore. Mina Win VM funkar utan problem.

Har en HP ML310e G8
Datastoren använder inbyggda kontrollern.

Trädvy Permalänk
Medlem
Plats
umeå
Registrerad
Jun 2005

Om diskarna i fråga används helt åt en given VM skulle jag köra med RDM (raw device mapping), då mappas disken 100% till en given VM och då slipper man det extra lagret med VMFS.

Trädvy Permalänk
Medlem
Registrerad
Dec 2008

Vad är det för typ av raid och diskar som ditt datastore består av? Är det rimligt att du får ut 200MB/sec i den konstellationen? Det jag tänker på är ifall 18.04 har något RAM-cache som stör och prestandan annars är kass. Bara en tanke

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Dec 2005
Skrivet av jocke92:

Vad är det för typ av raid och diskar som ditt datastore består av? Är det rimligt att du får ut 200MB/sec i den konstellationen? Det jag tänker på är ifall 18.04 har något RAM-cache som stör och prestandan annars är kass. Bara en tanke

Är två gamla ssd i raid 0 så det är rimligt. I win får jag ut runt 300 MB/sec

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Dec 2005
Skrivet av boibo:

Om diskarna i fråga används helt åt en given VM skulle jag köra med RDM (raw device mapping), då mappas disken 100% till en given VM och då slipper man det extra lagret med VMFS.

Inte möjligt med denna datastore men jag har det på alla andra.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001

Gissar att det är samma fenomen som på många andra HP Servrar med software-raid kontrollern. Detta kan nog vara av intresse: https://www.johandraaisma.nl/fix-vmware-esxi-6-slow-disk-perf...

Intel Core i7 8770k @ 4.8GHz | Asus Prime Z370-A | 16GB G.Skill DDR4 3200MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Dec 2005
Skrivet av Calle:

Gissar att det är samma fenomen som på många andra HP Servrar med software-raid kontrollern. Detta kan nog vara av intresse: https://www.johandraaisma.nl/fix-vmware-esxi-6-slow-disk-perf...

Precis. Driver är nergraderad och det förklarar inte varför jag på samma datastore får 20MB/sec med ubuntu 16.04 och 200 med ubuntu 18.04 eller har jag missat något?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jul 2001
Skrivet av Asus_84:

Precis. Driver är nergraderad och det förklarar inte varför jag på samma datastore får 20MB/sec med ubuntu 16.04 och 200 med ubuntu 18.04 eller har jag missat något?

Skickades från m.sweclockers.com

Jag som läste alldeles för snabbt, trodde du fick samma dåliga fart på båda.
Kör du samma virtuella diskkontroller på båda VMarna?
OpenVM tools är installerat?

Jag kör LSI Parallell på en 16.04.5 på ESXi 6.5 och får följande:
/dev/sda:
Timing cached reads: 13284 MB in 1.99 seconds = 6661.15 MB/sec
Timing buffered disk reads: 1594 MB in 3.00 seconds = 530.99 MB/sec

De är båda installerade som "minimal virtual machine".

Intel Core i7 8770k @ 4.8GHz | Asus Prime Z370-A | 16GB G.Skill DDR4 3200MHz | EVGA GeForce GTX 980ti SC+ | Supermicro Xeon-D 1528 | Asus MG279Q, Dell U2515H

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Jul 2002
Skrivet av Asus_84:

Hej

Har kommit fram till att jag får otroligt dålig läs prestanda i Linux 16.04 på min ESXI 6.5 server.

Har testat hastigheten med #sudo hdparm -Tt /dev/sda

16.04 ca 20MB/sec
18.04 ca 200MB/sec

Båda använder samma datastore. Mina Win VM funkar utan problem.

Har en HP ML310e G8
Datastoren använder inbyggda kontrollern.

Har du kollat vilken VM-version du har på resp. VM och som nämnts, kollat vilken virtuell diskkontroller som är inställd samt att VM Tools versionen är lika.

Skrivet av boibo:

Om diskarna i fråga används helt åt en given VM skulle jag köra med RDM (raw device mapping), då mappas disken 100% till en given VM och då slipper man det extra lagret med VMFS.

Prestandan degraderas inte allt för mycket med att köra med VMDKs, däremot så får du nackdelar så som att du inte kan migrera VM till annan lagring/host när man börjar knyta virtuell hårdvara till specifika fysiska diskar/hårdvara. Mycket av flexibiliteten blir oflexibel

.:Wks: Cooler Master Silencio 650|Core i5 3570 3.4 GHz|Asus P8Z77-V|8 GB| GT 465|1xDell U2311H, 2xAlienware AW2210 2xEizo 19|OCZ Revo 3 Drive 120 + Raptor 150:.
.:Server: Har ett gäng :) :.
-Learn the system, Play the system, Break the system-

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Dec 2005
Skrivet av Calle:

Jag som läste alldeles för snabbt, trodde du fick samma dåliga fart på båda.
Kör du samma virtuella diskkontroller på båda VMarna?
OpenVM tools är installerat?

Jag kör LSI Parallell på en 16.04.5 på ESXi 6.5 och får följande:
/dev/sda:
Timing cached reads: 13284 MB in 1.99 seconds = 6661.15 MB/sec
Timing buffered disk reads: 1594 MB in 3.00 seconds = 530.99 MB/sec

De är båda installerade som "minimal virtual machine".

Skrivet av Mr_Lazy:

Har du kollat vilken VM-version du har på resp. VM och som nämnts, kollat vilken virtuell diskkontroller som är inställd samt att VM Tools versionen är lika.

Prestandan degraderas inte allt för mycket med att köra med VMDKs, däremot så får du nackdelar så som att du inte kan migrera VM till annan lagring/host när man börjar knyta virtuell hårdvara till specifika fysiska diskar/hårdvara. Mycket av flexibiliteten blir oflexibel

Båda kör med samma inställningar dock så skiljer sig WM-tools versionen men båda har nyaste för respektive release.
VM version 13 på båda.
LSI Parallel på båda.

Uppdaterade den ena till ubuntu 18.04 i dag och då försvann problemet så det bör ligga i mjukvaran.

// Richard

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Dec 2005

Slutade med att jag bytte disk och kontroller. Problemet är inte löst men undviket.

Skickades från m.sweclockers.com