Forumdelen sponsras av

Asus RT-N66U + AdvancedTomato + Ownit IPTV = Extrem huvudvärk?

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

Asus RT-N66U + AdvancedTomato + Ownit IPTV = Extrem huvudvärk?

Hejsan!

Bakgrund: Jag vill lägga in en OpenVPN server på min router för att på ett simpelt sätt kunna komma åt mitt hemnätverk när jag befinner mig utanför hemmet. Körde tidigare min Asus RT-N66U med Asus stock firmware, men efter att ha läst på online så flashade jag in AdvanceTomato för att, vad jag trodde, på ett enklare sätt kunna köra min VPN server. Med Asus firmware hade jag följande setup som fungerade väl:

Tänkte mig att det skulle vara enkelt att skapa ett nytt VLAN med VID 501 (OWNITs IPTV) till Port 4 i Tomato på samma sätt som tidigare fungerade i Asus firmware, men det var det verkligen inte. Jag missar garanterat något, för det känns inte som att det bör vara så svårt. Jag lyckas åstadkomma två olika scenarion:

1) Internet fungerar på Port 1-3, IPTV fungerar ej på Port 4.
2) Internet fungerar ej på Port 1-3, IPTV fungerar på Port 4.

Mitt problem är att kombinera scenario 1 och 2 till ett nytt där både Internt och IPTV fungerar samtidigt. Skulle någon kunna guida mig i rätt riktning? Jag har suttit med detta hela helgen och har läst, vad som känn som, hela internet utan att lösa problemet.

Följande två bilder visar min konfiguration för scenario 1 resp. 2.

Scenario 1:

Scenario 2:

mvh
Fredrik

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Sep 2012

Om du utgår från scenario 2 och urmarkerar Tagged: yes från raden med Bridge: WAN borde det ge dig resultatet du vill ha. I nuläget försöker din router ta internet från VLAN 2 på WAN vilket inte kommer funka.

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

@sebmod: Hej!

Tack för svar. Jag testade att göra som du föreslog, men tyvärr så hjälpte det inte. Det verkar som att routern tappar all information om IP, Subnet, DNS, Gateway efter reboot och den kan inte hitta det igen. Se bilder nedan för konfiguration av VLAN samt förtydligande om vad jag menar med konfigurationen.

mvh
Fredrik

Trädvy Permalänk
Medlem
Plats
Västerås
Registrerad
Mar 2002

Varför har du satt WAN på både iptv och WAN tsm?
Ta bort WAN ifrån IPTV och sätt den som taggad bara

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

@claser: Hmm, det är inte möjligt att göra så. Rutan "Tagged" bredvid WAN är gråmarkerad om inte jag klickar i att WAN porten ska vara aktiv.

Trädvy Permalänk
Medlem
Registrerad
Mar 2019

robocfg

Skrivet av Fredrik94:

@sebmod: Hej!

Tack för svar. Jag testade att göra som du föreslog, men tyvärr så hjälpte det inte. Det verkar som att routern tappar all information om IP, Subnet, DNS, Gateway efter reboot och den kan inte hitta det igen. Se bilder nedan för konfiguration av VLAN samt förtydligande om vad jag menar med konfigurationen.

https://i.imgur.com/aRVaGqq.png

https://i.imgur.com/gzhAtD8.png

mvh
Fredrik

Hej @Fredrik94, om du testar med att ställa tillbaka allt som default under vlan och bara har port 1234 på vlan1 samt wan på vlan2.
Sedan ssh:ar du in i routern och skriver:

robocfg show

och sedan skicka en skrämdump på det.
Gör sedan samma sak för när du kör konfiguration 3 alltså vlan1 port 123, vlan2 wan untagged, vlan501 port 4 untagged samt wan tagged och sedan skickar en skrärmdump på samma kommando då.

jag ska se om man kan utläsa något då.

Med vänlig hälsning, csoM

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009
Skrivet av csom:

Hej @Fredrik94, om du testar med att ställa tillbaka allt som default under vlan och bara har port 1234 på vlan1 samt wan på vlan2.
Sedan ssh:ar du in i routern och skriver:

robocfg show

och sedan skicka en skrämdump på det.
Gör sedan samma sak för när du kör konfiguration 3 alltså vlan1 port 123, vlan2 wan untagged, vlan501 port 4 untagged samt wan tagged och sedan skickar en skrärmdump på samma kommando då.

jag ska se om man kan utläsa något då.

Med vänlig hälsning, csoM

Hej!

Tack för svar och tack för att du tar dig tid. Jag återkommer med print screen på söndag när jag är tillbaka vid datorn igen

Mvh
Fredrik

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Mar 2019

@Fredrik94:

Ok, super.

Om du ser mitt resultat av robocfg show:

admin@RT-AC3200:/tmp/home/root# robocfg show Switch: enabled Port 0: 1000FD enabled stp: none vlan: 2 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 1: DOWN enabled stp: none vlan: 11 jumbo: off mac: 00:00:00:00:00:00 Port 2: 10HD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 3: 100FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 4: 1000FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 5: 1000FD enabled stp: none vlan: 2 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 7: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00 Port 8: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00 VLANs: BCM5301x enabled mac_check mac_hash 1: vlan1: 2 3 4 5t 2: vlan2: 0 5 11: vlan11: 1 5t 46: vlan46: 0t 4t 5t 1045: vlan1045: 0 1 2t 3t 4t 5 1046: vlan1046: 0t 1 2 3 4t 5 7 8t 1047: vlan1047: 0 2 4t 5t 7 1099: vlan1099: 1t 2 3 1100: vlan1100: 0t 2t 4 5t 8t 1101: vlan1101: 3t 4 7t 1102: vlan1102: 0 2t 3t 4t 5 8t 1103: vlan1103: 0 2 8u

Som förklaring:

  • 1: vlan1: 2 3 4 5t
    är mitt LAN som portarna 1,2,3 är otaggade på

  • 2: vlan2: 0 5
    är WAN-sidan där wan-porten "0" är otaggad för internet

  • 11: vlan11: 1 5t
    Har jag valt för mina IOT-enheter på port 4 att köra på vlan 11 otaggat

  • 46: vlan46: 0t 4t 5t
    Är mitt TV VLAN 46 som jag tar in taggat på wan "0t" sedan går det taggat ut på min port 1 "4t" till en switch som jag senare taggar av trafiken i swtichen till min IPTV-box

Resten av raderna är förkonfigurerade och dem behöver man inte bry sig om just nu.

Dem första port-raderna talar om vilken fysisk port som är bunden emot motsvarande "robocfg port". Det är där jag tror att Tomatos Gui har krånglat till det och inte riktigt ställt in allt rätt då jag tror att GUIt blandar ihop vilka portar som är vilka.

Som du ser hos mig så är: "0" wan, "4" port 1, "3" port 2, "2" port 3 och "1" port 4 m.m.

Med vänlig hälsning, csoM

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

@csom:

Hej!

Här kommer informationen som du efterfrågade.

Följande resultat erhölls vid default inställningar

root@router:/tmp/home/root# robocfg show Switch: enabled gigabit Port 0: 100FD enabled stp: none vlan: 2 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 1: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00 Port 2: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00 Port 3: 1000FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 4: 100FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 8: 1000FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX VLANs: BCM53115 enabled mac_check mac_hash 1: vlan1: 1 2 3 4 8t 2: vlan2: 0 8t root@router:/tmp/home/root#

och följande erhölls med "konfiguration 3: vlan1 port 123, vlan2 wan untagged, vlan501 port 4 untagged samt wan tagged"

root@router:/tmp/home/root# robocfg show Switch: enabled gigabit Port 0: 100FD enabled stp: none vlan: 501 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 1: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00 Port 2: DOWN enabled stp: none vlan: 1 jumbo: off mac: 00:00:00:00:00:00 Port 3: 1000FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 4: 100FD enabled stp: none vlan: 501 jumbo: off mac: XX:XX:XX:XX:XX:XX Port 8: 1000FD enabled stp: none vlan: 1 jumbo: off mac: XX:XX:XX:XX:XX:XX VLANs: BCM53115 enabled mac_check mac_hash 1: vlan1: 1 2 3 8t 2: vlan2: 0 8t 501: vlan501: 0t 4 8t root@router:/tmp/home/root#

Hoppas du kan utläsa något vettigt.

mvh
Fredrik

Trädvy Permalänk
Medlem
Registrerad
Mar 2019

Som jag kan utläsa så har du bara saker sitter i port 3 och 4 samt wanporten?

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

@csom: Korrekt. För närvarande använder jag mig av LAN3 till min dator och LAN4 går till IP-TV boxen. LAN1-2 används mer sporadiskt, dock inte just nu.

Trädvy Permalänk
Medlem
Registrerad
Mar 2019

@Fredrik94:

Prova med att ställa in allt som default och skriv sedan in i terminalen:

robocfg vlan 1 ports "1u 2u 3u 8t" robocfg vlan 501 ports "0t 4u 8t"

Det känns som det ger samma resultat som konfiguration 3

Men det "ska" ge dig rätt förutsättning.

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

@csom: Hej!

Tack! Det fungerade, åtminstone tillfälligt. Efter en reboot av routern verkade inställningarna ha återgått till default. Har du koll på något sätt att spara dessa inställningar, eller måste jag helt enkelt mata in dem efter varje omstart?

mvh
Fredrik

Trädvy Permalänk
Medlem
Registrerad
Mar 2019
Skrivet av Fredrik94:

@csom: Hej!

Tack! Det fungerade, åtminstone tillfälligt. Efter en reboot av routern verkade inställningarna ha återgått till default. Har du koll på något sätt att spara dessa inställningar, eller måste jag helt enkelt mata in dem efter varje omstart?

mvh
Fredrik

Vad bra att det fungerade. Då stämde min teori. robocfg är ett verktyg som du styr den inbyggda switchen med och man kan sätta olika vlan m.m.
Jag tror att Tomatos Gui spökar till det i inställningarna och att du måste brygga vlan direkt i terminalen som vi gjorde nu innan. Jag vet inte om Gui speglar dessa inställningar sedan om du kollar under VLAN-fliken?

Ett sätt att få dessa inställningar att sparas efter varje reboot är att skriva in WAN-UP scriptet under Administration->Scripts:

robocfg vlan 1 ports "1u 2u 3u 8t" robocfg vlan 501 ports "0t 4u 8t"

Prova det.

Med vänlig hälsning, csoM

Trädvy Permalänk
Medlem
Plats
Täby
Registrerad
Okt 2009

@csom: Det där verkar ha löst problemet. Testade att reboota och nu fungerade allt! Ska hålla lite koll de närmsta dagarna så att det inte spökar.

Tack så oerhört mycket för all hjälp och din tid, guld värt!

Vänligen
Fredrik