Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Hårddisk eller kontroller strul?

Hej,

När jag kopierar stora filer till en specifik hårddisk så tar det dels väldigt lång tid men den fryser också välidgt ofta. Det är inte Windows i sig som fryser sig utan status dialogen för kopieringen. Det påverkar märkligt nog även internet även om Windows är installerad på en helt annan disk.

Idag har jag förjande diskar :

3001 GB WDC WD30EFRX-68EUZN0
3001 GB WDC WD30EFRX-68AX9N0
240 GB INTEL SSDSC2BW240A4 (Program)
1000 GB Samsung SSD 860EVO (Windows)
1000 GB WDC WD10EADS-00L5B1
2000 GB WDC WD20EARS-00MVWB0
2000 GB WDC WD20EARX-00PASB0

Det är en av 3001 GB diskarna som framkallar felet.

I eventloggen kan jag en väldig massa av dessa fel :

Ett nytt försök att utföra I/O-åtgärden på den logiska blockadressen 0x14c28c390 för disk 0 (PDO-namn: \Device\00000033) har utförts.
--
Återställning till enheten \Device\RaidPort1 utfärdades.
--

Jag har provat köra quick WD diagnostic check utan några fel.

Kan det vara kontrollern som till slut ger upp på moderkortet eller är det helt enkelt så att en av de nyare diskarna är defekt?

CPU : Intel Core i7 2600K Moderkort : Asus P8Z68-V PRO GEN3 Grafikkort :EVGA GeForce GTX 1080 Ti FTW3 iCX Gaming HDMI 3xDP 11GBMinne : Corsair 16GB (4x4096MB) CL9 1600Mhz XMS3 1,5V Chassi : Fractal Design Define r3 Nätdel : Corsair 650W ModulärtOS disk : Intel 530 240 GB SSD Övriga diskar : 1x Samsung 860 EVO SSD 1TB 2x WD Red 2 TB, 2x WD Green, 1x WD 750 GBOptisk enhet : Optiarc AD-7280S SATA

Trädvy Permalänk
Medlem
Registrerad
Mar 2012

Skulle nog köra ett fulltest på den disken. Har varit med om att trasiga block eller kluster av block ger rätt skumma problem och även påverkar andra diskar på samma kontroller. Om ett fulltest inte visar på några skadade block skulle jag prova att byta port med en annan disk och kanske även kabel och se om samma sak händer då.

Ryzen 3600 | ASUS X470-F | 16GB Corsair LPX B-die | GTX 1070

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Sep 2007

@Jimmy: Ibland har diskar som folk misstänkte gått sönder dagar efter att program sa att disken var ok. Kablar och porten dom kopplats till har också orsakat fel. Strömkabeln också.

Uteslut andra diskar genom att koppla ur dom.
Testa disken du misstänker med andra kablar och portar.

Backup är viktigt för i flera fall har man haft ett begränsat anta försök att komma åt grejerna på disken innan felet blev värre.

Trädvy Permalänk
Medlem
Registrerad
Aug 2016

Luktar diskfel, - har du haft strömavbrott eller plötslig avstängning medans disken används - det verkar som att de ibland skriver fulheter på skivan om man rycker strömmen mitt under diskaktiviteter... har harft mer än en incident med trubbliga sektorer på WD-diskar i just samband efter med strömavbrott...

Men visst kolla och byt SATA-kablar först och kika i diskens SMART och se om det är CRC-fel - vilket då typer på kabelbekymmer. - men har man ovanstående fel så kommer inget att synas på SMART dessvärre...

---

Kopiera/backuppa bort bort all data ur disken och skriv sedan disken med '0' från första sektorn till den sista sektorn med 'dd' med linux uppstartad på sticka (koppla loss alla andra diskar i datorn så att du inte gör fel om du inte är van med 'dd' och vet hur man hittar rätt disk i linux miljö)

En sådan skrivning brukar 'renovera' en småtrubblig WD-disk då när man skriver kontinuerligt mot disken då tittar den inte vad som fanns innan skrivet på skivan utan bara skriver på och rakt över områden som kanske potentiellt har lässvårigheter om man skulle försöka läsa dem.

Detta har jag fått gjort på WD-diskar ett flertal gånger innan de blir användbara igen inklusive i dom fallen när diskarna hård-hängde sig när vissa sektorer skulle läsas. - om man vill se det så, har jag ingen som helst förståelse för WD 'goda rykte' - det är dom diskarna som krånglat mest för mig...

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Backup är tyvärr svår att göra nu efter som disken är på 3TB och det är svårt att skrapa ihop så mycket utrymme på övriga diskar.

I WD Diagnostivs listas det 2 st 3TB

3001 GB WDC WD30EFRX-68EUZN0
3001 GB WDC WD30EFRX-68AX9N0

Jag vet ju inte vilken det är som strular av dem? Hur reder man ut det? Nu har jag bara valt ut en att köra extended test på men det tar tydligen väldigt lång tid? Den säger 6 timmar kvar och det har redan gått 7 timmar.

Inget strömavbrott eller liknande har uppstått och datorn har inte hanterats.

När jag tittar i event loggen så ser jag att det historiskt varit lite utspridda fel :

12 - Det finns ett felaktigt block på enhet \Device\Harddisk6\DR6.
13 - Ett nytt försök att utföra I/O-åtgärden på den logiska blockadressen 0x5d5628 för disk 0 (PDO-namn: \Device\00000033) har utförts.
13 - Återställning till enheten \Device\RaidPort0 utfärdades.
13 (15st) - Ett nytt försök att utföra I/O-åtgärden på den logiska blockadressen 0x358b8d68 för disk 3 (PDO-namn: \Device\00000036) har utförts.
14 - Ett nytt försök att utföra I/O-åtgärden på den logiska blockadressen 0x5d4de0 för disk 0 (PDO-namn: \Device\00000033) har utförts.
14 - Återställning till enheten \Device\RaidPort1 utfärdades.

Första siffran är datum

Den 14 brakar det loss och det är 100 tals med disk och storahci fel.

Har en helt ny SATA kabel liggande som jag ska prova på, det svåra är att luska ut vilken disk det är efter som jag har 2 lika stora diskar.

CPU : Intel Core i7 2600K Moderkort : Asus P8Z68-V PRO GEN3 Grafikkort :EVGA GeForce GTX 1080 Ti FTW3 iCX Gaming HDMI 3xDP 11GBMinne : Corsair 16GB (4x4096MB) CL9 1600Mhz XMS3 1,5V Chassi : Fractal Design Define r3 Nätdel : Corsair 650W ModulärtOS disk : Intel 530 240 GB SSD Övriga diskar : 1x Samsung 860 EVO SSD 1TB 2x WD Red 2 TB, 2x WD Green, 1x WD 750 GBOptisk enhet : Optiarc AD-7280S SATA

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Mina båda wd 3tb diskar var sjukt ostabila, ibland försvann de helt från windows. Hoppas du inte fått samma batch som mina var ifrån.

Hårddiskar som beter sig på det här sättet måste skrotas, jag skulle aldrig lita på dom. Troligen inget fel på själva skivan utan snarare kontrollern på hårddiskens kretskort

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Sep 2007
Skrivet av Jimmy:

Backup är tyvärr svår att göra nu efter som disken är på 3TB och det är svårt att skrapa ihop så mycket utrymme på övriga diskar.
...
Jag vet ju inte vilken det är som strular av dem? Hur reder man ut det? Nu har jag bara valt ut en att köra extended test på men det tar tydligen väldigt lång tid? Den säger 6 timmar kvar och det har redan gått 7 timmar.
...

Stopp, avbryt genast. Diskar kan gå sönder ännu mer innan den är klar.

Koppla ur disken tills du fått ihop utrymme för att göra backup. Vet du inte vilken så kopplar ur ena disken och se om felet är kvar. Funkar det så borde det vara disken som du kopplade ur.

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av panpo98:

Stopp, avbryt genast. Diskar kan gå sönder ännu mer innan den är klar.

Koppla ur disken tills du fått ihop utrymme för att göra backup. Vet du inte vilken så kopplar ur ena disken och se om felet är kvar. Funkar det så borde det vara disken som du kopplade ur.

Håller med. Dumt att lasta disken alls innan du fått av datan. Åk till närmaste datorbutik och köp en extern 4tb disk eller liknande

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Aug 2016

Ser inte att det finns någon som helst ursäkt att inte göra backup eller skylla på att man inte har plats - det är bara ut på stan och handla upp en 8TB extern USB-disk av Seagate eller WD (om du nu längre litar på de sistnämda) och göra backup _NU_ om dina data är värd mer än 2000:- i arbetstid eller affektionsvärde - men det är ditt val.

Kort sagt man pillar aldrig runt på misstänkt sjuk lagring innan man säkrat sig en backup på all sin data innan, man skall heller inte starta upp eller stänga av sjuka diskar utan du gör din backupp så fort det går så fort disken är startad (och man stänger inte av disken om den redan är uppe och snurrar utan påbörja backuppen så fort det går - och börja med det viktigaste först) - för du kanske bara har en enda chans och nästa gång disken rebootar eller startas om så kanske den inte längre startar utan gör en 'click of dead' (det händer dock inte så ofta och man kan för det mesta plåga snurrdiskarna med uppenbara sektorfel länge med ddrescue för att mjölka ut data sakta men säkert, men det händer då och då att de inte längre startar efter en OFF/ON och då kan ingen mjukvara i världen efteråt läsa ut någon data från disken - WD diskkontroller är för min del ökända att kunna krångla och få hjärnblödning även om själva mekanikdelen är helt OK. WD har kontrollerkortsbekymmer kort sagt.

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Anledningen till att inte köpa ny disk är att den kostar 1500 kr. Men jag åkte iväg och köpte mig en disk och kopierade över allt till den nya disken. Passade även på att köpa en SATA kabel och byta ut den på den befintliga "defekta" hårddisken.

Kopieringen fungerade utan problem, inga fel i eventloggen. Provade köra extended diagnostics och nu gick det klart fortare även om det fortfarande tog par timmar. Inga konstigheter hittade och åter igen inga varningar i evenloggen.

Det ser ut som att disken nu fungerar som den ska, troligt är att det var kabeln som strulade. Jag hade gärna kopplat in den gamla kabeln igen för att testa men tyvärr är moderkortet väldigt dumt konstruerat så att man måste plocka ut hela grafikkortet för att komma åt. Men det är väll ändå troligt att jag gör ett försök.

Problemet som kvarstår är att nu har jag en 4TB disk för 1500 kr som ser ut att vara onödig, har inte häller fler platser på moderkortet för diskar(fick ta bort en annan för att få in 4 TB disken). Ska se om de har någon form av öppet köp men högst troligt så försvinner öppet köp så snart förpackningen bryts på produkter som dessa.

Ett alternativ är att byta ut 1TB disken mot 4 TB disken men egentligen behöver jag inte mer utrymme och 1TB disken fungerar som den ska.

Det är lite märkligt faktiskt att SATA kablar(om det nu är den) bara ger upp sådär? Min dator står försluten på samma ställe alltid. Ser inte att det finns någon fläkt eller annan mekanisk del som skulle kunna komma åt kablarna. Jag har dock ett svagt minne av att jag fått byta defekt SATA kabel tidigare. I datorn sitter det en bladning av olika SATA kablar så jag kan inte peka på att någon specifik har undermålig kvalité.

Jag inser att det såklart fortfarande är fullt möjligt att det varit något annat än SATA kabeln som strulat och då är det inte omöjligt att det återkommer. Det är ju av den anledningen intressant att testa den "defekta" SATA kabeln.

CPU : Intel Core i7 2600K Moderkort : Asus P8Z68-V PRO GEN3 Grafikkort :EVGA GeForce GTX 1080 Ti FTW3 iCX Gaming HDMI 3xDP 11GBMinne : Corsair 16GB (4x4096MB) CL9 1600Mhz XMS3 1,5V Chassi : Fractal Design Define r3 Nätdel : Corsair 650W ModulärtOS disk : Intel 530 240 GB SSD Övriga diskar : 1x Samsung 860 EVO SSD 1TB 2x WD Red 2 TB, 2x WD Green, 1x WD 750 GBOptisk enhet : Optiarc AD-7280S SATA

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Visade sig att butiken faktsikt ger öppet köp! Så nu blir det till att verifiera att felet verkligen var kabeln.

Håller såklart med om att det var klintigt att inte FÖRST testa kabeln. På något vis tänker man att kablar går väll aldrig sönder men just SATA kablar verkar vara förslitningsskada!?

CPU : Intel Core i7 2600K Moderkort : Asus P8Z68-V PRO GEN3 Grafikkort :EVGA GeForce GTX 1080 Ti FTW3 iCX Gaming HDMI 3xDP 11GBMinne : Corsair 16GB (4x4096MB) CL9 1600Mhz XMS3 1,5V Chassi : Fractal Design Define r3 Nätdel : Corsair 650W ModulärtOS disk : Intel 530 240 GB SSD Övriga diskar : 1x Samsung 860 EVO SSD 1TB 2x WD Red 2 TB, 2x WD Green, 1x WD 750 GBOptisk enhet : Optiarc AD-7280S SATA

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Kul att du hittade felet. Fortfarande viktigt med backup, även om det verkar bra nu skulle jag skippa den disken bara för att, även om du byter kabel. Men jag har också en foliehatt av senaste snitt

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Jan 2004

Provade montera tillbaka kabeln och problemet uppenbarade sig direkt! Så kabeln är nu klipt och ersatt med en annna. Disken jag köpte får formateras och åka tillbaka.

Tack för hjälpen!

CPU : Intel Core i7 2600K Moderkort : Asus P8Z68-V PRO GEN3 Grafikkort :EVGA GeForce GTX 1080 Ti FTW3 iCX Gaming HDMI 3xDP 11GBMinne : Corsair 16GB (4x4096MB) CL9 1600Mhz XMS3 1,5V Chassi : Fractal Design Define r3 Nätdel : Corsair 650W ModulärtOS disk : Intel 530 240 GB SSD Övriga diskar : 1x Samsung 860 EVO SSD 1TB 2x WD Red 2 TB, 2x WD Green, 1x WD 750 GBOptisk enhet : Optiarc AD-7280S SATA