Raspberry pi statiskt ip, internett borta!

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

Raspberry pi statiskt ip, internett borta!

Jag skulle sätta statiskt ip på min paj så jag tog bort dhcp-client och uppdaterade min /etc/networking/interface med detta:

auto lo iface lo inet loopback iface eth0 inet static address 192.168.1.66 netmask 255.255.255.0 gateway 192.168.1.1

Nu mera fungerar inte internet. det står Network unreacheable
jag kan ping:a localhost
men inte ping gateway:n så ja kommer varken in där.

route -n ger inet resltat det finns inga addresser där.

Efter som jag tog bort isp-dgcp-client så kan jag inte hämta det igenn efterson internet är väck vad ska jag göra för att få detta att fungera igen???

Edit: skrev fel på gatesay häŕ men det stod gateway i config filem

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Jul 2008

snabb överblick så ser jag
gaeway 192.168.1.1

ändra till gateway

Trädvy Permalänk
Medlem
Registrerad
Okt 2013
Skrivet av samots:

snabb överblick så ser jag
gaeway 192.168.1.1

ändra till gateway

Det var jag som slant på en bokstav här i postem men det står gateway i config filen

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
SweClockers forum
Registrerad
Aug 2012

Sätt upp reservationer i DHCP-servern istället. Det är mycket smidigare.

Guide: Roota din HTC - BB-Kod-knappar på Prisjakt

              Min burk - Kvävekyld till 80%
8700K@stock
1070 Ti@stock

Ibland har jag fel, men då är det någon annans fel.

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Okt 2007

Har du tagit upp interface eth0 ?

Du borde kanske också lägga till "auto eth0" i din config.

- none -

Trädvy Permalänk
Medlem
Registrerad
Okt 2013
Skrivet av aztekk:

Har du tagit upp interface eth0 ?

Vad menar du med "tagit upp" ?

Ska lägga till auto eth0 o testa när ja kommer hem!

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Jul 2008

Jag har inte "auto eth0" i min /etc/network/interfaces så det borde ju fungera iallafall.
Du borde kunna ladda ner isp-dgcp-client paketet från nätet till en annan dator och skicka över det med scp till raspberry:n.

Trädvy Permalänk
Medlem
Registrerad
Okt 2014

DNS brukar ges av DHCP, kan det vara något?

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av Virre131:

Vad menar du med "tagit upp" ?

På raden som börjar med `auto` så definierar du vilka gränssnitt ("interface") du vill ska automatiskt konfigureras och köras igång när nätverkskonfigurationen läses in:

Skrivet av Virre131:

För närvarande har du alltså bara gränssnittet `lo` angivet, vilket gör att loopbackgränssnittet går upp, men inget mer.

Du definierar sedan parametrer för både loopbackgränssnittet (`iface lo`) och nätverkskretsens gränssnitt (`iface eth0`), men eftersom du inte sagt till att du vill att `eth0` ska "tas upp" så händer inget mer med det.

Du kan antingen ta upp gränssnittet manuellt med kommandot

sudo ifup eth0

(och ta ned med motsvarande `ifdown`) eller lägga till `eth0` i `auto`-raden för att det automatiskt ska kicka igång när nätverket konfigureras:

auto lo eth0

Du kan kontrolleras statusen för vilka gränssnitt som är uppe och med vilka inställningar genom kommandot

sudo ifconfig

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

Update:

Ändrade min network config till följande:

auto eth0 iface eth0 inet static address 192.168.1.65 netmask 255.255.255.0 gateway 192.168.1.1

ifconfig på pajen ger:

eth0 ....... inet addr: 192.168.1.65 Bcast:192.168.1.255 Mask:255.255.255.0 ....

ipconfig på min dator ger:

Connection-specific DNS Suffix . : lan Link-local IPv6 Address . . . . . : fe80::f0c3:a357:61 IPv4 Address. . . . . . . . . . . : 192.168.1.64 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . : 192.168.1.1

sudo route -nee ger 2 rader:

Gateway 92.168.1.1

rad2

destination 192.168.1.0 genmask 255.255.225.0

Vet inte hur det ska se ut om det är rätt. ska det vara 2 rader?
Var laddar man ner programet spc-dhcp-client någonstans som jag kan föra över o göra någon sorts offline install.
Några förslag?

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

Ok nu är problemet löst!!
Jag laddade ner .deb filerna och lage dom på usb o sedan till pajen och installerade dhcp:n igen
Tackar alla som hjälpte till !!

Trädvy Permalänk
Forumledare
Registrerad
Okt 2002
Skrivet av Virre131:

Update:

Ändrade min network config till följande:

auto eth0 iface eth0 inet static address 192.168.1.65 netmask 255.255.255.0 gateway 192.168.1.1

Det ser rimligt ut, men du borde inte ta bort loopbackgränssnittet; då kan det gå så här .

Exempel på `/etc/network/interfaces` med både `eth0` och `lo` aktiverat:

auto lo eth0 iface lo inet loopback iface eth0 inet static address 192.168.1.65 netmask 255.255.255.0 gateway 192.168.1.1

Nu med kortare användarnamn, men fortfarande bedövande långa inlägg.