Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Maj 2012

Problem med Arduino

Hej Sweclockers. Nyss fått hem en Arduino Micro Pro klon som jag skulle vilja flasha en .hex-fil till. Jag har försökt använda FLIP, men jag möts direkt av felkoden "AtLibUsbDfu.dll is missing" innan jag hinner göra något. Det funkar utan problem att använda sig av Arduions IDE för att ladda upp deras "Blink-exempel" till Arduinon.

Tack på förhand!

Main i7 7700k - msi Z170 Krait Gaming - msi GTX 1080 FE - Corsair LPX 16GB 2800 mhz - 2x intel 530 240GB [RAID 0] - be quiet! Straight Power e9 680w - Asus Xonar Essence STX - H100i

Laptop MacBook Air 13" early 2014

Kringutrustning Acer XB271HU - HHKB Professional 2 Purple Sliders - Realforce 88UB - IBM model M - Logitech G400 - Beyerdynamic DT-770 PRO 80Ω - Sennheiser HD6xx - Woo Audio WA6 - Blue Snowball

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Maj 2012

Problemet löst. Skrev in detta i avrdude för att "permanent" sätta Arduinon i bootloader-läget: avrdude -p atmega32u4 -P COM8 -c avr109 -b 1200.

Efter det var det fritt fram att flasha .hex-filen. Det var just "-c avr109" som var räddaren i nöden. Hoppas detta kommer till användning för någon annan.

Main i7 7700k - msi Z170 Krait Gaming - msi GTX 1080 FE - Corsair LPX 16GB 2800 mhz - 2x intel 530 240GB [RAID 0] - be quiet! Straight Power e9 680w - Asus Xonar Essence STX - H100i

Laptop MacBook Air 13" early 2014

Kringutrustning Acer XB271HU - HHKB Professional 2 Purple Sliders - Realforce 88UB - IBM model M - Logitech G400 - Beyerdynamic DT-770 PRO 80Ω - Sennheiser HD6xx - Woo Audio WA6 - Blue Snowball