Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Problem med WAMP

Jag har försökt att installera WAMP-server så att jag har något att köra min PHP-kod mot. Laddar ner den från http://www.wampserver.com/en/ och väljer "direct download" och installerar.

Problemet jag har är att ikonen inte blir grön, och när jag installerar så får jag heller inte upp en ruta med inloggningsuppgifter som jag ser att "andra" får. Någon som vet vad det kan bero på?

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2010

Någon ruta med inloggningsupggifter har jag ingen aning om. Kan inte säga att jag kommer ihåg att jag har fått sådant förr (och inte nu heller). Så det är svårt att veta utan att du visar vad det är.

Att den inte blir grön kan bero på många olika saker, är den röd eller orange?

"If the WampServer icon is NOT GREEN please ensure you have looked at these files :-
a - Apache error log
-- ( wampmanager -> Apache -> Apache error log )
-- ( wampmanager -> Apache -> Apache access log )
b - MySQL error log ( wampmanager -> MySQL -> MySQL log )
c - PHP error log ( wampmanager -> PHP -> PHP error log )"

http://forum.wampserver.com/read.php?2,129067

Maximus X Hero - 8700k @5.1GHz - H115i - 32GB LPX@3466MHz - MSI 980Ti Gaming - EVGA SuperNova 750 G2 - Asus vg248qe - FD R5

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

@Elghinnarisa:

Menar uppgifterna där man skriver in SMTP

Den är orange men kan det beror på ett annat program som den saknar?

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2010
Skrivet av Naruori:

@Elghinnarisa:

Menar uppgifterna där man skriver in SMTP

Den är orange men kan det beror på ett annat program som den saknar?

Svårt att säga utan att veta vad loggen säger.

Och guiden är skriven för WampServer 2 som du ser i bilderna. Nu är dom på 3.0.6. Så kan vara därför man inte får rutan där i slutet.

Maximus X Hero - 8700k @5.1GHz - H115i - 32GB LPX@3466MHz - MSI 980Ti Gaming - EVGA SuperNova 750 G2 - Asus vg248qe - FD R5

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

@Elghinnarisa:
Ska testa och installera om det senare idag, så får återkomma. Tack för dina svar!

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
Östersund
Registrerad
Jan 2011

Det är inte så att du har något annat program igång som redan har bundit upp porten? veta att Skype bland annat använder port 80..

CPU: i7 4770k Noctua NH-D14 MOBO: Maximus VI Hero GPU: GTX 980 RAM: 16 GB 1600 MHz Chassi: R4 PSU: Corsair AX860 Hörlurar: SteelSeries 840 Mus: Logitech G500s V.v. citera mig för att få svar.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

De frågar inte längre efter SMTP, det gjorde den i äldre versioner.

Vänsterklickar man på ikonen och går under Apache/MySQL och sedan Service administration så kan man se vilken tjänst som inte vill starta.

Högerklickar man och väljer Tools kan man testa portarna 80 (Apache) och 3306 (MySQL). Där får man även information om vilket program som blockerar den. Om det är Skype så stänger du av port 80 under Tools -> Options -> Advanced -> Connection -> "Use port 80 and 443..."

Du får ingen varning om "Visual C++ Redistributable"? För du behöver inte bara 2012 som de länkar till vid nerladdning, utan jag är alltid tvungen att installera fler. Jag har 2008,2010,2012,2013 och 2015; Beror på vilka PHP/Apache versioner du använder. Då jag använder PHP 5.3.7 - 7.1.1 så behövs alla.

Punkt 20 i felsökningstipsen tar upp C++.
If you have a 64-bit Windows, you must install both 32 and 64bit versions, even if you do not use Wampserver 64 bit.

Du finner senaste 3.0.8 patchen här:
http://forum.wampserver.com/read.php?2,138295

Deras felsöknings tips:
http://forum.wampserver.com/read.php?2,134915

Trädvy Permalänk
Medlem
Plats
Sundsvall
Registrerad
Dec 2006

Jag har alltid behövt installera VC++ alla versioner för att få igång det.

Canon 70D | 2x Dell Ultrasharp 24" | i7 3770k | 16B | GTX 780

Trädvy Permalänk
Medlem
Plats
Queenstown NZ
Registrerad
Apr 2011

Skulle tro att det är Skype som spökar med port 80 såvida du inte fick något felmeddelande under installationen som då brukar vara relaterat till VC++.

Står vilka du behöver här:
http://stackoverflow.com/questions/14557245/wamp-shows-error-msvcr100-dll-is-missing-when-install

Kom ihåg att installera om allt på nytt om detta är problemet.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013

Tack för alla era svar! Har haft väldigt mycket den senaste tiden, men kommer kommer kolla upp detta under helgen!

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2016

Stäng av skype eller byte port.

Skype använder sig av port 80 och dom krockar.

Edit: Har använt detta program i många år innan jag gick över till Linux.

Den blir aldrig grön eller orange så läge skype körs har haft detta problem innan.

Grön körs den i 0.0.0.0.
Orange körs i den i 127.0.0.1.

Man är inte dum för att man har stavproblem.
Läs mer om min synfel Visual Snow
Om mig ----> #16970666

Trädvy Permalänk
Medlem
Plats
*****
Registrerad
Aug 2006

Inte bara skype som snor porten. Även teamviewer och andra hostade tjänster. Se till att stänga ner alla host tjänster för att undvika problem, Du kan även köra en Netstat i cmd för att se vad som använder port 80

Inte Core i7 4790K
Asus Z97-A
Asus Nvidia GTX 970 STRIX
Kingston DDR3 HYPERX 8GB 1600MHZ X 2

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av johan_ek89:

De frågar inte längre efter SMTP, det gjorde den i äldre versioner.

Vänsterklickar man på ikonen och går under Apache/MySQL och sedan Service administration så kan man se vilken tjänst som inte vill starta.

Högerklickar man och väljer Tools kan man testa portarna 80 (Apache) och 3306 (MySQL). Där får man även information om vilket program som blockerar den. Om det är Skype så stänger du av port 80 under Tools -> Options -> Advanced -> Connection -> "Use port 80 and 443..."

Du får ingen varning om "Visual C++ Redistributable"? För du behöver inte bara 2012 som de länkar till vid nerladdning, utan jag är alltid tvungen att installera fler. Jag har 2008,2010,2012,2013 och 2015; Beror på vilka PHP/Apache versioner du använder. Då jag använder PHP 5.3.7 - 7.1.1 så behövs alla.

Punkt 20 i felsökningstipsen tar upp C++.
If you have a 64-bit Windows, you must install both 32 and 64bit versions, even if you do not use Wampserver 64 bit.

Du finner senaste 3.0.8 patchen här:
http://forum.wampserver.com/read.php?2,138295

Deras felsöknings tips:
http://forum.wampserver.com/read.php?2,134915

Får ingen varning om "Visual C++ Redistributable" men verkar som att port 80 inte är ledig utan används av "Server: Microsoft-IIS/10.0".

Ikonen är orange och det står "1 of 2 services is running".

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

@Naruori Det ser som om du aktiverat Microsoft inbyggda webbserver IIS på datorn/servern. Du behöver därför stänga av/avinstallera tjänsten alternativt byta port på Wamp.

Stänga av
1. Startmenyn
2. Skriv in services.msc och starta den
3. Scrolla ner till World Wide Web Publishing Service och stoppa tjänsten. Du kan även stänga av den permanent härifrån.

Avinstallera (Windows 7/8/10)
1. Kontrollpanelen
2. Program och funktioner
3. Aktivera eller inaktivera Windows-funktioner
4. Bocka ur Internet Information Services

Byta port
1. Högerklicka på Wamp
2. Tools
3. Use a port other than 80
4. Välj t.ex. 8080
5. Besök hemsidan med http://localhost:8080/

Du kan ju även byta port på IIS, om du har någon tjänst som behöver vara igång där med. Där har jag dock inga lättare steg att redogöra.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av johan_ek89:

@Naruori Det ser som om du aktiverat Microsoft inbyggda webbserver IIS på datorn/servern. Du behöver därför stänga av/avinstallera tjänsten alternativt byta port på Wamp.

Stänga av
1. Startmenyn
2. Skriv in services.msc och starta den
3. Scrolla ner till World Wide Web Publishing Service och stoppa tjänsten. Du kan även stänga av den permanent härifrån.

Avinstallera (Windows 7/8/10)
1. Kontrollpanelen
2. Program och funktioner
3. Aktivera eller inaktivera Windows-funktioner
4. Bocka ur Internet Information Services

Byta port
1. Högerklicka på Wamp
2. Tools
3. Use a port other than 80
4. Välj t.ex. 8080
5. Besök hemsidan med http://localhost:8080/

Du kan ju även byta port på IIS, om du har någon tjänst som behöver vara igång där med. Där har jag dock inga lättare steg att redogöra.

Tack för ditt svar! Vad gör "World Wide Web Publishing Service"? Är det säkert att bara stänga av den sådär?

I like to help as much as I like to learn.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

@Naruori World Wide Web Publishing Service är tjänsten för Server: Microsoft-IIS/10.0 och kommer ibland förinstallerat/aktiveras i en Windows 10 uppgradering.

Om du startar Internet Information Services (IIS) Manager via startmenyn alternativt söker efter inetmgr. Kan du där se i vänstermenyn vilka webbapplikationer som finns.

Om du inte har några webbapplikationer installerade så är det fritt fram att inaktivera. Om du märker att något slutar fungera, så kan du bara aktivera tjänsten igen.

IIS är Microsoft webbserver. Det finns ju Apache som du nu försöker installera och den tredje stora är nginx.

Trädvy Permalänk
Medlem
Registrerad
Jul 2013
Skrivet av johan_ek89:

@Naruori World Wide Web Publishing Service är tjänsten för Server: Microsoft-IIS/10.0 och kommer ibland förinstallerat/aktiveras i en Windows 10 uppgradering.

Om du startar Internet Information Services (IIS) Manager via startmenyn alternativt söker efter inetmgr. Kan du där se i vänstermenyn vilka webbapplikationer som finns.

Om du inte har några webbapplikationer installerade så är det fritt fram att inaktivera. Om du märker att något slutar fungera, så kan du bara aktivera tjänsten igen.

IIS är Microsoft webbserver. Det finns ju Apache som du nu försöker installera och den tredje stora är nginx.

Aha, tack för ditt svar! Fixat det nu

I like to help as much as I like to learn.