Installerade nya komponenter, nu bootar datorn inte.

Permalänk

Installerade nya komponenter, nu bootar datorn inte.

Så jag har köpt nytt moderkort och CPU som jag installerade idag. Fick igång datorn direkt efteråt och har spelat och streamat på den nästan hela dagen. Jag tyckte min CPU kylare lät lite väl mycket (Ryzen 7 3700x), så jag letade upp en tråd för att se om det gick att göra något åt. Någon skrev att man kunde ändra kurvan i BIOS, så då startade jag om den, men datorn hängde sig vid "restarting" fönstret. Väntade ca 1 minut, så fick jag nog och höll inne startknappen så att den stängdes ner helt. Då öppnade jag BIOS och ändrade på inställningen till silent, och sparade och startade om. Då står det "operating system not found. Try disconnecting any driver that does not have windows on it" eller väldigt liknande.

Tyckte detta var överjävla märkligt, då jag har spelat på datan hela dagen och allt har verkat frid och fröjd, och nu helt plötsligt så hittar den inte ens windows? Jag testade att sätta alla olika hårddiskar längst upp i boot-ordningen, men det fungerade inte. Jag testade att sätta på default settings i BIOS, funkade inte heller. Kan jag ha pajjat något när datorn hängde sig och att jag stängde av den manuellt?

Så.. Vad fan gör man nu då?

Permalänk
Medlem
Skrivet av ParanoidRocker:

Så jag har köpt nytt moderkort och CPU som jag installerade idag. Fick igång datorn direkt efteråt och har spelat och streamat på den nästan hela dagen. Jag tyckte min CPU kylare lät lite väl mycket (Ryzen 7 3700x), så jag letade upp en tråd för att se om det gick att göra något åt. Någon skrev att man kunde ändra kurvan i BIOS, så då startade jag om den, men datorn hängde sig vid "restarting" fönstret. Väntade ca 1 minut, så fick jag nog och höll inne startknappen så att den stängdes ner helt. Då öppnade jag BIOS och ändrade på inställningen till silent, och sparade och startade om. Då står det "operating system not found. Try disconnecting any driver that does not have windows on it" eller väldigt liknande.

Tyckte detta var överjävla märkligt, då jag har spelat på datan hela dagen och allt har verkat frid och fröjd, och nu helt plötsligt så hittar den inte ens windows? Jag testade att sätta alla olika hårddiskar längst upp i boot-ordningen, men det fungerade inte. Jag testade att sätta på default settings i BIOS, funkade inte heller. Kan jag ha pajjat något när datorn hängde sig och att jag stängde av den manuellt?

Så.. Vad fan gör man nu då?

Kolla så att den hittar din C:disk i Bios och att den är enabled. Hände mig efter lite pillande i bios att systemdisken inte va enabled.

Edit: du har inte tryckt in en till SSD som haft windows på sig?

Permalänk
Medlem

@ParanoidRocker: Har du testat göra som det stod, dvs koppla ur alla diskar som inte har Windows på sig? titt som tätt vill datorn köra en diskkontroll när man stänger av datorn med tvång för att reparera filer som var på väg att flyttas när den stängdes av.

Har du riktig otur kan ju din Windows disk ha blivit överhettad när processorfläkten inte fick köra så fort, låter den för mycket så är det nog bättre att byta ut CPU-fläkten då den som kommer med 3700X inte är den bästa.

Låt datorn svalna en stund och testa igen, kolla då även om disken hittas i bios.

Permalänk
Medlem
Skrivet av ParanoidRocker:

Så jag har köpt nytt moderkort och CPU som jag installerade idag. Fick igång datorn direkt efteråt och har spelat och streamat på den nästan hela dagen. Jag tyckte min CPU kylare lät lite väl mycket (Ryzen 7 3700x), så jag letade upp en tråd för att se om det gick att göra något åt. Någon skrev att man kunde ändra kurvan i BIOS, så då startade jag om den, men datorn hängde sig vid "restarting" fönstret. Väntade ca 1 minut, så fick jag nog och höll inne startknappen så att den stängdes ner helt. Då öppnade jag BIOS och ändrade på inställningen till silent, och sparade och startade om. Då står det "operating system not found. Try disconnecting any driver that does not have windows on it" eller väldigt liknande.

Tyckte detta var överjävla märkligt, då jag har spelat på datan hela dagen och allt har verkat frid och fröjd, och nu helt plötsligt så hittar den inte ens windows? Jag testade att sätta alla olika hårddiskar längst upp i boot-ordningen, men det fungerade inte. Jag testade att sätta på default settings i BIOS, funkade inte heller. Kan jag ha pajjat något när datorn hängde sig och att jag stängde av den manuellt?

Så.. Vad fan gör man nu då?

Det låter som du har råkat ut för den icke så trevliga NTFS-buggen, som kan inträffa när går när strömmen bryts vid skrivning till disken.

Med lite tur så kan du reparera partitionen, i annat fall är det ominstallation som gäller.
Kan inte på rak arm komma ihåg vilken mjukvara som eventuellt kan reparera partitionen.

Att någon hårdvara skulle gått sönder är mindre troligt.

Permalänk

@mrE1: Har inte satt in nya diskar. Den hittar alla!

Permalänk
Skrivet av Fenrisulvfan:

@ParanoidRocker: Har du testat göra som det stod, dvs koppla ur alla diskar som inte har Windows på sig? titt som tätt vill datorn köra en diskkontroll när man stänger av datorn med tvång för att reparera filer som var på väg att flyttas när den stängdes av.

Har du riktig otur kan ju din Windows disk ha blivit överhettad när processorfläkten inte fick köra så fort, låter den för mycket så är det nog bättre att byta ut CPU-fläkten då den som kommer med 3700X inte är den bästa.

Låt datorn svalna en stund och testa igen, kolla då även om disken hittas i bios.

Detta hände precis innan jag skulle sova så jag kollade inte. Men ska göra det!

Har svårt att tro att den blev överhettad, jag ändrade liksom på fläktinställningarna när datan inte ville starta, den kom max upp i 50 grader.

Permalänk
Skrivet av Viita:

Det låter som du har råkat ut för den icke så trevliga NTFS-buggen, som kan inträffa när går när strömmen bryts vid skrivning till disken.

Med lite tur så kan du reparera partitionen, i annat fall är det ominstallation som gäller.
Kan inte på rak arm komma ihåg vilken mjukvara som eventuellt kan reparera partitionen.

Att någon hårdvara skulle gått sönder är mindre troligt.

Well shit. Någon annan som vet vilken mjukvara som kan vara till hjälp?

Permalänk

Okay, nu har jag kollat så att kablarna sitter i, vilket de gör i båda ändarna. Jag har också testat att boota i Legacy mode istället för orginal mode (kommer inte ihåg vad det kallades), och det fungerade heller inte. Verkar som att jag inte har några fler val än att ladda ned windows och försöka reparera det via en USB sticka.

Permalänk
Medlem

Att ändra till Legacymode kommer inte hjälpa om du har formaterat hårddisken som en GPT-partition. (Idag bör du inte använda inställningen Legacymode om det inte är av speciell orsak.)
Du kan däremot behöva ändra inställning på "Secure Boot" för att ens kunna boota upp med en USB-sticka.

Jag vet att jag vid några tillfällen återställt rasade partitioner, dock har jag använt en sekundär dator som jag monterat dessa mekaniska diskar i. Har ingen aning om/hur det fungerar på en SSD.

Använder man sökorden "restore, recover, repair, corrupt, NTFS, partition" i passande kombination så får man en hel del sökträffar, men jag inser att det är för länge sedan jag utförde denna operation för att överhuvud taget komma ihåg vad jag använde för mjukvara.

Jag skulle rekommendera att om det slutar med att du installerar om Windows, installera tex macrium reflect och med jämna mellanrum göra en avbild av systemet till en annan disk, om en ominstallation av Windows anses vara mycket omständig.
Det är sedan mycket enkelt att bara återställa systemet, vare sig det är frågan om en korrupt hårddisk, virus eller handhavandefel.

Permalänk
Skrivet av Viita:

Att ändra till Legacymode kommer inte hjälpa om du har formaterat hårddisken som en GPT-partition. (Idag bör du inte använda inställningen Legacymode om det inte är av speciell orsak.)
Du kan däremot behöva ändra inställning på "Secure Boot" för att ens kunna boota upp med en USB-sticka.

Jag vet att jag vid några tillfällen återställt rasade partitioner, dock har jag använt en sekundär dator som jag monterat dessa mekaniska diskar i. Har ingen aning om/hur det fungerar på en SSD.

Använder man sökorden "restore, recover, repair, corrupt, NTFS, partition" i passande kombination så får man en hel del sökträffar, men jag inser att det är för länge sedan jag utförde denna operation för att överhuvud taget komma ihåg vad jag använde för mjukvara.

Jag skulle rekommendera att om det slutar med att du installerar om Windows, installera tex macrium reflect och med jämna mellanrum göra en avbild av systemet till en annan disk, om en ominstallation av Windows anses vara mycket omständig.
Det är sedan mycket enkelt att bara återställa systemet, vare sig det är frågan om en korrupt hårddisk, virus eller handhavandefel.

Okay, ska ändra tillbaka från Legacy mode ändå. Men ska tänka på Secure boot när jag har stickan i!

Det har väl hänt någon gång nu att jag har behövt ominstallera windows, utan att ha en backup, vilket suger stor dolme.. Ska definitivt spana in programmet Macrium reflect.

Permalänk

Okay, har gjort lite framsteg nu.
Köpte en USB sticka och slängde över en windows.iso på den. Försökte fixa felet med diverse kommandotolken grejer, men inget fungerade. Tillslut så tänkte jag att det är kört. Får väl installera windows på nytt. Har en SSD på 64 GB som ligger och skräpar i datorn, så jag valde den. Den installerade, men startade om många gånger, och på ett steg så stod det att man ska välja vilket OS man vill boota ifrån.. Så testade jag det andra alternativet, då det fanns två stycken, och se på självaste fan, min dator bootade! Nu laddade jag hem programmet som ni tipsade om, och jag håller på att skapa en kopia just i detta nu.

Men jag fattar ändå inte vad felet kan vara? Hur jag än gjorde i BIOS, så spelade det inte någon roll i vilken ordning jag satte boot ordern på. Det startade bara inte. Och helt plötsligt så startar det nu?

Permalänk
Medlem

I ett GPT-system så har man minst två partitioner, EFI-partionen där "boot loadern" ligger och sedan Windows-partitionen. Med tanke på att din Windows-installation verkar ha varit intakt så måste det ha varit endast EFI-partitionen som havererade. Denna är dock inte NTFS utan FAT32.
Förmodligen hade du kunnat återskapa boot-partitionen på det sätt som beskrivs här: https://www.youtube.com/watch?v=sOihh4ZNOf4

När du nu installerade om Windows på en annan disk, så har antingen EFI-partitionen på den ordinarie disken återskapats ELLER, så har du en ny EFI-partition med "boot loader" på 64GB-disken.
Du upptäcker detta enkelt genom att ta ut 64GB-disken.
En god idé är dock att säkerhetskopiera före, om det visar sig att du ändå behöver ge dit på att återskapa EFI-partitionen.

Permalänk

@Viita: Ärligt talat så förstod jag inte mycket av vad du skrev. Jag är ganska dålig på windows mjukvara...

Jag kunde tillslut kopiera min hårddisk och formatera orginalet och ominstallera windows. Fick gjort det men nu visar windows ingen text när jag ska installera saker, eller på ikonerna på skrivbordet, eller när man öppnar file explorer...

Nu är jag bortom att vara arg längre, nu vill jag bara lipa.. Att det ska vara så vansinnigt svårt att få datafan att fungera. Precis när man skaffat nya grejer också. Hur fan kan det bli fel när jag formaterade hårddisken??? JAG FATTAR INTEEE!!!

Permalänk
Medlem

Om inte hårddisken blivit raderad, testa Ultimate Boot CD och boota upp och testa att boota från bootloadern där. Det kan rädda systemet. Sen så skriver du i kommandotolken command /mbr
Det var så man gjorde förr i alla fall, tror det funkar fortfarande.

Permalänk

Vill tacka för all hjälp jag fått i tråden, nu fungerar datorn som den ska!