Automatisk backup till NAS?

Permalänk
Medlem

Automatisk backup till NAS?

Detta är nog en rätt banal fråga, jag har en Plexserve ri en nas (WD MyCloud Home) och laddar ner till min stationär dator.
När skärmen släcks kör jag igång en *.Batfil med följande i:
https://pastebin.com/GrcTAwR2

Kopierar jag med Robocopy programmet så flyttar jag filer i 800-1000Mbit, likaså om jag drar över filer i Utforskaren.
Men i ett CMD fönster verkar det max gå 100 mbit.
Hade Xcopy innan (se nedan) men även det kom upp i max 100mbit.

Någon som vet ett bra autobackup program som inte lider av flaskhals?
Man ska kunna bevaka filer med robocopy med, har inte hunnit så långt, skulle shyffla över runt 150-200gb film och det gick toksegt, bytte till Robocopy i stället och får samma problem där.

Körde detta tidigare:
https://pastebin.com/4g2Qf5Nx

Permalänk
Medlem

Tror din bas har stöd för syncthings, då kopierar den så fort ändringarna är gjorda eller när din enhet får kontakt.
Annars kan du lägga upp en ftp server och skriva något script.

Permalänk
Medlem

I ditt script vad gör /r funktionen?

Inte så att det är inställningen för önskad max överföringshastighet i kbyte eller nått då 10Mbyte skulle i runda slängar motsvara 100Mbit eller så.

Och vad händer isf om du lägger till en nolla till?

Mina misstankar är att antingenår det ett hastighetstak eller ett tidsintervall för något.

Permalänk
Medlem

WD MyCloud Home är väl inte någon resursrik NAS och kör du krypterat i överföring eller på filsystem kan det mycket väl ligga på 10-12 MB/s i fart då krypteringen på den stackars lilla ARM-proppen emuleras mjukvarumässigt.

vad är det för fart när du kopierar över en vanlig fil direkt ?

Program av den typen brukar inte ha hastighetsspärr - däremot kan det vara dumma blockstorlekar (för små) eller väntar på svar (ack) för varje del som sänds över innan den sänder nästa paket och det kan då sacka ned mycket.

Att kopiera lokalt på samma disk går alltid fort då svarstiderna är mycket korta för bekräftelse (ack)

Permalänk
Medlem
Skrivet av Rouge of Darkness:

I ditt script vad gör /r funktionen?

Inte så att det är inställningen för önskad max överföringshastighet i kbyte eller nått då 10Mbyte skulle i runda slängar motsvara 100Mbit eller så.

Och vad händer isf om du lägger till en nolla till?

Mina misstankar är att antingenår det ett hastighetstak eller ett tidsintervall för något.

/r[:n] är antalet återförsök om den skulle tappa kontakten, nog viktigare vid extern anslutning

Skrivet av xxargs:

WD MyCloud Home är väl inte någon resursrik NAS och kör du krypterat i överföring eller på filsystem kan det mycket väl ligga på 10-12 MB/s i fart då krypteringen på den stackars lilla ARM-proppen emuleras mjukvarumässigt.

vad är det för fart när du kopierar över en vanlig fil direkt ?

Program av den typen brukar inte ha hastighetsspärr - däremot kan det vara dumma blockstorlekar (för små) eller väntar på svar (ack) för varje del som sänds över innan den sänder nästa paket och det kan då sacka ned mycket.

Att kopiera lokalt på samma disk går alltid fort då svarstiderna är mycket korta för bekräftelse (ack)

Nej det är bokstavligen en låda med skit.
Är nog bättre att ta upp den och sätta disken i datorn, men nu när jag väll fått den att funka och har syncat ner allt från Onedrive, Gdrive, Dropbox m.m + en kopia av min privata backup så va de lätt o bara slänga upp en plexserver på den och låta sambon kasta dit det hon vill se på.

Får kolla på paketstorlekarna, höjde till högsta på nätverkskortet.

Det som förbryllar mig är att jag kan dra över filerna i Utforskaren eller använda Robocopy GUI't och det går upp mot 1 Gbit, men såfort jag kör en batchfil(som admin) så går det bara upp mot 100Mbit.

Har ändrat detta under advancerat för Nic'en:
Flow Controll: RX&TX Enabled (från RX)
Jumbo Package : 9014 (4088) bytes
Speed & Duplex: 1.0gbit full (Auto)
Transmit buffers: 4028 (512)

Permalänk
Medlem

Om du ändrar till jumbo frames så måste du göra det för båda nätverkskorten.