Apache-problem...är detta nån inställning eller?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Apache-problem...är detta nån inställning eller?

Har aldrig upplevt nåt liknande tidigare, men antar att det har med Apache att göra, och att OpenBSD's Apache kommer med lite specialinställningar.

När jag försöker ladda rot-sidan i htdocs funkar det bra.
Försöker jag ladda någon underkatalog så går det bra om jag anger sista slashen, men skriver jag inte dit sista slashen (vilket folk ju normalt inte gör om dom nu inte klickar på en färdig länk) så börjar den ladda från "server.hemma/" där server är server-namnet och hemma är påhittade domän-namnet (eftersom man måste ange ett sånt vid installation vare sig man har en domän eller ej).

Har kört samma server/domän-namn vid andra installationer och det har funkat, så jag antar att det är någon väldigt skum Apache-inställning.

Nån som kan hjälpa? Lite svårt problem att söka hjälp på....vad ska man söka på liksom? "/" kanske

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Ludvika
Registrerad
Jul 2002

vad jag vet så är det någon form av automatisk mod-rewrite som körs då folk glömmer sista slashet (som faktiskt ska vara med om det är en katalog man surfar till), som gör att man kommer fram ändå, ofta efter någon form av sökning eller hur det fungerar, för det blir lite segt.

Så det kanske går att aktivera / avaktivera. Jag läste något om detta på en site ganska nyligen... Hur som helst så kanske du kan lösa det med en egen mod_rewrite om du inte hittar någon inställning?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Oj, jag har aldrig hört talas om mod_rewrite

Jag vet bara att anger man inte "/" så hittas inte filen/katalogen och det får gå en vända fram och tillbaka igen till webbservern och så får man sin "/" automatiskt....typ.

Brukar ju alltid funka, har alltid gjort det förut och jag har kört webbservrar på både Windows och andra BSD.

EDIT: Lägga till denna rad hjälpte iallafall inte

# rule-based rewriting engine to rewrite requested URLs on the fly
LoadModule rewrite_module /usr/lib/apache/modules/mod_rewrite.so

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Registrerad
Mar 2003

Re: Apache-problem...är detta nån inställning eller?

Citat:

Ursprungligen inskrivet av Seb74
[...]
Nån som kan hjälpa? Lite svårt problem att söka hjälp på....vad ska man söka på liksom? "/" kanske

http://www.google.se/search?q=ending+url+with+slash

Trädvy Permalänk
Medlem
Plats
Bollnäs
Registrerad
Maj 2002

Man kan ju tvinga den att slänga dit ett slash efteråt (mod_rewrite)

Men när jag hade samma problem för många år sen, så fixade det sig genom att jag satt dit ett vettigt/riktigt ServerName i httpd.conf istället..

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av bogg
Man kan ju tvinga den att slänga dit ett slash efteråt (mod_rewrite)

Men när jag hade samma problem för många år sen, så fixade det sig genom att jag satt dit ett vettigt/riktigt ServerName i httpd.conf istället..

Men det är ju konstigt att detta aldrig hänt förut. Måste vara OpenBSD's Apache då som beter sig så här, och då borde ju många vara "drabbade", för jag kör än så länge httpd.conf helt orörd och standard install.

Dock kanske jag är ensam om att inte ha en egen riktig domän i mitt hemmanätverk...

Skulle ju vara kul att veta hur alla andra fungerande Apache kör....vad har dom för rad i konfen som fixar detta på det "normala" sättet måntro?

EDIT: Testar ändra ServerName (där det står i httpd.conf att man inte ska hitta på domän/server-namn för då kan det bli knas) och sätter det till min no-ip address istället, men det funkar inte heller tydligen
Och ja, jag startar om Apache mellan ändringar
EDIT2: Ändra till mitt lokala ip gör ingen skillnad heller. Oavsett vad jag ändrar till så står det fortfarande "väntar på server.hemma för dom som försöker gå in utifrån."

Ska jag behöva ändra server/domän-namn på hela servern, och säga att den heter "seb74" och att domänen är "no-ip.com" istälet för server.hemma som jag hittade på???

EDIT3: Nej ändra servernamn på hela burken till mitt no-ip hjälpte inte heller
Helt sjukt ju. Varför ska OpenBSD ha sån special-Apacheinställning för :S

CCNA sedan juni 2006

Trädvy Permalänk
Medlem
Plats
Bollnäs
Registrerad
Maj 2002

Info från Apaches FAQ för Apache 1.3-serien:

When you access a directory without a trailing "/", Apache needs to send what is called a redirect to the client to tell it to add the trailing slash. If it did not do so, relative URLs would not work properly. When it sends the redirect, it needs to know the name of the server so that it can include it in the redirect. There are two ways for Apache to find this out; either it can guess, or you can tell it. If your DNS is configured correctly, it can normally guess without any problems. If it is not, however, then you need to tell it.

Add a ServerName directive to the config file to tell it what the domain name of the server is.

The other thing that can occasionally cause this symptom is a misunderstanding of the Alias directive, resulting in an alias working with a trailing slash, and not without one. The Alias directive is very literal, and aliases what you tell it to. Consider the following example:

Alias /example/ /home/www/example/

The above directive creates an alias for URLs starting with /example/, but does not alias URLs starting with /example. That is to say, a URL such as http://servername.com/example/ will get the desired content, but a URL such as http://servername.com/example will result in a "file not found" error.

The following Alias, on the other hand, will work for both cases:

Alias /example /home/www/example

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Tack

Men jag fattar inte varför den inte kan ta inkommande förfrågan och bara lägga till slash på slutet UTAN att skriva om hela addressen med nåt jäkla servernamn.
Jag menar, det som kom in till servern är ju uppenbarligen rätt eftersom det hittade fram, så varför byta ut det mot något lokalt lagrat innan slashen klistras dit???
Är det kanske så att Apache inte har en aning om vad klienten skrivit in för address för att komma fram? Men i så fall borde ju seb74.no-ip.com i ServerName funka?

Sen testade jag ju att slänga in seb74.no-ip.com i ServerName och det gick inte heller. Kankse är nåt special i Apache 1.3, jag har ju bara kört Apache 2 tidigare.
Löser det sig inte blir det ju adjöss med OpenBSD och in med nåt annat jag vet inte vad, för såhär kan man ju inte ha det iallafall.

Tänker iallafall inte köpa mig någon riktig domän som lösning

CCNA sedan juni 2006

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

Det där har inte med OpenBSD att göra, det är Apache som fungerar så.

Har tyvärr glömt bort vad inställningen i httpd.conf heter, men jag kan leta runt.

EDIT: Hittade.

DirectorySlash On

http://httpd.apache.org/docs/2.2/mod/mod_dir.html

För övrigt så fungerar inte mitt Apache så och jag har det inte i min konfigurationsfil, så det är möjligt att OpenBSD har det avstängt i standardkonfigurationen (min httpd.conf är skriven från scratch).

Dessutom så anser jag att man inte kastar ut ett helt operativsystem för en så liten sak, bara att lägga till ett slash efter katalogen och vara lycklig (jag lägger alltid till slash efter kataloger av vana ), annars lär du få byta OS väldigt ofta. Nyckelord som användes i Apaches dokumentation när jag sökte: 'trailing slash', tredje träffen, 'apache trailing slash' ger första träffen på Google.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av m0REc
Det där har inte med OpenBSD att göra, det är Apache som fungerar så.

Har tyvärr glömt bort vad inställningen i httpd.conf heter, men jag kan leta runt.

EDIT: Hittade.

DirectorySlash On

http://httpd.apache.org/docs/2.2/mod/mod_dir.html

För övrigt så fungerar inte mitt Apache så och jag har det inte i min konfigurationsfil, så det är möjligt att OpenBSD har det avstängt i standardkonfigurationen (min httpd.conf är skriven från scratch).

Dessutom så anser jag att man inte kastar ut ett helt operativsystem för en så liten sak, bara att lägga till ett slash efter katalogen och vara lycklig (jag lägger alltid till slash efter kataloger av vana ), annars lär du få byta OS väldigt ofta. Nyckelord som användes i Apaches dokumentation när jag sökte: 'trailing slash', tredje träffen, 'apache trailing slash' ger första träffen på Google.

Stort tack, det lär ju underbart....kanske för underbart...

# apachectl start
Syntax error on line 357 of /var/www/conf/httpd.conf:
Invalid command 'DirectorySlash', perhaps mis-spelled or defined by a module not included in the server configuration
/usr/sbin/apachectl start: httpd could not be started

Sen är det ju lätt för mig att lägga till slash på slutet, men är ju inte säkert att alla andra som ska in och kolla grejer på servern är så noggranna.

CCNA sedan juni 2006

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

Aha, var tydligen 2.x-option. =/

Har du kollat igenom hela httpd.conf och kollat om det finns något liknande (läs kommentarerna)?

För min del fungerar det som sagt inte så.

Har tittat runt lite nu och Apache ska tydligen lägga till ett / på slutet som standard (DirectorySlash kom i 2.x för att kunna stänga av det).

EDIT:
Hittade ingenting i standard-httpd.conf heller så.

Tror snarare att det är ServerName och UseCanonicalName som ställer till saker. Men det står på on som standard så det ska vara korrekt.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av m0REc
Aha, var tydligen 2.x-option. =/

Har du kollat igenom hela httpd.conf och kollat om det finns något liknande (läs kommentarerna)?

För min del fungerar det som sagt inte så.

Har tittat runt lite nu och Apache ska tydligen lägga till ett / på slutet som standard (DirectorySlash kom i 2.x för att kunna stänga av det).

EDIT:
Hittade ingenting i standard-httpd.conf heller så.

Tror snarare att det är ServerName och UseCanonicalName som ställer till saker. Men det står på on som standard så det ska vara korrekt.

Jo jag har letat igenom och inte hittat något, förutom ServerName då, men det verkar inte funka att sätta den till seb74.no-ip.com vilket jag tycker det borde göra när man läser vad ServerName är och vad det är till för.

UseCanonicalName vet jag inte om det kan ha med saken att göra, men det är inget jag ändrat på iallafall.

EDIT: Verkar som att lägga till seb74.no-ip.com som ServerName funkar iallafall....ska fixa fler som kan verifiera. Har för mig jag ändrade precis så tidigare och någon sa att det inte funkade, men det kanske låg nåt cachat på hennes burk eller nåt jag vet inte.
Verkar som det funkar nu iallafall, ni kan ju testa med tex denna om ni orkar
Alltså UTAN sista slashen utskriven.
http://seb74.no-ip.com/sebastians_dator

CCNA sedan juni 2006

Trädvy Permalänk
SweClockers
Andreas Dimestam
Plats
Stockholm
Registrerad
Apr 2002

*flyttad*

Trädvy Permalänk
Medlem
Registrerad
Mar 2003

Re: Re: Apache-problem...är detta nån inställning eller?

Citat:

Ursprungligen inskrivet av jucce
http://www.google.se/search?q=ending+url+with+slash

Men kolla på denna länk! Lösningen finns här.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Re: Re: Re: Apache-problem...är detta nån inställning eller?

Citat:

Ursprungligen inskrivet av jucce
Men kolla på denna länk! Lösningen finns här.

Jo jag kikade igenom några av de första träffarna där.

Tror iallafall det är löst nu, med min no-ip address inskriven som ServerName i httpd.conf.
Tror jag testade det innan idag och fick verifierat att det inte funkade, men det kan ha varit nån cachad sida eller nåt hos testaren, för det verkar funka nu.

Testa själva om den laddar eller om den tugga på med server.hemma och inte kommer nånvart med länken nedan utan avslutande slashen.

http://seb74.no-ip.com/sebastians_dator

CCNA sedan juni 2006

Trädvy Permalänk
Testpilot
Plats
Norrköping
Registrerad
Sep 2002

För mig rättas adressen till och det blir ett / på slutet även om man skrev den utan, funkar perfekt med andra ord

Kolla gärna in min RGB-LED-ljusstake i galleriet
[Gigabyte GA-Z97MX-Gaming 5][Intel Core i5 4690K][Corsair XMS3 8GB][Gigabyte GeForce GTX 970 G1 Gaming]

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av hunden
För mig rättas adressen till och det blir ett / på slutet även om man skrev den utan, funkar perfekt med andra ord

Great, då var det ServerName i httpd.conf som skulle ändras till min no-ip address.
Har aldrig behövt göra så tidigare, men det kanske har med min "nya" uppkoppling att göra också där det som för så många andra med router är så att jag inte kan surfa in till min egen no-ip genom routern, utan får ha lokala alias i hemmet om jag vill att det ska funka.
Kanske det också som gör att den inte kan känna av sin egen address typ...

CCNA sedan juni 2006