CPU pendlar i Watt-tal och frekvens

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010

CPU pendlar i Watt-tal och frekvens

Hej!
Jag har ett fantastiskt jobbigt problem som inträffade idag när jag bytte cpu-fläkt.
Skulle spela COD: Black Ops och märkte att jag droppade i FPS i intervaller, märkbart droppade. Så jag gick in i SIW, System Information for Windows, och märkte att CPU:n pendlade i sin energiförsörjning. Från 44W till 140W. Märkte samtidigt att frekvensen på CPU:n pendlade mellan 800 MHz och 3000 MHz. Den fortsätter att göra så; konstant pendlande alltså.
Jag smaskade på lite kylpasta, kan jag ha tagit för mycket och lite har hamnat på fel ställe? Vad kan jag göra för att åtgärda?
Eller vad kan annars vara problemet? Går det att tvinga processor till en viss energiförbrukning?

Vänligen,
Jonathan

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005
Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010

Efter hasenfrasen's inlägg har jag suttit och googlat SpeedStep. Jag har ju en AMD processor så jag har testat att avaktivera dess motsvarigheter: C1E, Cool'n Quiet. Jag har uppdaterat BIOs.
Jag har försökt sätta Multipliern på x15 så den matchar hastigheten på min CPU.
Enligt CPU-Z så kvarstår mitt problem trots dessa åtgärder: Från 3,0 GHz till 800 MHz; Multipliern går från x15 till x4.
Om det nu är någon sorts SpeedStep som reglerar energiförsörjningen till CPU:n, varför fortsätter den reglera när jag spelar COD: Black Ops? Borde den inte sluta reglera när jag spelar t.ex.?
Finns det något sätt jag kan låsa den energin som ska tillföras CPU:n? Finns det något annat jag inte testat i BIOs som jag borde testa?

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Maj 2005
Skrivet av Jontett:

Efter hasenfrasen's inlägg har jag suttit och googlat SpeedStep. Jag har ju en AMD processor så jag har testat att avaktivera dess motsvarigheter: C1E, Cool'n Quiet. Jag har uppdaterat BIOs.
Jag har försökt sätta Multipliern på x15 så den matchar hastigheten på min CPU.
Enligt CPU-Z så kvarstår mitt problem trots dessa åtgärder: Från 3,0 GHz till 800 MHz; Multipliern går från x15 till x4.
Om det nu är någon sorts SpeedStep som reglerar energiförsörjningen till CPU:n, varför fortsätter den reglera när jag spelar COD: Black Ops? Borde den inte sluta reglera när jag spelar t.ex.?
Finns det något sätt jag kan låsa den energin som ska tillföras CPU:n? Finns det något annat jag inte testat i BIOs som jag borde testa?

Vad ligger temperaturen på processorn på under spelande? Du kan få just detta problem om kylaren sitter dåligt och temperaturen blir för hög. Då klockar processorn ned sig och sänker volten för att skydda processorn mot överhettning.

~Pelle~

Trädvy Permalänk
Medlem
Plats
karlskrona
Registrerad
Maj 2008
Skrivet av WrongTarget:

Vad ligger temperaturen på processorn på under spelande? Du kan få just detta problem om kylaren sitter dåligt och temperaturen blir för hög. Då klockar processorn ned sig och sänker volten för att skydda processorn mot överhettning.

Skrivet av Jontett:

Hej!
Jag har ett fantastiskt jobbigt problem som inträffade idag när jag bytte cpu-fläkt

Man skulle nog kunna säga att oddset är 100 mot 1 till WrongTargets fördel!

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av WrongTarget:

Vad ligger temperaturen på processorn på under spelande? Du kan få just detta problem om kylaren sitter dåligt och temperaturen blir för hög. Då klockar processorn ned sig och sänker volten för att skydda processorn mot överhettning.

Tack för ett vettigt svar!
Enligt SpeedFan låg temperaturen strax över 50 grader under tiden jag spelade, så det ska väl inte vara några problem? Och under tiden så droppade jag från 60 FPS, laggfritt, till 15 FPS med en djävla massa lagg.

Trädvy Permalänk
Hedersmedlem
Plats
Omnipresent
Registrerad
Okt 2004

Vad har du för OS? I Vista och W7 kan man ju ställa in hur datorn skall bete sig energisparmässigt, vad står det på din?

Gud är Död! - Nietzsche
Nietzsche är Död! - Gud

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av Jalle64:

Vad har du för OS? I Vista och W7 kan man ju ställa in hur datorn skall bete sig energisparmässigt, vad står det på din?

Jag har w7 och jag glömde nämna att jag ändrat de inställningarna. Satte de på hög prestanda, plus att jag aldrig hade detta problem trots standard inställningar förut.

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005
Skrivet av Jontett:

plus att jag aldrig hade detta problem trots standard inställningar förut.

...och vad har ändrats sedan "förut"?

Att SpeedStep/Cool&Quiet funkar vet du iaf om och så länge man inte överklockar typ med flytande kväve finns det ingen anledning att inaktivera den funktionaliteten.

Vad säger OCCT om din CPU och vad får du då för temp på kärnorna?

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av hasenfrasen:

...och vad har ändrats sedan "förut"?

Att SpeedStep/Cool&Quiet funkar vet du iaf om och så länge man inte överklockar typ med flytande kväve finns det ingen anledning att inaktivera den funktionaliteten.

Vad säger OCCT om din CPU och vad får du då för temp på kärnorna?

Ändrats sedan förut? Vad menar du?

De ändra kärnorna beter sig på samma vis. Det är just dom dropsen som man ser kommer med jämna mellanrum som aldrig slutar inträffa, trots belastning.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Dec 2008

Skumt problem. Det låter underligt att det skulle ha att göra med kylarbytet då temperaturen är så jämn och låg.

Orkar du byta tillbaka till standardkylaren och se om problemet kvarstår?

AZRock Z87 Extreme4 | i5 4670K | MSI GTX780 TwinFrozr | 8GB Corsair Vengance | Samsung 840 EVO 250GB | WD 3 TB | Corsair HX520 | HP LP3065 + 2x HP LP2065 (4960x1600) | Trulyergonomic keyboard (bruna) | Mionix Castor

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av Mackansson:

Skumt problem. Det låter underligt att det skulle ha att göra med kylarbytet då temperaturen är så jämn och låg.

Orkar du byta tillbaka till standardkylaren och se om problemet kvarstår?

Den låga temperaturen beror nog på att jag inte satt på locket till chassit utan att det står öppet, men dock så reagerar den ju konstigt ändå.

Ska ge det ett försök omedelbart.
Edit: Kylarbytet gjorde ingen skillnad, så vi kan väl utesluta den från ekvationen.
När multipliern ändrar sig till 800MHz, så går även CoreVoltagen ner till 1.0 från ca 1.4. Rörelsemönstret på CoreVoltagen kan man även följa i BIO:s.
Hårdvaruproblem?

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Dec 2008

Felet infann sig när du bytte kylare förra gången? Kan man misstänka att du kommit åt nåt då? Låter fortfarande lite konstigt.

AZRock Z87 Extreme4 | i5 4670K | MSI GTX780 TwinFrozr | 8GB Corsair Vengance | Samsung 840 EVO 250GB | WD 3 TB | Corsair HX520 | HP LP3065 + 2x HP LP2065 (4960x1600) | Trulyergonomic keyboard (bruna) | Mionix Castor

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av Mackansson:

Felet infann sig när du bytte kylare förra gången? Kan man misstänka att du kommit åt nåt då? Låter fortfarande lite konstigt.

Felet infann sig när jag bytte kylare igår. Har inte varit några problem innan. Jag vet inte vad jag kan ha kommit åt: det skulle vara att processorn fått sig lite skada för det krävdes en del kraft att montera dit skiten. Kan det vara så att det är dålig kontakt mellan cpu:n och moderkortet?

Trädvy Permalänk
Medlem
Plats
Åstorp
Registrerad
Okt 2008

Ställ bara in energialternativet i kontrollpanelen på "Hög Prestanda" då ska den inte droppa i frekvens längre.

Droppa i volt och frekvens är precis vad den ska göra, som text nu när jag skriver här på, så ligger min på 800mhz. Även när jag tabbar ut från spel, så sjunker den så fort man maximerar spelet igen är den på max.

AMD FX-8350 | Enermax Liqtech 120X | 8GB Kingston HyperX Grey 1600mhz | SSD: Samsung 840 120GB |HDD: Samsung F3 1TB, Western Digital Green 500GB | Gigabyte 990FXA-UD3 | Sapphire R9 290 | OCZ ZT 550w | Fractal Design Define R2 Black Pearl |Toshiba Chromebook 2 | Mac Mini 2011| BF3: Thursfield | Citera så svarar jag snabbare.

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av Eltarion:

Ställ bara in energialternativet i kontrollpanelen på "Hög Prestanda" då ska den inte droppa i frekvens längre.

Droppa i volt och frekvens är precis vad den ska göra, som text nu när jag skriver här på, så ligger min på 800mhz. Även när jag tabbar ut från spel, så sjunker den så fort man maximerar spelet igen är den på max.

Om du faktiskt tagit dig tiden att läsa igenom resten av tråden så hade du förstått att jag redan gjort detta, och att problem fortsätter medan jag är in-game. Jag droppar från 60 FPS till 20 i intervaller hela tiden.

Trädvy Permalänk
Hedersmedlem
Plats
Omnipresent
Registrerad
Okt 2004

Det enda jag kan komma på så här är att se om det finns nyare bios till ditt mobo

Gud är Död! - Nietzsche
Nietzsche är Död! - Gud

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av Jalle64:

Det enda jag kan komma på så här är att se om det finns nyare bios till ditt mobo

Det är up-to-date. Får se om det kommer några mer tips under helgen, annars plockar jag isär skiten, bygger ihop och till slut formaterar.
Det finns inget sätt att bestämma energin som ska driva CPU:n?

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005
Skrivet av Jontett:

Det finns inget sätt att bestämma energin som ska driva CPU:n?

Det är inte din cpu som är problemet. Det är inte den som gör att dina fps droppar från 60 till 20. Din graf från OCCT-testet säger att din cpu funkar normalt.

Det finns tre möjliga saker kvar att kolla upp.

1) Något lastar disken så att den har svårt att hålla jämt skägg med spelets behov. Defraggad?
2) Din grafik knasar på något sätt. Vad säger FURMARK om ditt grafikkort med burn-in mode?
3) Din internetanslutning knasar på något sätt. Vad säger UOTRACE om din ping mot din spelserver? (kör först en "trace" och välj sen "poll".

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av hasenfrasen:

Det är inte din cpu som är problemet. Det är inte den som gör att dina fps droppar från 60 till 20. Din graf från OCCT-testet säger att din cpu funkar normalt.

Det finns tre möjliga saker kvar att kolla upp.

1) Något lastar disken så att den har svårt att hålla jämt skägg med spelets behov. Defraggad?
2) Din grafik knasar på något sätt. Vad säger FURMARK om ditt grafikkort med burn-in mode?
3) Din internetanslutning knasar på något sätt. Vad säger UOTRACE om din ping mot din spelserver? (kör först en "trace" och välj sen "poll".

Fy fan vad skönt att höra de orden. De absolut bästa nyheterna jag fått på länge.
Jag har aldrig använt FURMARK innan men jag gjorde ett Benchmark-test med Xtreme Burning Mode:
SCORE:1889 points (60000 ms) - Options: XB

Angående internetanslutningen: När jag skulle starta spelet och testa UOTRACE stod det att spelet upptäckt att jag ändrat min hårdvara, någonting i den stilen iallafall. Ingenting har ändrats mer än att CPU:n pendlar upp och ner. Så jag tror på alternativ 1.
Funderar starkt på att formatera skiten utifall att det är någonting annat som spökar.

Trädvy Permalänk
Medlem
Plats
Örebro
Registrerad
Jun 2010

förlåt om jag lånar tråden lite, men min cpu är typ trasig? den är på 2ghz på load vet någon vad som kan va fel?

| i7 930 @ 3.7 ghz| FD R2 | GTX 970 | Cooler Master 850M | 3TB | Gigabyte X58A-UD3R| Corsair vengeance 1600mhz|

We stand alone, together.

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010

Har nu formaterat datorn och det löste inte problemet.
När jag startar spelet under en klockfrekvens-dropp så påpekar Steam att min hårdvara har ändrats och frågar om jag vill optimera inställningarna efter detta? Ska detta verkligen vara så om den nu går under SpeedStep? Detta verkar inte vara SpeedStep som reglerar min CPU, eller så reglerar den okontrollbart...
Detta måste vara något problem med min hårdvara, eller?

Trädvy Permalänk
Medlem
Plats
Hemma
Registrerad
Okt 2005
Skrivet av Jontett:

Har nu formaterat datorn och det löste inte problemet.
När jag startar spelet under en klockfrekvens-dropp så påpekar Steam att min hårdvara har ändrats och frågar om jag vill optimera inställningarna efter detta? Ska detta verkligen vara så om den nu går under SpeedStep? Detta verkar inte vara SpeedStep som reglerar min CPU, eller så reglerar den okontrollbart...
Detta måste vara något problem med min hårdvara, eller?

cod black ops fungerade alltså prima innan du bytte kylaren?

det spelet har ju blivit ganska känt för att ha prestandaproblem nämligen.

vad jag har läst så har du inte kunnat säkerställa att processorn klockat ner sig medans du spelar. ( kan ha missat )

t.ex rivatuner kan logga frekvens , på så sätt bör du kunna säkerställa om det är problemet eller ej.

| HAF932 | Xeon X5675 @ 4 GHz | ASUS P6T Deluxe V2 | 18 GB @ 1391 MHz | R9 290X | O2 + ODAC | Samsung 850 500 GB + 2x WD Black 640 GB @ raid 0 + 2x Samsung 500 GB @ raid 0 | Win10 Pro 64-bit |

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av Devildoll:

cod black ops fungerade alltså prima innan du bytte kylaren?

det spelet har ju blivit ganska känt för att ha prestandaproblem nämligen.

Jo det fungerade felfritt innan jag bytte kylaren. Jag tror ju inte att kylarbytet har orsakat detta, men det var i samband med bytet och efter installationen som jag upptäckte problem. Dagen innan hade jag inte detta problem.

Skrivet av Devildoll:

vad jag har läst så har du inte kunnat säkerställa att processorn klockat ner sig medans du spelar. ( kan ha missat )
t.ex rivatuner kan logga frekvens , på så sätt bör du kunna säkerställa om det är problemet eller ej.

Nej jag har inte säkerställt att CPU-klockfrekvens droppar under ingame. Ska undersöka detta omedelbart. Du vet inget annat program som kan logga frekvensen än RivaTuner? Verkar inte vara kompatibelt med min hårdvara.

Trädvy Permalänk
Medlem
Plats
Hemma
Registrerad
Okt 2005

coretemp kan logga. Core Temp

den loggar till en csv fil i programmappen . var 10e sekund.
funktionen måste aktiveras under "tools"

testade lite själv , och hos mig låg processorn på full fart under hela tiden som jag harde black ops igång.

| HAF932 | Xeon X5675 @ 4 GHz | ASUS P6T Deluxe V2 | 18 GB @ 1391 MHz | R9 290X | O2 + ODAC | Samsung 850 500 GB + 2x WD Black 640 GB @ raid 0 + 2x Samsung 500 GB @ raid 0 | Win10 Pro 64-bit |

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010

Så, nu har jag konstaterat att det är CPU:n som skapar FPS dropsen:
Körde CPU RightMark Test samtidigt som jag hade uppe CoreTemp. FPS droppade precis som jag trodde efter hur CPU:n pendlar:
Låg FPS
Hög FPS
Någon som har en aning om vad det handlar om?

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005
Skrivet av Jontett:

Någon som har en aning om vad det handlar om?

Kör: POWERCFG -ENERGY
och posta resultatet.

Processor Power Management in Windows 7 and Windows Server 2008 R2

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010

Tog idag med CPU:n till en polare och stoppade in skiten i hans dator.
Där funkade den prima. Lånade dessutom hem hans gamla CPU och testade i min dator och den har samma effekt, pendlandet osv.. Jag börjar tro att det är någonting fel på mitt moderkort. Eller är jag helt ute och cyklar?

Trädvy Permalänk
Medlem
Plats
Hemma
Registrerad
Okt 2005
Skrivet av Jontett:

Tog idag med CPU:n till en polare och stoppade in skiten i hans dator.
Där funkade den prima. Lånade dessutom hem hans gamla CPU och testade i min dator och den har samma effekt, pendlandet osv.. Jag börjar tro att det är någonting fel på mitt moderkort. Eller är jag helt ute och cyklar?

kan vara operativsystemet .
kan nog vara intressant att köra powercfg -energy i en kommandoprompt som hasenfrasen föreslagit

om polarn orkar så kan du låta honom köra din dator med hans operativsystem(hårddisk)

| HAF932 | Xeon X5675 @ 4 GHz | ASUS P6T Deluxe V2 | 18 GB @ 1391 MHz | R9 290X | O2 + ODAC | Samsung 850 500 GB + 2x WD Black 640 GB @ raid 0 + 2x Samsung 500 GB @ raid 0 | Win10 Pro 64-bit |

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Nov 2010
Skrivet av hasenfrasen:

Resultat uppladdat på 2Shared

Skrivet av Devildoll:

kan vara operativsystemet .
kan nog vara intressant att köra powercfg -energy i en kommandoprompt som hasenfrasen föreslagit

om polarn orkar så kan du låta honom köra din dator med hans operativsystem(hårddisk)

Jag formaterade och installerade om W7 i förrgår, så det känns ju konstigt att det skulle vara det?