HTPCn orkar inte riktigt med HD-film, bör uppgraderas?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Feb 2006

HTPCn orkar inte riktigt med HD-film, bör uppgraderas?

Hallå!
För ett tag sedan plockade jag ihop en liten mediadator med följande komponenter:

Zotac ION ITX A
1 st A-Data 2048MB 800Mhz
250GB Samsung 2.5" HD250HI M7 5400rpm
Samsung 8X Slot-In, SATA Slim
Sitter även en Seagate 320Gb 2.5" 5400rpm från min laptop i den.
Som så många andra så kör även jag XBMC.

När filmsamlingen sakta växte så märkte jag att datorn inte riktigt pallade att köra HD-filmer, de flyter inte riktigt bra. Hade inte problem med detta när datorn var ny. Så frågan är nu vad detta kan bero på? Är det helt enkelt att hårddiskarna börjar bli fulla och är för långsamma? Bör jag utöka RAM? Alla idéer är välkommna!

// X

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Maj 2011

Hur exakt inte orkar med menar du? Lagg på uppselning av HD film eller att hela datorn segar ner när du spelar upp ?

Om du har en annan dator kan du ju testa med den datorns HDD i HTPCn för att testa det.

Annars specifiera mer om problemet.

Trädvy Permalänk
Medlem
Plats
Kalmar
Registrerad
Jun 2011
Skrivet av X-modify:

Hallå!
För ett tag sedan plockade jag ihop en liten mediadator med följande komponenter:

Zotac ION ITX A
1 st A-Data 2048MB 800Mhz
250GB Samsung 2.5" HD250HI M7 5400rpm
Samsung 8X Slot-In, SATA Slim
Sitter även en Seagate 320Gb 2.5" 5400rpm från min laptop i den.
Som så många andra så kör även jag XBMC.

När filmsamlingen sakta växte så märkte jag att datorn inte riktigt pallade att köra HD-filmer, de flyter inte riktigt bra. Hade inte problem med detta när datorn var ny. Så frågan är nu vad detta kan bero på? Är det helt enkelt att hårddiskarna börjar bli fulla och är för långsamma? Bör jag utöka RAM? Alla idéer är välkommna!

Hårddisken är inte flaskhalsen, där är hastigheten helt klart nog om du inte gått upp rejält i kvalitet på filmerna. Sannolikt har du på något sätt fått in mer program i bakgrunden, skaffat nya codec eller så har din mediaspelare fått en uppdatering som inte funkat/ändrat hårdvaruinställningarna.

Testa med Mediaplayer Classic och DXVA aktiverat (osäker på om det är på som standard, annars aktivera och ha senaste drivrutinerna)

Storburk: i7 2600K@4,0 GHz, ASUS P8P67 Pro-M, FD Define Mini, CMH212+, CM M2 Silent 720W, 16 GB, R9 290X MSI Lightning, SSD + HDD - HTPC: i3 4330T, 4 GB, SSD, XFX HD7850, BeQuiet 550W - Bärbar: ASUS F3SR, Core2Duo@2,6-3,1Ghz 4 GB, SSD

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Feb 2006

Ber om ursäkt för att jag var lite oklar, problemet är att det laggar. Det är inte grovt lagg, men tillräckligt för att man ska störa sig på det. Det kan ligga någonting i det du säger Videoapan, min andra dator kraschade och jag var tvungen att använda htpc'n som enda dator under en tid. Det innebar att jag var tvungen att lägga in lite program och diverse. Har dock tagit bort i princip allt förutom XBMC nu, men kanske vore bäst med en total rensning och nyinstallation. Jag återkommer med resultat!

// X

Trädvy Permalänk
Medlem
Plats
Chonburi, Thailand
Registrerad
Apr 2005

Är du säker på att det inte är vanligt film judder?
Alltså det du får om du inte kör 24p?

Nämns inget annat så menar jag denna maskinen:
ASUS G53SW - Intel i7-2630QM @ 2.00Ghz - 12GB RAM - Nvidia GeForce GTX460M 1.5GB
Intel 510 SSD 128GB - Seagate Momentus XT SSHD 500GB - Windows 7 x64 Ultimate SP1
Chrome v38/latest, Chrome Canary och Firefox for development / debug

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Feb 2002

Kan du inte bara kolla hur din cpu användning ligger vid uppspelning? Då får du ju ganska snabbt reda på om det är det som är problemet...

... zzZZzzzZzzzzzZzzz ....

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2007

Vad kör du för OS i botten på XBMC? Windows, Linux eller mot förmodan OSX?

WS: Bärbar workstation, 2 * Dell U2412M
HTPC: Intel NUC, Canton GLE 496, Yamaha RV-A830, Sanyo PLV-Z700
Server: Intel Xeon E3-1240@3.4 GHz, ESXi, 16GB RAM, 8*2TB RAID-Z2 + SSD-cache
Slösurf: MacBook Air 11,6", Nokia Lumia 925, OnePlus Two
Kamera: Canon EOS 5DII + 1DIII, Canon 100/2.8 Macro, Canon 70-200/2.8L, Canon 24-70/2.8L

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Aktivera hårdvaruacceleration i xbmc

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Feb 2006
Skrivet av Fade-swe:

Kan du inte bara kolla hur din cpu användning ligger vid uppspelning? Då får du ju ganska snabbt reda på om det är det som är problemet...

Cpu användningen ligger på låga nivåer, så det verkar lungt där.

Skrivet av zyberzero:

Vad kör du för OS i botten på XBMC? Windows, Linux eller mot förmodan OSX?

Windows 7 Professional

Skrivet av Josasp:

Är du säker på att det inte är vanligt film judder?
Alltså det du får om du inte kör 24p?

Jag är inte säker på att jag fattar vad du menar, är inte särskilt insatt i allt detta....

Skrivet av zodiakonline:

Japp hårdvaruacceleration har jag haft aktiverat hela tiden.

// X

Trädvy Permalänk
Medlem
Plats
Osby
Registrerad
Aug 2010

kasta windows åt pepparn å kör in xbmc's egna linux dist kanske kan va ett tips ...uppgradering för 0 kr ...förutsatt att du fixar å installera det.

Carmilla: Intel 2600k, 8gb RAM 1600mhz, SSD EVO840, gtx760,. Workstation/Spelmaskin OS:Windows 8.1
Marcilla: AMD A4, 4gb RAM 1600mhz NAS/SQL/HTPC, OS: Linux MINT

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Köp en mediaspelare av märket Xtreamer.
Funkar perfekt till 720p/1080p och du slipper lagg med.
Koppla in 2 st 1TB externa hårddiskar,eller streama över ditt nätverk.
Klarar alla tänkbara format,och du slipper att konvertera.

Skall du spela upp BluRay-rippar så skall det till en rätt så kraftfull dator tyvärr.

Ser att du bara har 2GB Ram,som är i underkant för uppspelning av HD-material.

Mina tips är:

Uppgradera Ram-minnet till 3-4 GB,installera GOM Player.
Fungerar inte detta;köp en separat mediaspelare och spela upp från den.
Har en Xtreamer Sidewinder och är helnöjd.Har bara 1080p BluRay rippar på den.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2003
Skrivet av blogtweeter1:

Köp en mediaspelare av märket Xtreamer.
Funkar perfekt till 720p/1080p och du slipper lagg med.
Koppla in 2 st 1TB externa hårddiskar,eller streama över ditt nätverk.
Klarar alla tänkbara format,och du slipper att konvertera.

Skall du spela upp BluRay-rippar så skall det till en rätt så kraftfull dator tyvärr.

Ser att du bara har 2GB Ram,som är i underkant för uppspelning av HD-material.

Mina tips är:

Uppgradera Ram-minnet till 3-4 GB,installera GOM Player.
Fungerar inte detta;köp en separat mediaspelare och spela upp från den.
Har en Xtreamer Sidewinder och är helnöjd.Har bara 1080p BluRay rippar på den.

Har också en xtreamer sidewinder och har haft lite problem med den, den hittar inte datorer i nätverket, detta sker lite titt som tätt, varken OS X burkar eller Windows burkar. Men när den väl fungerar så gör den det smärtfritt, stödjer allt.

Spelburk: Fortress FT02 | R7 Ryzen 1700@Stock | Corsair AX850 | Samsung 830 256 GB | Palit Jetstream GTX 1080 | G.Skill 3200MHz 32GB RAM | ROG Swift PG279Q
HTPC 1: Streacom F1C | AMD A-5600K | Crucial M4 64 GB | 8 GB RAM @ 1866 MHz
HTPC 2: Raspberry Pi -> Raspbmc

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Som jag ser det är det en enkel lösning:

1)uppgradera datorn.
2)Köp en mediaspelare.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Skrivet av ZOiDVOiD:

kasta windows åt pepparn å kör in xbmc's egna linux dist kanske kan va ett tips ...uppgradering för 0 kr ...förutsatt att du fixar å installera det.

Detta tror jag också är lösningen. Atom med Nvidia ION ska flyta på bra med XBMC i Linux när allt är konfigurerat och klart. Till skillnad mot Windows blir inte Linux slöare med tiden på samma sätt. Möjligen om det kommer in damm i burken så att kylningen blir så dålig att processorn måste klocka ner sig för att inte överhettas. Så kolla att kylningen är OK också.

Om nu den var bra när den var ny, har du testat installera om den så att den blir likadan som när den var ny?

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Feb 2002
Skrivet av ZOiDVOiD:

kasta windows åt pepparn å kör in xbmc's egna linux dist kanske kan va ett tips ...uppgradering för 0 kr ...förutsatt att du fixar å installera det.

Äh, knappast windows som är problemet i det här fallet. Om prollen knappt är belastad under uppspelning och det "hackar" ändå så är det någon felinställning.

Kan det vara så att tv'n tidigare har stått på något yberduper 100hz läge och förstört bilden med onormalt mkt flyt?

Om tv'n klarar hantera 24p korrekt (kolla upp tv'n på nätet) = se till så att utsignalen är 24p (23.976hz) från din box till tv'n. Annars skickas den säkerligen ut med 50 eller 60hz och då får du ryck i panoreringar.

Klarar den inte 24p = Lev med juddret, eller slå på något bildförstörande som 100hz, brukar heta något som smooth motion eller något annat tjaffs. Personligen hade jag hellre sett med lite ryck när bilden panorerar.

Skrivet av ronnylov:

Detta tror jag också är lösningen. Atom med Nvidia ION ska flyta på bra med XBMC i Linux när allt är konfigurerat och klart. Till skillnad mot Windows blir inte Linux slöare med tiden på samma sätt. Möjligen om det kommer in damm i burken så att kylningen blir så dålig att processorn måste klocka ner sig för att inte överhettas. Så kolla att kylningen är OK också.

Om nu den var bra när den var ny, har du testat installera om den så att den blir likadan som när den var ny?

Han säger ju faktist att processorn knappt är belastad när han spelar upp film, så låter lite långsökt.

... zzZZzzzZzzzzzZzzz ....

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002

Jo, men ändå så säger att han inte hade problem med detta när datorn var ny så något måste ju ha hänt med datorn sedan den var ny...

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2004
Skrivet av Rosslan:

Har också en xtreamer sidewinder och har haft lite problem med den, den hittar inte datorer i nätverket, detta sker lite titt som tätt, varken OS X burkar eller Windows burkar. Men när den väl fungerar så gör den det smärtfritt, stödjer allt.

Hade samma problem som dig med att Xtreamern inte hittade de delade mapparna. Följde delningsguiderna som finns på Xtreamer.net och tog hem programmet Xtreamer Share Manager. Har två Xtreamers, streamar samma film i 1080p till båda enheterna samtidigt helt laggfritt och har inte längre problem med de delade mapparna.. Ett annat tips kan vara att inte köra Windows Server då det ledde till extrema laggproblem...

Edit: Bör väl även tillägga att jag köpte nyligen en ny Xtreamer Sidewinder på Elgiganten för 540kr. 840kr (internetpris) - 300kr i presentkort om man tecknar ComHem abb utan kostnad, två månader fritt och ingen uppsägningstid... ... Min sambo o mina barn älskar den lättanvändna Xtreamern och det bra priset är ju inget som tar emot heller. Blir en till snart då vi flyttar till hus.

Citera så jag hittar tillbaka...

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Nov 2003
Skrivet av Blomster:

Hade samma problem som dig med att Xtreamern inte hittade de delade mapparna. Följde delningsguiderna som finns på Xtreamer.net och tog hem programmet Xtreamer Share Manager. Har två Xtreamers, streamar samma film i 1080p till båda enheterna samtidigt helt laggfritt och har inte längre problem med de delade mapparna.. Ett annat tips kan vara att inte köra Windows Server då det ledde till extrema laggproblem...

Edit: Bör väl även tillägga att jag köpte nyligen en ny Xtreamer Sidewinder på Elgiganten för 540kr. 840kr (internetpris) - 300kr i presentkort om man tecknar ComHem abb utan kostnad, två månader fritt och ingen uppsägningstid... ... Min sambo o mina barn älskar den lättanvändna Xtreamern och det bra priset är ju inget som tar emot heller. Blir en till snart då vi flyttar till hus.

Okej, har faktiskt använt mig av de guider som finns på deras sida, dock har jag inte hört talas om det programet, fungerar det även till Mac OSX?

Spelburk: Fortress FT02 | R7 Ryzen 1700@Stock | Corsair AX850 | Samsung 830 256 GB | Palit Jetstream GTX 1080 | G.Skill 3200MHz 32GB RAM | ROG Swift PG279Q
HTPC 1: Streacom F1C | AMD A-5600K | Crucial M4 64 GB | 8 GB RAM @ 1866 MHz
HTPC 2: Raspberry Pi -> Raspbmc

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2004
Skrivet av Rosslan:

Okej, har faktiskt använt mig av de guider som finns på deras sida, dock har jag inte hört talas om det programet, fungerar det även till Mac OSX?

Testa detta:
http://shop.xtreamer.net/Support/questions/717/How+to+use+you...

Här är det andra som också har problem med OSX:
https://discussions.apple.com/thread/3204436?start=0&tstart=0

Här är länken till Windows-versionen:
http://xtreamer.net/downloads/community-projects/windows-shar...

Jag har även lagt in Xmp på min Xtreamer, då kan man enkelt ändra teman och lägga in andra funktioner. Kräver dock ett USB eller HDD i enheten. Blev lite offtopic men såg att du hade problem med streamingen så svarade iaf! Lycka till!

Citera så jag hittar tillbaka...

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Feb 2002
Skrivet av ronnylov:

Jo, men ändå så säger att han inte hade problem med detta när datorn var ny så något måste ju ha hänt med datorn sedan den var ny...

Han kan ha...

Ändrat inställning på tv'n.
Ändrat output inställningar i datorn när han använde den som just dator.
Installerat något som har överhanden vid uppspelning under den tiden han använde den som dator (codecpack/spelare osv)

Men att processorn inte belastas så tungt vid uppspelning tyder på att dxva går in och att datorn inte är för "Seg".

... zzZZzzzZzzzzzZzzz ....