FreeNAS och Deluge

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Jun 2014

FreeNAS och Deluge

Har precis byggt färdigt min nya server och fixat Plex Media Server. Skulle gärna vilja köra Deluge som torrent client och inte Transmission som finns som plugin. Någon som har installerat Deluge i jail och kan peka till någon bra guide? Har hittat denna fast kommer bara till en massa rutor som har några alternativ bockade, har klickat OK en evighet känns det som och det tar aldrig slut.. Det hjälper inte heller om jag väljer cancel då det bara fortsätter att komma upp. Jag är väldigt ny till FreeNAS så ni får ursäkta min okunnighet i ämnet.

Dator: i7-6700K | Asus MAXIMUS VIII HERO | Corsair Vengeance LPX 16GB (2 x 8GB) 2666MHz | Samsung 850-Series EVO 1TB | ASUS STRIX GTX 1080 | Corsair Air 540 | EVGA T2 850 | YAMAHA HS7 | Focusrite 2i2

Server: i3-6100 | Gigabyte GA-H270N-WIFI | Corsair Vengeance LPX 16GB (2 x 8GB) 2400MHz | WD Red 9TB (3 x 3TB) | Fractal Design Node 304 | Cooler Master V650

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Tips, om du nu inte redan har bestämt att det bara måste vara FreeNas (eller Nas4Free) och inte orkar mecka så mycket, XPenology (Synology DSM) är ett set-and-forget-for-lazy-persons alternativ - som kan köra Deluge med lite hjälp från http://forum.deluge-torrent.org/viewtopic.php?t=45281

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Jan 2007

Om du kör igång en jail instance, så ska du "bara" kunna installera det som om det vore freeBSD.
http://www.freshports.org/net-p2p/deluge/

Personligen så använder jag den färdiga transmission installationen och det funkar väldigt bra med Web-interfacet.

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Jun 2014

@hasenfrasen: är väldigt nöjd med freenas och kommer nog inte byta.

Dator: i7-6700K | Asus MAXIMUS VIII HERO | Corsair Vengeance LPX 16GB (2 x 8GB) 2666MHz | Samsung 850-Series EVO 1TB | ASUS STRIX GTX 1080 | Corsair Air 540 | EVGA T2 850 | YAMAHA HS7 | Focusrite 2i2

Server: i3-6100 | Gigabyte GA-H270N-WIFI | Corsair Vengeance LPX 16GB (2 x 8GB) 2400MHz | WD Red 9TB (3 x 3TB) | Fractal Design Node 304 | Cooler Master V650

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2007

Har gjort det i icke Jails i NAS4Free. Fungerade lika bra som i CentOS 6.6 när jag testkörde då.

Grundregel för felsökning: Bryt och begränsa.

Trädvy Permalänk
Medlem
Registrerad
Nov 2014

@medetix: Hej fick du igång Deluge? för kör också Deluge på min FreeNas(eller provar få till de iaf), lyckats installera å connecta med en client på min windows PC, men lägger jag till torrents så vill den ej ladda ner eller upp, kolla Portarna i inställningar för inkommande portar, men blir en gul triangel... får ingen port att öppna sig... har portat routern korrekt, men hjälper inte.
fixar jag server på min windows pc så funkar de fint.... dock säger de samma med porten, en gul triangel men de funkar iaf... så måste ju vara nån inställning i Jailen som är fel?

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Jun 2014

@FlourApaN^: YES! det fick jag faktiskt. Följde denna guiden och det funkade prima! https://gyazo.com/dcc8f1c90d7ccc7ebcec4fe207a27473

Dator: i7-6700K | Asus MAXIMUS VIII HERO | Corsair Vengeance LPX 16GB (2 x 8GB) 2666MHz | Samsung 850-Series EVO 1TB | ASUS STRIX GTX 1080 | Corsair Air 540 | EVGA T2 850 | YAMAHA HS7 | Focusrite 2i2

Server: i3-6100 | Gigabyte GA-H270N-WIFI | Corsair Vengeance LPX 16GB (2 x 8GB) 2400MHz | WD Red 9TB (3 x 3TB) | Fractal Design Node 304 | Cooler Master V650

Trädvy Permalänk
Medlem
Registrerad
Nov 2014

@medetix: de är den guiden jag med följde funka som sagt tills jag skulle ladda ner, men läst lite runt saken, å verkar som de är Bahnhof's portar som är stängda(även om min router har dem öppna), va jag kan söka mig till som svar. även om de funkar på min windows dator... men verkar som windows är snällare mot port problem än freenas... inte fått bekräftat av bahnhof ännu dock men skall ringa å kolla med dem på månda... har äntligen fått fiber nu så inte provat på tidigare nät heller...

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Jun 2014

@FlourApaN^: har du lagt till vart deluge ska laddas ner någonstans, jag har haft samma problem innan att ingen torrent laddades ner eller upp och då var det att jag glömde lägga till storage.

https://gyazo.com/cbc8d41279fd665b3729f105d1aa9731
https://gyazo.com/d5bba8cbe98102ce50b3a94d54558d89

Och sökvägen för deluge när du ska ladda ner någonting är /media/Filmer(Eller vliken mapp som nu är i din Media dataset)

Dator: i7-6700K | Asus MAXIMUS VIII HERO | Corsair Vengeance LPX 16GB (2 x 8GB) 2666MHz | Samsung 850-Series EVO 1TB | ASUS STRIX GTX 1080 | Corsair Air 540 | EVGA T2 850 | YAMAHA HS7 | Focusrite 2i2

Server: i3-6100 | Gigabyte GA-H270N-WIFI | Corsair Vengeance LPX 16GB (2 x 8GB) 2400MHz | WD Red 9TB (3 x 3TB) | Fractal Design Node 304 | Cooler Master V650

Trädvy Permalänk
Medlem
Registrerad
Nov 2014

@medetix: oj så dum man känner sig nu x)
Storage hade jag fixat, men när jag ladda ner något så hade jag ju bara gått in i mappen å kopierat destinations adressen direkt till mapparna(\\ip\nas\media\Movies).... inte använt /meda/Movies

woaw de var ju lätt fixat Tusen tack för hjälpen!

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Jun 2014
Skrivet av FlourApaN^:

@medetix: oj så dum man känner sig nu x)
Storage hade jag fixat, men när jag ladda ner något så hade jag ju bara gått in i mappen å kopierat destinations adressen direkt till mapparna(\\ip\nas\media\Movies).... inte använt /meda/Movies

woaw de var ju lätt fixat Tusen tack för hjälpen!

hehe inga problem!

Dator: i7-6700K | Asus MAXIMUS VIII HERO | Corsair Vengeance LPX 16GB (2 x 8GB) 2666MHz | Samsung 850-Series EVO 1TB | ASUS STRIX GTX 1080 | Corsair Air 540 | EVGA T2 850 | YAMAHA HS7 | Focusrite 2i2

Server: i3-6100 | Gigabyte GA-H270N-WIFI | Corsair Vengeance LPX 16GB (2 x 8GB) 2400MHz | WD Red 9TB (3 x 3TB) | Fractal Design Node 304 | Cooler Master V650

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2013

@medetix: Jag får följande fel och kan inte ansluta till web uit..

root@deluge:/ # /usr/local/etc/rc.d/deluged start Starting deluged. root@deluge:/ # /usr/local/lib/python2.7/site-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored. import libtorrent as lt

#1: Z370N ITX | i7 8700k | GTX 980 | 32GiB | 950 Pro 512GB
#2: P8Z77-M pro | i7 3770k | AMD 6970 | 16GiB

Server: Z370-G | i5 8600T | 32GiB | UnRAID 6.5.0 | 68TB
HTPC: i7 2600k | GTX 1050ti | 8GiB
Smartphone: Huawei Mate 10 Pro | Android 8.0 | root | Shure SE535

Trädvy Permalänk
Medlem
Plats
Karlshamn
Registrerad
Jun 2014
Skrivet av LudvigLindell:

@medetix: Jag får följande fel och kan inte ansluta till web uit..

root@deluge:/ # /usr/local/etc/rc.d/deluged start Starting deluged. root@deluge:/ # /usr/local/lib/python2.7/site-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored. import libtorrent as lt

hmm, har faktiskt ingen aning vad felet är, är ingen expert på detta. jag skulle börja om nytt.

Dator: i7-6700K | Asus MAXIMUS VIII HERO | Corsair Vengeance LPX 16GB (2 x 8GB) 2666MHz | Samsung 850-Series EVO 1TB | ASUS STRIX GTX 1080 | Corsair Air 540 | EVGA T2 850 | YAMAHA HS7 | Focusrite 2i2

Server: i3-6100 | Gigabyte GA-H270N-WIFI | Corsair Vengeance LPX 16GB (2 x 8GB) 2400MHz | WD Red 9TB (3 x 3TB) | Fractal Design Node 304 | Cooler Master V650

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2013

@medetix: fjärde gången jag installerar med olika metoder och får samma fel :/

#1: Z370N ITX | i7 8700k | GTX 980 | 32GiB | 950 Pro 512GB
#2: P8Z77-M pro | i7 3770k | AMD 6970 | 16GiB

Server: Z370-G | i5 8600T | 32GiB | UnRAID 6.5.0 | 68TB
HTPC: i7 2600k | GTX 1050ti | 8GiB
Smartphone: Huawei Mate 10 Pro | Android 8.0 | root | Shure SE535

Trädvy Permalänk
Medlem
Registrerad
Dec 2002
Skrivet av LudvigLindell:

@medetix: fjärde gången jag installerar med olika metoder och får samma fel :/

Tjah min första tanke. Det är ju ett fel på en viss rad. Editera filen och bläddra till raden det gäller och se om det hjälper. Uppdaterat systemet innan också? Prova skriva kommandot nedan i terminalen. Kommando söker genom några mappar med lib-filer och jämför dem med befintliga program de e bundna till och uppdaterar efter behov.
Skriv: sudo ldconfig

Edit: Då jag inte är helt hundra på hur det påverkar ditt system så gör det innan du har viktig data lagrat på burken "just in case" Ah hittade en sida som beskriver vad det gör mer ingående: https://www.lifewire.com/ldconfig-linux-command-4093742 Gammal dock men kanske hjälper. Dock konstigt att du får felet direkt efter ominstallation. Har du någon guide som du följt? Ifall du gör något "fel"?

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2013

@fragwolf: Har provat idfonfig men det hjälpte inte.

Filen:

""" This module is used to handle the importing of libtorrent. We use this module to control what versions of libtorrent this version of Deluge supports. ** Usage ** >>> from deluge._libtorrent import lt """ REQUIRED_VERSION = "0.14.9.0" def check_version(lt): from deluge.common import VersionSplit if VersionSplit(lt.version) < VersionSplit(REQUIRED_VERSION): raise ImportError("This version of Deluge requires libtorrent >=%s!" % REQUIRED_VERSION) try: import deluge.libtorrent as lt check_version(lt) except ImportError: import libtorrent as lt check_version(lt)

Fel version av libtorrent?

Sista gången som jag installerade nu följde jag guiden som är tidigare i denna tråd. Jag har inte gjort nåt fel, är säker på det

#1: Z370N ITX | i7 8700k | GTX 980 | 32GiB | 950 Pro 512GB
#2: P8Z77-M pro | i7 3770k | AMD 6970 | 16GiB

Server: Z370-G | i5 8600T | 32GiB | UnRAID 6.5.0 | 68TB
HTPC: i7 2600k | GTX 1050ti | 8GiB
Smartphone: Huawei Mate 10 Pro | Android 8.0 | root | Shure SE535

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Jan 2007
Skrivet av LudvigLindell:

@medetix: Jag får följande fel och kan inte ansluta till web uit..

root@deluge:/ # /usr/local/etc/rc.d/deluged start Starting deluged. root@deluge:/ # /usr/local/lib/python2.7/site-packages/deluge/_libtorrent.py:59: RuntimeWarning: to-Python converter for boost::shared_ptr<libtorrent::alert> already registered; second conversion method ignored. import libtorrent as lt

Det är ett problem med libtorrent 1.1 enligt http://forum.deluge-torrent.org/viewtopic.php?f=7&t=53939 felmeddelandet är lite kryptiskt bara, förstår inte varför den inte skulle klara läsa in samma bibliotek mer än en gång.
Installera libtorrent 1.0.9 så ska det funka

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2013
Skrivet av Bjrk:

Det är ett problem med libtorrent 1.1 enligt http://forum.deluge-torrent.org/viewtopic.php?f=7&t=53939 felmeddelandet är lite kryptiskt bara, förstår inte varför den inte skulle klara läsa in samma bibliotek mer än en gång.
Installera libtorrent 1.0.9 så ska det funka

Okej! Tack! Är det bara köra

pkg install libtorrent-rasterbar=1.0.9

edit: det var det inte

#1: Z370N ITX | i7 8700k | GTX 980 | 32GiB | 950 Pro 512GB
#2: P8Z77-M pro | i7 3770k | AMD 6970 | 16GiB

Server: Z370-G | i5 8600T | 32GiB | UnRAID 6.5.0 | 68TB
HTPC: i7 2600k | GTX 1050ti | 8GiB
Smartphone: Huawei Mate 10 Pro | Android 8.0 | root | Shure SE535

Trädvy Permalänk
Medlem
Registrerad
Dec 2002
Skrivet av LudvigLindell:

@fragwolf: Har provat idfonfig men det hjälpte inte.

Filen:

""" This module is used to handle the importing of libtorrent. We use this module to control what versions of libtorrent this version of Deluge supports. ** Usage ** >>> from deluge._libtorrent import lt """ REQUIRED_VERSION = "0.14.9.0" def check_version(lt): from deluge.common import VersionSplit if VersionSplit(lt.version) < VersionSplit(REQUIRED_VERSION): raise ImportError("This version of Deluge requires libtorrent >=%s!" % REQUIRED_VERSION) try: import deluge.libtorrent as lt check_version(lt) except ImportError: import libtorrent as lt check_version(lt)

Fel version av libtorrent?

Sista gången som jag installerade nu följde jag guiden som är tidigare i denna tråd. Jag har inte gjort nåt fel, är säker på det

Det sak vara LDCONFIG inte id Nu är jag inte säker på hur det funkar att installera saker som du gör men det funkar normalt inte att skriva som du gör för att installera. Du får söka på paketet du ska installera. Eller leta upp det på ex google och se vad det heter.

[size="1"]*signatur raderad*, referrallänkar behöver vi inte gömma i signaturer (§8 marknadsföring)[/size] Till MOD: Ditt smartskafft, man gömmer inte något som är helt synligt!

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2013

@fragwolf: aa sorry 😁 jag skrev med l, inte i

#1: Z370N ITX | i7 8700k | GTX 980 | 32GiB | 950 Pro 512GB
#2: P8Z77-M pro | i7 3770k | AMD 6970 | 16GiB

Server: Z370-G | i5 8600T | 32GiB | UnRAID 6.5.0 | 68TB
HTPC: i7 2600k | GTX 1050ti | 8GiB
Smartphone: Huawei Mate 10 Pro | Android 8.0 | root | Shure SE535

Trädvy Permalänk
Medlem
Registrerad
Dec 2009

Funkar det att köra deluge på freenas utan problem ?
Mvh

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Feb 2013

Har inte läst alla inlägg, men jag kör med ruTorrent och är helnöjd

§9

Citera för svar

- Stora Owncloud/Nextcloud-tråden: http://www.sweclockers.com/forum/122-server/1212245-officiell...
- Min blogg: Tech & Me https://www.techandme.se

Trädvy Permalänk
Medlem
Registrerad
Nov 2014
Skrivet av labbz0re:

Funkar det att köra deluge på freenas utan problem ?
Mvh

Jag kör Deluge å de funkar flawless iaf för mig🙂

Skickades från m.sweclockers.com