Några små css fel jag skulle behöva hjälp med

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002

Några små css fel jag skulle behöva hjälp med

Hej

Håller på med en ny sida och jag har stött på lite problem. Var ett tag sedan jag gjorde en sida i CSS så jag har glömt bort en del.

Som det ser ut nu så har jag en index.php där alla taggar ligger samt en layout.css.

sidan i sig är kan man säga en box som flyter fritt mitt på sidan med all information i.
I stil med denna: http://sebad.triphys.com

Bakgrunden är fadead från en grå nyans till en vit nyans och själva boxen har skuggor runt sig så den är sparad i png-24 med transparacy.

Till problemet!
min indexfil ser ut såhär:

<head> <link href="css/layout.css" rel="stylesheet" type="text/css"> </head> <body> <div id="kolumncontainer"> <div id="menu"> <div id="box"><img src="pix/buttons.png" width="149" height="170" /> <div id="main"> <div id="footer"> </div> </div> </div> </div> </div> </body>

och layout.css såhär:

@charset "utf-8"; /* CSS Document */ body {margin: 1em 0 0 1em; padding: 0; background: #e2e2e3 url(../pix/bg.gif) repeat-x;} /* sidlayout */ #kolumncontainer {width: 810px; height: 680px; border: 0px; background-image:url(../pix/page.png); background-repeat:no-repeat; margin-right: auto; margin-left: auto; overflow: hidden;} #menu {height: 494px; width: 151px; margin-left: 65px; margin-top: 117px; overflow: hidden; background-image:url(../pix/menu.png); background-repeat:no-repeat} #main {height: 384px; width: 510px; margin-left: 155px; overflow: hidden;} #box {height: 170px; width: 149px; margin-left: auto; margin-top: 50px; overflow: hidden;} #footer {height: 106px; width: 510px; margin-top: 388px; overflow: hidden;}

Problemet jag har är att alla boxar blir för stora samt försmå och allt ser bara lustigt ut i dreamweaver (designläget). Jag har en känsla av att något är fel, men jag kan inte sätta fingret på det.

Sedan har jag ett annat problem. Som ni ser så har jag lagt in "overflow: hidden;" på alla olika boxar i css'en, detta gjorde jag endast för att om jag inte har dem där så åker hela hemsidan ner jättelångt och håller sig inte centrerad i mitten. Varför det?

Mitt sista och kanske viktigaste problem är att när jag öppnar sidan i Internet Explorer 6.0 så är allt som är transparant färgat till turkos.. Detta ska väl ändå fungera?

Tack på förhand för hjälpen!

Trädvy Permalänk
Medlem
Plats
Globen, Stockholm
Registrerad
Jan 2005

Angående explorer 6.0 så klarar den inte transparenta bilder i PNG. Hur det är med GIF vet jag inte men tror inte det fungerar heller. Men det är jätteirriterande iallafall:O

Burk Nr.1 : Asus P8Z68 V-Pro | i7 2600k @ 4,4 | EVGA GTX780 Classified | Corsair Vengeance 8GB DDR3 1600Mhz | Corsair Obsidian 650D | Corsair TX650M | Corsair H100

Burk Nr.2 : MSI P35 Neo2 | Core 2 Duo E6850 @ 3,2Ghz | Powercolor Radeon HD5850 1GB | Corsiar Twin2X 6400 2x2GB | Corsair 550W

Trädvy Permalänk
Medlem
Plats
Växjö
Registrerad
Sep 2002

Det problemet tror jag faktiskt är löst:
http://koivi.com/ie-png-transparency/

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Dec 2003

Att förvänta sig att alla ska spara ner koden lokalt och göra en testsida är nog att överskatta folks hjälpsamhet. Posta en länk till sidan om du vill förbättra oddsen för vettig feedback.