SVT-play up and running för raspberry pi!

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

SVT-play up and running för raspberry pi!

Check it out

Lägg zipen i någon delad mapp och navigera sedan i xbian/raspmbc/openelec till add-ons, installera genom zip-fil.

Trädvy Permalänk
Medlem
Plats
Eskilstuna
Registrerad
Sep 2006

Är väl inget nytt?

Skickades från m.sweclockers.com

Richard aka inkui

Trädvy Permalänk
Medlem
Registrerad
Aug 2011
Skrivet av inkui:

Är väl inget nytt?

Skickades från m.sweclockers.com

Kanske inte. Men sedan svt-play addonen blev trasig då svt gjorde om sin sida har jag sett flera inlägg i trådar där folk undrar hur man får igång svt-play. Eftersom ingen postat en vettig lösning utan istället rekommenderar saker som Xot (som aldrig funkat bra och som folk heller inte får igång) tänkte jag att det kan vara idé att lägga ut en länk till denna nya add-on.

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2002

Bra postat, har själv undrat hur jag ska lösa detta (när den väl kommer i posten).
Någon Netflix lösning då, eller är det kört?

Trädvy Permalänk
Medlem
Registrerad
Aug 2011
Skrivet av Aresz:

Bra postat, har själv undrat hur jag ska lösa detta (när den väl kommer i posten).
Någon Netflix lösning då, eller är det kört?

Härligt!

Vet inte har inte undersökt det då jag inte använder netflix.

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2008
Skrivet av Aresz:

Bra postat, har själv undrat hur jag ska lösa detta (när den väl kommer i posten).
Någon Netflix lösning då, eller är det kört?

En lat lösning är att köpa ett till minneskort med "vanligt OS", och sen köra i browsern, borde väl fungera.

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2002
Skrivet av El_Raspberry:

En lat lösning är att köpa ett till minneskort med "vanligt OS", och sen köra i browsern, borde väl fungera.

Någon Windowsversion då? Känns inte helt hundra med raspberry o Windows? Inte alls?

Trädvy Permalänk
Inaktiv
Registrerad
Jan 2008
Skrivet av Aresz:

Någon Windowsversion då? Känns inte helt hundra med raspberry o Windows? Inte alls?

Nej, tänker en av de rekommenderade, Debian om jag inte missminner mig. Det enda Netflix kräver på en "dator" är browser, så ska fungera.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2004
Skrivet av El_Raspberry:

Nej, tänker en av de rekommenderade, Debian om jag inte missminner mig. Det enda Netflix kräver på en "dator" är browser, så ska fungera.

Och silverlight drm plugin som inte fungerar i linux...

Skickades från m.sweclockers.com

i7 8700k | NZXT Kraken x62 | Asus Strix Z370-F | 2*8GB G.Skill Trident Z | 3*Samsung 250 GB 850 EVO SSD | NZXT H500i | EVGA SuperNOVA G3 750W | Samsung 24" CFG70 | Asus VG248QE | Realforce 88UB | SteelSeries Rival 310 + SX | Sennheiser PC360 |

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Aug 2009
Skrivet av PierreB:

Och silverlight drm plugin som inte fungerar i linux...

Skickades från m.sweclockers.com

Hur gör netflix i safari då?

Eller funkar det bara i IOS/OSX-appen?

ASUS P9X79 | RX 580 | Corsair DDR3 XMS3 8x8Gb | Intel I7 3820 | 2x Samsung 840 Pro 256Gb + 1 Intel 520 256 + 1 Crucial M500 256Gb
DELL XPS 15 | I7 | 512GB | 16GB ram | 4K EYEFINITY

Trädvy Permalänk
Medlem
Registrerad
Aug 2002
Skrivet av El_Raspberry:

Nej, tänker en av de rekommenderade, Debian om jag inte missminner mig. Det enda Netflix kräver på en "dator" är browser, så ska fungera.

Stämmer nog inte, testade bara lite snabbt på en standard ubuntuinstall och det fungerade varken i FF eller Chrome.
Orkar inte engagera mig i varför men nån tidigare här snackade om Silverlight och det kan ju mkt väl stämma.

http://how-to.wikia.com/wiki/How_to_watch_Netflix_%28Watch_In...
Enligt den så verkar Silverlight krävas ja.

OBS! Mina inlägg ska, där applicerbart, ses som mer allmänt filosoferande och avspeglar långt ifrån alltid min personliga åsikt i frågan.

Trädvy Permalänk
Medlem
Registrerad
Aug 2002
Skrivet av orig_rejser:

Hur gör netflix i safari då?

Eller funkar det bara i IOS/OSX-appen?

http://www.microsoft.com/getsilverlight/Get-Started/Install/D...
Spana under "system requirements", verkar kunna besudla OSX

OBS! Mina inlägg ska, där applicerbart, ses som mer allmänt filosoferande och avspeglar långt ifrån alltid min personliga åsikt i frågan.

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Sep 2004

Ios/osx har stöd för silverlight men linux har inte det. Google tv har också stöd men men.

Skickades från m.sweclockers.com

i7 8700k | NZXT Kraken x62 | Asus Strix Z370-F | 2*8GB G.Skill Trident Z | 3*Samsung 250 GB 850 EVO SSD | NZXT H500i | EVGA SuperNOVA G3 750W | Samsung 24" CFG70 | Asus VG248QE | Realforce 88UB | SteelSeries Rival 310 + SX | Sennheiser PC360 |

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Aug 2009

Synd att dom lade ned moonlight

ASUS P9X79 | RX 580 | Corsair DDR3 XMS3 8x8Gb | Intel I7 3820 | 2x Samsung 840 Pro 256Gb + 1 Intel 520 256 + 1 Crucial M500 256Gb
DELL XPS 15 | I7 | 512GB | 16GB ram | 4K EYEFINITY

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Dec 2005

Tack så mycket nu har jag två stycken glada barn här hemma snart

Fractal Design R3 - Moderkort: MSI Z170 KRAIT GAMING - Intel i7 6700k 4 ghz @ Hyper 212 - 2xGigabyte GeForce GTX 780 3GB OC Windforce rev2.0 SLI -Corsair 12GB DDR4 VENGEANCE - SDD 2xIntel 330 128 GB - Corsair TX850W - 3xDell 24 tums IPS Ultrasharp tum 5760x1200
http://retrotvspel.nu//
Bärbar:Lenovo ThinkPad T440s

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Skrivet av LessGifted:

Check it out

Lägg zipen i någon delad mapp och navigera sedan i xbian/raspmbc/openelec till add-ons, installera genom zip-fil.

Jag får inte ens upp alternativet installera från zip.
Kör xbmc-git plus pvr-addons på Arch Linux.
Enda pluginsen jag kan aktivera är de som finns i officiella repositoryt, trots att jag försökt packa upp xip-filen manuellt i .xbmc/addons. SVT Play 2.04 finns ju men det funkar inte.

Jag får väl fortsätta använda pirateplayer istället...

Trädvy Permalänk
Medlem
Registrerad
Aug 2011
Skrivet av Ac3R:

Tack så mycket nu har jag två stycken glada barn här hemma snart

Härligt att höra. Jag blev barnsligt glad själv

Skrivet av ronnylov:

Jag får inte ens upp alternativet installera från zip.
Kör xbmc-git plus pvr-addons på Arch Linux.
Enda pluginsen jag kan aktivera är de som finns i officiella repositoryt, trots att jag försökt packa upp xip-filen manuellt i .xbmc/addons. SVT Play 2.04 finns ju men det funkar inte.

Jag får väl fortsätta använda pirateplayer istället...

Märkligt. Dock vet jag inte hur xbmc beter sig i arch. Testa att installera om xbmc?

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Skrivet av LessGifted:

Härligt att höra. Jag blev barnsligt glad själv

Märkligt. Dock vet jag inte hur xbmc beter sig i arch. Testa att installera om xbmc?

Jag ska testa ta bort .xbmc i min hemmamapp. Kom på att jag uppgraderade från en tidigare xbmc-installation så det kan vara gamla inställningar som ligger kvar och spökar. Men funkar SVT play för dig nu då? Inget XML error?

Edit: Jo nu fick jag upp alternativet att installera från zip, men då säger den att tillägget har fel struktur...

Trädvy Permalänk
Medlem
Registrerad
Aug 2011
Skrivet av ronnylov:

Jag ska testa ta bort .xbmc i min hemmamapp. Kom på att jag uppgraderade från en tidigare xbmc-installation så det kan vara gamla inställningar som ligger kvar och spökar. Men funkar SVT play för dig nu då? Inget XML error?

Edit: Jo nu fick jag upp alternativet att installera från zip, men då säger den att tillägget har fel struktur...

SVT-play flyter på fint i 720p. Första gången jag startade buffrade det på o crashade o hade sig men sen löste det av sig självt mirakulöst på något sätt. Nu flyter allt på. Inget XML-error.

Testa o installera om xbmc. Jag är långt ifrån expert på området så jag vet faktiskt inte vad som kan vara fel. Men med tanke på att tillägget är konstruerat med raspberry-pi porteringarna av XBMC och då (som jag förstod det) använder dig av "vanliga" XBMC kan du ju uppstå någon konflikt där.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Skrivet av LessGifted:

SVT-play flyter på fint i 720p. Första gången jag startade buffrade det på o crashade o hade sig men sen löste det av sig självt mirakulöst på något sätt. Nu flyter allt på. Inget XML-error.

Testa o installera om xbmc. Jag är långt ifrån expert på området så jag vet faktiskt inte vad som kan vara fel. Men med tanke på att tillägget är konstruerat med raspberry-pi porteringarna av XBMC och då (som jag förstod det) använder dig av "vanliga" XBMC kan du ju uppstå någon konflikt där.

Jaha. Jo jag kör alltså på vanlig dator med Arch Linux 64-bit, inte raspberry pi (trodde pluginen var plattformsoberoende) men blev intresserad om jag kunde få detta plugin att funka med git-versionen av XBMC frodo. Jag har i och för sig även lagt in PVR-tillägget. Kan ju vara att de plötsligt ändrat något i plugin-strukturen eftersom detta är en utvecklingsversion och att detta plugin inte hunnit anpassats för detta. Det kommer väl så småningom. xbmc-git var nyinstallerat så ominstallation lär inte hjälpa.

Trädvy Permalänk
Medlem
Registrerad
Aug 2011
Skrivet av ronnylov:

Jaha. Jo jag kör alltså på vanlig dator med Arch Linux 64-bit, inte raspberry pi (trodde pluginen var plattformsoberoende) men blev intresserad om jag kunde få detta plugin att funka med git-versionen av XBMC frodo. Jag har i och för sig även lagt in PVR-tillägget. Kan ju vara att de plötsligt ändrat något i plugin-strukturen eftersom detta är en utvecklingsversion och att detta plugin inte hunnit anpassats för detta. Det kommer väl så småningom. xbmc-git var nyinstallerat så ominstallation lär inte hjälpa.

Jag föreslår att du skapar en ny tråd i linuxdelen av forumet. Där finns det säkert folk med större kompetens som kan hjälpa dig. Lycka till

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2003

Hej! Försöker få igång SVT Play. Jag har lagt zip-filen på ett USB och jag kan se zippen i filhanteraren på Raspberryn på TVn.

Instruktionen lyder så här:
"Lägg zipen i någon delad mapp och navigera sedan i xbian/raspmbc/openelec till add-ons, installera genom zip-fil."

Ska jag i RASPBMC gå till "Videor --> Tillägg --> Hämta fler"? För där hittar jag inte någon zip?

Vad är nästa steg? Jag har kört fast. Måste jag föra över zippen eller packa upp den först i filhanteraren på ngt sätt? (Helst utan SSH och Linux-kommandon : )

Edit:
Ok, så här gör man för att packa upp zip-filen för de som inte vet.
Inne i XBMC på Raspberryn väljer man System --> Inställningar --> Tillägg --> Installera från zip. Då uppdateras eller installeras SVT Play.

Löst
Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Skrivet av LessGifted:

Jag föreslår att du skapar en ny tråd i linuxdelen av forumet. Där finns det säkert folk med större kompetens som kan hjälpa dig. Lycka till

Felet var att jag hade laddat ner fel zip-fil. Jag gick till downloads till höger på den där sidan och laddade ner filen https://github.com/downloads/nilzen/xbmc-svtplay/plugin.video...
Men detta är inte rätt zip-fil.

Det funkar utmärkt om jag istället går till denna sida:
https://github.com/nilzen/xbmc-svtplay/tree/frodo
Och trycker på knappen "ZIP" - "Download this repository as a zip file" uppe till vänster på sidan och sedan installerar tillägg från zip-fil inuti xbmc frodo beta. Då får jag in version 3.00 av SVT Play tillägget och jag kan titta på SVT Play igen. Detta kanske hjälper någon som råkar välja fel fil precis som jag gjorde (och detta bör vara relevant även för de som kör detta på raspberry pi).

Så nu äntligen har jag XBMC med både fungerande SVT Play och fungerande PVR-klient!

Trädvy Permalänk
Medlem
Registrerad
Jun 2004

SVT Play har precis slutat fungera. Hur är det för er andra?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Aug 2011
Skrivet av ronnylov:

Felet var att jag hade laddat ner fel zip-fil. Jag gick till downloads till höger på den där sidan och laddade ner filen https://github.com/downloads/nilzen/xbmc-svtplay/plugin.video...
Men detta är inte rätt zip-fil.

Det funkar utmärkt om jag istället går till denna sida:
https://github.com/nilzen/xbmc-svtplay/tree/frodo
Och trycker på knappen "ZIP" - "Download this repository as a zip file" uppe till vänster på sidan och sedan installerar tillägg från zip-fil inuti xbmc frodo beta. Då får jag in version 3.00 av SVT Play tillägget och jag kan titta på SVT Play igen. Detta kanske hjälper någon som råkar välja fel fil precis som jag gjorde (och detta bör vara relevant även för de som kör detta på raspberry pi).

Så nu äntligen har jag XBMC med både fungerande SVT Play och fungerande PVR-klient!

Grejt!

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Okt 2002
Skrivet av Laiban:

SVT Play har precis slutat fungera. Hur är det för er andra?

Skickades från m.sweclockers.com

Ja har slutat funka för mig med efter senaste uppgraderingen av xbmc-git. Funkade idag innan jag uppgraderade...

Trädvy Permalänk
Medlem
Registrerad
Nov 2012

Funkar här..

Skrivet av Laiban:

SVT Play har precis slutat fungera. Hur är det för er andra?

Skickades från m.sweclockers.com

Funkade inte för mig heller idag men tankade ner version 3 av SVTplay från
https://github.com/nilzen/xbmc-svtplay/zipball/frodo

och installerade zip filen via den inbyggda funktionen "install addon from zipfile".
Funkar perfekt nu.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2003

Tyvärr funkar inte Homeland på SVT Play med XBMC på Raspberry Pi (RaspBMC). Det gäller inte generellt utan bara Homeland. Övriga strömmar blir finfin kvalitet. Homeland däremot ser ut som skit och kraschar efter en minut.
: (

Trädvy Permalänk
Medlem
Registrerad
Aug 2011

Blä. Nu får jag scriptfel på vart eviga program.

Hur går det för er andra.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jun 2003