Usel prestanda i BF4 med 7970 CF

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007

Usel prestanda i BF4 med 7970 CF

Har problem att få CF att rulla ordentligt i BF4, jag får sämre prestanda med två kort än med ett. Problemet gissar jag är att GPU usage ligger kring 30-40% som mest och då är det ju inte så konstigt att FPSen är låg (40-60). Är det någon inställning jag har missat som man måste fixa? Har endast stängt av ULPS och inaktiverat CPU core park. Har så klart googlat en massa men kommer helt ärligt inte fram till någonting vettigt.

Datorn:

2500k@5GHz
7970GHz-edition i CF
8GB RAM
Asus P8P67 WS
Intel 335 series 240GB
120Hz skärm
Windows 7 Professional

Edit: Får precis samma FPS i high som ultra.

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

Fick precis samma problem när jag prövade med en polares kort. Vi hittade inte heller någon lösning på problemet.

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

Cpu usage?

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007
Skrivet av MaarOlo:

Cpu usage?

Hög, kring 80-90%.

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

Runt 95% för mig. Men det är även så med bara ett kort.

Trädvy Permalänk
Medlem
Registrerad
Okt 2013
Skrivet av Kakann:

Hög, kring 80-90%.

Rätta mig om jag har fel någon, men kan cpun flaska?

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av MaarOlo:

Rätta mig om jag har fel någon, men kan cpun flaska?

DEn borde inte göra det med den klockfrekvensen.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007
Skrivet av MaarOlo:

Rätta mig om jag har fel någon, men kan cpun flaska?

Det kan jag inte tänka mig, alltså det är ju sämre med två kort än med ett. Med ett kort rullar det helt ok på ultra (average 60 kanske) och riktigt bra på high (100+ fps) men med två kort ligger jag på average 40 fps oavsett grafikinställning.

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av Kakann:

Det kan jag inte tänka mig, alltså det är ju sämre med två kort än med ett. Med ett kort rullar det helt ok på ultra (average 60 kanske) och riktigt bra på high (100+ fps) men med två kort ligger jag på average 40 fps oavsett grafikinställning.

Instämmer, det borde inte gå sämre.

Trädvy Permalänk
Medlem
Plats
127.0.0.1
Registrerad
Sep 2003

Stängt av frame pacing?
Den har halverat fps i senare betaversioner av 13.11...
Kör du med vSync?

1: Intel i7-3930K | 32GB Corsair Dominator GT | Asus Rampage IV Extreme x79 | 2 x 1080 GameRock Premium 8GB | 2 x Samsung Pro 840 512GB | Corsair AX1200i | BenQ XL2411 24" / W1070 135" | Bose QC25 | Windows 10 Pro x64 | HTC Vive |
2: Intel Core i7-4700HQ | 32GB RAM | Intel HM87 Express | GTX 780M | 17" | Windows 10 x64 |

Trädvy Permalänk
Medlem
Registrerad
Okt 2013
Skrivet av Kakann:

Det kan jag inte tänka mig, alltså det är ju sämre med två kort än med ett. Med ett kort rullar det helt ok på ultra (average 60 kanske) och riktigt bra på high (100+ fps) men med två kort ligger jag på average 40 fps oavsett grafikinställning.

Jaha, ... fast jag vet inte vad som är fel då :/ så kan tyvärr inte hjälpa till.

Trädvy Permalänk
Medlem
Registrerad
Jun 2012
Skrivet av Dalton Sleeper:

Stängt av frame pacing?
Den har halverat fps i senare betaversioner av 13.11...
Kör du med vSync?

Hur stänger man av detta? Trodde det följde med när man aktiverade CF i CCC

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007
Skrivet av Dalton Sleeper:

Stängt av frame pacing?
Den har halverat fps i senare betaversioner av 13.11...
Kör du med vSync?

Har testat det av och på, gör ingen skillnad. Körde just med Vsync av, ingen skillnad.

Finns något som heter "AMD CrossFireX Mode", någon som har koll på vilken iställning den ska vara på? Disabled/default/AFR friendly/optimize 1x1/use amd pre-defined profile är det som finns att välja på.

Skrivet av Raz159:

Hur stänger man av detta? Trodde det följde med när man aktiverade CF i CCC

CCC - Gaming - 3D Application Settings

Trädvy Permalänk
Medlem
Plats
127.0.0.1
Registrerad
Sep 2003
Skrivet av Kakann:

Finns något som heter "AMD CrossFireX Mode", någon som har koll på vilken iställning den ska vara på? Disabled/default/AFR friendly/optimize 1x1/use amd pre-defined profile är det som finns att välja på.

Jag kör bara globala inställningar vilket fungerar utmärkt i 99% av fallen... (bör vara pre-defined)

1: Intel i7-3930K | 32GB Corsair Dominator GT | Asus Rampage IV Extreme x79 | 2 x 1080 GameRock Premium 8GB | 2 x Samsung Pro 840 512GB | Corsair AX1200i | BenQ XL2411 24" / W1070 135" | Bose QC25 | Windows 10 Pro x64 | HTC Vive |
2: Intel Core i7-4700HQ | 32GB RAM | Intel HM87 Express | GTX 780M | 17" | Windows 10 x64 |

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Nov 2009

testa byt till win8.1 pro om möjligt

[Dator: Amd Phenom II x4 955 |Corsair 4bg XMS3 | Sapphire 6950 @ 6970 RIP | Gigabyte 790XTA-UD4 | Corsair 850AX | Coolmaster Stacker]

Trädvy Permalänk
Medlem
Plats
Jönköping
Registrerad
Okt 2003

Jag har exakt samma problem, jag får stadigare fps om jag inaktiverar crossfire... :/

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007
Skrivet av dalmatinac:

testa byt till win8.1 pro om möjligt

Mitt moderkort verkar helt enkelt sakna drivrutiner/stöd för Windows 8 så det kan jag tyvärr inte köra.

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Dec 2006
Skrivet av Kakann:

Mitt moderkort verkar helt enkelt sakna drivrutiner/stöd för Windows 8 så det kan jag tyvärr inte köra.

Har hört flera som har blivit av med detta problem genom att använda win 8+.
Låter väldigt konstigt att det inte finns något stöd för win 8 till ditt MB. Har kört det på bra mycket äldre moderkort.

Core i7 4790K. Asus GTX 1080. A-DATA XPG 16gb. Samsung 840 250GB x2. Corsair HX520.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007
Skrivet av RasmusAlb:

Har hört flera som har blivit av med detta problem genom att använda win 8+.
Låter väldigt konstigt att det inte finns något stöd för win 8 till ditt MB. Har kört det på bra mycket äldre moderkort.

Tycker det samma, det är ju inget gammalt och framförallt inget dåligt moderkort. Men som du ser här i listan så finns inte windows 8 att välja på: http://www.asus.com/Motherboards/P8P67_WS_Revolution/#support

Trädvy Permalänk
Medlem
Registrerad
Jun 2012

Under FAQ finns det frågor om Windows 8.1, så moderkortet borde ha stöd för det.

Trädvy Permalänk
Medlem
Plats
Varberg
Registrerad
Dec 2006
Skrivet av Kakann:

Tycker det samma, det är ju inget gammalt och framförallt inget dåligt moderkort. Men som du ser här i listan så finns inte windows 8 att välja på: http://www.asus.com/Motherboards/P8P67_WS_Revolution/#support

Nä det finns ju inte att välja bland driversen. Det här kanske kan vara intressant annars http://www.pcpro.co.uk/blogs/2012/08/06/getting-older-drivers...

"In most cases this shouldn’t be too much of an upheaval, because Windows 8 works just fine with device drivers originally designed for Windows 7"

Core i7 4790K. Asus GTX 1080. A-DATA XPG 16gb. Samsung 840 250GB x2. Corsair HX520.

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Har även väldigt låg fps med 7970 CF i BF4. Installerade mitt andra kort idag. Något jag har märkt med mina kort är att en ligger alltid på runt 5% usage (endast i BF4 som jag har märkt hittills). Något som vet hur man skulle kunna fixa detta problem?

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007

Nu har jag installerat Windows 8.1 och fått igång drivrutinerna till moderkortet, tack för tips etc!

Nu funkar CF och båda korten jobbar max, dock stänger spelet av sig efter typ 10-15 sekunders spelande (den svarta skärmen med ett blinkande streck uppe till höger kommer fram). Vad kan man göra åt det? Campaign funkar men inte MP.

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Kakann, har dina fps problem försvunnit nu när du har installerat Windows 8.1?

För att svara på din fråga så ska du installera punkbuster, lägg till BF4 i pbsetup.exe och installera även punkbuster med pbsvc.exe.
pbsetup.exe kan du ladda ner från evenbalance's hemsida, pbsvc.exe hittar du i: Program\Origin Games\Battlefield 4\_Installer\pb\pbsvc.exe (något sådant, du borde kunna hitta).

Trädvy Permalänk
Medlem
Registrerad
Dec 2004
Skrivet av Kakann:

Nu har jag installerat Windows 8.1 och fått igång drivrutinerna till moderkortet, tack för tips etc!

Nu funkar CF och båda korten jobbar max, dock stänger spelet av sig efter typ 10-15 sekunders spelande (den svarta skärmen med ett blinkande streck uppe till höger kommer fram). Vad kan man göra åt det? Campaign funkar men inte MP.

Enligt en patch tidigare skulle de fixat den svarta skärmen har jag för mig, men det har de uppenbarligen inte gjort. Spelet är bara så pass ostabilt, och antingen har man tur eller så har man inte det. Det bästa är nog att vänta på ny patch, och spela något annat under tiden.

Skulle annars kolla så du har senaste drivers etc, basic grej, men kan lösa.

Trädvy Permalänk
Medlem
Plats
Vännäs
Registrerad
Dec 2009

Hade 2st 7970 nyss och hade samma problem, låg gpu usage, kring 50-60% på en 64 server. Provade verkligen allt, men fick inte till det så skickade tillbaka korten och köpte ett 780ti. 99%usage och helt underbar fps i BF4.

Så tror inte det är bara att CPU:n flaskar, crossfire fungerar väldigt uselt också.

I7 7700K@5.0Ghz|Asus Prime Z270-A|Noctua NH-D14|Samsung 850 1000gb|Zotac GTX 1080Ti AMP Extreme|Corsair Vengeance LPX 3000mhz 16GB|EVGA Supernova 850w|Corsair 650D|Acer XB270HU

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Det jag svarade är helt klart lösningen på hans problem med att spelet crashar.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007
Skrivet av mikaelbb:

Kakann, har dina fps problem försvunnit nu när du har installerat Windows 8.1?

För att svara på din fråga så ska du installera punkbuster, lägg till BF4 i pbsetup.exe och installera även punkbuster med pbsvc.exe.
pbsetup.exe kan du ladda ner från evenbalance's hemsida, pbsvc.exe hittar du i: Program\Origin Games\Battlefield 4\_Installer\pb\pbsvc.exe (något sådant, du borde kunna hitta).

Tack, det borde lösa problemet. Har inte tid att testa just nu dock.

Alla problem med CF etc. har löst sig nu när jag har installerat windows 8.1. Nu är det istället CPUn som flaskar, riktigt skönt i-landsproblem att en 2500k i 5GHz flaskar Skulle gissa att jag snittar 100fps på typ Paracel Storm eller vad det heter.

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Dec 2007

Fortfarande är jag inte helt nöjd, när jag kör multiplayer ligger korten på ca. 65% load och jag snittar kanske 65-70 FPS. När jag kör campaign ligger korten kostant på >97%. Är det verkligen min 2500k i 5GHz som flaskar så mycket?

Trädvy Permalänk
Medlem
Plats
Karlstad
Registrerad
Aug 2001
Skrivet av Kakann:

Är det verkligen min 2500k i 5GHz som flaskar så mycket?

Nej.

Jag har en 2500K @4.6GHz med två 7970. (inte kollat load för varje kort, men kan göra det)
Beroende på karta och hur många spelare, men det är sällan jag ser fps under 100 i vart fall, ofta över 120, snittvärden.
Högsta och lägsta värde varierar från 200 ner till 70-80 i få extrema fall.
1080p, ultra.

Hur funkar crossfire i t.ex 3DMark(Firestrike)? Får du runt 16200 GPU-poäng så funkar crossfire.
Flera som har problem med crossfire i just BF4.

TuF Z370 Pro, 8600K @5, NH-D15, 16GB Corsair 3GHz @3.2+
MSI 1060 GamingX 6GB @2.1/4.7. Corsair RM750x
Corsair HS50, M65 Sabre, K65 Rapidfire
AOC Agon 322QC4