Pi-hole segar ner nätverket

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

Pi-hole segar ner nätverket

Hej som rubriken lyder har jag problem med pi-hole. Det är nämligen så att det äter upp nästan precis 50% av min hämtnings hastighet om man mäter med speedtest och vad jag fattat det som ska det inte göra det. Om någon vet felet får ni gärna förklara. //Tim

Trädvy Permalänk
Medlem
Registrerad
Maj 2014
Skrivet av Timinem:

Om någon vet felet får ni gärna förklara. //Tim

Kanske för att den, med little google sökning, blockerar 1.6 miljoner domäner. Så när trafik kommer in så går den igenom alla 1.6 miljoner domäner och kollar om den skall blockera eller inte. Har inte en sådan själv, men fungerar säkert som brandväggar eller access-listor fungerar och den är helt enkelt för klen att leverera en throughput på din max hastighet med en sådan pass stor lista.

Trädvy Permalänk
Medlem
Registrerad
Sep 2012

Finns minst en tråd om pi-hole: http://www.sweclockers.com/forum/trad/1416906-pi-hole-hardwar..., kollat den?

HTPC: Silverstone Sugo SG05W Vit, Asus H110I-Plus, G4560, Corsair Vengeance LPX 2133 MHz 2x4GB, WD Blue 250 GB, MSI GeForce GT 1030 Passive OC 2GB, (& ett antal enkortsdatorer med div användningsområden).

Trädvy Permalänk
Medlem
Registrerad
Okt 2013

@MatteN: Men jag hittar inget om det alla säger att det funkar kanon. Har dock sett en kille med samma problem men han sa att han hade löst det längre ner i tråden men förklarade aldrig hur. Nu hittar jag inte den tråden

Trädvy Permalänk
Medlem
Plats
Sundsvall
Registrerad
Maj 2003

Om det nu är så att du blockerar 1.6 miljoner domäner är förslaget att du tar bort mahakala-listan. Jag själv blockerar ca 100K-domäner och de flesta verkar överens om att det är bra nog. Mahakala-listan blockerar en del legitima domäner och segar ner prestandan en hel del.

https://github.com/pi-hole/pi-hole/commit/963eacfe0537a7abddf...

Stationär: FD Define Nano S, AMD R5 1600, Biostar X370GTN, G-Skill Ripjaws V 16GB 3600Mhz @ 3200Mhz CL16, Radeon RX 570, Samsung 850 EVO 1TB, Corsair SF450, Arctic Freezer 33
HTPC: In-Win BP671, AMD Athlon 5350, Asus AM1I-A, Geforce GT 710, 4GB 1600Mhz, Corsair Force LS 60GB, One for all UCR7960 (+ Flirc)
NAS: HP Proliant N54L, 2x WD Red 2TB (Raid 1), WD Green 2TB, FreeNAS 11

Trädvy Permalänk
Medlem
Plats
Götaland
Registrerad
Sep 2003

Har du provat att ge Pajjen mer stöm?

Jag känner igen fenomenet nämligen.
Min Pi 2 B slöade ner mitt internet kopiöst. (färsk installation)
Jag hade pajjen inkopplat i routern som levererade 500mA via USB.

Sedan läser jag att Pi 2 B kräver mer ström än så,
så nu matar jag 2A i pajjen, går som en dröm!

Trädvy Permalänk
Medlem
Registrerad
Jul 2002

Men det Pi-hole gör är att vara DNS filter inget annat.
Där väl ipadressen är skickad till datorn så skickas kommunikationen mellan din dator och servern.

Ingen trafik går genom Pi-hole'n.

Får du 100% om du kopplar ur den?

En fundering, raspberryn har 100 Mbit/s, det är inte så att din switch går ner till 100 Mbit/s på alla portar när den är inkopplad?

42? Seven and a half million years and all you can come up with is 42?!
► FD Define R2 | Win10Pro | i5-2500K | Hyper212+ SP120PWM | P8P67 PRO | CML8GX3M2A1600C9 | DUAL-GTX1060-O6G | Samsung 830 | Intel X25-M G2 | AX750 | AOC G2460PQU | Dell 1908FP |► Raspberry Pi 2 | Osmc |► MOTO 4+ |

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Aug 2012

Jag hade samma problem när jag körde Pi-hole på Pi2b. Bytte till en Pi3B och fick mycket bättre prestanda.

GAMINGRIGG: I7 6700K@4,4Ghz. 32GB DDR4. EVGA GTX 1080 TI FTW3 ACX.
SERVER: Core I5 3500K 6x 2Tb WD Caviar Green.
NAS: DS1813+ 5x 4TB Wd Red.
HTPC/VR: i5-7500. 8GB DDR4. EVGA GTX 1080 FTW ACX.