Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008

Hur uppdatera SymPy via Pip3?

Hej!

Jag har SymPy 1.0 men jag vill uppdatera till senaste version. Hur gör jag det? Jag sitter på en Ubuntumaskin. Pip3 är installerat.
I detta fall är det Dev jag vill installera.

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Plats
här..
Registrerad
Jun 2006

pip --update install sympy ?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008
Skrivet av Sir. Haxalot:

pip --update install sympy ?

Skickades från m.sweclockers.com

Blir det Dev-versionen då? Devversionen är 1.01. Den jag har nu är 1.0.
Orsaken är för att jag vill kunna använda nonlinsolve i Sympy. Men den finns inte i 1.0, endast i 1.01.

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Plats
Järfälla
Registrerad
Jan 2004

Följ instruktionerna från deras github: https://github.com/sympy/sympy

Då kan du ta det senaste. Kanske inte förvänta dig att den är stabil, men de kanske har någon release där men som inte finns i pip.