Forumdelen sponsras av

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

DisplayPort - var ligger felet?

Hej!

Förutsättningar: Jag har ett GeForce GTX 1050 kopplat till en Viewsonic VP3268-4K via DisplayPort-kabel. Riggen kör senaste Win10 och barebone Nvidia-drivisar (bara drivisar, inte PhysX eller 3D-trams) som alltid är uppdaterade.

Problem: Nvidias drivrutiner kraschar mest hela tiden och skärmen blir svart nån sekund medan de startar om. Felet har följt mig över flera versioner av drivisar. Jag har även bytt DP-kabel från en 'gratis' variant till en tydligt 4K-godkänd från Kjell & Co. Jag har inte installerat om Windows eller provat annan skärm (fastskruvad).

Fråga: Var ligger felet? Vilken komponent i kedjan är troligen skyldig?

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jun 2008

@Arneby: Prova avinstallera drivrutinen helt från datorn via t.ex. https://www.guru3d.com/files-details/display-driver-uninstall... och liknande så att det inte finns ett spår av de gamla och installera den senaste från nvidias hemsida. Tror felet ligger i just drivrutinen.

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

Nu har jag gjort detta. Bootat datorn i Safe Mode, kört DDU, startat om och installerat senaste drivrutinen igen.

Det hjälpte inte

Så åter till grundfrågan; var i kedjan dator->GPU->DP-kabel->skärm ligger mest troligen felet?

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Sep 2007

@Arneby: Du bör testa att göra en ren installation från DVD/USB minne. Det finns oändligt med saker i Windows som kan börja bugga och bråka med tex drivrutiner.

Vissa fel har krävt att man också tog bort alla partitioner på disken för att felen blev kvar när dom bara formaterade och installerade om.

Är man inte så pigg på det så kan man låna / köpa en disk som man lite snabbt testar att göra det på men ha bara en disk kopplad. Annars kan DVD/USB lägga något på andra disken som Windows behöver. Bla blir det svårare att veta vilken disk som orsakar fel i framtiden. Andra diskar kopplar du in efteråt. Helt efter att du kollat om felet är kvar.

https://www.microsoft.com/sv-se/software-download/windows10
Verktyget laddar ned Win 10 och låter dig välja mellan DVD, USB mm som du använder för att installerar om.

Trädvy Permalänk
Medlem
Plats
\\Localhost
Registrerad
Mar 2006

Kan bero på ostabil gpu. Testa att köra in afterburner och fjutta på lite mer ström eller klocka ner kortet 50mhz eller nått och se om det blir bättre.

Går du inte ape shit på spännings slidern så är lite överspänning ingen fara.
Men kan ävwn va överhättande spänningsstyrning på kortet där av testa klocka ner så kortet inte behöver lika mycket ström.

Asus Z97-A, I7 4790K @4.8GHz 1.29V, 24Gb ram, 2x GIGABYTE GTX 970 WindForce 3X OC @ 1511Mhz/7246Mhz.
[Lista] De bästa gratisprogrammen

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2011

Hade liknande problem... provade ny DP kabel, formaterade datorn, DDU osv osv... fick flasha om kortet med detta för att det skulle funka korrekt.
Härligt när dem inte verkar ha släppt denna på GeForce experience programmet *suck*
Firmware update

Sen har det varit rätt mycket disskussioner ang DP kablar och " pin 20 " man kan
läsa mer om det Här

Friskt kopplat, Hälften brunnet

ASUS STRIX 980 GTX | Asus P8Z68 Deluxe-Gen 3 | Intel Core i7 3770K | 32 GB Crucial Ballistix DDR3 PC12800/1600MHz CL9 (4 x 8GB) | Noctua NH-D15 | samsung 850 Pro SSD 120gb | Fractal Define R5 | Seasonic Force 80+ Gold 750W |

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Arneby: Vet du att det är drivrutinen som kraschar, till exempel via felmeddelanden? Eller är det att skärmen blir svart då och då rent spontant?

För som antytt kan de första, när det verkligen kommer meddelande om krascher, vara just defekt hårdvara i GPU. Och det andra vara problem med överföringen, fullt möjligt en felkonstruerad kabel som matar ström från skärm till grafikkort på pinne 20. Eller helt enkelt en kabel som inte orkar bandbredden över den längd du har.

Det senare kan man ofta verifiera genom att minska bandbredden, till exempel köra 4K/30 istället för 60 Hz som halverar bandbredden. Ifall blinkningar och svart skärm upphör, då är det sannolikt kabeln.

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

@Farthinder - Tack! Kört denna firmware upgrade nu och so far so good. Tack igen!

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2011

@Arneby: Får hoppas att det var där problemet låg satte själv i flera timmar och sökte och läste...

Friskt kopplat, Hälften brunnet

ASUS STRIX 980 GTX | Asus P8Z68 Deluxe-Gen 3 | Intel Core i7 3770K | 32 GB Crucial Ballistix DDR3 PC12800/1600MHz CL9 (4 x 8GB) | Noctua NH-D15 | samsung 850 Pro SSD 120gb | Fractal Define R5 | Seasonic Force 80+ Gold 750W |

Trädvy Permalänk
Medlem
Plats
umeå
Registrerad
Jun 2005

Ah displayportkabel.

mitt tips är att köra något annat. vi hade en surface pro 3 som krashade varje gång skärmarna gick i viloläge. Enda lösningen (efter 3 bytta datorer) var att köra DP till DVI adapters och DVI på skärmarna. Samma sak ska funka med HDMI.

så testa DP-HDMI eller DP-DVI beroende på vad du har för ingångar på skärmen.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2011
Skrivet av boibo:

Ah displayportkabel.

mitt tips är att köra något annat. vi hade en surface pro 3 som krashade varje gång skärmarna gick i viloläge. Enda lösningen (efter 3 bytta datorer) var att köra DP till DVI adapters och DVI på skärmarna. Samma sak ska funka med HDMI.

så testa DP-HDMI eller DP-DVI beroende på vad du har för ingångar på skärmen.

du menar att man inte kan " väcka skärmen? " löses lätt genom att dra ut strömkabeln till displayen ( inte power off! utan ryck strömmen vänta några sec ) har la haft det problemet 1-2 ggr, tror att det har att göra med att DP är en aktiv signal, som på ngt sätt blir felaktig ( typ att datorn inte känner igen den ) och då får man rycka power kabeln

Friskt kopplat, Hälften brunnet

ASUS STRIX 980 GTX | Asus P8Z68 Deluxe-Gen 3 | Intel Core i7 3770K | 32 GB Crucial Ballistix DDR3 PC12800/1600MHz CL9 (4 x 8GB) | Noctua NH-D15 | samsung 850 Pro SSD 120gb | Fractal Define R5 | Seasonic Force 80+ Gold 750W |

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

Nej, där var jag alltför snabb. Problemet är tillbaka

@Thomas - det svartnar utan ngt felmeddelande. Alltså precis som när man tvångsomstartar drivrutinen.

@Boibo - med 32" och 3840x2160 vill jag köra DP

Nu får nog grafikkortet åka till Inet för utbyte.

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013
Skrivet av Arneby:

@Thomas - det svartnar utan ngt felmeddelande. Alltså precis som när man tvångsomstartar drivrutinen.

Testa som skrivet att sänka frekvensen och se om det försvinner. Då är det kabeln som är den vanliga orsaken.

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

@Thomas - uppdateringsfrekvensen är nu 59 Hz enligt Windows. Det är väl inte så högt? Vad bör jag sätta den till?

Och eh, var gör jag det numera?

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014

Kolla om där är kontakt mellan pin 20. Är där det, är det kabeln som troligen orsakar problemet. Och som sagt, även Kjells kablar har visat sig ha dessa fel.

Thomas och Farthinder sa detta tidigare i tråden, men det verkar ha förbisetts. Det är viktigt att kolla!
(Ingen verkar ha bekräftat att ni kollat det iaf, inte ens TS)

@Arneby Jo 3840x2160 @ 59/60Hz är mycket bandbredd.
Är om jag minns rätt som 1920x1080 i 240Hz

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2011
Skrivet av Paddanx:

Tror ni båda behöver läsa detta:
https://www.sweclockers.com/forum/trad/1453075-varning-for-vi...

Kolla om där är kontakt mellan pin 20. Är där det, är det kabeln som troligen orsakar problemet. Och som sagt, även Kjells kablar har visat sig ha dessa fel.

Thomas och Farthinder sa detta tidigare i tråden, men det verkar ha förbisetts. Det är viktigt att kolla!
(Ingen verkar ha bekräftat att ni kollat det iaf, inte ens TS)

@Arneby Jo 3840x2160 @ 59/60Hz är mycket bandbredd.
Är om jag minns rätt som 1920x1080 i 240Hz

Har läst den ^^ kollade ganska omgående min kabel. Vet att många som t.ex. komplett osv har börjat märka kablar på deras sida med " ej pin 20 " eller ngt dylikt

Friskt kopplat, Hälften brunnet

ASUS STRIX 980 GTX | Asus P8Z68 Deluxe-Gen 3 | Intel Core i7 3770K | 32 GB Crucial Ballistix DDR3 PC12800/1600MHz CL9 (4 x 8GB) | Noctua NH-D15 | samsung 850 Pro SSD 120gb | Fractal Define R5 | Seasonic Force 80+ Gold 750W |

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av Farthinder:

Har läst den ^^ kollade ganska omgående min kabel. Vet att många som t.ex. komplett osv har börjat märka kablar på deras sida med " ej pin 20 " eller ngt dylikt

Ahh oki.

Jag editerade mitt inlägg för det kändes tjatigt med länk och allt igen.
Och det är bra att de börjat skriva det rakt ut. Har själv sett problemet också.

Det kan ju dock finnas fler orsaker till samma problem...

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013
Skrivet av Arneby:

@Thomas - uppdateringsfrekvensen är nu 59 Hz enligt Windows. Det är väl inte så högt? Vad bör jag sätta den till?

Och eh, var gör jag det numera?

Kolla hur du länkar in användaren med @

Du ändra detta i Nvidia-drivrutinen eller i Windows bildskärms-inställningar, avancerat någonting.

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Jul 2011

@Paddanx:
Håller med till fullo! jag var helt tokig ett tag när jag inte fick igång min nya skärm xD ( gick då över till DP 144hz ) glad som man var, kom hem plugga in och.... svart, följt av *infoga svordomsramsa här* sen en rackarns massa googlande och svaret för mig iaf, fanns på swec

Friskt kopplat, Hälften brunnet

ASUS STRIX 980 GTX | Asus P8Z68 Deluxe-Gen 3 | Intel Core i7 3770K | 32 GB Crucial Ballistix DDR3 PC12800/1600MHz CL9 (4 x 8GB) | Noctua NH-D15 | samsung 850 Pro SSD 120gb | Fractal Define R5 | Seasonic Force 80+ Gold 750W |

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av Farthinder:

@Paddanx:
Håller med till fullo! jag var helt tokig ett tag när jag inte fick igång min nya skärm xD ( gick då över till DP 144hz ) glad som man var, kom hem plugga in och.... svart, följt av *infoga svordomsramsa här* sen en rackarns massa googlande och svaret för mig iaf, fanns på swec

Mer imponerad att du lyckades googla på en "svart" skärm

Jag tror ärligt att TS har lite störningar och är på gränsen på vad kabeln ska klara. Kjell + Certifierad kabel, är som Aliexpress stämplad spänningsomvandlare. Kan fungera... men vem vet. Nästan allt på kjell idag är ju deras egna märken, eller deltaco udda. Allt är inte dåligt, men det är lite som biltema varor numera.

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

Uppdateringsfrekvens sänkt till 30 Hz sedan några timmar tillbaka. Verkar lösa problemet (peppar peppar)

Om så faktiskt är fallet; vilken är den trasiga länk som behöver bytas?

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

Ja, det verkar lira med 30 Hz. Ingen glitch på ett dygn nu. Huzza!

Borde jag gå till Kjell & Co och gnälla på kabeln?

Vad förlorar jag på att inte köra 60 Hz (det här är ingen speldator)?

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

@Arneby: Jämför känslan i muspekaren, flytta fönster i Windows etc.

Detta är en av första DP8K-certifierade kablarna: https://www.prisjakt.nu/produkt.php?p=4660089

Jag gick igenom DP8K här: https://www.sweclockers.com/artikel/25325-teknikstund-de-fem-...

Trädvy Permalänk
Medlem
Plats
Nacka
Registrerad
Aug 2006

Hm, jag har alltså den här: https://www.kjell.com/se/sortiment/dator-natverk/kablar-adapt...

Fy på sig Kjell!