Problem med nätverkskort och kernel på gammal laptop

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Problem med nätverkskort och kernel på gammal laptop

Jag sitter och försöker installera linux på en gammal 166 MHz laptop jag fått gratis.

Då jag inte hade någon större lust att lägga ner massa tid på installationen till den så drog jag in Debian netinstall.

Tyvärr var det inte så enkelt som jag hade hoppats. Det första problemet var att efter jag installerat den med 2.6.8-1 kernel så startade den om direkt efter jag valt kernel i bootloadern (grub).

Började om igen och körde denna gången med 2.4.27 kernel istället och då bootade den upp normalt men efter den laddat modulen till nätverkskortet (3c589) får jag "eth0: interrupt(s) dropped!". Det ploppar upp ungefär 2 gånger i minuten. Kortet fungerar bra att använda både till surfning och filöverföring, dock är det fruktansvärt irriterade att när man använder datorn och det där ständigt ploppar upp.

Jag undrar om någon har en lösning på problemet med nätverkskortet eller kernel ? Nätverkskortet är det som är mest akut.

Trädvy Permalänk
Medlem
Plats
Borås
Registrerad
Maj 2002

Man hittar alltid nåt om man söker på felmeddelanden på google

http://www.google.com/search?hl=en&q=3c589+eth0%3A+interrupt%...

flippy @ Quakenet

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Jul 2004

Jo försökte med det först men ledsnade på att lästa mailing lists på alla möjliga språk från tyska till arabiska.

Tänkte man kunde få ett lite snabbare svar här

EDIT: Problemet löste sig efter jag installerade en 386 kompilerad kernel istället för en 686 som verkar vara default. Efter jag lyckats få in en 2.6 kernel löste sig även problemet med nätverket.