extern hårdisk fryser överföring vid 100%

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Sep 2015

extern hårdisk fryser överföring vid 100%

Har en 2tb Segate hårdisk (st2000dl003-9vt166) som har problem när jag flyttar över saker. Jag kan flytta små filer (upp till 100mb) utan att de saktar ner och i vettig hastighet, men så fort hårdisken kommit upp på 100% använding fryser överförningen och den slutar flytta över filerna. Så när jag ska flytta 2gb, så flyttar den 100mb, sen slutar den då hårdisken är på 100% och överförningen fryser. Jag har testat både windows filemanager och teracopy men båda leder till samma problem. Jag har formaterat om den flertals gånger till olika format (både långa formateringar och snabb formateringar) men de har inte hjälp häller. Har även testat den med olika datorer men de hjälper ändå inte. Finns de lösning till detta? När man söker på google kommer bara C: 100% upp som är för att snabba upp windows, alltså inte för att fixa min externa hårdisk.

tack i förväg

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Om externa hårddisken är fragmenterad går en kopiering snabbt men dess flush av skrivcache lång tid. Vänta och se om den "löser upp sig" efter ett par minuter. Prova även att avinstallera ditt antivirus - många är rent av vidriga vad gällande prestanda.

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Sep 2015

Hårdisken är in princip tom (endast 30mb använd), har haft problemet i över 6månader (testar då och då) och har inget anti virus på de datorer jag använt (stängt av Windows egna tillome).

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

Vad säger S.M.A.R.T status om din externa hårddisk? https://en.wikipedia.org/wiki/S.M.A.R.T.

Trädvy Permalänk
Medlem
Registrerad
Aug 2016

Provat med någon annan OS än windows och även på annan hårdvara/dator? - ibland är det USB-drivrutinerna i kombination med moderkortets USB-chip som låser sig och du ser disken på 100% lastad utan att det läser/skriver något tills det eventuellt gör en timeout och så försöker den igen och det kanske går att köra en stund till. Det är massor av saker under huven som skall fungera - det är att det finns minne, DMA och att timing fungerar. moderkortet har AHCI-läget aktivt etc.

Har sett problemet på tex. HD-disk-dockor och det är inte fel på enheterna som sådan utan det är missmatch mellan olika drivrutiner för USB och dess hårdvara och det kan krångla i windows men går utmärkt i Linux eller tvärt om på exakt samma hårdvara och disk.

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Sep 2015

Smart visar inget fel. Testat olika datorer, olika kablar, tillomed tatt ut hårdisken och satt i den i olika datorer men inget av de hjälper. Även testat Linux.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Okt 2002
Skrivet av ThaManWithTheHat:

Smart visar inget fel. Testat olika datorer, olika kablar, tillomed tatt ut hårdisken och satt i den i olika datorer men inget av de hjälper. Även testat Linux.

Skickades från m.sweclockers.com

Kolla med Seagates egna verktyg om det hittar något skumt med disken:
länklänk

-:| i7-3930K | P9X79 Deluxe | 32GB 1600Mhz | Corsair TX750W |:-
-:| Ryzen7 2700X | Strix x470-I | 32GB 3200Mhz | GTX1070 | EVGA G2 550W |:-
-:| Citera för svar |:-

Trädvy Permalänk
Medlem
Plats
Där hemma
Registrerad
Jun 2017
Skrivet av GreyWilk:

Kolla med Seagates egna verktyg om det hittar något skumt med disken:
länklänk

eller CrystalDiskInfo
https://crystalmark.info/en/software/crystaldiskinfo/

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Apr 2013
Skrivet av ThaManWithTheHat:

Har en 2tb Segate hårdisk (st2000dl003-9vt166) som har problem när jag flyttar över saker. Jag kan flytta små filer (upp till 100mb) utan att de saktar ner och i vettig hastighet, men så fort hårdisken kommit upp på 100% använding fryser överförningen och den slutar flytta över filerna. Så när jag ska flytta 2gb, så flyttar den 100mb, sen slutar den då hårdisken är på 100% och överförningen fryser. Jag har testat både windows filemanager och teracopy men båda leder till samma problem. Jag har formaterat om den flertals gånger till olika format (både långa formateringar och snabb formateringar) men de har inte hjälp häller. Har även testat den med olika datorer men de hjälper ändå inte. Finns de lösning till detta? När man söker på google kommer bara C: 100% upp som är för att snabba upp windows, alltså inte för att fixa min externa hårdisk.

tack i förväg

Vad kör du på för port? Låter som väldigt långsamt USB. Se till att du kör på Högsta USB-hastigheten

Du hade provat i Linux sa du, har du även provat att nolla disken totalt, vilket är något helt annat än att formatera.

Kommandot är följande: dd if=/dev/zero of=/dev/sdX bs=1M

Detta kommer skriva över allt på disken till den tar slut och då avsluta med ett felmeddelande på att den är full.

X ska ersättas med den bokstav som disken motsvaras av i Linux. Denna kan ses med blkid eller lsblk samt i GUI med GParted (gparted) samt Diskar (gnome-disks) Observera att du enbart ska använda bokstaven, inte efterföljande siffra eftersom siffran bara tömmer partitionen och inte hela disken. Anledningen till detta är att du även vill tömma partitionstabellen och andra dolda utrymmen ifall något konstigt fel förekommer i partitionstabellen. Sedan kan jag rekommendera att använda det Nya GPT istället för MBR för partitionstabellen eftersom det är säkrare, även om disken är mindre än 2TB.

Server: AMD Ryzen 7 1800X 8/16 | ASUS Crosshair VI hero | 64 GB Corsair RAM @3000 MHz | ASUS radeon RX 460 2GB | Samsung 960 PRO 512 GB M.2 | 2x 2 TB Samsung 850 PRO SSD | 6x Seagate 10 TB | NEC PA301W @ 2560x1600 | Linux Mint 19 Cinnamon

Trädvy Permalänk
Medlem
Plats
Sthlm
Registrerad
Apr 2004

Med det länkade serienumret hittar man en disk utan usb skal. Vad är det för usb-sata adapter du har?

Det låter ju som att den packar ihop när skrivcachen blir full.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Plats
Skövde
Registrerad
Sep 2015

Har testat disken med seagates verktyg utan någon lycka, programmet förs när den skulle reparera problemen och sen fick jag ett error. CrystalDiskInfo säger att de inte är något fel på disken.

Skrivet av OldComputer:

Vad kör du på för port? Låter som väldigt långsamt USB. Se till att du kör på Högsta USB-hastigheten

Du hade provat i Linux sa du, har du även provat att nolla disken totalt, vilket är något helt annat än att formatera.

Kommandot är följande: dd if=/dev/zero of=/dev/sdX bs=1M

Detta kommer skriva över allt på disken till den tar slut och då avsluta med ett felmeddelande på att den är full.

X ska ersättas med den bokstav som disken motsvaras av i Linux. Denna kan ses med blkid eller lsblk samt i GUI med GParted (gparted) samt Diskar (gnome-disks) Observera att du enbart ska använda bokstaven, inte efterföljande siffra eftersom siffran bara tömmer partitionen och inte hela disken. Anledningen till detta är att du även vill tömma partitionstabellen och andra dolda utrymmen ifall något konstigt fel förekommer i partitionstabellen. Sedan kan jag rekommendera att använda det Nya GPT istället för MBR för partitionstabellen eftersom det är säkrare, även om disken är mindre än 2TB.

Testat flera olika datorer och flera olika portar (både 2.0 och 3.0) så porten bör inte vara några problem. Även tagit ut disken och kopplat in den direkt med sata så tror ej de är felet.
Kan testa de i linux, men tror inte de kommer funka häller, har nollat disken förr i andra program dock var de via windows. Men värt ett försök. Om det inte funkar tror jag att jag ger upp disken.

Skrivet av henkiii:

Med det länkade serienumret hittar man en disk utan usb skal. Vad är det för usb-sata adapter du har?

Det låter ju som att den packar ihop när skrivcachen blir full.

Skickades från m.sweclockers.com

Jag köpte hårdisken av en kompis (för 2-3år sen och då funka den) då han inte använde den och jag fick den i en läsare, men de kan antagligen vara så att han stoppa den där i. Läsaren är en KÖNIG CSU3HDE35S100 men har även testat disken via sata och får samma problem så de bör inte vara läsarens fel, har även använt den läsaren till andra diskar förr utan några problem.

Trädvy Permalänk
Medlem
Plats
Malmö
Registrerad
Maj 2014
Skrivet av ThaManWithTheHat:

Har testat disken med seagates verktyg utan någon lycka, programmet förs när den skulle reparera problemen och sen fick jag ett error. CrystalDiskInfo säger att de inte är något fel på disken.

Okej, säger Seagates verktyg att något är fel och den ska reparera, då är där fel.
Börja med att ta backup på allt viktigt du kan från den disken, för jag misstänker stora problem.

Crystal disk Info säger mycket, mycket mer än "Bra/Dålig", men man måste veta hur man ska läsa det. Finns många ex på diskar som SMART-mässigt säger "ingen fara"... medan de drunknar i problem.

Ta denna tråd tex:
https://www.sweclockers.com/forum/trad/1526969-mapp-forsvann-...

CDI säger bra, men som du kan se i mitt inlägg, kan man väldigt tydligt utläsa att den disken har allvarligt problem.
Vill du ha hjälp att tolka dens riktiga status, länka en skärmdump på info med programmet (och ta med samtliga rader info) på din disk.

Och som det låter från beskrivningen, har han och du väldigt likt problem... då hans också fryser vid 100% last, och slutar svara. Detta kallas Command Timeout, och är något som ofta är kritiskt tecken på allvarliga fel. Det är disken som "ger upp" eller fastnar i evigt försökande.

Tex RAID diskar har en spärr på ca 7sek här, så om inget sker efter 7 sek, returnerar de "fel/error" istället, just för att om de väntar längre, kastas disken ut som totalt defekt. En icke NAS/RAID disk kan försöka i flera minuter med omöjliga jobb dock, vilket hänger system, eller skapar oändligt väntande, som du verkar beskriva.

Gällande Seagates mjukvara, ta det direkt i SATA porten (dvs disken direkt i SATA anslutning), då USB kontrollern kan få panik och sluta svara om den får fel den inte kan hantera. Den fungerar säkert kanon när allt är bra med disken, men när HDDn får problem så skapar den ännu mer problem.