Försöker starta teamspeak server men får meddelandet ELF binary type "0".

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016

Försöker starta teamspeak server men får meddelandet ELF binary type "0".

Hej jag har Ubuntu 12.4 att installera en teamspeak server via en tutorial som jag följde men har tyvärr tappat bort länken. När jag ska starta så kommer detta upp och jag förstår inte hur man fixar det. Själva servern startar inte heller och vet inte om jag har gjort rätt i ini filen.

Felmeddelande från terminalen.

ELF binary type "0" not known. ./ts3server_linux_amd64: 1: ./ts3server_linux_amd64: Syntax error: word unexpected (expecting ")")

Trädvy Permalänk
Medlem
Registrerad
Sep 2006

Posta ini-filen till att börja med så vi får kika i den.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016
Skrivet av HerrNilsson:

Posta ini-filen till att börja med så vi får kika i den.

Förlåt jag rensade bort hela teamspeak mappen från Ubuntu servern för att börja om så det existerar inte längre. Men på ip där skrev jag min vanliga ip som man får från whatismyip.com fast servers ip då och inte min hemmadators ip. Sen fyllde jag i resten där jag visste in om man behövde öppna portar men det gjorde jag ej. 30033 porten och något till kan ha varit 9987 stod i ini filen. Fanns ju ingen förklaring vad som skulle fyllas i.

Trädvy Permalänk
Medlem
Registrerad
Sep 2006
Skrivet av Ikasera:

Förlåt jag rensade bort hela teamspeak mappen från Ubuntu servern för att börja om så det existerar inte längre. Men på ip där skrev jag min vanliga ip som man får från whatismyip.com fast servers ip då och inte min hemmadators ip. Sen fyllde jag i resten där jag visste in om man behövde öppna portar men det gjorde jag ej. 30033 porten och något till kan ha varit 9987 stod i ini filen. Fanns ju ingen förklaring vad som skulle fyllas i.

Enligt felmeddelandet hade du mest troligt med ett tecken som inte skulle vara där, eller som saknades. Testa igen och får du inte rätt på det så posta felmeddelande + ini-fil.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016

@HerrNilsson: Nu hittar jag ingen bra tutorial för när jag ska ladda ner zip filen via wget så finns dem ej antagligen så är dem utgångna har du en tutorial att bjuda på ?

Trädvy Permalänk
Medlem
Registrerad
Sep 2006
Skrivet av Ikasera:

@HerrNilsson: Nu hittar jag ingen bra tutorial för när jag ska ladda ner zip filen via wget så finns dem ej antagligen så är dem utgångna har du en tutorial att bjuda på ?

Serverversionen har du här https://www.teamspeak.com/downloads#server
Varför måste du köra wget? Skickar över den med SFTP bara.

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Registrerad
Apr 2013
Trädvy Permalänk
Medlem
Registrerad
Apr 2013
Skrivet av HerrNilsson:

Serverversionen har du här https://www.teamspeak.com/downloads#server
Varför måste du köra wget? Skickar över den med SFTP bara.

Varför köra ett extra steg

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016

Tillagd måste man verkligen använda mariadb? Tänkte bara testa nu och har phpmyadmin samt så hittar jag ingen ini eller config för anslutning till databasen.

EDIT: Får samma nu igen.

Använder denna nu!

machine_id= default_voice_port=9987 voice_ip=0.0.0.0 licensepath= filetransfer_port=30033 filetransfer_ip=127.0.0.1 query_port=10011 query_ip=127.0.0.1 query_ip_whitelist= query_ip_blacklist= dbplugin=ts3db_sqlite3 dbpluginparameter= dbsqlpath= dbsqlcreatepath= dblogkeepdays=90 logpath= logquerycommands=0 dbclientkeepdays=30

Error

./ts3server_startscript.sh start Starting the TeamSpeak 3 server ELF binary type "0" not known. ./ts3server: 1: ./ts3server:ELF: not found TeamSpeak 3 server could not start root@gesior:/home/teamspeak3-server_linux_amd64# ./ts3server: 2: ./ts3server: Syntax error: Unterminated quoted string

Trädvy Permalänk
Medlem
Registrerad
Sep 2006
Skrivet av aluser:

Varför köra ett extra steg

För att man inte hittar en wget-länk som funkar? Det är inte så att det tar en förmiddag...

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Registrerad
Sep 2006
Skrivet av Ikasera:

Tillagd måste man verkligen använda mariadb? Tänkte bara testa nu och har phpmyadmin samt så hittar jag ingen ini eller config för anslutning till databasen.

EDIT: Får samma nu igen.

Använder denna nu!

machine_id= default_voice_port=9987 voice_ip=0.0.0.0 licensepath= filetransfer_port=30033 filetransfer_ip=127.0.0.1 query_port=10011 query_ip=127.0.0.1 query_ip_whitelist= query_ip_blacklist= dbplugin=ts3db_sqlite3 dbpluginparameter= dbsqlpath= dbsqlcreatepath= dblogkeepdays=90 logpath= logquerycommands=0 dbclientkeepdays=30

Error

./ts3server_startscript.sh start Starting the TeamSpeak 3 server ELF binary type "0" not known. ./ts3server: 1: ./ts3server:ELF: not found TeamSpeak 3 server could not start root@gesior:/home/teamspeak3-server_linux_amd64# ./ts3server: 2: ./ts3server: Syntax error: Unterminated quoted string

Vilken guide har du kört?

Dator: https://www.inet.se/kundvagn/bild/9823049/
Server: 2x HP ProLiant Microserver Gen8, 16GB/st, ESXi 6.0
NAS: Synology DS413 4st 3TB | QNAP TS-879 Pro 8st 2TB

Trädvy Permalänk
Medlem
Plats
Olofström
Registrerad
Feb 2012

Skaffa Discord istället. Gratis och funkar bättre.

Skickades från m.sweclockers.com

Chassi: Fractal Design R5 CPU: Intel i7 6700K RAM: 16Gb DDR4 Moderkort: Asus Z170 Pro Grafik: GTX 1080 STRIX OS: W10
Bra Steam design: Metro for Steam Mitt Nintendo ID: SW-0939-9900-1006

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016

@HerrNilsson: Jag tankade bara servern och sökte upp ini filen på ett forum. Det är väl det enda som behövs om jag har förstått docs/firststart eller vad filer heter rätt.

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Mar 2005

Det här är över mitt kunskapsområde men vid en googling på felmeddelandet så handlar nästan alla trådar om folk som försöker köra linuxbinärer under FreeBSD. Det låter som din maskin inte gillar ts3-binären.

Vad ger kommandot uname -a för output? Vad sägs det när du kör ldd ts3server_linux_amd64?

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016
Skrivet av jagardaniel:

Det här är över mitt kunskapsområde men vid en googling på felmeddelandet så handlar nästan alla trådar om folk som försöker köra linuxbinärer under FreeBSD. Det låter som din maskin inte gillar ts3-binären.

Vad ger kommandot uname -a för output? Vad sägs det när du kör ldd ts3server_linux_amd64?

GNU/kFreeBSD Ikasera 9.3-RELEASE-p33 FreeBSD 9.3-RELEASE-p33 #0: Wed Jan 13 17:55 :39 UTC 2016 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC x86_64 amd64 Intel(R) Xeon(R) CPU E3-1225 V2 @ 3.20GHz GNU/kFreeBSD

Den filen var inte med i packet.

Trädvy Permalänk
Medlem
Plats
Solna
Registrerad
Mar 2005
Skrivet av Ikasera:

GNU/kFreeBSD Ikasera 9.3-RELEASE-p33 FreeBSD 9.3-RELEASE-p33 #0: Wed Jan 13 17:55 :39 UTC 2016 root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC x86_64 amd64 Intel(R) Xeon(R) CPU E3-1225 V2 @ 3.20GHz GNU/kFreeBSD

Den filen var inte med i packet.

Då är vi nog närmare en förklaring. För du skriver i ditt första inlägg att du kör Ubuntu 12.4 och det ser inte ut att stämma. Teamspeak 3 server finns tillgängligt i ports för FreeBSD så det känns spontant som att den vägen borde vara enklare att gå. Här finns instruktioner: http://bin63.com/how-to-install-teamspeak-3-server-on-freebsd

Felet du fick tidigare beror med största sannolikhet på att du försöker köra en linuxbinär på FreeBSD. Det är inte så att du råkar följa en Ubuntu-guide?

Trädvy Permalänk
Avstängd
Registrerad
Apr 2016

@jagardaniel: Ja. Nu har jag tankat ner Freebds servern och lagt in den på dedicated trodde det var ubuntu först men glömt att jag hade bytat av en anledning I alla fall jag har lagt in servern och även provat starta .sh filerna men det funkar inte heller just nu.

root@ikasera:/home/teamspeak# ./ts3server_startscript.sh start Starting the TeamSpeak 3 server TeamSpeak 3 server could not start root@Ikasera:/home/teamspeak# ELF interpreter /libexec/ld-elf.so.1 not found

Kollade över commandet och testade funkade inte.

root@Ikasera:/home/teamspeak# make install clean; rehash make: *** No rule to make target 'install'. Stop. -bash: rehash: command not found root@Ikasera:/home/teamspeak#