Installerade openSUSE på ASUS X551 - UEFI problem

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008

Installerade openSUSE på ASUS X551 - UEFI problem

Hej!

Jag testade att installera openSUSE på min ASUS X551 Sonic Master. Denna dator kom original med Windows 8.0 och har något som kallas UEFI.

När jag installerade openSUSE och skulle starta om datorn efter att openSUSE var installerat klart så kunde mitt BIOS inte känna av någon boot-lista. Inga hårddiskar. Dock USB-minnet kunde BIOS känna av.

Om openSUSE har förstört min dator så får jag väll acceptera detta. Datorn är 2 år gammal och kostade 2200 kr. Dessutom har den blivit seg.

Men kan jag rädda datorn? Eller har openSUSE totalt förstört datorn?

De linuxsystem som jag har testat på datorn innan är:
* Ubuntu
* Lubuntu
* Debian
* Fedora

Men alla dessa är tråkiga linuxdistribution - speciellt Debian. Jag valde openSUSE för det är en linuxdistribution för arbete och affärer.

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Registrerad
Nov 2016

Nu har jag ingen koll på openSUSE men man kanske behöver BIOS för det och inte UEFI?
Isåfall kan du prova att aktivera "legacy boot" i dina UEFI-inställningar!

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008
Skrivet av klisk:

Nu har jag ingen koll på openSUSE men man kanske behöver BIOS för det och inte UEFI?
Isåfall kan du prova att aktivera "legacy boot" i dina UEFI-inställningar!

Så här ser det ut på mitt BIOS. Men det finns inget om "Boot option priorites".

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Registrerad
Nov 2016

@heretic16: prova ta bort fast boot och kolla om det dyker upp någonstans, kan även vara under security eller någon annan flik!

Det är Launch CSM, sätt den till enabled och kolla om det funkar.

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008
Skrivet av klisk:

@heretic16: prova ta bort fast boot och kolla om det dyker upp någonstans, kan även vara under security eller någon annan flik!

Det är Launch CSM, sätt den till enabled och kolla om det funkar.

Detta har jag testat. Fungerade inte. Så länge jag inte kan se någon "Boot option priorites" så kan jag inte starta ett OS.

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Registrerad
Nov 2016

Lite svårt att hjälpa då jag inte vet hur opensuse funkar eller vilken bootloader som används eller något, är heller ingen expert men hade liknande problem med min arch-installation ett tag
Har du kollat om du måste inaktivera Secure-boot?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Apr 2002
Skrivet av heretic16:

Boot Option #1 [Windows Boot Manager]

Förväntar den sig inte ett Windows OS då, kolla om det går att ändra till något annat?

Trädvy Permalänk
Medlem
Plats
Halmstad
Registrerad
Apr 2002

https://en.opensuse.org/openSUSE:UEFI#The_Boot_Manager

Kolla så du inte måste enabla support för Secure Boot.

How to enable or disable Secure Boot support

"Secure Boot support in openSUSE 12.3 is still considered experimental. The installation program YaST can not automatically detect whether secure boot is enabled. During the installation it offers an option to manually enable Secure Boot support. Turning that option on is required for shim to be installed. To enable or disable support for Secure Boot in an installed system the YaST bootloader module can be used."

Nu kanske det inte behövs i nyaste OpenSUSE men skadar inte att kolla.

Och om du inte redan gjort det, se till att du har uppdaterat till senaste BIOS också.

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008
Skrivet av Åsa-Nisse:

https://en.opensuse.org/openSUSE:UEFI#The_Boot_Manager

Kolla så du inte måste enabla support för Secure Boot.

How to enable or disable Secure Boot support

"Secure Boot support in openSUSE 12.3 is still considered experimental. The installation program YaST can not automatically detect whether secure boot is enabled. During the installation it offers an option to manually enable Secure Boot support. Turning that option on is required for shim to be installed. To enable or disable support for Secure Boot in an installed system the YaST bootloader module can be used."

Nu kanske det inte behövs i nyaste OpenSUSE men skadar inte att kolla.

Och om du inte redan gjort det, se till att du har uppdaterat till senaste BIOS också.

Hej jag har både testat Launch CSM och Secure boot.

Inget av detta fungerar.

Skickades från m.sweclockers.com

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008
Skrivet av Åsa-Nisse:

Förväntar den sig inte ett Windows OS då, kolla om det går att ändra till något annat?

Jag har kört linux på datorn. Ville komma bort från Windows 10.

Skickades från m.sweclockers.com

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |

Trädvy Permalänk
Medlem
Plats
Örnsköldsvik
Registrerad
Jun 2008

Linux mint fungerar iallafall fall.

Skickades från m.sweclockers.com

| CPU: MMX 200 MHz Intel Pentium I| GPU: Voodo2 3dfx 8 Mb| RAM: SDRAM 32 Mb 133 Mhz | PSU: 3V fläkt 2W | Chassi: HP Vectra VE 5| Skärm: HP Ergo 1024| HDD: Toshiba 2033 MB | OS: Windows 95 B | Mus: HP |