Problem med installationen av *buntu distros

Trädvy Permalänk
Medlem
Plats
Höganäs
Registrerad
Aug 2002

Problem med installationen av *buntu distros

Som bilderna visar

Detta sker i dem flesta Ubuntu distros inklusive Linux Mint 19, Arch vill inte heller. Secure Boot/CSM är konfigurerat för Legacy. Det ska installeras på en egen HDD, dator i signatur.

PS3 Slim 320GB (1TB) | Wii U Premium | Xbox 360 250GB | X1 1TB | PS4 (4TB, Nyko Data Bank) | iPhone SE 32GB Black | Huawei T3 MediaPad 10" | New 3DS XL + KatsuKity's Capture Card | PS Vita 32GB | pfSense PC 2x1Gbit + 16-port 1Gbit Switch + D-Link 868L (som AP) | Ryzen 1700, 16GB DDR4 3000Mhz, 240GBx2 SSD, GTX 980, 3TB, A320M-DS2 | Windows 10 Home 64-bit | Apple Macbook Pro 13" Mid-2013

Trädvy Permalänk
Medlem
Plats
Småland, långt ute i mörka skogen.
Registrerad
Maj 2018

Kan bara gissa att din dator/minne/grafikkort är överklockat. Sänk allt till standard/stock och prova igen.

Linux och Android

Trädvy Permalänk
Medlem
Plats
Höganäs
Registrerad
Aug 2002

@Adoby: Det är inte överklockat eller har höga temperaturer.

PS3 Slim 320GB (1TB) | Wii U Premium | Xbox 360 250GB | X1 1TB | PS4 (4TB, Nyko Data Bank) | iPhone SE 32GB Black | Huawei T3 MediaPad 10" | New 3DS XL + KatsuKity's Capture Card | PS Vita 32GB | pfSense PC 2x1Gbit + 16-port 1Gbit Switch + D-Link 868L (som AP) | Ryzen 1700, 16GB DDR4 3000Mhz, 240GBx2 SSD, GTX 980, 3TB, A320M-DS2 | Windows 10 Home 64-bit | Apple Macbook Pro 13" Mid-2013

Trädvy Permalänk
Medlem
Plats
Småland, långt ute i mörka skogen.
Registrerad
Maj 2018

Vad händer om du inte försöker installera utan köra Ubuntu från USB-minnet?

Vad händer om du försöker köra minnestest?

Förresten, är USB-minnet friskt? Kan du köra Ubuntu på annan dator med det?

Jag skulle gissa att det är problem med någon hårdvara. Ett sätt att felsöka är att koppla bort/byta ut hårdvara tills det funkar. Inkluderar minneskretsar, grafikort och CPU. Det behöver inte vara fel på hårdvara. Det kan vara Linux som försöker använda det fel.

En drastisk åtgärd är att göra en reset på bios till default. Men gör du det kanske annat slutar fungera?

Linux och Android

Trädvy Permalänk
Medlem
Plats
Höganäs
Registrerad
Aug 2002

Jag använde relativt nyligen USB-minnet för att installera om Windows, går utmärkt. Minnestest utförde jag när jag monterade Ryzen setupen och har inte haft några problem sedan dess. I samband ominstallationen flashade jag BIOSet till senaste, inställningarna resettades automatiskt. Men optimized default gör begränsar möjligheten att installera Linux (CSM med bias för UEFI).

I Ubuntu Mate 16 så kan jag få någorlunda bild men "splashscreenen" försvinner inte för vidare interaktion, alla andra distros ger mig korrupt bild. När jag startar distrona i MBR så är problematiken i stort sett detsamma men i allt är i commandline - då får jag mededelandet att EDIDn på skärmen genom HDMIn inte hittas.

Googlar jag så är antangandet gammal kernel och/eller dåliga drivers, och drivers kan jag inte installera om när OSet inte installeras i första hand och jag har likmed noll kunskap med commandline för manuell process.

PS3 Slim 320GB (1TB) | Wii U Premium | Xbox 360 250GB | X1 1TB | PS4 (4TB, Nyko Data Bank) | iPhone SE 32GB Black | Huawei T3 MediaPad 10" | New 3DS XL + KatsuKity's Capture Card | PS Vita 32GB | pfSense PC 2x1Gbit + 16-port 1Gbit Switch + D-Link 868L (som AP) | Ryzen 1700, 16GB DDR4 3000Mhz, 240GBx2 SSD, GTX 980, 3TB, A320M-DS2 | Windows 10 Home 64-bit | Apple Macbook Pro 13" Mid-2013

Trädvy Permalänk
Medlem
Plats
Småland, långt ute i mörka skogen.
Registrerad
Maj 2018

Vad händer om du tittar på annan video-output än HDMI? Jag har aldrig testat att använda HDMI på någon av mina Linux-burkar. Kanske det är HDMI-output som ställer till det för dig? Testa annan skärm utan HDMI. Bara famlar i mörkret...

Funkar det kan du installera NVidia-drivrutiner och prova HDMI igen.

Om du startar med en ny live-USB så tycker jag att du borde ha rätt fräsch kärna och drivrutiner.

Linux och Android

Trädvy Permalänk
Medlem
Plats
Höganäs
Registrerad
Aug 2002

Jag har ingen annan skärm och skärmen har bara VGA, DVI och HDMI. Grafikkortet har inte VGA, har ingen DVI kabel liggandes och det känns udda HDMI skulle vara problemet när det fungerar i överlag perfekt, så jag har bara använt HDMI för det har bara fungerat - tills nu. Men jag kan inte installera om drivrutiner för linux för jag har inte kunskapen (som jag nämnde tidigare) nog för att göra det, hade hoppats att pakethanteraren fixade den biten när inte bilden fungerar till att börja med. Har även provat köra Live (try before install biten) men det är samma sak där.

Notera att "artefakt" problematiken har BARA dykt upp under linux, bilden är perfekt i Windows så varken grafikkortet eller skärmen är problemet.

PS3 Slim 320GB (1TB) | Wii U Premium | Xbox 360 250GB | X1 1TB | PS4 (4TB, Nyko Data Bank) | iPhone SE 32GB Black | Huawei T3 MediaPad 10" | New 3DS XL + KatsuKity's Capture Card | PS Vita 32GB | pfSense PC 2x1Gbit + 16-port 1Gbit Switch + D-Link 868L (som AP) | Ryzen 1700, 16GB DDR4 3000Mhz, 240GBx2 SSD, GTX 980, 3TB, A320M-DS2 | Windows 10 Home 64-bit | Apple Macbook Pro 13" Mid-2013

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Okt 2009

Skärmen "verkar" ha felaktig eller saknad EDID information.

Det kanske tex rör sig om en bra och billig "korea" skärm?
Flera av dessa kan sakna korrekt EDID information men skärmen kan ev fungera bra med Windows som antingen kanske har någon form av workaround för felet (då leverantören normalt bara säljer till windows användare ). Ev kanske windows på ett automatiskt sätt auto fixar vissa typer av fel bättre än linux. Jag vet inte orsaken, men jag själv köpte en catleap som jag var tvungen att overrida EDID informationen på för att få den att funka bra i Linux ( medan den funkade bra i windows).

Ev har just dessa saker börjat funka lite bättre nu för tiden pga nyare versioner av linux men jag var i alla fall tvungen att göra lite manuella inställningar för att få den att fungera bra i början.
Dvs något i stil med nedanståede var jag tvungen att göra på min monitor för att kunna nyttja full upplösning (2560x1440).
https://ubuntuforums.org/archive/index.php/t-2038997.html

Temporärt test
----
Du kan ev försöka med extra kernel options att begränsa upplösningen till VGA mod bara för att se om det kan fungera...
tex testa med extra kernel option
*1:: vga=788
eller kanse något i stil med
*2:: vga=normal fb=false

(*1 bör begränsa upplösningen till 800x600 vilket har större chans att funka med korrupt EDID
https://www.pendrivelinux.com/vga-boot-modes-to-set-screen-re... )
(*2 försöker disable framebuffer, osäker om det kan hjälpa, men kan ev vara värt att testa
https://help.ubuntu.com/lts/installation-guide/i386/ch05s03.h...

Edit: annars kan du ev försöka koppla upp datorn mot en vanlig tv hos dig (eller någon bekant) om du inte har tillgång till någon extra monitor.
Det mest extra jag hittade var annars
vga=0x300 or vga=0x301
(vilket borde ge upplösning 640x400 eller 640x480 vilket är de två lägsta upplösningarn som jag personligen kunnat tänka mig att testa med under felsökningar)

tips om att testa med tv instället för vanlig monitor, och testa med 640x400
Trädvy Permalänk
Medlem
Plats
!
Registrerad
Dec 2007

prova arch, enda som funkade för mig med 1a gen ryzen .....

Gigabyte AX370 Gaming k3, Ryzen 1600, GSkill DDR4 16Gb, 500Gb Samsung Evo M2, Nvidia MSI 1070, 1Tb Sata SSD

Trädvy Permalänk
Medlem
Plats
Småland, långt ute i mörka skogen.
Registrerad
Maj 2018

Kunde försöka med en live-distro som redan har Nvidia-drivrutiner installerade.

Tydligen har Pop!_OS en NVidia-variant. Har aldrig testat.

https://system76.com/pop

Linux och Android

Trädvy Permalänk
Medlem
Plats
Höganäs
Registrerad
Aug 2002

Pop! OS funkar att installera och köra, men det låter mig inte välja upplösning och det är just nu VÄLDIGT lågupplöst, och jag tror som @Milt säger att det kan vara en EDID problem. Är däremot inte helt självsäker på att definiera utan att det går åt helvete.

EDID problemet kan nog också vara anledningen till varför PS4an inte ville ge bild vid direktanslutning (har det annars kopplat till mitt capture card).

PS3 Slim 320GB (1TB) | Wii U Premium | Xbox 360 250GB | X1 1TB | PS4 (4TB, Nyko Data Bank) | iPhone SE 32GB Black | Huawei T3 MediaPad 10" | New 3DS XL + KatsuKity's Capture Card | PS Vita 32GB | pfSense PC 2x1Gbit + 16-port 1Gbit Switch + D-Link 868L (som AP) | Ryzen 1700, 16GB DDR4 3000Mhz, 240GBx2 SSD, GTX 980, 3TB, A320M-DS2 | Windows 10 Home 64-bit | Apple Macbook Pro 13" Mid-2013

Trädvy Permalänk
Medlem
Plats
Småland, långt ute i mörka skogen.
Registrerad
Maj 2018

Felet verkar alltså nu mycket tydligt vara kopplat till skärmen. Troligen kan du hitta information om hur andra har löst detta genom att googla. Eftersom du verkar vilja hålla det hemligt vad det är för skärm så är det svårt att hjälpa dig med detta steg.

Linux och Android

Trädvy Permalänk
Medlem
Plats
Höganäs
Registrerad
Aug 2002

Whoops jag glömde skriva vad det är för skärm, Asus VS239HR. Skärmen köpte jag billigt vid tillfället, så det kan vara en kvalité fråga.

Jag fick möjligheten att välja upplösning efter ett par omstarter, däremot inte max upplösningen som är 1080p. Kan för nuvarande bara använda 1600x900 som valbart men jag kan tvinga in 1080p genom nvidias kontrollpanel, hoppas bara att det inte biter mig i röven.

Men det är udda att jag måste vända mig till specifik distro för att få bild, går det att "tvinga av" EDID identifiering i dem andra distros utan att göra det mycket jobbigare för mig? För PoP! funkar men jag är mer intresserad av *buntu då den inofficiella listan av Steam Play kompatibilitet rapporterar högre siffror med fungerande spel.

PS3 Slim 320GB (1TB) | Wii U Premium | Xbox 360 250GB | X1 1TB | PS4 (4TB, Nyko Data Bank) | iPhone SE 32GB Black | Huawei T3 MediaPad 10" | New 3DS XL + KatsuKity's Capture Card | PS Vita 32GB | pfSense PC 2x1Gbit + 16-port 1Gbit Switch + D-Link 868L (som AP) | Ryzen 1700, 16GB DDR4 3000Mhz, 240GBx2 SSD, GTX 980, 3TB, A320M-DS2 | Windows 10 Home 64-bit | Apple Macbook Pro 13" Mid-2013

Trädvy Permalänk
Medlem
Plats
Småland, långt ute i mörka skogen.
Registrerad
Maj 2018

Det finns Linux-drivrutiner för din skärm. Google är din vän...

Använd Pop tills du köpt/lånat en DVI-kabel och kan testa om det hjälper.

Eller installera OS med en annan skärm inkopplat. Flytta skärm, burk eller hdd. TV med hdmi, som nämndes ovan borde funka. En del OS kan installeras helt utan skärm med ssh.

Eller sätt i ett gammalt billigt grafikkort och installera OS och Nvidia-drivrutiner.

Edit:

PoP!_OS är baserat på Ubuntu 18.04. Nog ett utmärkt val av OS.

https://pop.system76.com/docs/difference-between-pop-ubuntu/

Linux och Android

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012

@Ohem: Det går att tvinga "av" EDID i xorg.conf. Kör så själv med min "Korea skärm" 1440p i 100Hz.

Hade mycket problem i början att få bild med skärmen och fick googla massor och klippa och klistra för att testa mig fram. Hade dock en custom EDID fil som jag kunde falla tillbaka på när det sket sig.

Chassi: FD Arc mini R2 | PSU: CM700V | MB: Asus Maximus V Gene Z77 | CPU: I5-3570K | RAM: 16GB Corsair LP | GPU: MSI Radeon RX580 Armor 8GB | SSD: Crucial MX300 750GB | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition