Trädvy Permalänk
Medlem
Plats
Älmhult
Registrerad
Dec 2011

Portforward, vad är felet?

Tjena jag försöker portforwarda Minecraft för att starta en server från min dator. Så här ser mina inställningar ut https://imgur.com/rob8i06

Jag kan inte förstå varför det inte funkar. Hört att brandväggen kan vara ett problem men jag har stängt av alla inställningar på brandväggen som jag hittar samt antivirus bara för att.

Destination IP måste vara ifyllt. Och jag kan bara välja enheter som finns på mitt nätverk så där har jag valt min dators IP. MAC kan jag inte ändra. Testat starta om routern men det gjorde inget heller.

Tack på förhand!

i7 7700K // Radeon RX 480 8GB // Corsair 16GB DDR4 3000Mhz CL15
Vengeance // MSI Z270 TOMAHAWK // Samsung 850 EVO 500GB // Fractal Design Integra M 550W

Trädvy Permalänk
Medlem
Plats
Hedesunda
Registrerad
Dec 2005

För det första, inaktivera UPNP och NAT-PMP, det är DU som ska ha full koll på vad som NAT'as, inte nåt shady program.

De flesta high-end routers har även brandväggsregler som måste överensstämma med NAT'ningen.

Har du satt statisk IP i routerns DHCP för din minecraft-server?

Vad har du för extern IP-adress om du går till http://whats.myip.rs/

Det kan ju vara så att din ISP NAT'ar din End Point så att du inte har en egen publik internetadress.

Trädvy Permalänk
Medlem
Registrerad
Dec 2011

Windows pc?
Du måste tillåta java i brandväggen, testa att slå av windows brandväggen helt innan du bankar huvudet i väggen som snabbtest

Trädvy Permalänk
Medlem
Plats
Älmhult
Registrerad
Dec 2011
Skrivet av hasenfrasen:

För det första, inaktivera UPNP och NAT-PMP, det är DU som ska ha full koll på vad som NAT'as, inte nåt shady program.

De flesta high-end routers har även brandväggsregler som måste överensstämma med NAT'ningen.

Har du satt statisk IP i routerns DHCP för din minecraft-server?

Vad har du för extern IP-adress om du går till http://whats.myip.rs/

Det kan ju vara så att din ISP NAT'ar din End Point så att du inte har en egen publik internetadress.

Min IP är statisk, rätt säker på det.

https://imgur.com/TnXkUSY
https://imgur.com/1sqJkc5

Det här är min brandvägg.

Att stänga av UPNP och NATPMP gjorde inget än så länge.

Skrivet av Spiffman:

Windows pc?
Du måste tillåta java i brandväggen, testa att slå av windows brandväggen helt innan du bankar huvudet i väggen som snabbtest

Brandväggen var avstängd som jag nämnde ovan, men har accepterat porten i min brandvägg nu istället

i7 7700K // Radeon RX 480 8GB // Corsair 16GB DDR4 3000Mhz CL15
Vengeance // MSI Z270 TOMAHAWK // Samsung 850 EVO 500GB // Fractal Design Integra M 550W

Trädvy Permalänk
Medlem
Plats
011
Registrerad
Mar 2010
Skrivet av tripletutorial:

Min IP är statisk, rätt säker på det.

https://imgur.com/TnXkUSY
https://imgur.com/1sqJkc5

Det här är min brandvägg.

Att stänga av UPNP och NATPMP gjorde inget än så länge.

Brandväggen var avstängd som jag nämnde ovan, men har accepterat porten i min brandvägg nu istället

Vilken IP ger du dem som tänkt ansluta till din server då? Säker på att den inte är bakom CG-NAT?

Jag brukar förutsätta att man förstår skillnad mellan adresser inom ditt eget LAN och din publika IPadress, men eftersom du censurerat din lokala adress (som är helt oväsentlig) så tänker jag att du kanske även försökt få folk att ansluta till densamma:)

Trädvy Permalänk
Medlem
Plats
Älmhult
Registrerad
Dec 2011
Skrivet av Worse:

Vilken IP ger du dem som tänkt ansluta till din server då? Säker på att den inte är bakom CG-NAT?

Jag brukar förutsätta att man förstår skillnad mellan adresser inom ditt eget LAN och din publika IPadress, men eftersom du censurerat din lokala adress (som är helt oväsentlig) så tänker jag att du kanske även försökt få folk att ansluta till densamma:)

Nja jag har lite mer koll än så. Jag ger den IPn man får fram på whatsmyip eller ipchicken, men jag ser ju att porten inte är öppen genom att kolla på http://www.portchecktool.com/

"Bakom CG-NAT"? Där snackar du franska med mig dock.

Men tack för att du tog dig tid att svara, det kunde ju varit det likaväl

i7 7700K // Radeon RX 480 8GB // Corsair 16GB DDR4 3000Mhz CL15
Vengeance // MSI Z270 TOMAHAWK // Samsung 850 EVO 500GB // Fractal Design Integra M 550W

Trädvy Permalänk
Medlem
Registrerad
Jun 2006

Jag är rätt säker på att du inte har statisk IP från din internetleverantör, såvida du inte har ett företagsabonnemang. Finns nog ingen internetleverantör som har tjänsten med statisk IP till privatpersoner (kanske finns undantag). Ditt problem är nog så att du inte har publik IP. Ring din internetleverantör och kolla. Om du inte har det, så be om det. Det brukar inte kosta något. Har du inte publik IP spelar det ingen roll hur många portar du öppnar för det kommer inte att funka.

Vilken internetleverantör har du?

Bytt nick från Defcon till Eazy.

Trädvy Permalänk
Medlem
Plats
Älmhult
Registrerad
Dec 2011
Skrivet av Eazy:

Jag är rätt säker på att du inte har statisk IP från din internetleverantör, såvida du inte har ett företagsabonnemang. Finns nog ingen internetleverantör som har tjänsten med statisk IP till privatpersoner (kanske finns undantag). Ditt problem är nog så att du inte har publik IP. Ring din internetleverantör och kolla. Om du inte har det, så be om det. Det brukar inte kosta något. Har du inte publik IP spelar det ingen roll hur många portar du öppnar för det kommer inte att funka.

Även om så är fallet så kvittar det just nu, min prioritering är att öppna porten sen får vi se om det funkar eller inte. Jag har Telia, och innan de uppgraderade till den nya routerhemsidan så har jag kunnat ha minecraft servrar innan och öppna portar.

Jag tror att jag möjligtvis måste acceptera den genom mitt internets brandvägg (se inlägg ovan med bilder). Problemet är att jag vill inte leka runt där för jag vet inte vad jag gör. Det är cirka 7 olika fält som ska fyllas i så det är lite skrämmande för den ovana.

i7 7700K // Radeon RX 480 8GB // Corsair 16GB DDR4 3000Mhz CL15
Vengeance // MSI Z270 TOMAHAWK // Samsung 850 EVO 500GB // Fractal Design Integra M 550W

Trädvy Permalänk
Medlem
Registrerad
Jun 2006
Skrivet av tripletutorial:

Även om så är fallet så kvittar det just nu, min prioritering är att öppna porten sen får vi se om det funkar eller inte. Jag har Telia, och innan de uppgraderade till den nya routerhemsidan så har jag kunnat ha minecraft servrar innan och öppna portar.

Jag tror att jag möjligtvis måste acceptera den genom mitt internets brandvägg (se inlägg ovan med bilder). Problemet är att jag vill inte leka runt där för jag vet inte vad jag gör. Det är cirka 7 olika fält som ska fyllas i så det är lite skrämmande för den ovana.

Ja, fast IP eller inte är ju som du sa inte så viktigt just nu, men det kan ju ändå vara så att du inte har publik IP längre om de nu gjort någon förändring. Vilket IP får du från Telia. Du kan ju bara nämna första delen av IP't om du inte vill säga hela.

Edit:
Telia har en guide här:
https://www.telia.se/privat/support/info/oppna-portar-tradlos...

Kanske funkar för din router... fanns fler guider där.

Bytt nick från Defcon till Eazy.

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Har du skrivit in samma ip du Portforward i Mc serverns properties? kommer dok inte ihåg om man var tvungen att göra det för att få det att funka.

Trädvy Permalänk
Medlem
Plats
Älmhult
Registrerad
Dec 2011
Skrivet av Eazy:

Ja, fast IP eller inte är ju som du sa inte så viktigt just nu, men det kan ju ändå vara så att du inte har publik IP längre om de nu gjort någon förändring. Vilket IP får du från Telia. Du kan ju bara nämna första delen av IP't om du inte vill säga hela.

Edit:
Telia har en guide här:
https://www.telia.se/privat/support/info/oppna-portar-tradlos...

Kanske funkar för din router... fanns fler guider där.

Vad jag vet är att jag har portforwardat rätt. Det är inga konstigheter, det är något som blockerar det dock.

213.67.197.26 är min IP.

Skrivet av dksomese:

Har du skrivit in samma ip du Portforward i Mc serverns properties? kommer dok inte ihåg om man var tvungen att göra det för att få det att funka.

Tack men det ska man inte göra. Då startar inte servern

i7 7700K // Radeon RX 480 8GB // Corsair 16GB DDR4 3000Mhz CL15
Vengeance // MSI Z270 TOMAHAWK // Samsung 850 EVO 500GB // Fractal Design Integra M 550W

Trädvy Permalänk
Medlem
Registrerad
Jun 2006
Skrivet av tripletutorial:

Vad jag vet är att jag har portforwardat rätt. Det är inga konstigheter, det är något som blockerar det dock.

213.67.197.26 är min IP.

Tack men det ska man inte göra. Då startar inte servern

Visar http://whats.myip.rs/ samma IP som du ser i routern?

Bytt nick från Defcon till Eazy.

Trädvy Permalänk
Medlem
Plats
Älmhult
Registrerad
Dec 2011
Skrivet av Eazy:

Visar http://whats.myip.rs/ samma IP som du ser i routern?

Ja det är min WAN IP adress!

i7 7700K // Radeon RX 480 8GB // Corsair 16GB DDR4 3000Mhz CL15
Vengeance // MSI Z270 TOMAHAWK // Samsung 850 EVO 500GB // Fractal Design Integra M 550W

Trädvy Permalänk
Medlem
Registrerad
Jun 2006
Skrivet av tripletutorial:

Ja det är min WAN IP adress!

Ja, då har du nog publik IP. Ingen av guiderna jag länkade till som kan appliceras på din router?

Bytt nick från Defcon till Eazy.

Trädvy Permalänk
Medlem
Registrerad
Jun 2007

Ser ut som om att du missat att sätta upp en allow-regel för porten under "IPv4 Firewall Rules"?

Main>> Enthoo Evolv | Z170M-Plus | i5-6600K @ 4.4 @ H100i | GTX 980 @ HG10 H100i | 16GB | 500GB SSD + NAS | CM G650M
HIDs>> Asus VG248QE 144Hz + 2x 24" | Steelseries Rival @ QcK+ | QPAD MK-50 & QH-90 | Line6 UX2 | AT2020 | Audioengine 5+
4K-HTPC>> Antec Fusion Remote | i5-3470S | GTX 1050 Ti | 8GB | 120GB SSD + NAS | Sony STR-DN860 | Samsung UE60KS7005
Server>> HP MicroServer Gen8 | Xeon E3-1240 v2 | 16GB | 240GB SSD + 4TB Misc>> Huawei P20 Pro | Gear S2C | Surface Pro

Trädvy Permalänk
Medlem
Plats
Söder om fjällen
Registrerad
Sep 2012

Istället för att forwarda så kan du använda ngrok, funkar perfekt för mig och min kompis.
Tar 5 minuter att fixa
https://www.youtube.com/watch?v=ar-9Ku0vBeo

Trädvy Permalänk
Medlem
Registrerad
Maj 2010
Skrivet av Wikai:

Ser ut som om att du missat att sätta upp en allow-regel för porten under "IPv4 Firewall Rules"?

^This

Citera för svar!

Trädvy Permalänk
Medlem
Plats
Orilla
Registrerad
Jul 2009

@tripletutorial

Bör vara något i denna stilen under IPv4 Firewall Rules

Action = Permit

Protocol = TCP/UDP (gissningsvis udp men vilken du nu använder, är du osäker kan du lägga till en regel för båda som är identisk bortsett detta fältet).

Src IP/Subnet = 0.0.0.0 (förmodligen - brukar betyda vilken adress som helst). Detta för att du inte vet vilken IP dina polare har som ansluter till dig, om du vet kan du lägga upp specifika adresser, isf är det x.x.x.x 255.255.255.255 som gäller, men då får du givetvis ha en rad per polare som ska ansluta.

Src port = 0 (förmodligen - brukar betyda vilken port som helst). Detta för att du inte vet vilken port som din polares MC klient slumpar fram för att ansluta till din server.

Dst IP/Subnet = MC serverns IP (192.168.x.x dvs).

Dst port = Porten du använder för MC servern.

DSCP = Kan du nog skippa, annars 0. Detta är QoS och hanterar trafikprioritering, med 0 så blir trafiken hanterad som något som kallas "best effort" men med största sannolikhet finns det inte någon QoS konfiguration på din router i övrigt vilket innebär att all trafik hanteras med samma prioritet och trafiken till din server kommer inte att påverkas negativt. Det är bäst att låta bli detta om du inte vet vad du gör då det kan bli lite negativ åverkan på ditt nätverk om det blir tokigt i konfigurationen.

You have earned my respect and my friendship.