Forumdelen sponsras av

Går ej ljus, men får packet drop och errors

Trädvy Permalänk
Medlem
Registrerad
Sep 2018

Går ej ljus, men får packet drop och errors

Hej

Hade gjort ett liknande post innan men funderade på en sak... Det hade skett ett kabelbrott och jag tog inte emot ljus.. fine. Däremot så såg jag droppade paket och errors, vad kan detta exakt bero på? Det går ingen ljus, så ingen trafik igenom.

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Feb 2014

@matte06: Kan tycka att det saknas lite info här.
Vart såg du errors (dator, router, konverter osv), var det inkommande eller utgående errors?
Vet du ifall det var avbrott på en eller båda fibrerna (Tx, Rx)?

Trädvy Permalänk
Medlem
Registrerad
Sep 2018
Skrivet av InaneG:

@matte06: Kan tycka att det saknas lite info här.
Vart såg du errors (dator, router, konverter osv), var det inkommande eller utgående errors?
Vet du ifall det var avbrott på en eller båda fibrerna (Tx, Rx)?

Sorry, stämmer helt rätt att det saknas info. Skrev detta väldigt fort och förstår att man inte har fått respons, vanligtvis beskriver jag utförligt. Men men!

Det kom ingen inkommande ljus (Rx), men jag skickar ljus dock så länken är inte död än. Errorsen såg jag på en L3 switch (så basically nästan en router..). Det jag undrar över här är, om man inte får inkommande ljus, vad är direkt meningen med errors och congestions? De är ju man väl inte intresserad av om det kommer ej trafik in? Eller tänker jag fel? Eller å andra sidan, errorsen och droppade paket är anledningen till varför man inte tar inkommande ljus? Skulle vara nice om man kunde få detaljerad och utförlig förklaring om hur dessa errors och congestions fungerar. Det finns ju olika typer av errors så man vill gärna veta skillnaden på alla. Btw, det var CRC errors som visades.

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Feb 2014

@matte06: CRC är ett helt paket som enheten inte kan återbygga, så det droppas.

Vad är det för switch du kikar på. Tycker att det känns konstigt att du får errors om du inte har Rx, för får du inget ljus så bör switchen anse att länken är nere och inte ens försöka skicka paket på den. När du kollar ljuset, kikar du på switchen eller en ljusmätare? Tänker att de kanske är en SFP (eller vad du nu kör) som har pajat, då brukar man kunna se helskumma fel.

Skulle inte vilja påstå att errors osv gör att du inte får ljus, däremot så kan motsatt vara sant. Om du får dåligt ljus så kan de resultera i CRCs och FECs.

Vet du om felen är inbound eller outbound?

Antar att det är länken till din L3 switch som ljuset strular på?

Trädvy Permalänk
Medlem
Registrerad
Sep 2018
Skrivet av InaneG:

@matte06: CRC är ett helt paket som enheten inte kan återbygga, så det droppas.

Vad är det för switch du kikar på. Tycker att det känns konstigt att du får errors om du inte har Rx, för får du inget ljus så bör switchen anse att länken är nere och inte ens försöka skicka paket på den. När du kollar ljuset, kikar du på switchen eller en ljusmätare? Tänker att de kanske är en SFP (eller vad du nu kör) som har pajat, då brukar man kunna se helskumma fel.

Skulle inte vilja påstå att errors osv gör att du inte får ljus, däremot så kan motsatt vara sant. Om du får dåligt ljus så kan de resultera i CRCs och FECs.

Vet du om felen är inbound eller outbound?

Antar att det är länken till din L3 switch som ljuset strular på?

Det är en L3 switch (juniper). Det är därför jag undrar, kanske skedde dessa errors innan länken gick ner? Jag kollar på switchen och ingen ljusmätare eller OTDR då jag har ej tillgång till det. Det är korrekt att det är en SFP som har pajat. Men eftersom jag inte tar emot ljus, men dock skickar ljus, då är väl länken inte helt "död" än eller? Jag skickar ljus, men får inget ljus, så den switchen som alltså inte skickar ljus är ju inte väl helt död än? Jag är alldeles ny till det här så du får gärna lära/rätta mig.

Nej precis, då är det så att errorsen inte beror på att ljuset är nere. Det låter logiskt å andra sidan att om länken är nere men att man får errors så borde errors inte spelar någon roll då länken är nere. Hade länken varit uppe och det skedde errors så borde det vara intressant.

Felet är inbound (om jag tänker rätt), för det är en access switch som är kopplad till en distributionswitch. Så accces switchen är nere. Och ja, det är länken till L3 switchen som strular.

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Feb 2014

@matte06: Troligaste scenariot, bitfelen kom in innan länken gick ner. Men vi spånar vidare lite.

Har inte tillgång till ett juniper CLI just nu så kommandona kan vara lite fel då jag bara kör dom från huvudet.
Om du kör en "show interface interface-namn (ie xe-x/x/x, et-x/x/x)" vad ligger ""Last flapped" på?
Min tanke här är att vi kikar ifall länken flappar (går konstant upp och ner), detta skulle kunna orsaka CRC felen.

Beroende på konfigurationen samt hårdvaran på den andra sidan så är det inte omöjligt att hårdvaran rapporterar länken som igång.
Får hårdvaran där in ljus och saknar autoneg så kan den tro att den är igång, kör du autoneg så bör de vara stendött där med.
Vet du att ljuset kommer fram hela vägen? Inte helt omöjligt att SFPn rapporterat till junipern att den skickar ljus, trots att den inte gör de.

Länken på junipern bör vara stendöd då den inte får in ljus, detta ser du lättast med ex "show interface interface-namn", eller "show interfaces brief".

Slutligen så kan du köra "clear interfaces statistics interface-namn", då kan du lätt se ifall räknarna gå uppåt eller inte utan att behöva komma ihåg vad den stod på.

Summerat så skulle jag säga att länken antigen flappar eller är helt nere. (inga paket = död länk, typ). Är länken helt nere så bör du inte få in några errors då junipern bara borde droppa dom. Det kan vara att den rapporterar in dom som CRC på output men det borde den inte göra. Så jag skulle vilja försöka få reda på varför du får errors om länken är helt död.

Antar att du kör en Juniper EX 2xxx, 3xxx eller 4xxx. Tror att alla dessa kommandon ska gå att köra på alla dom men är inte helt säker, för alla dom kör väl JunOS?

Kör du GUIt så har jag tyvärr ingen aning hur man kikar på dessa saker, har aldrig använt det.

Trädvy Permalänk
Medlem
Registrerad
Sep 2018
Skrivet av InaneG:

@matte06: Troligaste scenariot, bitfelen kom in innan länken gick ner. Men vi spånar vidare lite.

Har inte tillgång till ett juniper CLI just nu så kommandona kan vara lite fel då jag bara kör dom från huvudet.
Om du kör en "show interface interface-namn (ie xe-x/x/x, et-x/x/x)" vad ligger ""Last flapped" på?
Min tanke här är att vi kikar ifall länken flappar (går konstant upp och ner), detta skulle kunna orsaka CRC felen.

Beroende på konfigurationen samt hårdvaran på den andra sidan så är det inte omöjligt att hårdvaran rapporterar länken som igång.
Får hårdvaran där in ljus och saknar autoneg så kan den tro att den är igång, kör du autoneg så bör de vara stendött där med.
Vet du att ljuset kommer fram hela vägen? Inte helt omöjligt att SFPn rapporterat till junipern att den skickar ljus, trots att den inte gör de.

Länken på junipern bör vara stendöd då den inte får in ljus, detta ser du lättast med ex "show interface interface-namn", eller "show interfaces brief".

Slutligen så kan du köra "clear interfaces statistics interface-namn", då kan du lätt se ifall räknarna gå uppåt eller inte utan att behöva komma ihåg vad den stod på.

Summerat så skulle jag säga att länken antigen flappar eller är helt nere. (inga paket = död länk, typ). Är länken helt nere så bör du inte få in några errors då junipern bara borde droppa dom. Det kan vara att den rapporterar in dom som CRC på output men det borde den inte göra. Så jag skulle vilja försöka få reda på varför du får errors om länken är helt död.

Antar att du kör en Juniper EX 2xxx, 3xxx eller 4xxx. Tror att alla dessa kommandon ska gå att köra på alla dom men är inte helt säker, för alla dom kör väl JunOS?

Kör du GUIt så har jag tyvärr ingen aning hur man kikar på dessa saker, har aldrig använt det.

Shit har faktiskt inte junipern bredvid mig här så blir svårt..
Om jag får minnas så hade den inte flappat den dagen, men det är ju iofs ologiskt för att CRC tickade. Om det flappar så tickar CRC:en vilket tyder på skadad kabel bland annat. Men det behöver ju dock inte vara bara skadad kabel va? Läste om STP fel, speed missmatch osv.

Citat:

Beroende på konfigurationen samt hårdvaran på den andra sidan så är det inte omöjligt att hårdvaran rapporterar länken som igång.
Får hårdvaran där in ljus och saknar autoneg så kan den tro att den är igång, kör du autoneg så bör de vara stendött där med.
Vet du att ljuset kommer fram hela vägen? Inte helt omöjligt att SFPn rapporterat till junipern att den skickar ljus, trots att den inte gör de.

Så med andra ord, när man inte får ljus (inkommande ljus) så innebär det att länken är helt död? T.ex stod det ungefär så här: "Tx: -2.xx, Rx: -inf*". Så som jag förstår är Tx (transceiver) vilket innebär att den skickar ljus och Rx (receiver) tar emot ljus. Så i det här fallet skickade jag ljus men tog inte emot ljus. Men som du nämnde, jag vet inte om ljuset når hela vägen. Då får man ta en sån där OTDR och mäta vilket jag ej har tillgång till. Jag försöker bara förstå hur sånt hänger ihop. Jag hoppas att det är som du nämner, att hårdvaran tror att den skickar ljus men att den inte gör det. Men då måste jag som du nämner att jag clearar statistiken och kollar om det tickar, för då vet jag att det sker trafik eller hur? För att i min värld så är en en länk död när både Tx och Rx står på noll. Skickar man ljus men inte tar emot ljus så är väl länken inte död än. Det som är död är ju den som inte skickar ljus. Men den som inte skickar ljus tar ju ändå emot ljus.. fan blir förvirrad här.

Citat:

Summerat så skulle jag säga att länken antigen flappar eller är helt nere. (inga paket = död länk, typ). Är länken helt nere så bör du inte få in några errors då junipern bara borde droppa dom. Det kan vara att den rapporterar in dom som CRC på output men det borde den inte göra. Så jag skulle vilja försöka få reda på varför du får errors om länken är helt död.

Länken var nere då switchen var helt död, (den som inte skickade ljus alltså). Men som sagt, errorsen kanske kom innan. Angående CRC output/input. Output är att det sker CRC på utgående interface. Då är det ju den länken som är påverkad, dock tror jag inte att det var erros på ingående interface.

Trädvy Permalänk
Medlem
Plats
::1
Registrerad
Feb 2014
Citat:

Shit har faktiskt inte junipern bredvid mig här så blir svårt..
Om jag får minnas så hade den inte flappat den dagen, men det är ju iofs ologiskt för att CRC tickade. Om det flappar så tickar CRC:en vilket tyder på skadad kabel bland annat. Men det behöver ju dock inte vara bara skadad kabel va? Läste om STP fel, speed missmatch osv.

Exakt finns en hel del olika saker som kan göra att länken flappar, allt ifrån att fibern är skadad till att SFPn är kass. Har sätt patchar som inte sitter i ODFer som dom ska, smuts i ODFen/patchen. Reflektioner i fibern osv. Allt detta är ju i lager ett. Men som du säger så kan det vara conf som spökar, dock så brukar det inte bara börja spöka då. Utan då brukar det vara i samband med att man konfar nått.

Citat:

Så med andra ord, när man inte får ljus (inkommande ljus) så innebär det att länken är helt död? T.ex stod det ungefär så här: "Tx: -2.xx, Rx: -inf*". Så som jag förstår är Tx (transceiver) vilket innebär att den skickar ljus och Rx (receiver) tar emot ljus. Så i det här fallet skickade jag ljus men tog inte emot ljus. Men som du nämnde, jag vet inte om ljuset når hela vägen. Då får man ta en sån där OTDR och mäta vilket jag ej har tillgång till. Jag försöker bara förstå hur sånt hänger ihop. Jag hoppas att det är som du nämner, att hårdvaran tror att den skickar ljus men att den inte gör det. Men då måste jag som du nämner att jag clearar statistiken och kollar om det tickar, för då vet jag att det sker trafik eller hur? För att i min värld så är en en länk död när både Tx och Rx står på noll. Skickar man ljus men inte tar emot ljus så är väl länken inte död än. Det som är död är ju den som inte skickar ljus. Men den som inte skickar ljus tar ju ändå emot ljus.. fan blir förvirrad här.

Haha jo de kan vara lätt att bli förivrad här. För att förenkla de hela så kan vi säga att länken är död då du inte tar emot ljus, så glömmer vi hur det kan tänkas se ut på anda sidan. Det är bara spekulationer från min sida.

SFPn kommer alltid att skicka ljus förutsatt att porten inte är nedstängd, så Tx kommer 9/10 ggr att ha ett värde oberoende om du tar in ljus eller ej.

Om du tömmer statistiken så ser du rätt snabbt om du skickar paket ja. Men även om du kör en "show interface description" och tittar på det berörda interfacet. Står den som UP UP så är den igång, DOWN DOWN så är den administrativt nere, UP DOWN så är den nere av någon annan anledning i detta fall då vi inte tar emot något ljus.

Yes du har helt rätt med Tx och Rx. Det där betyder att du skickar med -2.xx dBm och att du inte får in något ljus. Jag skulle vänta med att hyra en OTDR. Är de din fiber eller är det en förhyrning från ex Skanova eller någon annan?

Vad finns på andra sidan, är det eran utrustning eller någon annans ex en ISP eller nått åt de hålet?

Citat:

Länken var nere då switchen var helt död, (den som inte skickade ljus alltså). Men som sagt, errorsen kanske kom innan. Angående CRC output/input. Output är att det sker CRC på utgående interface. Då är det ju den länken som är påverkad, dock tror jag inte att det var erros på ingående interface.

Är det errors på utgående så låter det ännu mer som att det är SFPn som har pajat, nu blir jag osäker om jag har sätt CRCs eller rena drops. Skulle nästan kika på hur många ampere SFPn ligger på. De gånger jag har sätt errors på utgående så brukar det även vara så att SFPn använder sjukt mycket ampere.