Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Forumdelen sponsras av

Trädvy Permalänk
Medlem
Plats
Vellinge
Registrerad
Nov 2002

EdgeRouter-X och Telias IPTV

Hej alla.

Ny här på forumet och jag skulle behöva lite hjälp. Flyttade hemifrån och fick tipset från en polare att ska Ubiquiti produkter så jag köpte en nätt EdgeRouter-X samt deras Lite AP. Dum nog så kollade jag inte riktigt upp routern om den fungerade med Telias fiber. Har läst tråden om Asus routrarna som ganska lätt kan lägga Telias IPTV på port 4. Men när jag ställde in routern insåg jag ganska snabbt att det inte skulle bli lätt att ställa in.

Jag förstår att Telia kör med VLAN (vid 845) när det gäller IPTV. Går det EdgeRouter-X att få till liknande lösning som Asus routrarna? Har inte riktigt kommit in kommit in hur man ställer in VLAN och liknande. Jag ställde in routern som en vanlig WAN till LAN. Går det att ställa in den så att IPTV kan tryckas ut på en enskild port så jag kan koppla in TV-apparaten?

//Fritz

Apple Mackbook Pro 15" Retina 2013

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Jag lånar tråden lite istället för att starta en ny

Jag har också köpt mig en EdgeRouter X och fått allt att fungera finfint förutom just IPTVn (leverantör är Bredbandsbolaget i mitt fall). Känns som jag har sökt igenom hela nätet men blir inte mycket klokare på hur jag ska göra.

Idag har jag en router från Asus och där har jag fått IPTVn att fungera genom inställningarna som ni ser på bilden nedan.

Bildlänk

Min fråga är om någon duktig här inne skulle kunna hjälpa till lite med att "översätta" inställningarna från Asus till EdgeRouterns config?

Tack

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Okt 2001

Typ så här:
Använd wizard wan+2lan2 och välj eth0 som wan och resten lan.
Skapa vlan 1 internet, 100 local och 845 iptv på interface switch0.
Sätt ip-nummer DHCP på switch0.1.
Sätt ip-nummer 192.168.1.1 på switch0.100.
Byt interface från eth0 till switch0.1 på default NAT och firewall rules som skapats av wizarden.
Ta bort ip-nummer från eth0 och lägg in eth0 i switch0.
Byt interface från switch0 till switch0.100 för DNS.
Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
Sätt PVID 845 på eth4 (IPTV här)
Sätt PVID 100 på eth1 till eth3 (LAN här)

/Knight

Idag kom Athlon64

Trädvy Permalänk
Medlem
Plats
Stockholm
Registrerad
Dec 2006

Flesta som har IPTV har väl en box/router från IPTV leverantören, använd den burken för bara TV, och sen sin egna bra router till resten av nätverket, om man inte får till det på anat vis..

Man splitar tex med en switsh före router och IPTV box.

Acer Predator Helios 300

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Knightmare:

Typ så här:
Använd wizard wan+2lan2 och välj eth0 som wan och resten lan.
Skapa vlan 1 internet, 100 local och 845 iptv på interface switch0.
Sätt ip-nummer DHCP på switch0.1.
Sätt ip-nummer 192.168.1.1 på switch0.100.
Byt interface från eth0 till switch0.1 på default NAT och firewall rules som skapats av wizarden.
Ta bort ip-nummer från eth0 och lägg in eth0 i switch0.
Byt interface från switch0 till switch0.100 för DNS.
Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
Sätt PVID 845 på eth4 (IPTV här)
Sätt PVID 100 på eth1 till eth3 (LAN här)

/Knight

Tack, ska prova när jag kommer hem!

Skrivet av ggustavsson:

Flesta som har IPTV har väl en box/router från IPTV leverantören, så vad är problemet? använd den burken för bara TV, och sen sin egna bra router till resten av nätverket...

Men om man kan klara sig på enbart en liten router som är typ 7x10 cm istället för två stora boxar, så är det en betydligt snyggare lösning i min värld.

Trädvy Permalänk
Medlem
Plats
Stureplan
Registrerad
Mar 2008

"Tvångsmata dig med nitroglycerinkabbare"

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Knightmare:

Typ så här:
Använd wizard wan+2lan2 och välj eth0 som wan och resten lan.
Skapa vlan 1 internet, 100 local och 845 iptv på interface switch0.
Sätt ip-nummer DHCP på switch0.1.
Sätt ip-nummer 192.168.1.1 på switch0.100.
Byt interface från eth0 till switch0.1 på default NAT och firewall rules som skapats av wizarden.
Ta bort ip-nummer från eth0 och lägg in eth0 i switch0.
Byt interface från switch0 till switch0.100 för DNS.
Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
Sätt PVID 845 på eth4 (IPTV här)
Sätt PVID 100 på eth1 till eth3 (LAN här)

/Knight

Tyvärr fick jag inte din guide att fungera Knightmare, men jag kanske har missförstått något steg..(?) Är det de rätta inställningarna för bredbandsbolaget som du har lyckats få fram?

Jag mailade BBB och frågade och fick bara detta som svar:

"Vi har tyvärr ingen bekräftad information om hur du ska konfigurera en egen router för vår TV-tjänst. Det jag vet vissa kunder har gjort är att slå igång IGMP-snooping och multicast på den LAN-port i routern där TV-boxen är inkopplad."

Skrivet av Gunvald Larsson:

Tack men den har jag provat utan framgång. Sen har jag förstått det som att man helst ska använda hårdvaruswitch och det exemplet är mjukvaruswitch(?)

Trädvy Permalänk
Medlem
Plats
Stureplan
Registrerad
Mar 2008
Skrivet av Jepqe:

Tyvärr fick jag inte din guide att fungera Knightmare, men jag kanske har missförstått något steg..(?) Är det de rätta inställningarna för bredbandsbolaget som du har lyckats få fram?

Jag mailade BBB och frågade och fick bara detta som svar:

"Vi har tyvärr ingen bekräftad information om hur du ska konfigurera en egen router för vår TV-tjänst. Det jag vet vissa kunder har gjort är att slå igång IGMP-snooping och multicast på den LAN-port i routern där TV-boxen är inkopplad."

Tack men den har jag provat utan framgång. Sen har jag förstått det som att man helst ska använda hårdvaruswitch och det exemplet är mjukvaruswitch(?)

Använder ingen switch alls. Utan har Telias TV i eth2 på min Edge, ska fungera med den guiden...

"Tvångsmata dig med nitroglycerinkabbare"

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Gunvald Larsson:

Använder ingen switch alls. Utan har Telias TV i eth2 på min Edge, ska fungera med den guiden...

Okej, fast som jag har förstått det utnyttjar du då inte den inbyggda "hårdvaruswitchen" som ska ger bättre prestanda.

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Knightmare:

Typ så här:
Använd wizard wan+2lan2 och välj eth0 som wan och resten lan.
Skapa vlan 1 internet, 100 local och 845 iptv på interface switch0.
Sätt ip-nummer DHCP på switch0.1.
Sätt ip-nummer 192.168.1.1 på switch0.100.
Byt interface från eth0 till switch0.1 på default NAT och firewall rules som skapats av wizarden.
Ta bort ip-nummer från eth0 och lägg in eth0 i switch0.
Byt interface från switch0 till switch0.100 för DNS.
Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
Sätt PVID 845 på eth4 (IPTV här)
Sätt PVID 100 på eth1 till eth3 (LAN här)

/Knight

Nu har jag lyckats att få det att fungera för Telia (BBB har jag dock inte fått till än).

Fick klia mig i huvudet vid vissa steg. Men prestandan blev mycket(!) bättre med det här än om man kör med "bridge". Så om någon gröngöling (som jag) kommer hit och behöver lösningen för Telias IPTV så har jag skrivit ner hur jag fick det att fungera:

- Kör wizarden Basic setup (sätt eth0 som WAN)
- Skapa tre olika VLAN på switch0; 1 (Internet), 100 (Local) och 845 (Telia IPTV)
- Sätt att switch0.1 ska använda DHCP
- Byt interface från eth0 till switch0.1 under menyn "Firewall/NAT" -> "Firewall Policies" samt "NAT" (de regler som skapats av wizarden)
- Byt interface från switch0 till switch0.100 under menyn "Services" -> "DNS"
- Ta bort IP-numret från eth0
- Slå på VLAN Aware för switch0 och bocka i alla eth-portar
- Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
- Sätt PVID 845 på eth1 (på port 1 har jag min IPTV)
- Sätt PVID 100 på eth2, eth3 och eth4 (på port 2, 3 och 4 har jag vanligt LAN)
Sista två steget var jag tvungen att göra i ett och samma moment annars fick jag problem. Så gör följande två ändringar i "Config Tree":
- Ta bort IP-numret frånn switch0
- Sätt IP-numret som du tog bort från switch0 (i mitt fall 192.168.1.1/24) på switch0.100

Tack till Knight!

(Återkommer om jag löser BBB)

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Okt 2001
Skrivet av Jepqe:

Nu har jag lyckats att få det att fungera för Telia (BBB har jag dock inte fått till än).

Fick klia mig i huvudet vid vissa steg. Men prestandan blev mycket(!) bättre med det här än om man kör med "bridge". Så om någon gröngöling (som jag) kommer hit och behöver lösningen för Telias IPTV så har jag skrivit ner hur jag fick det att fungera:

- Kör wizarden Basic setup (sätt eth0 som WAN)
- Skapa tre olika VLAN på switch0; 1 (Internet), 100 (Local) och 845 (Telia IPTV)
- Sätt att switch0.1 ska använda DHCP
- Byt interface från eth0 till switch0.1 under menyn "Firewall/NAT" -> "Firewall Policies" samt "NAT" (de regler som skapats av wizarden)
- Byt interface från switch0 till switch0.100 under menyn "Services" -> "DNS"
- Ta bort IP-numret från eth0
- Slå på VLAN Aware för switch0 och bocka i alla eth-portar
- Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
- Sätt PVID 845 på eth1 (på port 1 har jag min IPTV)
- Sätt PVID 100 på eth2, eth3 och eth4 (på port 2, 3 och 4 har jag vanligt LAN)
Sista två steget var jag tvungen att göra i ett och samma moment annars fick jag problem. Så gör följande två ändringar i "Config Tree":
- Ta bort IP-numret frånn switch0
- Sätt IP-numret som du tog bort från switch0 (i mitt fall 192.168.1.1/24) på switch0.100

Tack till Knight!

(Återkommer om jag löser BBB)

Bra att det funkar! Ja dom sista två stegen kan strula lite då man tappar uppkopplingen till routern när man tar bort IP-numret. Om jag minns rätt löste jag det genom att lämna en eth-port utanför konfigen i ett eget subnät till allt var uppe och lirade. Då kopplade jag upp mig mot en av de vanliga LAN-portarna och konfigurerade den sista porten med switch0 och VLAN.

/Knight

EDIT: @Jepqe Vad är det för nät du har? Telia öppen fiber? De olika IPTV leverantörerna borde sända på samma VLAN i samma nät. Jag har tex Telia öppen fiber och IPTV från Viasat på VLAN 845. När jag kollar på din config från Asus router ser det dock ut som att BBB sänder IPTV utan VLAN. Detta kan du testa genom att koppla din BBB IPTV-box direkt till väggen. Om TV funkar då så har du internet och iptv på samma nät.

Idag kom Athlon64

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av Knightmare:

Bra att det funkar! Ja dom sista två stegen kan strula lite då man tappar uppkopplingen till routern när man tar bort IP-numret. Om jag minns rätt löste jag det genom att lämna en eth-port utanför konfigen i ett eget subnät till allt var uppe och lirade. Då kopplade jag upp mig mot en av de vanliga LAN-portarna och konfigurerade den sista porten med switch0 och VLAN.

/Knight

EDIT: @Jepqe Vad är det för nät du har? Telia öppen fiber? De olika IPTV leverantörerna borde sända på samma VLAN i samma nät. Jag har tex Telia öppen fiber och IPTV från Viasat på VLAN 845. När jag kollar på din config från Asus router ser det dock ut som att BBB sänder IPTV utan VLAN. Detta kan du testa genom att koppla din BBB IPTV-box direkt till väggen. Om TV funkar då så har du internet och iptv på samma nät.

Ja så skulle man ju också kunna göra klart, blir samma resultat

Mina föräldrar har Telia och där har jag routern just nu. Jag själv har BBB och ja, den fungerar direkt i uttaget så antar att det är utan VLAN då. Måste skaffa en router till innnan jag kan testa hos mig, men du menar alltså att jag skulle kunna köra PVID 100 (istället för 845) på porten för IPTV, eller är jag ute och snurrar? Eller hur får routern att bara "släppa förbi" en port från WANet?

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Okt 2001
Skrivet av Jepqe:

Mina föräldrar har Telia och där har jag routern just nu. Jag själv har BBB och ja, den fungerar direkt i uttaget så antar att det är utan VLAN då. Måste skaffa en router till innnan jag kan testa hos mig, men du menar alltså att jag skulle kunna köra PVID 100 (istället för 845) på porten för IPTV, eller är jag ute och snurrar? Eller hur får routern att bara "släppa förbi" en port från WANet?

Nej PVID 100 funkar inte för multicast routas inte per default. PVID 1 borde dock funka men nu tänker jag bara högt. Om du tar bort VLAN 845 från din befintliga config (både på wan och iptv portarna) och sätter PVID 1 på porten till iptv-boxen. Då routas "internet" från vlan 1 till vlan 100 på lan-portarna och iptv switchas till iptv-porten.

/Knight

EDIT:
Något sånt här kanske funkar?
- Kör wizarden Basic setup (sätt eth0 som WAN)
- Skapa två olika VLAN på switch0; 1 (Internet) och 100 (Local)
- Sätt att switch0.1 ska använda DHCP
- Byt interface från eth0 till switch0.1 under menyn "Firewall/NAT" -> "Firewall Policies" samt "NAT" (de regler som skapats av wizarden)
- Byt interface från switch0 till switch0.100 under menyn "Services" -> "DNS"
- Ta bort IP-numret från eth0
- Slå på VLAN Aware för switch0 och bocka i alla eth-portar
- Sätt PVID 1 på eth0 (Baserat på att Internet är på VLAN 1 otaggat)
- Sätt PVID 1 på eth1 (på port 1 har jag min IPTV)
- Sätt PVID 100 på eth2, eth3 och eth4 (på port 2, 3 och 4 har jag vanligt LAN)
Sista två steget var jag tvungen att göra i ett och samma moment annars fick jag problem. Så gör följande två ändringar i "Config Tree":
- Ta bort IP-numret frånn switch0
- Sätt IP-numret som du tog bort från switch0 (i mitt fall 192.168.1.1/24) på switch0.100

Idag kom Athlon64

Trädvy Permalänk
Medlem
Plats
Akalla
Registrerad
Nov 2015
Skrivet av Jepqe:

Nu har jag lyckats att få det att fungera för Telia (BBB har jag dock inte fått till än).

Fick klia mig i huvudet vid vissa steg. Men prestandan blev mycket(!) bättre med det här än om man kör med "bridge". Så om någon gröngöling (som jag) kommer hit och behöver lösningen för Telias IPTV så har jag skrivit ner hur jag fick det att fungera:

- Kör wizarden Basic setup (sätt eth0 som WAN)
- Skapa tre olika VLAN på switch0; 1 (Internet), 100 (Local) och 845 (Telia IPTV)
- Sätt att switch0.1 ska använda DHCP
- Byt interface från eth0 till switch0.1 under menyn "Firewall/NAT" -> "Firewall Policies" samt "NAT" (de regler som skapats av wizarden)
- Byt interface från switch0 till switch0.100 under menyn "Services" -> "DNS"
- Ta bort IP-numret från eth0
- Slå på VLAN Aware för switch0 och bocka i alla eth-portar
- Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
- Sätt PVID 845 på eth1 (på port 1 har jag min IPTV)
- Sätt PVID 100 på eth2, eth3 och eth4 (på port 2, 3 och 4 har jag vanligt LAN)
Sista två steget var jag tvungen att göra i ett och samma moment annars fick jag problem. Så gör följande två ändringar i "Config Tree":
- Ta bort IP-numret frånn switch0
- Sätt IP-numret som du tog bort från switch0 (i mitt fall 192.168.1.1/24) på switch0.100

Tack till Knight!

(Återkommer om jag löser BBB)

Tack för guiden! Det tog några försök innan jag fick det att funka men nu är jag nästan där. Jag sparade eth1 utanför switch0 (IPTV på eth2) och när jag ansluter min dator till den fungerar allt bra men när jag flyttar kabeln till eth3 eller 4 tar det stopp. Jag får ett externt IP-nummer på switch0.1 men kommer inte ut på internet?

Jag förstår helt enkelt inte var kopplingen mellan vlan 1 och vlan 100 sker?

Trädvy Permalänk
Medlem
Registrerad
Sep 2012

@TjalleBanan:

Jag gjorde precis som du och lämnade eth1 utanför, men för mig fungerade det direkt när jag sen stoppade in nätverkskabeln i eth3/4.
Har du skrivit rätt i Vlan aware?

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Okt 2007
Skrivet av Jepqe:

Nu har jag lyckats att få det att fungera för Telia (BBB har jag dock inte fått till än).

Fick klia mig i huvudet vid vissa steg. Men prestandan blev mycket(!) bättre med det här än om man kör med "bridge". Så om någon gröngöling (som jag) kommer hit och behöver lösningen för Telias IPTV så har jag skrivit ner hur jag fick det att fungera:

- Kör wizarden Basic setup (sätt eth0 som WAN)
- Skapa tre olika VLAN på switch0; 1 (Internet), 100 (Local) och 845 (Telia IPTV)
- Sätt att switch0.1 ska använda DHCP
- Byt interface från eth0 till switch0.1 under menyn "Firewall/NAT" -> "Firewall Policies" samt "NAT" (de regler som skapats av wizarden)
- Byt interface från switch0 till switch0.100 under menyn "Services" -> "DNS"
- Ta bort IP-numret från eth0
- Slå på VLAN Aware för switch0 och bocka i alla eth-portar
- Sätt PVID 1 och VID 845 på eth0 (Baserat på att Internet är på VLAN 1 otaggat och IPTV VLAN 845 taggat)
- Sätt PVID 845 på eth1 (på port 1 har jag min IPTV)
- Sätt PVID 100 på eth2, eth3 och eth4 (på port 2, 3 och 4 har jag vanligt LAN)
Sista två steget var jag tvungen att göra i ett och samma moment annars fick jag problem. Så gör följande två ändringar i "Config Tree":
- Ta bort IP-numret frånn switch0
- Sätt IP-numret som du tog bort från switch0 (i mitt fall 192.168.1.1/24) på switch0.100

Tack till Knight!

(Återkommer om jag löser BBB)

Då jag också har fiber med internet och TV from telia på samma sätt som du, undrar jag om detta har fungerat bra?
Verkar vara lite fulconfat då switchen exponeras mot WAN, så jag undrar om det finns några bieffekter av denna conf och hur är det med prestandan?

- none -

Trädvy Permalänk
Medlem
Registrerad
Jun 2009

Tänkte att jag skriver min lösning på detta "problem" också. Gjorde det väldigt simpelt för mig genom att brygga eth0.845 (WAN) till switch0.845. Fungerar utmärkt enligt mig, märker inte av några prestandaproblem överhuvudtaget. Jag kan även nämna att jag inte provat köra några Play-tjänster på STBn, så vet ej om det fungerar eller inte, men borde göra det så länge den unicast trafiken också kommer på vlan 845.

Nedan finns en liten nätskiss som visar hur jag kopplat, relevant konfiguration för EdgeRouter-X (tror inte jag missat något iaf) samt relevant VLAN konfiguration i min Netgear switch som STB är kopplad mot.
Denna lösning kräver ingen Multicast/IGMP konfiguration och man behöver inte heller lägga till eth0 (WAN-interfacet) i switch0.

Nätskiss:

Dold text

EdgeRouter X konf:

Bara en bild som visar switch0 konfen i WebGUIt:

set interfaces bridge br0 aging 300 set interfaces bridge br0 bridged-conntrack disable set interfaces bridge br0 hello-time 2 set interfaces bridge br0 max-age 20 set interfaces bridge br0 priority 32768 set interfaces bridge br0 promiscuous disable set interfaces bridge br0 stp false set interfaces ethernet eth0 vif 845 bridge-group bridge br0 set interfaces ethernet eth0 vif 845 description Telia-IPTV set interfaces ethernet eth0 vif 845 mtu 1500 set interfaces ethernet eth1 mtu 1518 set interfaces switch switch0 mtu 1518 set interfaces switch switch0 switch-port interface eth1 vlan pvid 1 set interfaces switch switch0 switch-port interface eth1 vlan vid 845 set interfaces switch switch0 switch-port vlan-aware enable set interfaces switch switch0 vif 1 address 192.168.1.1/24 set interfaces switch switch0 vif 1 mtu 1518 set interfaces switch switch0 vif 845 bridge-group bridge br0 set interfaces switch switch0 vif 845 description switch0.845_Telia-IPTV set service dns forwarding listen-on switch0 set service dns forwarding listen-on switch0.1 set service ubnt-discover interface br0 disable set service ubnt-discover interface eth0 disable set service ubnt-discover interface eth0.845 disable set service ubnt-discover interface switch0.845 disable

Dold text

Netgear GS108T VLAN konf:

Dold text

Asus P8P67 Deluxe B3, Intel Core i7 2600K @ 4.4GHz, Corsair H70 (2x Scythe GT 1450rpm), Corsair 16GB 1600MHz XMS3, Corsair AX 850W, ASUS GeForce GTX 1070 ROG Strix, ASUS Xonar DGX, Samsung 850 EVO 250GB & OCZ Vector 256GB & WD Blue 1TB, ASUS VG248QE & DELL U2312HM

Trädvy Permalänk
Medlem
Plats
Stenungsund
Registrerad
Okt 2007

Ser fint ut och var precis vad jag själv tänkt göra från första början. Sedan läste jag om hur bryggning påverkar prestanda negativt och valde därför en annan lösning. Nu når jag full hastighet båda hållen med DPI aktiverat.

Vad har du för lina?
Har du lust att göra ett par prestanda tester och dela med dig utav?

Skickades från m.sweclockers.com

Edit, får kanske rätta mig själv här ändå då det verkar som att ER-X tydligen stöder offloading via hwnat för Bridged interface.

- none -

Trädvy Permalänk
Medlem
Registrerad
Jun 2009

@aztekk Ja precis, det glömde jag bort att skriva med i ERX konfen ovan och verkar inte som det går att redigera det inlägget längre heller.
Aktiveras med: set system offload hwnat enable
https://help.ubnt.com/hc/en-us/articles/115006567467-EdgeRout...

Kanske är ganska nytt att den har stöd för hardware offloading av bridged interfaces?

Skickades från m.sweclockers.com

Edit: Har en 100/100 lina. Har tyvärr inte möjlighet för tillfället att prova prestandatest på Bridge interface, men borde finnas någon ute på internet som provat det redan med hardware offloading igång.

Asus P8P67 Deluxe B3, Intel Core i7 2600K @ 4.4GHz, Corsair H70 (2x Scythe GT 1450rpm), Corsair 16GB 1600MHz XMS3, Corsair AX 850W, ASUS GeForce GTX 1070 ROG Strix, ASUS Xonar DGX, Samsung 850 EVO 250GB & OCZ Vector 256GB & WD Blue 1TB, ASUS VG248QE & DELL U2312HM

Trädvy Permalänk
Medlem
Registrerad
Jan 2019

Hi everyone, sorry that I'm posting in english. I found this thread VERY helpful as I also have ER-X and want to change provider to Telia(Lithuania) and I don't want to use their router. The setup here seems quite straightforward.

The only thing I don't quite understand is if I need to add any new firewall rules to alow UDP traffic from specific IPs, as I've seen this mentioned a lot on Ubiquiti forums, but it seems that it's usually talked about in relation to IGMP proxy.

Is it unnecessary when IPTV comes on VLAN?

Please don't feel that you need to reply in english. I will use google translate if needed.

P.S. Thank you all for posting these guides. I don't think I would be able to figure it out myself.

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Jun 2009

@pechka: Welcome to SweClockers! If you bridge the IPTV VLAN WAN and LAN interfaces, for example eth0.845 (WAN) and switch0.845 (LAN), then there's no need to setup any specific firewall rules or configure IGMP Proxy. You can try to follow my setup as described in my earlier post. The only thing you might have to change is the interfaces used and the VLAN, in case it's not 845 in Telia(Lithuania). Don't hesitate to ask if any questions arise

Asus P8P67 Deluxe B3, Intel Core i7 2600K @ 4.4GHz, Corsair H70 (2x Scythe GT 1450rpm), Corsair 16GB 1600MHz XMS3, Corsair AX 850W, ASUS GeForce GTX 1070 ROG Strix, ASUS Xonar DGX, Samsung 850 EVO 250GB & OCZ Vector 256GB & WD Blue 1TB, ASUS VG248QE & DELL U2312HM

Trädvy Permalänk
Medlem
Plats
Mitt i Skåne
Registrerad
Okt 2001
Skrivet av pechka:

Is it unnecessary when IPTV comes on VLAN?

Yes it is unnecessary. The igmp proxy is to stop the Multicast from flooding all the interfaces. With the vlan setup Multicast is already limited to the vlan interfaces.

Skickades från m.sweclockers.com

Idag kom Athlon64

Trädvy Permalänk
Medlem
Registrerad
Jan 2019
Skrivet av flaxehytt:

@pechka: Welcome to SweClockers! If you bridge the IPTV VLAN WAN and LAN interfaces, for example eth0.845 (WAN) and switch0.845 (LAN), then there's no need to setup any specific firewall rules or configure IGMP Proxy. You can try to follow my setup as described in my earlier post. The only thing you might have to change is the interfaces used and the VLAN, in case it's not 845 in Telia(Lithuania). Don't hesitate to ask if any questions arise

Thanks! I think I will try both and see what works better. So if I use bridging I'd have to use the command line? Although it seems that it's possible to use Config tree as well, right?

Skrivet av Knightmare:

Yes it is unnecessary. The igmp proxy is to stop the Multicast from flooding all the interfaces. With the vlan setup Multicast is already limited to the vlan interfaces.

Skickades från m.sweclockers.com

Thanks, that makes sense.

Trädvy Permalänk
Medlem
Registrerad
Jun 2009
Skrivet av pechka:

Thanks! I think I will try both and see what works better. So if I use bridging I'd have to use the command line? Although it seems that it's possible to use Config tree as well, right?

Yes, you should be able to use the Config tree if you'd prefer that. I'm pretty sure it has all of the options that the CLI has.

Skickades från m.sweclockers.com

Asus P8P67 Deluxe B3, Intel Core i7 2600K @ 4.4GHz, Corsair H70 (2x Scythe GT 1450rpm), Corsair 16GB 1600MHz XMS3, Corsair AX 850W, ASUS GeForce GTX 1070 ROG Strix, ASUS Xonar DGX, Samsung 850 EVO 250GB & OCZ Vector 256GB & WD Blue 1TB, ASUS VG248QE & DELL U2312HM

Trädvy Permalänk
Medlem
Registrerad
Jan 2019

Guys, I think I have one more question, actually two, sorry... E.g. in the switch/vlan aware configuration, where does the set top box get it's IP from? Telia? Do I need to set switch0.6 (IPTV comes on vlan6) to "Use DHCP" or is "No address" ok?

Also, would there be any advantage to setting VLAN6 to use local DHCP server (er-x)?

And is there any need to add firewall rules to block some potentially unwanted traffic coming from VLAN6? As far as I understand, it's wide open if I configure it as @Knightmare and @Jepqe suggested?

Skickades från m.sweclockers.com

Trädvy Permalänk
Medlem
Registrerad
Sep 2012

Jag har följt guiden och fick det fungera klockrent hemma hos mig. Jag bor i en förening där vi i föreingen har avtal med Telia. Men när jag skulle göra samma sak hos mina föräldrar fungerar det inte. Dom har öppen fiber, eller vad det kallas, där dom kan välja fritt vilken operatör dom vill. Dom har bara en switch med 8 st portar som sitter på väggen.
Måste man göra nåt annorlunda för att få det att fungera då? Har testat med både vlan 845 och 243