Ingen skrivaccess till nätverksenhet mountad i RPi4

Permalänk
Medlem

Ingen skrivaccess till nätverksenhet mountad i RPi4

Jag skaffade nyss en RPi4 och kör Raspbian på den. Jag har tänkt lagra filer från den på min NAS (enklaste möjliga med Windows 10 med SMB-fildelning). Hur jag än försöker lyckas jag inte få skrivaccess till nätverksenheten. Jag kan se allt, men inte skriva. Skriva funkar fint från andra enheter (Windows 10, Windows 7) som jag kopplat NAS:en till.

I Windows har jag ställt in så att "Everyone" har full behörighet till den aktuella enheten.

Vad gör jag för fel?

Permalänk
Medlem

Även om du har tillåtit allt på share level måste du även sätta motsvarande NTFS-rättigheter.

Permalänk
Medlem
Skrivet av hasenfrasen:

Även om du har tillåtit allt på share level måste du även sätta motsvarande NTFS-rättigheter.

Jag har ALLT på hela NAS:en satt med full behörighet. Det är bara jag som kan komma åt grejerna, så det finns ingen anledning för mig att ha nåt med begränsad behörighet.

Permalänk
Medlem

Det är skillnad åtkomst och filrättigheter. Åtkomsträttigheterna sätter du på utdelningen (smb share) medans filrättighetern sätts på katalogen och dess arv (ntfs-rättigheter). Högerklicka på katalogen och fliken security och redigera så ser du vilka användare som har vilka rättigheter.

Permalänk
Medlem
Skrivet av hasenfrasen:

Det är skillnad åtkomst och filrättigheter. Åtkomsträttigheterna sätter du på utdelningen (smb share) medans filrättighetern sätts på katalogen och dess arv (ntfs-rättigheter). Högerklicka på katalogen och fliken security och redigera så ser du vilka användare som har vilka rättigheter.

Har satt fulla behörigheter på alla ställen. Och det funkar som sagt fint på mina två Windows-datorer.

Permalänk
Medlem

Vad menar du med "Alla ställen"? Vilka credentials använder RPi4'an? Om det är "nobody" lär du aktivera "Gäst/Guest" på Windows 10 datorn och tillåta skrivning för det är default bara läsrättigheter.

Permalänk
Medlem

Nej, jag loggar in som primäranvändare.

Permalänk
Medlem

Har du följd de guider som finns och fått det att fungera - innan du börjar med saker som användare där man måste logga in med passord?.

En sak till, på vad lagras filerna som samba skall hantera? - om det görs på en USB-sticka eller SD-minne med VFAT eller exFAT så tror jag inte att det kommer att fungera bra utan kräver en unix-kompatibelt filsystem som ext4, BTRFS eller NTFS.

Det beror på att VFAT och exFAT har en mycket simplare rättighetsmatris och begrepp som 'user, group, other' finns inte där utan är emulerad av linux med fasta defaultvärden i samband med montering för att över huvud taget vara accessbar - kort sagt om man ändrar en användarnamn på en fil i en VFAT - var skall denna metadata lagras??? VFAT-filsystemet har inget sådant eller ens känner till begreppet.

Permalänk
Medlem

1. Jag har sen ett tag min NAS, gjord av en äldre dator som delar ut två hårddiskar som nätverksdiskar genom Windows SMB. Primärt för min vanliga skrivbordsdator (W10), min surfplatta (Android, spela upp filmer och serier i VLC) och för min antika laptop (W7). Jag har inte följt några guider, utan bara startat vanlig fildelning, ställt in behörigheter, och sen har det funkat utan några konstigheter. Alla diskar där använder NTFS.

2. I går köpte jag en RPi4, som jag kör Raspbian på. Systemet ligger på ett 32 GB SD-kort, och har en bootpartition på 256 MB och VFAT, sen en "övrig" på ca 29.5 GB med ext4. Tyvärr är det inte riktigt genomskinligt vad som ligger på vilken partition. När jag väljer att visa enheter i filhanteraren visas en enhet som heter "root link" och som jag kan gå in på (då syns "allt"). Den andra heter "SC32G.drive" och är inte åtkomlig. Men de två har olika egenskaper ("root link" står som "mount point" medan "SC32G.drive" står som "folder"), så det matchar inte det jag är van vid från andra system, där enheter är logiska eller fysiska enheter, som man kan gå in på och direkt se exakt vad som ligger på vilken enhet.

Permalänk
Medlem

finns massor av guides - har du provat och följt någon av dessa ??

ett av säkert många (första bästa på sökord 'raspian set up samba' i google)

https://pimylifeup.com/raspberry-pi-samba/

som i princip visar steg för steg hur du gör - även i slutet på för inställning i windows.

sedan skulle jag ganska snabbt fundera på att ha själva fillagring på annan media än SD-minne och RPi4 USB3 klarar runt 190 MB/s och väl mycket mer än vad nätverksuttaget orkar med (runt 80-90 MB/s)

Dock RPI4 är ingen kraftverk och skall du köra 2.5" USB-diskar så bör det göra via en USB3-hub med väggvårta som egen försörjning för att mata diskarna. Och en sak till, även SSD-diskar drar mycket ström i pulser när de läser och skriver även om genomsnittet är lägre än en snurrdisk. så att jacka in en SSD-disk via adapter på USB3 direkt till RPI4 är heller inte så bra ide.

Permalänk
Medlem

@xxargs

Jag tror det har blivit nåt missförstånd här. Min RPi ska inte vara server eller fillagring. Tvärt om, anledningen till att jag är så angelägen om att få till en nätverksåtkomst från min NAS till RPi:en är för att slippa lagra nåt på SD-kortet.

Alltså:
Jag har en NAS baserad på Windows 10 Pro, som delar ut två hårddiskar över nätverket genom vanlig fildelning. På min RPi vill jag mounta en eller båda av nätverksdiskarna, för att kunna lagra filer direkt till dem. Problemet är att jag inte lyckas få skrivbehörighet på diskarna när de är mountade på RPi:n. Läsa går fint, men skriva ger "Permission denied", trots att jag har satt alla behörigheter till fullo på NAS:en.

Permalänk
Medlem

Swisch swosch... det är något som far över huvudena. Jag noterar att du inte har kommenterat ATT det är skillnad på share-rättigheter och fil-rättigheter - två helt olika saker - som man måste sätta rätt - och du vill fortfarande ha hjälp?

Permalänk
Medlem
Skrivet av hasenfrasen:

Swisch swosch... det är något som far över huvudena. Jag noterar att du inte har kommenterat ATT det är skillnad på share-rättigheter och fil-rättigheter - två helt olika saker - som man måste sätta rätt - och du vill fortfarande ha hjälp?

Hmm, svarade jag inte att jag har satt båda till full behörighet?

Permalänk
Medlem

Kan du verifiera om RPI4 får lov att skriva till NTFS? Det kan ju vara så att alla rättigheter stämmer men inte att RPI4 får till det?

Vad jag läst hade jag kollat så du har NTFS-3g installerat, då det är en ny RPI installation: Nedan klippt från internet:

"The system might not have the files for writing to NTFS partitions installed.
Try this in terminal:
sudo apt-get install ntfs-3g
and install both ntfs-3g and all its dependencies.
Then reboot your system, and attempt to open the NTFS drive for write access. You should now be able to write to the NTFS drive."

Prova det.

Permalänk
Medlem
Skrivet av Azathoth:

Kan du verifiera om RPI4 får lov att skriva till NTFS? Det kan ju vara så att alla rättigheter stämmer men inte att RPI4 får till det?

Vad jag läst hade jag kollat så du har NTFS-3g installerat, då det är en ny RPI installation: Nedan klippt från internet:

"The system might not have the files for writing to NTFS partitions installed.
Try this in terminal:
sudo apt-get install ntfs-3g
and install both ntfs-3g and all its dependencies.
Then reboot your system, and attempt to open the NTFS drive for write access. You should now be able to write to the NTFS drive."

Prova det.

Det där har jag redan gjort, så nåt annat är fel. :/

Permalänk
Medlem

Är användarkontot "Gäst/Guest" på W10 är aktiverat? Är kontot "Gäst/Guest" adderat till NTFS-rättigheterna? Finns kontot "Gäst/Guest" med i share-rättigheterna? Använder RPi'm SMBv1, SMBv2 eller SMBv3? Windows 10 har SMBv1 default avslaget men går att aktivera.

Du visar ju inga bilder på någon av inställningarna så vi har ju bara att gissa på vad "allt är aktiverat" betyder.

Permalänk
Medlem

Använder inte nåt gästkonto, utan loggar på som huvudanvändaren. Funkar smidigt på mina övriga enheter som ansluter till NAS:en.

I delningsinställningarna finns "Everyone" och den användaren har läs-, skriv- och exekveringsrättigheter.

Eftersom jag kan logga på och se allt utgår jag från att RPi:n klarar SMBv2/3, annars hade det väl inte blivit nån anslutning alls (i alla fall var det resultatet när jag försökte dela filer förra året till en enhet som bara klarade SMBv1)?

Permalänk
Medlem

Du saknar Guest på Permission-fliken på W10-burken. Anger du "NAS\user" och inte bara "user" på RPi'n som användare för då försöker den logga den in som RPiHostName\user

Enklast blir det som du installerar Wireshark på W10-burken och ser efter exakt vad som går fel - så slipper man tro en massa och pilla i blindo.

Permalänk
Medlem

Om jag försöker logga på som NAS/user i stället för user får jag "mount error(13): Permission denied."

Jag ska kika på vad Wireshark kan berätta. Tyvärr står NAS-burken lite dumt, så jag måste stå på knä i ett förråd och hålla mus/tangentbord i luften för att jobba med den. Eftersom det är "plug and play", mer eller mindre, för alla normala enheter har det inte varit nåt bekymmer eftersom jag bara ställde in den där, startade och så har jag inte behövt röra den efteråt. Men tydligen ska Linux inte låta sig tämjas så enkelt...

Permalänk
Medlem

Wireshark verkar vara skräp. Startar inte, utan bara står och snurrar. Får klara mig utan det. Men samtidigt förstår jag inte hur en TCP-sniffer ska hjälpa till med behörighetsproblem - det ligger väl inte på den nivån?

Permalänk
Medlem
Skrivet av cyklonen:

Om jag försöker logga på som NAS/user i stället för user får jag "mount error(13): Permission denied."

Jag ska kika på vad Wireshark kan berätta. Tyvärr står NAS-burken lite dumt, så jag måste stå på knä i ett förråd och hålla mus/tangentbord i luften för att jobba med den. Eftersom det är "plug and play", mer eller mindre, för alla normala enheter har det inte varit nåt bekymmer eftersom jag bara ställde in den där, startade och så har jag inte behövt röra den efteråt. Men tydligen ska Linux inte låta sig tämjas så enkelt...

Vilken metod använder du för att montera katalogen?
Nu har jag iofs bara ett par RPi3:or och någon RPi b+ snurrandes, för mig fungerar det bäst att montera via fstab, köra rapi-config->boot option->wait for network at boot [Yes]

Redigera /etc/fstab via nano eller annan editor, (sudo nano /etc/fstab)
lägg rad enligt:

//IP_till_servern/Utdelad_katalog cifs defaults,rw,username=Användarnamn,password=Lösenord.domain=Domänens/Arbetsgruppens_namn 0 0

ex:

//192.168.0.120/Media cifs default,rw,username=adam,password=eva.domain=workgroup 0 0

Glöm inte att spara.
Nu starta antingen om Pi:n eller kör kommandot: sudo mount -a

Permalänk
Medlem

Hmm, helt plötsligt funkar det, trots att jag gjort precis likadant som i går. Mysko!

Men jag kan bara skriva till enheten som su, och det funkar ju inte i längden.
Rättigheterna på den delade platsen blir:
drwxr-xr-x, och det går inte att ändra. Behöver ju ha drwxrwxr-x åtminstone.

Permalänk
Medlem

Ok, jag gav upp och körde in MotionEyeOS på ett nytt kort, startade på det och sen kopplade på nätverkslagring. Funkade utan problem, så det är inget fel på min Windows-inställning i NAS:en, utan bara Linux som gör manuellt enhetsmountande onödigt komplicerat.