Port forward på en Edgemax X vill inte fungera

Permalänk
Medlem

Port forward på en Edgemax X vill inte fungera

Hej,
Jag har precis kopplat in en Edgemax X som sitter som router in på mitt hemmanätverk.
Jag har en homeassistant hemautomationsserver jag vill komma åt med hjälp at port forwarding men det verkar som att routern inte skickar vidare för jag får connection refused när jag går på min dynamiska DNS-adress.
Jag har en Dynamisk DNS på home assistant och den funkar för det blir rätt address med nslookup och skriver jag in adressen med port 80 kommer jag till min router.

tips på vad som kan vara felkonfigurerat?
Funkade bra med min gamla Asus-router..
I övrigt går routern fint.

Permalänk
Medlem

Vissa portar 80/443 är reserverade av routern web gui. Vill du använda 80 måste du flytta routerns gui bort från den porten först.

Permalänk
Protectera AB
Skrivet av turbo_500:

Hej,
Jag har precis kopplat in en Edgemax X som sitter som router in på mitt hemmanätverk.
Jag har en homeassistant hemautomationsserver jag vill komma åt med hjälp at port forwarding men det verkar som att routern inte skickar vidare för jag får connection refused när jag går på min dynamiska DNS-adress.
Jag har en Dynamisk DNS på home assistant och den funkar för det blir rätt address med nslookup och skriver jag in adressen med port 80 kommer jag till min router.

tips på vad som kan vara felkonfigurerat?
Funkade bra med min gamla Asus-router..
I övrigt går routern fint.

Hur har du ställt in routern? Det ska inte vara några problem att skicka port 80 vidare till en host på insidan.

Permalänk
Medlem

Får du en publik IP-adress?
För att få det att fungera ska det räcka att följa guiden
https://help.ui.com/hc/en-us/articles/217367937-EdgeRouter-Po...

Permalänk
Medlem

Nu har jag tyvärr inte erfarenhet av specifikt Edgerouter, men det låter som att Hairpin NAT inte är aktiverat på routern. Utan Hairpin NAT så fungerar din port forward endast för anslutningar som kommer utifrån internet, inte för anslutningar som görs från det lokala nätverket.

Permalänk
Medlem

Börja med att gå in under Firewall/NAT och säkerställ att korrekt gränssnitt för internet är satt under "WAN interface" och även att ditt/dina gränssnitt på insidan är tillagda under "LAN interface" och slutligen att bockrutan "Hairpin NAT" är bockad. Därefter ska du kunna nå interna tjänster på utside-adressen.

Men precis som tidigare har nämnts i tråden så behöver du också säkerställa att du ändrat portarna för webbgränssnittet på routern från standard 80/443 till något annat, t.ex. 8080 och 8443 eller 444. Detta gör du under "Config Tree", "service", "gui" och i rutorna "http-port" och "https-port". Skriv in något annat i dessa och tryck på "Preview" och "Apply" för att bekräfta.

Vad gäller port-vidarebefordring så kan du göra detta antingen direkt under "Port Forwarding" genom att lägga upp en ny regel där med samma port för "Original port" och "Forwarding-to port" samt med serverns IP-adress i "Forwarding-to address" samt välj TCP som protokoll. Väl värt att notera är att EdgeRouter inte lägger upp brandväggsregel för portvidarebefordringar som standard, för att detta ska ske så måste du trycka på "Show advanced options" och bocka i "Auto firewall". Annars måste du även gå in och skapa en regel på WAN-IN/ETH0-IN som tillåter trafiken, så jag kan rekommendera att slå på automatiken för enkelhetens skull.

Det andra alternativet till ovan är att under "NAT"-fliken lägga upp en "Destination NAT rule" med "Translation Address" satt till serverns IP, välja protokoll och även inkommande interface (ETH0/WAN) samt "Translations Port" och "Dest Port" till samma om inte annat önskas. Men du måste då även lägga upp brandväggsregeln manuellt.

Permalänk
Medlem

Hej,
Nu har jag komit en bit - har inte hunnit greja så mycket.. men det visade sig att port forward fungerade när jag testade med en dator som inte låg på mitt nätverk, kopplar jag på en VPN-tunnel så är det OK men inte om jag stänger av VPN.
Är det normalt?
Kan det ha med att göra att min Wifi accesspunkt som stökar? jag har alltid haft accesspunkt och router från WAN i samma men nu har jag delat på det och konfigurerade in asus som accesspunkt.
Fungerar bra i övrigt men irriterande..
Är NAT att föredra mot PF? Jag har nu satt upp båda....

Permalänk
Medlem
Skrivet av turbo_500:

Hej,
Nu har jag komit en bit - har inte hunnit greja så mycket.. men det visade sig att port forward fungerade när jag testade med en dator som inte låg på mitt nätverk, kopplar jag på en VPN-tunnel så är det OK men inte om jag stänger av VPN.
Är det normalt?
Kan det ha med att göra att min Wifi accesspunkt som stökar? jag har alltid haft accesspunkt och router från WAN i samma men nu har jag delat på det och konfigurerade in asus som accesspunkt.
Fungerar bra i övrigt men irriterande..
Är NAT att föredra mot PF? Jag har nu satt upp båda....

Precis som har sagts tidigare måste du fylla i Hairpin NAT/(NAT loopback på andra fabrikat) för att kunna kommunicera med din publika ip och sedan bli forwardad till din interna servers ip (detta för att din interna server ska skicka tillbaka trafiken till din routers interna ip, för din HA-server kommer se som att trafiken kommer från din router och inte ditt interna ip från din klient). Home Assistant kör på port 8123 som standard och borde inte spela någon roll för port 80/443. Eftersom du kan kommunicera med din HA om du ansluter via VPN så är det högst troligt att det är NAT loopback som saknas.

Vilket som sedan är att föredra mellan NAT och PF känns som en konstig fråga. Port Forward är en del av NAT a.k.a. DNAT. Medans termen NAT oftast relaterar till Cisco’s PAT eller IP-tables SNAT.

DNAT skickar vidare trafiken som kommer till ett visst interface eller IP på en viss port till en annan IP och port.

SNAT döljer din interna IP bakom en publik IP. (Kortfattat)

Mvh, csoM

Permalänk
Medlem

Hej,
får det inte att fungera.
Detta är det enda jag har i min router.
Går jag på min dybamiska DNS när jag är på VPN fungerar det men kopplar jag ner VPN så kommer jag inte fram utan måste då köra med den interna IP-adressen.
Detta fungerade innan jag bytte router.

Permalänk
Medlem
Skrivet av turbo_500:

Hej,
får det inte att fungera.
Detta är det enda jag har i min router.
Går jag på min dybamiska DNS när jag är på VPN fungerar det men kopplar jag ner VPN så kommer jag inte fram utan måste då köra med den interna IP-adressen.
Detta fungerade innan jag bytte router.

https://i.postimg.cc/DwX0M3ty/router-conf.jpg

Jag ser att du har ikryssat "Both" under prorokoll. Det räcker med tcp där.
Om du klickar i Show advanced options så ska du också välja: Auto firewall: "Enable auto firewall (automatically open ports for specified port forwarding rules)"

Det ska räcka för att få det att fungera.

/Mvh, csoM