Datorn fryser vid snabb nedladdning

Permalänk
Medlem

Datorn fryser vid snabb nedladdning

Hejsan!

För cirka 1 månad sen fick jag in fiber i villan, 500mbit. I o med detta beställde jag en ny extern HDD på 12tb (WD My Book desktop) som kom i veckan. När jag igår kväll skulle inviga denna fantastiska setup tillsammans med min dator går det ganska dåligt.

Jag provar ladda ner en större fil på cirka 100gb till HDDn och den sticker genast iväg på 15mb/s+ i några sekunder sedan fryser hela datorn. Musen går att röra men ingenting går att trycka på. Jag stänger av datorn och startar upp igen, omedveten om kopplingen. Datorn fungerar, men när jag startar nedladdningen sker exakt samma sak igen.

Är min lina nu FÖR snabb för min dator eller va fan händer? Detta hände sent igår så jag gick o la mig och har inte hunnit felsöka mer. Tänkte jag chansar att någon kanske har lösningen på problemet innan jag kommer hem o börjar felsöka!

Insåg nu att denna kanske hamnade i fel kategori, fritt fram att flytta den

Mvh

Permalänk
Medlem

Testa att sätta en nedladdningbegränsning i din torrentklient. Får du samma problem om du laddar ner till en ssd?

Permalänk
Medlem
Skrivet av Printscreen:

Testa att sätta en nedladdningbegränsning i din torrentklient. Får du samma problem om du laddar ner till en ssd?

Att begränsa nedladdningen är min första aktion när jag kmr hem, kan även prova ladda ner till ssdn.

Permalänk
Medlem

Okej detta är min felsökning än så länge:

Jag provade begränsa nedladdningshastigheten till 5 mb/s, datorn fryser då inte längre. DOCK det som händer istället, efter cirka 20 sekunder är att nedladdningshastigheten går ner till cirka 50 kb/s. Dessa 5 mb/s bibehålls alltså inte.

Jag provade ladda ner till SSDn som OSet ligger på med begränsad hastighet och där förekommer inte problemet.

Eftersom jag här om dagen förde över från EXTERN -> EXTERN provade jag göra samma sak igen. Jag kopplade in min andra externa i datorn och förde över ett gäng större filer, från extern till extern och DÅ funkar det superbra! Ligger på cirka 40 mb/s.

Jag provade efter detta att ladda ner till min gamla trötta externa och den klarar galant att bibehålla 5 mb/s (jag provade inte ta bort begränsningen).

Jag provade att koppla in den nya externa i min andra dator och köra igång en nedladdning där. Den stack iväg till cirka 10 mb/s sen började datorn frysa.

Jag förstår inte riktigt vart problemet ligger, från Extern till Extern går det att överföra hur snabbt/mycket som helst via en dator, men om jag laddar ner direkt till HDDn så blir det pannkaka av allt.

Någon som har några idéer?

Permalänk
Medlem

Om jag får tokspekulera lite så kan det vara så att både ditt nätverkskort och din usb-kontroller går via samma nord/sydbrygga (Du har ju gammalt nehalem-system) och då blir "chokat" eftersom du kör hög fart både på nätverkskortet och usb-portarna.

Med lite tur så kan du komma runt det genom att köra på annan USB-port, kanske en som inte går via chipset-kontrollern, utan en extern.

Men min teori här är att du måste "mellanlanda" på något, så att du inte maxar både nätverk och usb-kontroller samtidigt.

Permalänk
Medlem
Skrivet av Printscreen:

Om jag får tokspekulera lite så kan det vara så att både ditt nätverkskort och din usb-kontroller går via samma nord/sydbrygga (Du har ju gammalt nehalem-system) och då blir "chokat" eftersom du kör hög fart både på nätverkskortet och usb-portarna.

Med lite tur så kan du komma runt det genom att köra på annan USB-port, kanske en som inte går via chipset-kontrollern, utan en extern.

Men min teori här är att du måste "mellanlanda" på något, så att du inte maxar både nätverk och usb-kontroller samtidigt.

Men! Som jag skrev tidigare så funkar det bra när jag kör med min andra externa i samma port på samma system. Skulle det vara problemet borde det vara oberoende av HDD eller?

Permalänk
Medlem
Skrivet av kreekill:

Men! Som jag skrev tidigare så funkar det bra när jag kör med min andra externa i samma port på samma system. Skulle det vara problemet borde det vara oberoende av HDD eller?

Ja oj, missade helt den punkten, läste för snabbt

Om en annan hårddisk fungerar bra så kanske det är din externa hårddisk som strular, den verkar ju vara den gemensamma nämnaren här. Ladda hem Crystal disk info och kolla SMART status, den kanske börjar bli dålig?

Permalänk
Medlem

Kör du på USB2 eller USB3-port?

Permalänk
Medlem
Skrivet av Printscreen:

Ja oj, missade helt den punkten, läste för snabbt

Om en annan hårddisk fungerar bra så kanske det är din externa hårddisk som strular, den verkar ju vara den gemensamma nämnaren här. Ladda hem Crystal disk info och kolla SMART status, den kanske börjar bli dålig?

Disken är sprillans ny, anlände i måndags Men får kolla smart status i EM när jag kommer hem.

Permalänk
Medlem
Skrivet av Juggernawt:

Kör du på USB2 eller USB3-port?

Jag vill säga att det är USB3 men det kanske är ett dåligt antagande av mig, har faktiskt inte kollat. Datorn har 7 usb-portar och jag har provat lite olika.

Permalänk
Medlem
Skrivet av kreekill:

Okej detta är min felsökning än så länge:

Jag provade begränsa nedladdningshastigheten till 5 mb/s, datorn fryser då inte längre. DOCK det som händer istället, efter cirka 20 sekunder är att nedladdningshastigheten går ner till cirka 50 kb/s. Dessa 5 mb/s bibehålls alltså inte.

Jag provade ladda ner till SSDn som OSet ligger på med begränsad hastighet och där förekommer inte problemet.

Eftersom jag här om dagen förde över från EXTERN -> EXTERN provade jag göra samma sak igen. Jag kopplade in min andra externa i datorn och förde över ett gäng större filer, från extern till extern och DÅ funkar det superbra! Ligger på cirka 40 mb/s.

Jag provade efter detta att ladda ner till min gamla trötta externa och den klarar galant att bibehålla 5 mb/s (jag provade inte ta bort begränsningen).

Jag provade att koppla in den nya externa i min andra dator och köra igång en nedladdning där. Den stack iväg till cirka 10 mb/s sen började datorn frysa.

Jag förstår inte riktigt vart problemet ligger, från Extern till Extern går det att överföra hur snabbt/mycket som helst via en dator, men om jag laddar ner direkt till HDDn så blir det pannkaka av allt.

Någon som har några idéer?

Har upplevt samma sak.
Om du kör t.ex. qBittorrent ändra följande:

Verktyg->alternativ->avancerat->DiscCache
Jag har satt den till 2000 MiB. Du kan experimentera.

Det som händer är att din mekaniska disk alltför ofta måste skriva massor av småsaker. Rena mardrömmen för mekaniska diskar.
Om du ökar disccache så behöver den inte skriva lika många småsaker utan kan vänta lite.

Medans allt segar ner kan du alltid ta fram "resursövervakaren" och kolla aktiv tid på alla hårddiskar. Om den står på 100% så är det detta som är felet. Hårddisken hinner inte med nått annat.

Permalänk
Medlem

många USB3 drivrutiner är jäkligt tveksamma. Fick leta som en tok till mitt x99 moderkort innan jag hittade en USB3 drivrutins version som faktiskt funkade. Så uppdatera drivisar och chipset, blir en bra start

// LZ

Permalänk
Medlem
Skrivet av kreekill:

Okej detta är min felsökning än så länge:

Jag provade begränsa nedladdningshastigheten till 5 mb/s, datorn fryser då inte längre. DOCK det som händer istället, efter cirka 20 sekunder är att nedladdningshastigheten går ner till cirka 50 kb/s. Dessa 5 mb/s bibehålls alltså inte.

Jag provade ladda ner till SSDn som OSet ligger på med begränsad hastighet och där förekommer inte problemet.

Eftersom jag här om dagen förde över från EXTERN -> EXTERN provade jag göra samma sak igen. Jag kopplade in min andra externa i datorn och förde över ett gäng större filer, från extern till extern och DÅ funkar det superbra! Ligger på cirka 40 mb/s.

Jag provade efter detta att ladda ner till min gamla trötta externa och den klarar galant att bibehålla 5 mb/s (jag provade inte ta bort begränsningen).

Jag provade att koppla in den nya externa i min andra dator och köra igång en nedladdning där. Den stack iväg till cirka 10 mb/s sen började datorn frysa.

Jag förstår inte riktigt vart problemet ligger, från Extern till Extern går det att överföra hur snabbt/mycket som helst via en dator, men om jag laddar ner direkt till HDDn så blir det pannkaka av allt.

Någon som har några idéer?

Låter som att du har trubbel med att det är en SMR disk. SMR wikipedia. De har bedrövlig prestanda när stora mängder små block skrivs. Intressant läsning för dig: Arstechnica artikel. Det finns relaterade artiklar med för mer info.

Du borde kunna titta disklast som tidigare sagt. Det är möjligt att IO är på 100% trots att du skriver i kb/s när din stackars disk skriver om 100 tals mb för att lägga till någon MB i en torrent "chunk".

Du borde kunna lösa det genom att lägga datan på en annan (icke SMR disk) tills torrenten är klar och sedan flytta hela filen i ett svep. Prestandatappet är inte lika brutalt då

Permalänk
Medlem
Skrivet av FX9:

Har upplevt samma sak.
Om du kör t.ex. qBittorrent ändra följande:

Verktyg->alternativ->avancerat->DiscCache
Jag har satt den till 2000 MiB. Du kan experimentera.

Det som händer är att din mekaniska disk alltför ofta måste skriva massor av småsaker. Rena mardrömmen för mekaniska diskar.
Om du ökar disccache så behöver den inte skriva lika många småsaker utan kan vänta lite.

Medans allt segar ner kan du alltid ta fram "resursövervakaren" och kolla aktiv tid på alla hårddiskar. Om den står på 100% så är det detta som är felet. Hårddisken hinner inte med nått annat.

Jag kikade i task manager igår när detta hände och aktiviteten stod på 100%. Ska testa detta ikv!

Permalänk
Medlem
Skrivet av FX9:

Har upplevt samma sak.
Om du kör t.ex. qBittorrent ändra följande:

Verktyg->alternativ->avancerat->DiscCache
Jag har satt den till 2000 MiB. Du kan experimentera.

Det som händer är att din mekaniska disk alltför ofta måste skriva massor av småsaker. Rena mardrömmen för mekaniska diskar.
Om du ökar disccache så behöver den inte skriva lika många småsaker utan kan vänta lite.

Medans allt segar ner kan du alltid ta fram "resursövervakaren" och kolla aktiv tid på alla hårddiskar. Om den står på 100% så är det detta som är felet. Hårddisken hinner inte med nått annat.

Provade detta, följde ditt tips o satte 2000 MiB och nu rullar det på betydligt bättre! Jag förstod inte riktigt vad inställningen gjorde dock. Är det något negativt att öka den för mkt?

Tack så mkt!

Permalänk
Medlem
Skrivet av kreekill:

Provade detta, följde ditt tips o satte 2000 MiB och nu rullar det på betydligt bättre! Jag förstod inte riktigt vad inställningen gjorde dock. Är det något negativt att öka den för mkt?

Tack så mkt!

Den reserverar den mängden RAM minne på din dator. Så om du har begränsat med RAM så kanske det inte är så bra

Permalänk
Medlem

Troligen cappar din IOPS eller disk kö, har sett liknade problem med tex Torrents och SQL och har med att dessa läser och skriver inte sekventiellt utan mer "random" om det dessutom är över USB är det bara värre. Kolla diskkön med Perfmon och sedan gör ett test från tex http://ovh.net/files/ som har "större" filer som går att tanka sekventiellt

Permalänk
Medlem
Permalänk
Medlem
Skrivet av eXim:

Troligen cappar din IOPS eller disk kö, har sett liknade problem med tex Torrents och SQL och har med att dessa läser och skriver inte sekventiellt utan mer "random" om det dessutom är över USB är det bara värre. Kolla diskkön med Perfmon och sedan gör ett test från tex http://ovh.net/files/ som har "större" filer som går att tanka sekventiellt

Problemet var IOPS, löstes genom att öka RAM cache mängden så den skriver större segment i taget istället för att hela tiden mata på massa små segment