Raspberry Pi 4: SSD Hårddisk stänger av sig själv

Permalänk
Medlem

Raspberry Pi 4: SSD Hårddisk stänger av sig själv

Hej
Jag har en Raspberry Pi 4 4GB versionen och mitt problem är att jag har en SSD hårddisk inkopplat i den och vad som händer är att den som kopplar ut sig själv och sen går det inte att använda den längre. Måste starta om Pi:en för att komma in igen.

Hoppas på snabbt svar!

Permalänk
Medlem

Har du fler hårddiskar inkopplade, då kan det vara strömförsörjningsproblem.

Permalänk
Medlem
Skrivet av Mollet:

Hej
Jag har en Raspberry Pi 4 4GB versionen och mitt problem är att jag har en SSD hårddisk inkopplat i den och vad som händer är att den som kopplar ut sig själv och sen går det inte att använda den längre. Måste starta om Pi:en för att komma in igen.

Hoppas på snabbt svar!

Testa att koppla hårddisken via en strömmatad USBhubb.

Permalänk
Medlem
Skrivet av Mollet:

Hej
Jag har en Raspberry Pi 4 4GB versionen och mitt problem är att jag har en SSD hårddisk inkopplat i den och vad som händer är att den som kopplar ut sig själv och sen går det inte att använda den längre. Måste starta om Pi:en för att komma in igen.

Hoppas på snabbt svar!

Vad använder du för PSU för att driva Raspberry:n?

Permalänk
Medlem
Skrivet av Zirgo:

Har du fler hårddiskar inkopplade, då kan det vara strömförsörjningsproblem.

Nej, det är bara min SSD jag använder.

Permalänk
Medlem
Skrivet av Amerald:

Vad använder du för PSU för att driva Raspberry:n?

Jag använder en 30W Xiaomi Laddare just nu.

Permalänk
Medlem

SSD kan dra mycket ström i pulser - SSD (via USB) och bör nog matas via en USB-hub med egen nätadapter så att det bara är datasignalering mellan RPI och USB-hub

Sedan kan USB/SATA-chipet i sig ha egna saker för sig och tex. stänga av SSD/HD efter en tids inaktivitet

Permalänk
Rekordmedlem

Låter som om du skulle behöva en ssd med egen nätdel eller driva den via en powerhub.

Permalänk
Medlem
Skrivet av mrqaffe:

Låter som om du skulle behöva en ssd med egen nätdel eller driva den via en powerhub.

Jag köpte denna till min SSD: hårddisk kabinett
Måste jag ha en annan variant kanske eller är det min power supply som strular?

Permalänk
Rekordmedlem
Skrivet av Mollet:

Jag köpte denna till min SSD: hårddisk kabinett
Måste jag ha en annan variant kanske eller är det min power supply som strular?

Jag tror inte din nätdel strular (om inte pin strular/krachar) utan mer troligt är att det beror på att du inte kan belasta usbporten med så hög effekt som ssdn behöver, Pin är inte försedd med portar som ska klara extra höga effekter och många lagringsenheter ligger verkligen på eller över maxeffekt som "usbdataportar" ska klara. Det finns ju också många tillbehör som även har ström via gpio kontakten för att inte överbelasta usb. Problemet finns ju även på många datorer men de brukar ibland ha nån laddport som klarar mycket högre ström än dataportarna.

En ssd som drar mindre effekt eller nått som ger den en egen nätdel är troligen vad du behöver, en usb 3.0 port får bara belastas med max 900mA dvs 4,5W och det är rätt många ssder som drar däromkring eller över det när de körs via sata och du kopplar ju dessutom på en usb-sata adapter som också behöver drivas så det finns nog inte mycket effektmarginaler oavsett hur stabil matningen till själva pin är.

Permalänk
Medlem

Såg nåt liknande nyligen där nedgradering till kernel 4.19 fick det stabilt.

edit: https://github.com/raspberrypi/linux/issues/3981