Raspberry pi tangentbord och remote desktop

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Raspberry pi tangentbord och remote desktop

Så jag installerade Raspberry pi med wheezy och ny försöker jag ställa in inställningarna, fast det går inte så bra. Tangentbord envisas på att vara inställt på gb och kan inte få det till sv layout. Jag har gått in i options och ändrat så att den ska köra på svensk/qwerty/standard/standard och Logitech sv standard i options. Men den kör fortfarande på gb och det är svårt att skriva i terminalen nära man inte vet vilka täcken man skriver in.

Samt så installerade jag XRDP och kunde ansluta till den första gången, sedan startade jag Raspberry pi och nu får jag, "xrdp_mm_process_login_response: login failed" varje gång jag försöker att logga in. XRDP service är igång.

Någon som vet hur man fixar dessa problem?

Trädvy Permalänk
Medlem
Plats
Bästkusten
Registrerad
Feb 2011

Funkar inte "dpkg-reconfigure keyboard-configuration" ?

Chassi: Svart, PSU: 230 volt, Moderkort: Stort, CPU: Med fläkt, Minne: Tappat, GPU: Klarar MsPaint jättebra, Hårddiskar: Stor och liten, Mus: Med rullhjul, Tangentbord: Svenskt, Skärm: Platt

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av TheCadde:

Funkar inte "dpkg-reconfigure keyboard-configuration" ?

Jag får ju upp så att jag kan ställa in det på svenskt keyboard, fast den vägrar att byta keyboard layout, och låser sig på gb.

Trädvy Permalänk
Medlem
Plats
HVA
Registrerad
Aug 2004

Vill minnas att det är flera mindre inställningar som kan göras när man konfigurerar tangentbord och inte bara välja sv tangentbord..?

Trädvy Permalänk
Medlem
Plats
plast
Registrerad
Sep 2011

Sök och du skola finna

...

var fri

...

Trädvy Permalänk
Medlem
Registrerad
Okt 2011
Skrivet av d0b:

Sök och du skola finna

Funka inte. filen finns och det står "setxkbmap sv" men fortfarande gb layout.

Trädvy Permalänk
Medlem
Plats
Bästkusten
Registrerad
Feb 2011

Har du ens alla filer? Kanske inte fungerar för att du saknar t.ex filen för sv layout?

Chassi: Svart, PSU: 230 volt, Moderkort: Stort, CPU: Med fläkt, Minne: Tappat, GPU: Klarar MsPaint jättebra, Hårddiskar: Stor och liten, Mus: Med rullhjul, Tangentbord: Svenskt, Skärm: Platt

Trädvy Permalänk
Medlem
Registrerad
Okt 2011

Om jag trycker ctrl+alt+f2 så funkar det, fast bara om jag är i terminalen, och jag lämnar så kör den på gb layout fortfarande.

Edit: om jag använder remote desktop så fungerat tengentbordet som det ska, men om jag använder tangentbordet genom rpi så funkar det inte.