Permalänk

nfs hastighet

Hejsan allihopa

Jag har skapat en nfs partition på min server som jag delar ut till min lilla eeepc900 .
Nätverket är på 100Mbit/s garanterat för att när jag laddat hem saker ifrån dom båda så kan hastigheten komma upp i 5-10 MB/s vilket är bra men överföringen på nfs partitionen kommer inte upp i mer än 1.2MB/s vilket är 10Mbit/s . Så jag undrar vad som är fel?

Permalänk
Medlem

Menar du nfs eller ntfs?

Permalänk

Jag menar nfs alltså "network file system". På server köra jag Debian 5 lenny 64-bit och på eeepcu kör jag eeebuntu 2.0

Permalänk
Medlem

Det kan vara ett bra utgångsläge att börja med att mäta upp hur mycket bandbredd du har när man ska felsöka.
iperf är din vän.

Permalänk

iperf visar mellan 5-8 MB/s i överföring

Permalänk
Medlem

Du kan testa lite olika blocksize, 32k har jag för mig fungerar bra med NFS v3 som jag antar att du kör, kör du NFS v2 så är max 8k.

mount -o rsize=32768,wsize=32768 hostname:/path/to/nfs/share /mount/point/

Permalänk

Jag kom precis på vad som möjligtvis kunde vara problemet. Jag sitter på ett stadsnät i och har 100/10 . Om det är problemet så betyder det att packeten går via switchen i källaren i bostadshuset? för att annars är det bara min 100mbit switch som är emellan datorerna.Kan det vara så?

Permalänk
Medlem

Haha, när jag såg titeln till tråden så trodde jag att du menade nfs = Need For Speed

Permalänk
Medlem

Mycket möjligt, du kan testa med

traceroute IP

för att se vilken väg paketen tar.
Om du vill göra en fullösning så är det bara att lägga till routes med hjälp av:

route add -net remoteIP(eller DNS) netmask 255.255.255.255 dev eth0

på båda datorerna.

Permalänk

När jag gjorde det så kom det fram att det gick genom bredbands2 switch
kan någon förklara varför detta är på detta vis ?!! det borde väl gå genom ,min switch eller?

Permalänk
Medlem
Skrivet av Mysticsam:

När jag gjorde det så kom det fram att det gick genom bredbands2 switch
kan någon förklara varför detta är på detta vis ?!! det borde väl gå genom ,min switch eller?

Har du publika IP-adresser på båda maskinerna? Ligger de i samma IP-nät? annars kommer all trafik gå via Bredband 2s router som jag antar är default route för dina maskiner.

Permalänk
Medlem
Skrivet av Mysticsam:

När jag gjorde det så kom det fram att det gick genom bredbands2 switch
kan någon förklara varför detta är på detta vis ?!! det borde väl gå genom ,min switch eller?

Kolla upp arp-tabellen så har du nog ditt svar.

Permalänk

tack för alla tips nu har jag ett annat problem ,, jag vill ändra titeln på denna tråd som jag har skapat och lägga till "[LÖST]" efteråt. Hur går jag till väga?