Permalänk

Distro för HTPC

Hej.

Har i stort sätt alltid kört windows till allting, men nu har jag lessnat då surroundljudet (Dolby Digital) slutar fungera i samband med windows uppdateringar.

Har en yamaha rx-v467 kopplad med toslink till htpcn.
Fick tidigare surround att lira på win 11 ( Med denna fix https://www.youtube.com/watch?v=6kwXEQ3O2Q0 )
Och nu samma sak på win10.

Till frågan:

Finns det något bättre OS för htpc som har stöd för 5.1 och streamingappar (Amazon Prime, Disney+, HboMax, Spotify mm) ?

Eller finns det något bättre för windows?

Mod får gärna flytta tråden till en bättre passande forumsdel.

Permalänk
Keeper of the Bamse

Du kör väl den här för Windows? Då får du riktigt surround. Jag får riktig Atmos i windows, om videokontainern stödjer det försåss (wink wink, nudge nudge)

https://apps.microsoft.com/store/detail/dolby-access/9N0866FS...

Kör sen HDMI rakt in i receivern, så sköter den resten. Från recevern kopplar du sen TVn

Permalänk

@Printscreen
Får bild kopplat från GPU till reciver till TV med HDMI
Men inget ljud. Alls
Kan inte välja HDMI som ljudkälla i windows.

Gpun är en RX 550

Permalänk
Medlem
Skrivet av Mathrohas:

@Printscreen
Får bild kopplat från GPU till reciver till TV med HDMI
Men inget ljud. Alls
Kan inte välja HDMI som ljudkälla i windows.

Gpun är en RX 550

Det ska gå och enda sättet att faktiskt få riktigt 5.1 till förstärkaren då toslink inte har bandbredd nog för det, utan att komprimering sker...

Har du senaste drivrutinerna till kortet? Har du valt hdmi ingång på förstärkaren och att den ska plocka ljud från hdmi?

Permalänk
Skrivet av Sweex:

Det ska gå och enda sättet att faktiskt få riktigt 5.1 till förstärkaren då toslink inte har bandbredd nog för det, utan att komprimering sker...

Har du senaste drivrutinerna till kortet? Har du valt hdmi ingång på förstärkaren och att den ska plocka ljud från hdmi?

Senast drivisarna och valt hdmi på förstärkaren ja.

Hittar dock ingen hdmi ljudkälla i win

Permalänk

Plockade ur GPUn och kör hdmi till MB med en 3000g istället.
Då får jag ljud dock endast stereo.
5.1 och 7.1 är gråmarkerade.
Finns inget alternativ för Spatialljud annat än "Windows Sonic för hörlurar

Permalänk
Livsnjutare 😎

Jag hade, utan att veta huruvida det fungerar eller ej, testat Ubuntu.

Mycket funkar faktiskt rakt ut lådan med Unbuntu tbh.

Permalänk
Keeper of the Bamse
Skrivet av Mathrohas:

Plockade ur GPUn och kör hdmi till MB med en 3000g istället.
Då får jag ljud dock endast stereo.
5.1 och 7.1 är gråmarkerade.
Finns inget alternativ för Spatialljud annat än "Windows Sonic för hörlurar

Har du installerat Dolby-appen och klickat dig igenom den? Då ska det dyka upp Atmos for Home Theater som alternativ

Permalänk
Skrivet av andreas_dock:

Jag hade, utan att veta huruvida det fungerar eller ej, testat Ubuntu.

Mycket funkar faktiskt rakt ut lådan med Unbuntu tbh.

Ska testa ubuntu på annan disk 👍

Skrivet av Printscreen:

Har du installerat Dolby-appen och klickat dig igenom den? Då ska det dyka upp Atmos for Home Theater som alternativ

Jodå jag har försökt med dolby access appen, men eftersom jag ej har något alternativ annat än "windows sonic" i spatialljud så får jag bara "Configuration Failed"

Permalänk
Medlem

Jag tror inte Yamaha 467 har Dolby Atmos, har själv köpt förstärkare som klarar av det och skillnaden är rejält, du bör dock kunna välja 5.1 i windows.

Permalänk
Skrivet av DaydreamerVlad:

Jag tror inte Yamaha 467 har Dolby Atmos, har själv köpt förstärkare som klarar av det och skillnaden är rejält, du bör dock kunna välja 5.1 i windows.

Det har du nog rätt i.
Kollade yamahas hemsida för spec.

CINEMA DSP
DSP Programs
SILENT CINEMA / Virtual CINEMA DSP
Dolby TrueHD
Dolby Digital Plus
Dolby Pro Logic IIx
DTS-HD Master Audio

Ska den stödja.

Men just nu är jag bara glad om jag får igång någon utav dem för 5.1.
Lite trött på PCM 🙃

Permalänk

3000g slutade ge signal helt och hållet via hdmi
Endast bild via rx 550.

Provade speldatorn (win11 och 3060ti) till receivern via HDMI och det ger både bild och ljud dock endast PCM.

Nä det blir och testa ubuntu

Permalänk
Keeper of the Bamse
Skrivet av Mathrohas:

3000g slutade ge signal helt och hållet via hdmi
Endast bild via rx 550.

Provade speldatorn (win11 och 3060ti) till receivern via HDMI och det ger både bild och ljud dock endast PCM.

Nä det blir och testa ubuntu

Jag skulle bli förvånad om det är operativsystemets fel här faktiskt, men återkom gärna med resultat!

Permalänk
Medlem

Kan inte svar för just din förstärkare och hur den kommer funka.
Men jag har genom åren kört flertalet förstärkare från både Onkyo och Pioneer kopplade till en htpc med linux på. Har kört både Ubuntu, Manjaro och Fedora och har alltid utan några större problem eller ansträngningar fått 5.1 att lira fint. Jag använder alltid HDIM, och i det fåtal fall då distron i fråga inte känt igen 5.1 så har det inte varit svårare än att gå in i systeminställningarna och slå på / välja 5.1 i listan av konfigurationsmöjligheter.
Vad gäller specifika standarder eller protokoll (eller vad man ska kalla det) så har jag ingen direkt aning då jag inte hakar upp mig på sådant. Så länge det spelar 5.1 och det "låter bra" så är jag nöjd.

Numera går allt fler distributioner över till att använda Pipewire istället för Pulseaudio som styrning och kontroll för ljud. Vilket åtminstone i teorin ska göra saker lättare och smidigare konfigurera ljudet och med bättre stöd för hårdvara och diverse ljudprotokoll. För mig funkar det bra väldigt bra och smidigt.
Jag skulle förslå att börja med Fedora som för mig är väldigt stabilt, ligger i framkant med mjukvara (både program och linuxkärnan) och uppdateringar och anamar ny teknik. Vilket oftast är det man vill när det gäller multimedia, gaming och hårdvara.

Permalänk

@mrazster
Tack!
Har kikat lite på fedora och ubuntu nu.
Fedora ser riktigt trevligt ut.
Ska ge det ett försök.

Fick iallafall fart på ljudet genom grafikkortet genom att uppdatera bios på moderkortet.
Dock endast pcm.

Permalänk

Har installerat fedora och får bild om jag kör med hdmi direkt till tvn.
Använt denna som guide https://www.youtube.com/watch?v=RrRpXs2pkzg

Dock ingen signal alls om jag kopplar receivern emellan.
Vad missar jag?

Permalänk

Nu har jag både bild och ljud genom recivern i fedora
Dock endast PCM

Hmm kan det vara min hårdvara iallfall som spökar?

Permalänk
Medlem

En tanke kring att använda Linux för sånt här är att det väl är (eller var i alla fall) svårt att få högsta kvalitet på DRM-skyddat innehåll, alltså Netflix exempelvis. Jag har för mig att inga distros hade stöd för det DRM som krävdes och således blev det bara 720p och jag har för mig att även ljudet begränsades i antal kanaler eller så. Det kanske är löst nu dock, det var ett tag sedan jag kollade på det.

Permalänk
Medlem
Skrivet av Mathrohas:

Nu har jag både bild och ljud genom recivern i fedora
Dock endast PCM

Hmm kan det vara min hårdvara iallfall som spökar?

Blev lite nyfiken på detta för egen del nu.
Inte för att jag tänker anstränga mig onödigt mycket. men blev som sagt nyfiken på jag kunde åstakomma bättre då min förstärkare också stödjer allehanda ljudstandarder och protokoll.

Men det verkar som stödet i linux för diverse Dolby XXX vara lite sisådär.
Men det finns lite möjligheter och lösninger. Programet Easy Effects verkar vara ett av dom. Har aldrig provat eller använt det själv. Denna tråd och specifikt detta inlägg, ger en hel del info och hintar om möjligheter.

Någon av dagarna framöver kommer jag nog sätta mig och pilla lite med det och se vad det kan leda till.

Permalänk

Vet inte om jag har upptäckt något eller inte.

Fick samma sak med fedora som windows.
Helt sonika får jag ingen bild på hdmi via recivern, men får bild om jag kopplar direkt till TVn.
Installerade Kubuntu istället. Samma sak där.

Jag satt mig framför receivern och kollade igenom menyerna och se på fan.

Under 'Signal info' står alltså
HDMI output
DVI input

Jag letade då fram en dvi-d/hdmi kabel och körde dvi från grafikkortet till hdmi på recivern vidare via hdmi till TVn och fick bild på en gång.

Till frågan.
Varför tror receivern att den får signal via DVI när Hdmi är inkopplat i gpun

Permalänk

För h@%#+!*s j%€&a s#@t !

Bytte ut HDMI kabeln och nu funkar sk#@ten.

Permalänk
Keeper of the Bamse
Skrivet av Mathrohas:

För h@%#+!*s j%€&a s#@t !

Bytte ut HDMI kabeln och nu funkar sk#@ten.

Bra, då kan du ju installera Windows igen så du slipper alla framtida problem med Linux och DRM-skyddat material
(Och allt annat strul som linux på desktop medför... ha gärna linux, fast på en lekdator som inte är viktig)