SSD bootar inte i AHCI

Permalänk
Medlem

SSD bootar inte i AHCI

Tja swec!

Så fort jag ställer in AHCI i bios så bluescreenar min samsung 830 128gb och startar om. Den vill helt enkelt inte boota i AHCI men IDE funkar fint.

Har senaste firmware osv.

Vad kan vara problemet?

Permalänk
Medlem

Du måste ändra lite i windows innan du kan boota med en annan kontroller.
http://www.evga.com/forums/tm.aspx?m=18077&mpage=1

Permalänk
Medlem
Skrivet av Svensktiger:

Du måste ändra lite i windows innan du kan boota med en annan kontroller.
http://www.evga.com/forums/tm.aspx?m=18077&mpage=1

Redan gjort det.

Permalänk
Medlem
Skrivet av makkesk8:

Redan gjort det.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci]
"Start"=dword:00000000

Spara i notepad och spara som .bat bara tryck på den sen starta om

Permalänk
Medlem
Citat:

Slå till AHCI efter installation av Windows 7:

Först kolla så ert moderkorts BIOS verkligen stödjer AHCI. Var man slår till det kan skilja mellan olika kort, hos mitt Asus-kort finns valet i Main-menyn under Storage Configuration där man kan välja att köra SATA i IDE, AHCI eller Raid. Men ändra inget nu!
I Windows så skapa en återställningspunkt för säkerhets skull. Hur ni gör det skrev jag om här.
Avsluta alla program. Tryck på Windows-knappen och skriv in ‘regedit’ i sökrutan och tryck Retur. Kommer det upp en UAC-ruta som frågar om tillåtelse så tryck Ja.
I Registereditorn så leta upp och klicka på följande registerundernyckel i trädet till vänster:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
* SE NOTIS – Fler Registervärden – NEDAN *
I den högra rutan: klicka på Start i kolumnen Namn och sedan på Ändra.
Skriv 0 (numerisk nolla) i rutan Data, och klicka sedan på OK.
Stäng Registereditorn genom att klicka Avsluta i Arkiv-menyn.
Starta om datorn och gå direkt in i BIOS. Slå till AHCI och spara ändringen.
Efter Windows 7 nu startar upp så kommer drivrutinerna till AHCI att installeras. Till sist så starta om Windows ytterligare en gång för att slutföra installationen.

Efter ändring till AHCI så kan det hända att er disk(ar) dyker upp under ikonen Säker borttagning av maskinvara. Det är helt normalt och inget att bry sig om.

Fler registervärden:
Det finns 4 möjliga registervärden att ändra beroende på om man vill starta med ide, ms ahci, raid eller Intels ahci (Intel® Rapid Storage Technology):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pciide
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor

Ändrar man allas startvärde till 0 så bör det funka att skifta mellan dem i bios.

Källa: http://bengansblogg.wordpress.com/2010/11/25/sla-till-ahci-mo...