Forumdelen sponsras av

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Benq xl2420t no signal detected

Hej,

Har en benq xl2420t från 2012 som verkar ha fått fel.
Den har fungerat felfritt genom en DVI till DVI koppling till mitt grafikkort där jag har haft 120hz. Men igår så skulle jag också koppla mitt grafikkort till en tv som ligger bredvid genom hdmi och då slocknade min skärm plötsligt(TV:n funkade däremot genom hdmi kopplingen).

Problemet nu:
1. är att DVI till DVI kopplingen inte verkar fungera längre (inte hunnit prova med en annan dvi sladd ännu då jag inte har någon ytterligare). Får "no signal detected"
2. Dessutom så fungerar det inte när jag direkt kopplar hdmi uttaget från skärmen till hdmi uttaget på grafikkortet. Får "no signal detected"

3. Däremot fungerar det att koppla hdmi uttaget på grafikkortet till hdmi uttaget på TV:n som ligger bredvid.

Det enda sättet som jag har lyckats få en bild på min skärm är när jag använder hdmi uttaget på skärmen och kopplar den till mini-displayport uttaget genom en adapter på mitt grafikkort.
Mitt grafikkort är AMD Gigabyte HD7950. Jag har testat att installera grafikdrivrutinerna på nytt.

Någon tanke kring vad felet är och vart det sitter? Är det fel på skärmen eller grafikkortet eller är det något jag gör som är fel?

Trädvy Permalänk
Medlem
Plats
Orust
Registrerad
Dec 2010

koppla in den vanliga skärmen i datorn och håll sedan in windows knappen, när du håller in W knappen trycker du 2 gånger på P. En liten stund där efter borde det kanske dyka upp en bild.

Testa annars skärmen med någon annan dator om du har och se om den reagerar där.

| Asus Z170-A | i5 6600K | ASUS R7 260x | 2*4Gb ddr4 2666 | corsair cx750m | Phanteks eclipse p400 |

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

@dellxps600: Har testat det där fick inget svar
Väljer också såklart DVI som input mode på skärmen.

Testade förresten en helt ny DVI kabel och jag fick ingen respons då heller.

Trädvy Permalänk
Medlem
Plats
Orust
Registrerad
Dec 2010

Testat att koppla dvi till tv:n? Testa annars att ha hdmi från tv:n och dvi från skärmen och se sen om du kan få igång den med att dubblicera bilden. Då kan du ju även se vad som försigår på tv:n också.

| Asus Z170-A | i5 6600K | ASUS R7 260x | 2*4Gb ddr4 2666 | corsair cx750m | Phanteks eclipse p400 |

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

@dellxps600: No signal detetcted ännu en gång.

Har förresten provat på en annan dator och fick samma svar igen.

Hur kopplar man DVI till tv:n?

Trädvy Permalänk
Medlem
Plats
Orust
Registrerad
Dec 2010

Okej. Det är ju samma som på datorskärmen. Dvs om du har dvi utgång på tv:n. annars blir det ju svårt.

Men om det är samma resultat på skärmen med en annan dator så borde det ju vara så att det är fel på dvi porten på skärmen.

Om du har tillgång till vga på gpu och skärm kanske du kan testa om det fungerar. Annars vet jag nog inte. Kanske någon krets som bränt i skärmen eller ngt.

| Asus Z170-A | i5 6600K | ASUS R7 260x | 2*4Gb ddr4 2666 | corsair cx750m | Phanteks eclipse p400 |

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

@dellxps600: Hade ingen DVI port på TV:n, det jag däremot testade nu var att koppla HDMI uttaget från TV:n till DVI uttaget på grafikkortet genom en HDMI till DVI adapter och då fick jag bild. Detta borde väl utesluta att det är fel på grafikkortets DVI port?

Har ingen vga port på grafikkortet verkar det som.
Men fan surt om skärmens dvi port plötsligt gått sönder, är det vanligt? Tror min garanti också är ute då den är köpt 2012 från Webhallen (har för mig att det gällde i 3år)
Att jag får "no signal detected" genom att koppla hdmi i skärmen direkt till hdmi i grafikkortet, betyder det också att HDMI porten i skärmen är sönder? Som sagt får endast bild när jag kopplar HDMI i skärmen till minidisplayport i grafikkortet genom adapter...

Trädvy Permalänk
Medlem
Registrerad
Sep 2013

har också problem med min xl2420t som jag kör via DP och nu på sista veckorna så har jag fått problem med att skärmen blir svart i ca 2secunder då och då. Där det också är No signal
händer helt random.

har nya nvidia drivrutiner men skall testa att byta till antingen DVI eller en ny DP kabel.

[CENTER]
Rigg: Asus Maximus V Formula - i7-3770K 4.4Ghz - Ripjaws 16GB - GeForce GTX970 G1 Gaming - RM850 - NZXT S340
Networking: NetGear ORBI WIFI SYSTEM - Synology DiskStation DS1817+ + 5x3TB Raid5 + 120GB Cash SSD.

#Playstation 4 PRO
Bahnhof For President

Trädvy Permalänk
Medlem
Plats
Orust
Registrerad
Dec 2010

Hmm. Låter som om det vore trasigt i skärmen. Men om den inte reagerar på HDMI-HDMI men fungerar med HDMI-MDP låter också konstigt. Då tar ju skärmens HDMI utag emot signaler.

| Asus Z170-A | i5 6600K | ASUS R7 260x | 2*4Gb ddr4 2666 | corsair cx750m | Phanteks eclipse p400 |

Trädvy Permalänk
Medlem
Plats
Orust
Registrerad
Dec 2010

Har du testat från HDMI på grafikkortet till DP? Har du 3 st PD 1 st MDP 1 st VGA 1 st HDMI 1 st DVI?

Finns det någon source inställning på skärmen som kanske är fel inställd?

| Asus Z170-A | i5 6600K | ASUS R7 260x | 2*4Gb ddr4 2666 | corsair cx750m | Phanteks eclipse p400 |

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

@dellxps600:
På mitt grafikkort har jag två Mini DP, 1 HDMI och 1 DVI.
På min skärm har jag 2 HDMI, 1 stor DP (vanlig), 1 D-sub, 1 DVI.

Kan inte koppla hdmi från grafikkortet till DP i skärmen, har varken en sån kabel eller adapter.
Och jag ställer alltid in rätt source, tror jag iallafall.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Vet inte om det gör någon skillnad men det är alltid DVI Dual link kabel som jag har använt (för 120hz)

Trädvy Permalänk
Medlem
Plats
Orust
Registrerad
Dec 2010

Okej.

Jadu, då har jag inte en aning. Kanske är det så att skärmen börjat ge sig. Om garantin har gått ut kanske du kan skruva isär och felsöka själv. Sök lite guider på google och youtube så kanske du hittar någon lösning.

Om det nu är skärmen det är fel på vill säga.

| Asus Z170-A | i5 6600K | ASUS R7 260x | 2*4Gb ddr4 2666 | corsair cx750m | Phanteks eclipse p400 |

Trädvy Permalänk
Bildexpert 📺
Thomas Ytterberg
Registrerad
Mar 2013

Hängde inte med i alla svängar men en förklaring kan vara att du kör både DVI och HDMI där grafikkortet endast orkar med en TMDS-ström i taget och det ligger en prioritet på HDMI. Dvs så länge du kör HDMI stänger den av DVI.

Det skulle kunna förklara varför det blev bild med DP->HDMI-omvandlare. Ifall omvandlaren är aktiv så är det en DP-signal som körs ut grafikkortets perspektiv.

Detta kan eventuellt också styras av någon switch på grafikkortet, så att du får två TMDS-strömmar fördelade som två single link över DVI och HDMI. Men då får du alltså inte mer än 60 Hz över DVI.

Den lösning som borde fungera är annars DP till skärmen och HDMI till TV:n

Läs mer i SweClockers guider till BildskärmarKöpguide för skärmPixelklockanDVI & VGAHDMITVLjusstyrkaTV 2016/17TV-priser

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

@Laxpudding: Det du säger låter helt klart tänkbart. Har ingen koll på om det finns någon switch. Kan man få det att fungera på något sätt om det är så att strömmen inte räcker till?
Har förresten beställt en DP kabel för skärmen och hoppas på det bästa.

Trädvy Permalänk
Medlem
Registrerad
Jan 2012

Testade använda DP porten nu på skärmen till MDP i grafikkortet och fick lyckligtvis bild och 120hz. Antar att jag får acceptera att dvi är sönder på skärmen och att den börjat ge upp (många konstiga beteenden).