Cisci Aironet, i Fedora Core 4

Trädvy Permalänk
Medlem
Plats
Sätila
Registrerad
Jul 2004

Cisci Aironet, i Fedora Core 4

Edit: stavfel i rubriken ( ), CISCO ska det vara!

Hej,
Jag har nyligen instalerat Fedora Core 4 (KDE) på min bärbara Acer Aspire 1454Lci.
Till denna har jag ett Cisco Aironet 802.11a/b/g trådlöst nätverkskort.
Jag har lyckats med att fixa mitt vanliga nätverkskort utan problem, men när jag ska göra samma sak med mitt trådlösa hittas inte detta av nätvekshanteraren.
Det syns altså inte om man skriver ifconfig,

Hur ska man gå till väga? Tips om drivrutiner?
Jag har sökt efter lösningar men det finns inte så mycket information om Fedora Core 4. (som jag hittar)
Vore väldigt glad om någon kunde hjälpa mig.
Tack på förhand!

iMac Core Duo 2GHz, 1GB RAM, 256MB VRAM, Mac OS 10.4.6, iLife '06

Trädvy Permalänk
Medlem
Plats
Knivsta
Registrerad
Maj 2003

På min laptop hittade pcmcia-cs mitt aironet kort och laddade moduleno ch det var bara att associera.

Annars kan du testa att köra: modprobe airo_cs
Om inte det funkar kanske du måste ladda modulen yenta_socket.

Trädvy Permalänk
Medlem
Plats
Sätila
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av e-cone
På min laptop hittade pcmcia-cs mitt aironet kort och laddade moduleno ch det var bara att associera.

Annars kan du testa att köra: modprobe airo_cs
Om inte det funkar kanske du måste ladda modulen yenta_socket.

Hmm, jag lyckas ändå inte ricktigt, men tack för svaret.
Skulle du kunna förklara lite närmre hur jag ska göra?
Kör du också Fedora Core 4?

iMac Core Duo 2GHz, 1GB RAM, 256MB VRAM, Mac OS 10.4.6, iLife '06

Trädvy Permalänk
Medlem
Plats
-
Registrerad
Feb 2004

Om du skriver modprobe airo_cs i en terminal så laddas modulen airo_cs. Om den innehåller stöd för ditt kort så ska det funka.

Trädvy Permalänk
Medlem
Plats
Knivsta
Registrerad
Maj 2003

Jag kör inte Fedora jag kör CRUX med egen kompilerad kärna.

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

Mitt Cisco Aironet 350 Mini-PCI fungerar fint i Linux (Gentoo), men jag har kompilerat in det direkt i kärnan, dock skulle modulen heta airo om jag kompilerat det som modul.

Så testa

modprobe airo

om airo_cs inte skulle fungera.

Observera att du måste vara root när du gör detta.

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Sätila
Registrerad
Jul 2004
Citat:

Ursprungligen inskrivet av m0REc
Mitt Cisco Aironet 350 Mini-PCI fungerar fint i Linux (Gentoo), men jag har kompilerat in det direkt i kärnan, dock skulle modulen heta airo om jag kompilerat det som modul.

Så testa

modprobe airo

om airo_cs inte skulle fungera.

Observera att du måste vara root när du gör detta.

Detta fungerade, tack så mycket.
Nu hittar Fedora Core nätverkskortet och klarar av att ansluta till nätverket som vi har hemma.
Men jag kan inte pinga eller komma åt nätverket på något sätt.
Om jag kör iwconfig står det att jag är ansluten till "default" som vårat nätverk heter.
Men som sagt mer än så kan jag inte göra.
Är det någon som har några ideer om hur jag ska göra??

Tack för alla svar.

Om någon vill ha mer information för att eventuellt kunna hjälpa mig så säg bara till.

iMac Core Duo 2GHz, 1GB RAM, 256MB VRAM, Mac OS 10.4.6, iLife '06

Trädvy Permalänk
Medlem
Plats
Knivsta
Registrerad
Maj 2003

Verkar som du inte har en ip adress, kör kommanot dhclient eth0 eller eth1, (vilket som är ditt trådlösa) så får du en ip address från din accesspunkt,router eller vad du har.

Trädvy Permalänk
Medlem
Plats
Sätila
Registrerad
Jul 2004
Citat:

Verkar som du inte har en ip adress, kör kommanot dhclient eth0 eller eth1, (vilket som är ditt trådlösa) så får du en ip address från din accesspunkt,router eller vad du har.

Hmm, även fast jag har statisk ip adress??

Mina inställningar:

ifconfig ath0:
ath0 Link encap:Ethernet HWaddr 00:40:96:A7:DD:D3
inet addr:192.168.0.137 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::240:96ff:fea7:ddd3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:24 errors:30 dropped:0 overruns:0 frame:30
TX packets:9 errors:1 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:7493 (7.3 KiB) TX bytes:1176 (1.1 KiB)
Interrupt:5 Memory:e0e20000-e0e30000

Iwconfig ath0:
ath0 IEEE 802.11g ESSID:"default" Nickname:"localhost"
Mode:Managed Frequency:2.437 GHz Access Point: 00:80:C8:14:4F:3D
Bit Rate:36 Mb/s Tx-Power:50 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=10/94 Signal level=-85 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:1 Missed beacon:0

Inställningar:
Ip : 192.168.0.137
Netmask: 255.255.255.0
Gateway: 192.168.0.1
Primary DNS: 192.168.0.1

iMac Core Duo 2GHz, 1GB RAM, 256MB VRAM, Mac OS 10.4.6, iLife '06

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Dec 2002

DNS osv rätt inställda?

Kör du en lokal DNS?

Vim
Kinesis Classic Contoured (svart), Svorak (A5)
Medlem i signaturgruppen Vimzealoter.

Trädvy Permalänk
Medlem
Plats
Sätila
Registrerad
Jul 2004

Jag kör en lokal dns på 192.168.0.1.
La även till 81.163.0.130 (Telias).
Men det funkar fortfarande inte.
Det funkar om jag använder mitt vanliga nätverkskort så det är nog inget fel på Dns instälningarna.

iMac Core Duo 2GHz, 1GB RAM, 256MB VRAM, Mac OS 10.4.6, iLife '06