Permalänk
Medlem

apt-get upgrade problem!

Försöker köra apt-get upgrade phpmyadmin, webmin medmera men det går ej. Får bara detta..

root@test:/# apt-get upgrade phpmyadmin
Läser paketlistor... Färdig
Bygger beroendeträd
Läser tillståndsinformation... Färdig
Följande paket har hållits tillbaka:
bind9-host dnsutils libbind9-30 libisccc30 libisccfg30 linux-image-server linux-server
Följande paket kommer att uppgraderas:
webmin
1 uppgraderade, 0 nyinstallerade, 0 att ta bort och 7 ej uppgraderade.
E: Kunde inte erhålla låset /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Kunde inte låsa hämtningskatalogen
root@test:/#

Någon som vet?

Med vänliga hälsningar

Permalänk
Medlem

Vad säger "sudo apt-get update" ?

Permalänk
Medlem

jag är root. kört sudo -s innan..

Permalänk
Medlem

efter en hard reboot så funkar det fint igen.

Permalänk
Hedersmedlem

Antagligen hade apt-get dödats på ett icke-snällt sett tidigare så att dess lockfil inte rensats. Efter omstart så kanske den rensades automatiskt, eller så jämförde den helt enkelt tiden för loggfilens skapande och senaste reboot och listade ut själv att loggfilen var en gammal relik.