Problem strömma DHCP genom switch TP-link T1600G-28TS

Permalänk

Problem strömma DHCP genom switch TP-link T1600G-28TS

Hej!

Jag blir inte klok på detta. Hoppas någon med mer nätverkskunskaper än mina ringa kan hjälpa mig. Min setup är som följer:
Fiber in som vidarebefordras direkt till en Asus Nighthawk R7000 router (192.168.1.1) som sköter DHCP-tilldelning och wifi. Denna är i sin tur kopplad till en switch TP-link T1600G-28TS (192.168.1.100), en så kallad smart switch med L2+ vad nu det innebär exakt , som fördelar vidare uppkopplingen till alla rum. I ett av rummen har jag en Netgear WNDR3700 (192.168.1.2) som jag laddat med dd-wrt för att kunna köra den som en extra wifi acesspunkt för att stödja min R7000. Jag har stängt av DHCP-tilldelning på WNDR3700 för att allt skall skötas via min R7000.
Problemet är att när min accesspunkt WNDR3700 är kopplad via TP-link switchen till DHCP-routern R7000 får inget som är kopplat till min extra accesspunkt någon ip address tilldelad via DHCP. Om jag istället bypassar switchen och kopplar in accesspunkten direkt i ett av de lediga uttagen på min R7000 fungerar allt perfekt och allt som är kopplat vara sig via kabel eller wifi till min accesspunkt blir tilldelad en ip via dhcp. Det är den config jag kör nu men irriterar mig oerhört på att inte kunna lösa detta via switchen.

Det är uppenbarligen switchen som på något vis blockerar genomströmmningen av dhcp-tilldelning. Vet någon hur jag skall konfigurera min "smarta" switch för att öppna upp för detta? Detta är helt utanför min kompetens. Switchen stöder DHCP relay, option 82, DHCP snooping et.c Skall detta konfigureras på något sätt? Har även läst att DHCP kommunicerar via UDP 67-68 men kan inte hitta hur jag skulle kunna strömma dessa obehindrat till definierade portar/uttag på switchen. Jag vill också tillägga att min R7000 är inkopplad på port 1 på switchen och inte någon av de 4 SFP uplink-portarna.

Tacksam för all hjälp jag kan få.

Permalänk
Medlem
Skrivet av Holayoman:

Switchen stöder DHCP relay, option 82, DHCP snooping et.c Skall detta konfigureras på något sätt?

Nej.
Din switch ska vara konfigurerad som en vanlig enkel L2-switch utan något som helst lull-lull.

Gör en factory reset på den om du är osäker på vad du håller på med.

Permalänk
Medlem

Låter som att du behöver en en iphelper på din L2 switch.
Går säkert att konfa någonstans i gränssnittet om du inte känner dig hemma med CLI.

Permalänk
Medlem
Skrivet av Kalasis:

Låter som att du behöver en en iphelper på din L2 switch.
Går säkert att konfa någonstans i gränssnittet om du inte känner dig hemma med CLI.

Ip helper är något som används i en router.
En switch jobbar på L2/ethernet och där finns inte ens något som heter ip.

Menar du att TS switch i själva verket är en router?
Det borde väl gå att konfigurera switchen så att den uppför sig som en switch kan man tycka.

Permalänk
Medlem
Skrivet av madtop:

Ip helper är något som används i en router.
En switch jobbar på L2/ethernet och där finns inte ens något som heter ip.

Menar du att TS switch i själva verket är en router?
Det borde väl gå att konfigurera switchen så att den uppför sig som en switch kan man tycka.

Kanske är bakfyllehjärnan som strular till det för mig. Noterade bara L2+ där du kan behöva komma att aktivera DHCP-relay för att få den funktionalitet hen eftersträvar. Vet ju dock inte hur TS config ser ut på switchen om det pillats omedvetet.
Bästa vore ju att byta ut switchen till en typisk dumswitch eller läsa lite guider om hur sagda switch bör confas I hens situation.

Permalänk
Inaktiv
Skrivet av madtop:

Ip helper är något som används i en router.
En switch jobbar på L2/ethernet och där finns inte ens något som heter ip.

OT men IP helper används när DHCP servern och DHCP klinten inte står i samma broadcast domain. Det behöver inte alls betyda Layer3 utan räcker med att servern och klienten sitter på olika VLAN.

Permalänk
Inaktiv

Antar att du inte har några VLAN konfigurerade på switchen? Antar att det är samma port du använder när du "bypassar" switchen som du annars använder?

Jag skulle resetta den, om du inte har en massa "config"i den.

Permalänk
Medlem
Skrivet av studiox_swe:

OT men IP helper används när DHCP servern och DHCP klinten inte står i samma broadcast domain. Det behöver inte alls betyda Layer3 utan räcker med att servern och klienten sitter på olika VLAN.

Ännu mer off topic: Mellan två broadcast-domäner (ip-nät) behöver man en burk som terminerar L2, gör vägval på ip-nivå (routing) för att slutligen lägga på en ny L2-header. En sådan burk kallas för det mesta för en router. Att sedan vissa kallar den routern för "L3-switch" är bara förvirrande.

Skrivet av Holayoman:

Problemet är att när min accesspunkt WNDR3700 är kopplad via TP-link switchen till DHCP-routern R7000

Är du säker på att det inte är din AP som strular?
Vad händer om du ansluter en dator direkt till switchen?

Permalänk
Rekordmedlem

Hur har du konfat Netgear WNDR3700 till ap, det går ju att göra på minst 3 olika i wrt men jag undrade mest om vad du för med dess wanport och vart den är kopplad.

Permalänk
Skrivet av madtop:

Ännu mer off topic: Mellan två broadcast-domäner (ip-nät) behöver man en burk som terminerar L2, gör vägval på ip-nivå (routing) för att slutligen lägga på en ny L2-header. En sådan burk kallas för det mesta för en router. Att sedan vissa kallar den routern för "L3-switch" är bara förvirrande.

Är du säker på att det inte är din AP som strular?
Vad händer om du ansluter en dator direkt till switchen?

Tack för alla snabba svar!
Jag började med att göra en factory reset av switchen vilket inte gjorde någon skillnad. Jag har inte flera VLAN men switchen har från grunden ett VLAN där alla switchens portar ligger. Vad jag förstod det så bör de avancerade DHCP-alternativen endast användas då samma DHCP-server ska arbeta mellan olika VLAN eller subnät. så är inte fallet.
Efter lite mer felsökning verkar det vara min AP som strular. Då jag kopplar in en annan WNDR3700 (AP) jag har liggandes som är fabriksåterställd fungerar allt finfint. I alla fall då jag bara använder den trådbundna switchdelen av min andra WNDR3700. Tyvärr tillåter inte firmwaren från fabrik att den trådlösa delen används i AP-syfte varför jag flashat den med dd-wrt som har fullt stöd för detta.
Det är alltå min flashade AP som strular. Det konstiga är fortfarande att den fungerar precis som jag vill då jag kopplar den direkt in i min DHCP-router (R7000) och tilldelar IP till både LAN- och WLAN-delen på APn. Då jag istället kopplar APn till switchen som i sin tur är ansluten till R7000 dör allt. Vid switchens trafikövervakning registreras bara Tx-paket på den porten jag kopplar in APn i, inga Rx-paket.
Det måste vara någon subtil inställning i min AP som min R7000 antingen ignorerar eller klarar av samtidigt som det helt blockerar switchen.
Idéer mottages tacksamt!

Permalänk

Jag använde denna guide för övrigt för min AP:
https://www.dd-wrt.com/wiki/index.php/Wireless_Access_Point

Permalänk
Medlem
Skrivet av Holayoman:

Efter lite mer felsökning verkar det vara min AP som strular.
Idéer mottages tacksamt!

Hade det på känn. En switch strular sällan.

En av de enklaste sakerna du kan prova är att ansluta kabeln från routern i en LAN-port (inte WAN) på din AP. Jag är nästan säker på att det funkar då.

Permalänk
Rekordmedlem
Skrivet av Holayoman:

Jag använde denna guide för övrigt för min AP:
https://www.dd-wrt.com/wiki/index.php/Wireless_Access_Point

Den guiden ställde väl inte om enheten i ap mode eller missade jag det ? Det finns som sagt minst 3 olika sätt att göra det och exakt vilka skillnader det blir vet jag inte och kan inte heller testa just nu men AP läge väljer man här >

Permalänk
Skrivet av madtop:

Hade det på känn. En switch strular sällan.

En av de enklaste sakerna du kan prova är att ansluta kabeln från routern i en LAN-port (inte WAN) på din AP. Jag är nästan säker på att det funkar då.

Jag har alltid kört med kabeln till LAN-delen på min AP, inte WAN även om den går att konfigurera om till en extra LAN-port i interfacet.

Skrivet av mrqaffe:

Den guiden ställde väl inte om enheten i ap mode eller missade jag det ? Det finns som sagt minst 3 olika sätt att göra det och exakt vilka skillnader det blir vet jag inte och kan inte heller testa just nu men AP läge väljer man här >
https://www.dd-wrt.com/wiki/images/f/fe/VAP1.jpg

Japp, det är precis där jag har konfigurerat wifi som AP efter att ha inaktiverat WAN och DHCP på min AP.

Jag har nu resetat min AP igen och gjort inställningarna igen efter att ha dubbelkollat med andra guider på nätet. De säger allt i princip samma sak. Jag har även testat att flasha min AP med en firmware från open wrt istället som många föredrar. Lite enklare gränssnitt och mindre val men resultatet blir om och om igen precis samma: APn fungerar perfekt då inkopplad direkt i min router som sköter dhcp. Kopplar jag in min AP via switchen dör allt och inget kopplat till APn lyckas få en IP adresserad till sig. Att det fungerade med en fabriksåterställd AP börjar jag undra om det inte var eftersom jag ej gått in och avaktiverat den inbyggda dhcp-servern i APn...
Jag undrar om det trots allt inte är min switch som hanterar dhcp-paketet på ett sätt som inte min AP tycker om. Kanske någon funktion som hindrar att mer än ett ip tilldelas per port på switchen. Jag börjar dock nå gränsen till hur mycket tid det är värt att lägga ner på något som trots allt fungerar då jag kopplar direkt in i routern även om det inte var den funktion jag eftersträvade från början.

Tack alla för hjälpen i alla fall, jag slänger självklart in ett meddelande om jag löser det!

Permalänk
Medlem
Skrivet av Holayoman:

funktion som hindrar att mer än ett ip tilldelas per port på switchen. Jag börjar dock nå gränsen till hur mycket tid det är värt att lägga ner på något som trots allt fungerar då jag kopplar direkt in i routern även om det inte var den funktion jag eftersträvade från början.

Tack alla för hjälpen i alla fall, jag slänger självklart in ett meddelande om jag löser det!

Det är ju en avancerad switch som har stöd för en del dhcp-manipulering. Men att dessa ska vara påslagna default verkar vara mycket skumt. Kolla i konfigurationen efter t.ex " ip source binding", "arp inspection", "dhcp snooping".

Och vet du att det är dhcp som inte funkar? Funkar det om du sätter en statisk ip på någon dator?

Permalänk
Medlem

Måste du ha WNDR kopplad till switchen då? Om det funkar som du vill när den är kopplad direkt till R7000 är det väl bara att köra så, eller missar jag något?

Permalänk

Hittat felet!

Skrivet av svalle:

Måste du ha WNDR kopplad till switchen då? Om det funkar som du vill när den är kopplad direkt till R7000 är det väl bara att köra så, eller missar jag något?

Du har helt rätt resultatet blir detsamma dvs allt funkar! Så otroligt irriterande bara att inte hitta vad felet berodde på... Plus att det blir en switch "extra" till NASen sett från WNDR.

Skrivet av madtop:

Det är ju en avancerad switch som har stöd för en del dhcp-manipulering. Men att dessa ska vara påslagna default verkar vara mycket skumt. Kolla i konfigurationen efter t.ex " ip source binding", "arp inspection", "dhcp snooping".

Och vet du att det är dhcp som inte funkar? Funkar det om du sätter en statisk ip på någon dator?

Jag har gått igenom switchen och allt är mycket riktigt avslaget dvs att den verkar agera precis som vilken "död" switch som helst så länge man själv inte gör någon modifikation.
Tack vara dina och alla andras tips tror jag mig nu ha hittat felet! Du hade helt rätt att det inte var fel på dhcp som jag trodde. Statisk ip fungerade inte heller nämligen. När jag kollade i loggen på switchen såg jag att den berörda porten kopplade upp och sen ifrån direkt igen var 5e sekund. Skall även nämna att när jag bypassade switchen fick jag inte mer än 100Mbps uppkoppling trots att alla enheter skall klara 1000Mbps... Enligt min kabeltestare är kabeln hel. Enligt "kabeltestaren" i switchen är Par A och D 22m och B och C 77m... Jag testade därför att tvinga ner hastigheten på den porten i switchen från auto till 100 och vips så fungerar allt perfekt!!! Jag har helt enkelt en inte trasig men dålig kabel. Blir till att göra om termineringarna, alternativt dra en helt ny!

Tack än en gång för all hjälp!!