Permalänk
Medlem

Fel IP i spel - HamachiLAN

Hejsan!

Jag och mina kompisar plockade upp gamla goa C&C Generals Zero Hour häromdan, alla köpte complete collection på Origin

Först funkade det helt utan problem! Hamachi strular ju självklart ibland och man får starta om servicen -.-

Men sen fick en av mina kompisar problem, problemet är att hans spel använder sig av hans lokala ip: "192.168.0.1" istället för hamachi IP:n.

Försöker ställa om nätverksadapterprioriteringar under nätverksanslutningar för att spelet ska använda sig av Hamachi-IP istället men det verkar som att detta inte finns i Windows 10?!

Hittar bara providerordning under avancerade inställningar.

Någon som vet hur man kan fixa detta på annat sätt då Windows 10 skummar sig?

Tack på förhand!!

Permalänk
Inaktiv

"Vanliga" kontrollpanelen finns ju kvar i Windows 10, Windows+X -> Control panel

Permalänk
Medlem
Skrivet av studiox_swe:

"Vanliga" kontrollpanelen finns ju kvar i Windows 10, Windows+X -> Control panel

Tack för svar. Problemet kvarstår dock om man går in via den kontrollpanelen ändå :/ Finns fortfarande bara providerordning.....

Permalänk
Medlem

Testa ändra Metric på Hamachis nätverksadapter:

Control panel -> Network and internet -> Network and Sharing Center -> Change adapter settings

Högerklicka på Hamachis adapter -> Properties -> IPv4 -> Advanced -> Avbocka "Automatic Metric" -> Ändra till valfritt nummer.

Underligt nog verkar ett högre metric-nummer betyda högre prioritet (trodde lägre nummer = högre prio, av vad jag hittar på google så ska lägre metric = högre prio) men när jag testar mellan mitt trådlösa och trådbundna så prioriteras wifin över sladd ifall wifi-adaptern har högre metric (satte sladd = 10, Wifi = 20, vilket gör att wifin prioriteras enligt speedtests).

Här får ni testa er fram helt enkelt, för mig så är högre metric = högre prio...
Använd dock inte Metric = 1. Bäst är väl att köra på 10, 20, 30, etc.
1 verkar användas för någon slags "loopback", vad det nu betyder.

Nätverk är inte mitt område, men det funkar för mig i Windows 10.

Glöm inte att sätta manuell metric på samtliga adaptrar så det blir rätt prio.

EDIT:

Efter flera tester så visar det sig att det var som jag trodde.
Lägre metric = högre prio.

Permalänk
Medlem
Skrivet av apamedvapen:

Testa ändra Metric på Hamachis nätverksadapter:

Control panel -> Network and internet -> Network and Sharing Center -> Change adapter settings

Högerklicka på Hamachis adapter -> Properties -> IPv4 -> Advanced -> Avbocka "Automatic Metric" -> Ändra till valfritt nummer.

Underligt nog verkar ett högre metric-nummer betyda högre prioritet (trodde lägre nummer = högre prio, av vad jag hittar på google så ska lägre metric = högre prio) men när jag testar mellan mitt trådlösa och trådbundna så prioriteras wifin över sladd ifall wifi-adaptern har högre metric (satte sladd = 10, Wifi = 20, vilket gör att wifin prioriteras enligt speedtests).

Här får ni testa er fram helt enkelt, för mig så är högre metric = högre prio...
Använd dock inte Metric = 1. Bäst är väl att köra på 10, 20, 30, etc.
1 verkar användas för någon slags "loopback", vad det nu betyder.

Nätverk är inte mitt område, men det funkar för mig i Windows 10.

Glöm inte att sätta manuell metric på samtliga adaptrar så det blir rätt prio.

EDIT:

Efter flera tester så visar det sig att det var som jag trodde.
Lägre metric = högre prio.

Hade satt på 1 först, vilket verkar vara loopback, men när jag googlat förut så har jag hittat guider om hur man LANar spel med Hamachi och då står det att man ska sätta den på 1 för allra högsta prio. Nu satte jag 10 på Hamachi och 20 på lokala. Han har dock fortfarande 192.168.0.8 IP i spelet. Det lokala IP:t som för mig är hamachi IP.

Försökte binda spelet med en viss adapter med hjälp av BindIP-programmet. Lyckades inte få kommandot att funka i CMD dock.

Så problemet kvarstår :< Förstår inte att Microsoft kan missa en sån sak i nätverksinställningarna? Vilket de verkar ha gjort?

Permalänk
Medlem
Skrivet av Funkish:

Hade satt på 1 först, vilket verkar vara loopback, men när jag googlat förut så har jag hittat guider om hur man LANar spel med Hamachi och då står det att man ska sätta den på 1 för allra högsta prio. Nu satte jag 10 på Hamachi och 20 på lokala. Han har dock fortfarande 192.168.0.8 IP i spelet. Det lokala IP:t som för mig är hamachi IP.

Försökte binda spelet med en viss adapter med hjälp av BindIP-programmet. Lyckades inte få kommandot att funka i CMD dock.

Så problemet kvarstår :< Förstår inte att Microsoft kan missa en sån sak i nätverksinställningarna? Vilket de verkar ha gjort?

Ah, vad synd
Önskar att jag kunde hjälpa mer men min saknar tyvärr kunskap.

Ett trick jag vet som har fungerat förut iallafall (tror senast jag gjorde detta var i Windows XP så det kanske inte funkar längre) är att man deaktiverar samtliga nätverksadaptrar förutom Hamachi, sedan startar man spelet. När spelet är igång minimerar man det och aktiverar alla adaptrar igen.
Eftersom Hamachis adapter var den enda aktiverade så väljer spelet att försöka ansluta via Hamachis adapter (dock utan nätverk, tills dess att man aktiverar alla adaptrar igen).
Det är värt att testa iallafall om ingen kommer med en riktig lösning

Permalänk
Medlem
Skrivet av apamedvapen:

Ah, vad synd
Önskar att jag kunde hjälpa mer men min saknar tyvärr kunskap.

Ett trick jag vet som har fungerat förut iallafall (tror senast jag gjorde detta var i Windows XP så det kanske inte funkar längre) är att man deaktiverar samtliga nätverksadaptrar förutom Hamachi, sedan startar man spelet. När spelet är igång minimerar man det och aktiverar alla adaptrar igen.
Eftersom Hamachis adapter var den enda aktiverade så väljer spelet att försöka ansluta via Hamachis adapter (dock utan nätverk, tills dess att man aktiverar alla adaptrar igen).
Det är värt att testa iallafall om ingen kommer med en riktig lösning

Tack för försöket!

Gör det du säger och får 127.0.0.1 när jag ska ha 25.50.87.131?? Men sen när jag aktiverar den vanliga adaptern så byter spelet till 192.168.0.8 igen även fast det är på när man aktiverar den.

Permalänk
Inaktiv
Skrivet av Funkish:

Tack för svar. Problemet kvarstår dock om man går in via den kontrollpanelen ändå :/ Finns fortfarande bara providerordning.....

Kollade precis, jag utgick från att det såg likadant ut (då network i kontrollpanelen inte ser ut att ha ändrats) - men du har helt rätt "Adapters and Bindings" finns inte i Windows 10 - jävla idioter att ändra saker som det inte finns någon som helst anledning till att ändra....