Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004

Ingen meny med Grub

Har bestämt mig för att installera Arch på en ny SSD efter en tids testande i VirtualBox, och behöver lite hjälp med Grub.

Jag har formaterat SSD:n med GPT och partitioner för /, /boot, /swap och /home, inga konstigheter där, /boot är FAT32.
Installerar grub med UEFI-stöd, har ett AsRock Z77 Extreme 4-moderkort som stöder det.

Problemet jag har är att när jag installerat grub:
grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub

och skapat config:
grub-mkconfig -o /boot/grub/grub.cfg

och sedan startar om datorn så kommer jag bara till en Grub 2.02 prompt/CLI, dvs inga OS att välja bland.
Installationen av Grub i sig verkar dock vara OK, då jag får en ny post i moderkortets Boot-meny där jag kan välja "Grub" efter installationen, och kommer då till prompten som sagt.

Vad är det jag behöver göra för att få Grub att fatta var min Arch-installation är? Jag har provat flytta grub.cfg till olika platser i /boot enligt en del tips som jag googlat fram, men jag får inte till det.

Hoppas att någon har lite tips att dela med sig av.

Trädvy Permalänk
Medlem
Plats
Strängnäs
Registrerad
Okt 2012

@Cinder Har själv inte testat Arch med UEFI än 😉 men har du läst detta ifrån deras wiki?
https://wiki.archlinux.org/index.php/GRUB/EFI_examples

Skickades från m.sweclockers.com

Chassi: FD Arc mini R2 | PSU: CM700V | MB: Asus Maximus V Gene Z77 | CPU: I5-3570K | RAM: 16GB Corsair LP | GPU: MSI Radeon RX580 Armor 8GB | SSD: Crucial MX300 750GB | Input: CM Quick Fire TK, Roccat Kone Pure Optical, Steam Controller | OS: Kubuntu 18.04 LTS & KDE Neon User Edition

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004
Skrivet av Lembritt:

@Cinder Har själv inte testat Arch med UEFI än 😉 men har du läst detta ifrån deras wiki?
https://wiki.archlinux.org/index.php/GRUB/EFI_examples

Ja jag hittade den där också, och testade göra som dom beskriver, men fick aldrig "Launch EFI Shell From Filesystem Device" att fungera, säger bara "Not found". Måste nog testa detta en gång till för att se om jag gjorde nåt fel.

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

@Cinder: Jag kör Arch Linux i EFI-mode och dina kommandon ser ut att stämma för att installera bootloadern.

Har du stängt av Secure Boot i UEFI på moderkortet? Samt snabbstart bör vara disablat också. Delete alla secure boot keys och chroot in i Arch Live CD och mounta / och /boot och installera om bootloadern med samma kommandon. Gör en output av lsblk och visa hur det ser ut för dig.

i7
GTX
4K

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010

@Lembritt: hehe, kollade på den häromdagen, och den är lite rörig tycker jag Brukar vara rätt straight forward, även vid dual boot med Win

Gör inte mitt misstag och formatera boot om windows finns installerat. Det räcker att mounta efi-partitionen

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010

När du kör "grub-mkconfig" borde programmet skriva ut vilka operativsystem som hittas, något i denna stil:

root # grub-mkconfig -o /boot/grub/grub.cfg Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.9 done

Står det inte "Found linux image" så kommer det inte synas något menyalternativ GRUB.

Jag antar att du följt https://wiki.archlinux.org/index.php/GRUB#UEFI_systems?
Väldigt viktigt är att du startar installationen via UEFI, annars blir det inte rätt.

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av ToJa92:

När du kör "grub-mkconfig" borde programmet skriva ut vilka operativsystem som hittas, något i denna stil:

root # grub-mkconfig -o /boot/grub/grub.cfg Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.9 done

Står det inte "Found linux image" så kommer det inte synas något menyalternativ GRUB.

Jag antar att du följt https://wiki.archlinux.org/index.php/GRUB#UEFI_systems?
Väldigt viktigt är att du startar installationen via UEFI, annars blir det inte rätt.

Gäller det där EFI-mode också?

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004
Skrivet av Dockland:

@Cinder: Jag kör Arch Linux i EFI-mode och dina kommandon ser ut att stämma för att installera bootloadern.

Har du stängt av Secure Boot i UEFI på moderkortet? Samt snabbstart bör vara disablat också. Delete alla secure boot keys och chroot in i Arch Live CD och mounta / och /boot och installera om bootloadern med samma kommandon. Gör en output av lsblk och visa hur det ser ut för dig.

Secure Boot är avslaget, Fast Boot också. Hur raderar man alla secure boot keys? Har inte satt några lösenord, så tror dock inte att det finns några. Återkommer med lsblk, men det ska vara:

/dev/sda1 = /boot
/dev/sda2 = swapon
/dev/sda3 = /
/dev/sda4 = /home

Skrivet av ToJa92:

När du kör "grub-mkconfig" borde programmet skriva ut vilka operativsystem som hittas, något i denna stil:

root # grub-mkconfig -o /boot/grub/grub.cfg Generating grub.cfg ... Found linux image: /boot/vmlinuz-3.2.9 done

Står det inte "Found linux image" så kommer det inte synas något menyalternativ GRUB.

Jag antar att du följt https://wiki.archlinux.org/index.php/GRUB#UEFI_systems?
Väldigt viktigt är att du startar installationen via UEFI, annars blir det inte rätt.

Det har inte stått "Found linux image" en enda gång när jag kört grub-install. Då kör jag ju grub-install inifrån arch-chroot för min installation, så det känns ju mycket märkligt.

På ArchWiki står det:
"If GRUB loads but drops you into the rescue shell with no errors, it may be because of a missing or misplaced grub.cfg. This will happen if GRUB UEFI was installed with --boot-directory and grub.cfg is missing OR if the partition number of the boot partition changed (which is hard-coded into the grubx64.efi file)."
Jag har ju installerat med --efi-directory men gissar att detsamma gäller. Var exakt ska grub.cfg hamna egentligen?
Den ligger nu i /boot/grub/grub.cfg

Jag har partitionerad med GParted, men /boot ska vara FAT32, med boot och eps-flaggor så jag vet inte om något skulle vara galet där..

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Cinder:

Secure Boot är avslaget, Fast Boot också. Hur raderar man alla secure boot keys? Har inte satt några lösenord, så tror dock inte att det finns några. Återkommer med lsblk, men det ska vara:

/dev/sda1 = /boot
/dev/sda2 = swapon
/dev/sda3 = /
/dev/sda4 = /home

Det har inte stått "Found linux image" en enda gång när jag kört grub-install. Då kör jag ju grub-install inifrån arch-chroot för min installation, så det känns ju mycket märkligt.

På ArchWiki står det:
"If GRUB loads but drops you into the rescue shell with no errors, it may be because of a missing or misplaced grub.cfg. This will happen if GRUB UEFI was installed with --boot-directory and grub.cfg is missing OR if the partition number of the boot partition changed (which is hard-coded into the grubx64.efi file)."
Jag har ju installerat med --efi-directory men gissar att detsamma gäller. Var exakt ska grub.cfg hamna egentligen?
Den ligger nu i /boot/grub/grub.cfg

Jag har partitionerad med GParted, men /boot ska vara FAT32, med boot och eps-flaggor så jag vet inte om något skulle vara galet där..

Jag brukar köra ungefär såhär, inte helt komplett kanske

loadkeys sv-latin1

lsblk

nvme0n1 259:0 0 119.2G 0 disk
nvme0n1p1 259:1 0 512M 0 part
nvme0n1p2 259:2 0 8G 0 part
nvme0n1p3 259:3 0 110.8G 0 part

mkfs.fat -F32 /dev/nvme0n1p1

mkswap /dev/nvme0n1p2
swapon /dev/nvme0n1p2

mkfs.ext4 /dev/nvme0n1p3

mount /dev/nvme0n1p3 /mnt
UUID=cff2fc9f-c8ad-4f9a-95b0-83ba9addc06

# mkdir /mnt/boot
# mount /dev/nvme0n1p1 /mnt/boot

nano /etc/pacman.d/mirrorlist

pacstrap /mnt base base-devel

genfstab -U /mnt >> /mnt/etc/fstab

Så kollar jag att det ser ok ut i fstab

arch-chroot /mnt

ln -sf /usr/share/zoneinfo/Europe/Stockholm /etc/localtime

hwclock --systohc

nano -w /etc/locale.gen

Uncomment en_US.UTF-8 UTF-8

# locale-gen

nano -w /etc/locale.conf
LANG=en_US.UTF-8

nano -w /etc/vconsole.conf
KEYMAP=sv-latin1

nano -w /etc/hostname

nano -w /etc/hosts

mkinitcpio -p linux

pacman -S install intel-ucode

mount -t efivarfs efivarfs /sys/firmware/efi/efivars

bootctl install

nano -w /boot/loader/entries/arch.conf

title Arch Linux
linux /vmlinuz-linux
initrd /intel-ucode.img
initrd /initramfs-linux.img
options root=cff2fc9f-c8ad-4f9a-95b0-83ba9addc06 rw

passwd

useradd -m -G wheel,storage,input,audio,disk -s /bin/bash användarnamn
passwd användarnamn

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub

umount -R /mnt

sedan reboot

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004
Skrivet av Dockland:

Jag brukar köra ungefär såhär, inte helt komplett kanske

...

mkinitcpio -p linux

pacman -S install intel-ucode

mount -t efivarfs efivarfs /sys/firmware/efi/efivars

bootctl install

nano -w /boot/loader/entries/arch.conf

title Arch Linux
linux /vmlinuz-linux
initrd /intel-ucode.img
initrd /initramfs-linux.img
options root=cff2fc9f-c8ad-4f9a-95b0-83ba9addc06 rw

passwd

useradd -m -G wheel,storage,input,audio,disk -s /bin/bash användarnamn
passwd användarnamn

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub

umount -R /mnt

sedan reboot

mkinitcpio har jag inte kört nu, läste att man egentligen inte behöver göra det nånstans i wikin?
mount -t efivarfs efivarfs /sys/firmware/efi/efivars har jag inte heller kört - är det kritiskt för att detta ska funka?
Funderar på att testa köra bootctl istället och se om det skulle fungera bättre, är inte ett måste att för mig att ha grub som bootloader.

Annars ser allt som du gör identiskt ut med det jag har gjort.

Trädvy Permalänk
Medlem
Plats
Sturup
Registrerad
Jan 2007

Jag körde med systemd-boot sist jag körde arch och uefi, tyckte det var väldigt enkelt och smidigt jämfört med grub.
https://wiki.archlinux.org/index.php/Systemd-boot

Skickades från m.sweclockers.comj

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Cinder:

mkinitcpio har jag inte kört nu, läste att man egentligen inte behöver göra det nånstans i wikin?
mount -t efivarfs efivarfs /sys/firmware/efi/efivars har jag inte heller kört - är det kritiskt för att detta ska funka?
Funderar på att testa köra bootctl istället och se om det skulle fungera bättre, är inte ett måste att för mig att ha grub som bootloader.

Annars ser allt som du gör identiskt ut med det jag har gjort.

Kanske inte behövs, men det har alltid fungerat för mig

Mount -t gör jag alltid

E: Efter reboot installerar jag nvidiadrivisar som root. Sedan valfri DE, lightdm och konfar greeter under /etc/lightdm/lightdm.conf

[Seat:*] ... greeter-session=lightdm-yourgreeter-greeter

(saxat från Arch Linux Wiki)

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Aug 2010
Skrivet av Dockland:

Gäller det där EFI-mode också?

Ja, det ska det göra enligt wikin (följande står i början: "Unless specified as EFI 1.x, EFI and UEFI terms are used interchangeably to denote UEFI 2.x firmware."). Men om du med EFI menar Apples variant så finns detaljer i den här artikeln.

Du får gärna citera eller nämna mig (@ToJa92) om du svarar på något jag skrivit.

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004

Jag tror att jag har blandat ihop lite i mina mounts... har hela tiden mountat /dev/sda1 till /boot, när det i mina anteckningar står /mnt/boot
Det "kan" ju vara en orsak till problem... Insåg nyss att när jag kör arch-chroot och ls /boot så ligger vmlinuz-linux och initramfs mm där, men så fort jag mountar /dev/sda1 till /boot så ligger ju bara EFI och loader där.
Pacstrap installerar väl kanske också saker till fel ställe om jag mountar /dev/sda1 till /boot och inte /mnt/boot

Testade nämligen att installera bootctl, och det gav Error: vmlinuz-linux not found.

Här är min antecknade lista som jag går efter:

Disk Partitioning #Partition disk with GParted USB boot = 512Mb fat32 -set boot flag swap = 4096Mb linux-swap system = ext4 arch install home = ext4 user files Installing Arch Linux #set key map to swedish loadkeys sv-latin1 #mount file systems root: mount /dev/sdaX /mnt others: mkdir /mnt/boot mount /dev/sdaY /mnt/boot lsblk (check) #install arch base pacstrap /mnt base base-devel #generate fstab file (U = UUID, L = Labels) genfstab -L /mnt >> /mnt/etc/fstab #change root to new installation arch-chroot /mnt #set locale uncomment en_US and sv_SE in /etc/locale.gen locale-gen #create hostname file nano /etc/hostname -> arch #edit hosts nano /etc/hosts 127.0.1.1 arch.localdomain arch #set time zone ln -sf /usr/share/zoneinfo/Europe/Stockholm /etc/localtime timedatectl (check) hwclock --systohc Installing Bootloader #install bootloader (GRUB) pacman -S grub efibootmgr --noconfirm mount /dev/sda1 /boot grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub grub-mkconfig -o /boot/grub/grub.cfg #create fstab file genfstab /mnt >> /mnt/etc/fstab #reboot umount /mnt reboot

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Cinder:

Jag tror att jag har blandat ihop lite i mina mounts... har hela tiden mountat /dev/sda1 till /boot, när det i mina anteckningar står /mnt/boot
Det "kan" ju vara en orsak till problem... Insåg nyss att när jag kör arch-chroot och ls /boot så ligger vmlinuz-linux och initramfs mm där, men så fort jag mountar /dev/sda1 till /boot så ligger ju bara EFI och loader där.
Pacstrap installerar väl kanske också saker till fel ställe om jag mountar /dev/sda1 till /boot och inte /mnt/boot

Testade nämligen att installera bootctl, och det gav Error: vmlinuz-linux not found.

Här är min antecknade lista som jag går efter:

Disk Partitioning #Partition disk with GParted USB boot = 512Mb fat32 -set boot flag swap = 4096Mb linux-swap system = ext4 arch install home = ext4 user files Installing Arch Linux #set key map to swedish loadkeys sv-latin1 #mount file systems root: mount /dev/sdaX /mnt others: mkdir /mnt/boot mount /dev/sdaY /mnt/boot lsblk (check) #install arch base pacstrap /mnt base base-devel #generate fstab file (U = UUID, L = Labels) genfstab -L /mnt >> /mnt/etc/fstab #change root to new installation arch-chroot /mnt #set locale uncomment en_US and sv_SE in /etc/locale.gen locale-gen #create hostname file nano /etc/hostname -> arch #edit hosts nano /etc/hosts 127.0.1.1 arch.localdomain arch #set time zone ln -sf /usr/share/zoneinfo/Europe/Stockholm /etc/localtime timedatectl (check) hwclock --systohc Installing Bootloader #install bootloader (GRUB) pacman -S grub efibootmgr --noconfirm mount /dev/sda1 /boot grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub grub-mkconfig -o /boot/grub/grub.cfg #create fstab file genfstab /mnt >> /mnt/etc/fstab #reboot umount /mnt reboot

Ja, det kan vara det som är problemet.

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004

Nu har jag installerat bootctl och det verkar boota Arch, men det är fortfarande något som är galet med min installation.
Får detta felmeddelande direkt vid start av Arch, kommer inte till vanliga root-terminalen:

:: running early hook (udev) starting version 232 :: running hook (udev) :: Triggering uevents... :: performing fsck on '/dev/sda3' /dev/sda3: clean, 42626/1572864 files, 472341/6291456 blocks ::mounting '/dev/sda3' on real root [ 2.483166] EXT4-fs (sda3) Cannot load crc32c driver. mount: mount(2) failed: /new_root: No such file or directory You are now being dropped into an emergency shell. sh: can't access tty: job control turned off [rootfs]# _

Detta alltså från en helt nyformaterad disk enligt mitt tillvägagångssätt i post ovan. Vad är det som spökar??

EDIT: mkinitcpio spökade, la till "crc32c_generic" och "crc32c_intel" som moduler i /etc/mkinitcpio.conf och körde sen mkinitcpio -p linux så gick det att boota till Arch

Nu måste jag bara klura ut hur jag ska få nätverk att fungera, kan inte ens pinga google. Det är mycket mer som inte funkar "out of the box" nu jämfört med när jag körde i VirtualBox. Inte att fördömma dock, jag ser det hela som en lärorik utmaning, och snart är jag nog framme vid ett skrivbord

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001

Nu verkar det ha löst sig men för att göra det enklare, i mitt tycke i varje fall, om det uppstår framtida problem är att rensa /boot (avinstallera Grub först!). Sen bygger du kärnan med stöd för EFI-stub om den inte har det (vilket jag tror Arch-kärnan har) samt kernel command string "root=PARTUUID=[whatever du får fram med 'blkid']".

Se till att ha /boot mountad när du kör installationsscriptet för kärnan.

mkdir /boot/EFI/Boot/

cp /boot/vmlinuz-whatever-kärnan-heter.img /boot/EFI/Boot/vmlinuz.efi

Skit i bootloader och initramfs tills vidare. Du ska kunna boota direkt från BIOS. När det sen funkar, då kan du konfigurera de andra bitarna.

Beträffande nätverk måste du enable;a och starta systemd-networkd.service och systemd-resolved.service om du kör DHCP och vill ha din DNS den vägen.

Innan du gör det behöver du säga åt systemd att uppdatera resolv.conf genom en symlink:
ln -snf /run/systemd/resolve/resolv.conf /etc/resolv.conf

Testa även:

ip link set [nätverkskortets namn, t.ex. eno1] up

Prova pinga dig själv för att se att det funkar. Kan du pinga dig själv men inte www.google.com är det DNS-inställningarna det är fel på.

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004
Skrivet av DasIch:

Nu verkar det ha löst sig men för att göra det enklare, i mitt tycke i varje fall, om det uppstår framtida problem är att rensa /boot (avinstallera Grub först!). Sen bygger du kärnan med stöd för EFI-stub om den inte har det (vilket jag tror Arch-kärnan har) samt kernel command string "root=PARTUUID=[whatever du får fram med 'blkid']".

Skulle du kunna beskriva det här mer i detalj, har aldrig byggt nån kärna, och är du säker på att det egentligen behövs?
Om du förstår orsaken till mina problem får du gärna förklara, då det blev lite mer konfiguration med mkinitcpio än jag förväntade mig.

Skrivet av DasIch:

Se till att ha /boot mountad när du kör installationsscriptet för kärnan.

mkdir /boot/EFI/Boot/

cp /boot/vmlinuz-whatever-kärnan-heter.img /boot/EFI/Boot/vmlinuz.efi

Skit i bootloader och initramfs tills vidare. Du ska kunna boota direkt från BIOS. När det sen funkar, då kan du konfigurera de andra bitarna.

Beträffande nätverk måste du enable;a och starta systemd-networkd.service och systemd-resolved.service om du kör DHCP och vill ha din DNS den vägen.

Innan du gör det behöver du säga åt systemd att uppdatera resolv.conf genom en symlink:
ln -snf /run/systemd/resolve/resolv.conf /etc/resolv.conf

Testa även:

ip link set [nätverkskortets namn, t.ex. eno1] up

Prova pinga dig själv för att se att det funkar. Kan du pinga dig själv men inte www.google.com är det DNS-inställningarna det är fel på.

Ska testa dina förslag för att starta nätverket ikväll. Stort tack!

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001
Skrivet av Cinder:

Skulle du kunna beskriva det här mer i detalj, har aldrig byggt nån kärna, och är du säker på att det egentligen behövs?
Om du förstår orsaken till mina problem får du gärna förklara, då det blev lite mer konfiguration med mkinitcpio än jag förväntade mig.

Jag har inte gjort det för Arch, som har organiserat det lite annorlunda (och kluddigare i mitt tycke) än Gentoo, så jag får främst hänvisa till wikin där. Gentoo har det organiserat med symlinkar så du konfigurerar dina "kernel sources" i /usr/src/linux, vilket jag kan tycka är smidigt och inte borde vara nåt problem att ordna i Arch. Jag är dock inte helt säker på hur det ska göras korrekt. Så, Arch Wiki it is:
https://wiki.archlinux.org/index.php/Kernels/Traditional_comp...

Det är absolut inget som behöver göras. Kärnar konfigurerar du om du behöver lägga till någon funktion, eller om du av någon anledning vill banta ned den genom att ta bort onödiga saker.

Så länge du vet vad du ändrar är det dock inte så svårt. Poängen med mitt förslag är att börja med minimalt med saker som kan gå fel. På ett modernt moderkort med UEFI innebär det att du bara behöver kärnan för att boota. Därefter är det bara lägga till saker du vill ha, som en bootloader.

Processen är i princip:

Installera nödvändiga verktyg (base-devel paketet)
Skapa en katalog för "kernel sources"
Ladda ned och packa upp
"Städa upp" kernel tree
Generera en default Arch-config (så du utgår ifrån konfigurationen du redan har)
Konfigurera med de ändringar du vill ha
Kompilera och installera moduler (make && make modules_install)
Kopiera (och byt namn till vmlinuz-nånting) till /boot
Slutligen gör du som jag föreslog och gör en kopia av vmlinuz-nåting som du döper om till *.efi och lägger i /boot/EFI/Boot (osäker om detta är case sensitive, men det är så det heter här och vissa UEFI är kinkiga med i vilken katalog *.efi ligger).

Men som sagt, kolla wikin.

Orsaken till dina problem ser ut att vara att du mountat /boot fel. När du installerat har kärnan lagts i filsystemet på din root-partition istället för din EFI-partition. Grub säger i sin tur inte ifrån att det blivit fel, eftersom den hittat filerna i en katalog som heter /boot (där din EFI-partition borde varit mountad).

Om jag förstått dig rätt har du nu lagt sakerna på rätt ställe och då funkar det. Så, mitt förslag är absolut inte nödvändigt. Det är mest ett bra sätt att börja felsöka när man kliar sig i huvudet och undrar varför i helskotta burken inte vill boota.

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004

Nu har jag pillat vidare och fick som sagt Bootctl att fungera bra med Arch, men med mycket pill har jag även lyckats ha sönder något. Höll på att fixa med xorg och trodde att den hade hängt sig, så jag hård-resettade, men nu lyckas jag inte boota för att "PARTUUID: *mitt rootdisk-ID här* not found" (denna hittas av bootctl som bootar in i arch, men som jag fattar det hittas inte samma ID för mount).

Måste jag köra igenom hela proceduren med pacstrap osv för att laga detta, och skriver pacstrap över en massa inställningar? Eller går det på något enkelt sätt att laga boot-delen, med t.ex. mkinitcpio från live-USB igen?

Trädvy Permalänk
Avstängd
Plats
/home
Registrerad
Apr 2010
Skrivet av Cinder:

Nu har jag pillat vidare och fick som sagt Bootctl att fungera bra med Arch, men med mycket pill har jag även lyckats ha sönder något. Höll på att fixa med xorg och trodde att den hade hängt sig, så jag hård-resettade, men nu lyckas jag inte boota för att "PARTUUID: *mitt rootdisk-ID här* not found" (denna hittas av bootctl som bootar in i arch, men som jag fattar det hittas inte samma ID för mount).

Måste jag köra igenom hela proceduren med pacstrap osv för att laga detta, och skriver pacstrap över en massa inställningar? Eller går det på något enkelt sätt att laga boot-delen, med t.ex. mkinitcpio från live-USB igen?

Kolla med kommandot ls -lR /dev/disk/

Jämför ID med /etc/fstab för din /

i7
GTX
4K

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004
Skrivet av Dockland:

Kolla med kommandot ls -lR /dev/disk/

Jämför ID med /etc/fstab för din /

PARTUUID verkar stämma överens mellan dom två.. :/

Trädvy Permalänk
Hedersmedlem
Plats
Stockholm
Registrerad
Aug 2001

Är du säker på att "PARTUUID=XXX not found" är din rootdisk? Hur ser din fstab ut - vad har du för enheter specade där? Har du andra OS och/eller filsystem på datorn?

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Jan 2004
Skrivet av DasIch:

Är du säker på att "PARTUUID=XXX not found" är din rootdisk? Hur ser din fstab ut - vad har du för enheter specade där? Har du andra OS och/eller filsystem på datorn?

Ja det var den, men det verkade som att linux kernel hade fått tuppjuck, mkinitcpio gav en massa fel.
Installerade pacman -S linux och gjorde en ny mkinitcpio -p linux så funkade det att boota igen.