Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Hur mycket cpu kraft går åt när man tittar på 4K video på en intel i7-9700K? (eller ungefär samma cpu)

Trädvy Permalänk
Datavetare
Plats
Stockholm
Registrerad
Jun 2011

Har man en Intel CPU med iGPU och installerar drivarna för den så det går att använda Quick Sync tar det nästan ingen CPU-kraft alls att avkoda film.

4k YouTube klipp avkodas med minimal CPU-belastning trots att CPUn är klockad till endast 1,38 GHz och endast har två kärnor (är en Surface Pro 4 med en i7-6650U)

Det är möjligt att använda Quick Sync även om man har en dGPU!

Care About Your Craft: Why spend your life developing software unless you care about doing it well? - The Pragmatic Programmer

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Feb 2002
Skrivet av Yoshman:

Har man en Intel CPU med iGPU och installerar drivarna för den så det går att använda Quick Sync tar det nästan ingen CPU-kraft alls att avkoda film.

4k YouTube klipp avkodas med minimal CPU-belastning trots att CPUn är klockad till endast 1,38 GHz och endast har två kärnor (är en Surface Pro 4 med en i7-6650U)
https://i.imgur.com/fEPSCjd.png

Det är möjligt att använda Quick Sync även om man har en dGPU!

klippet är inte pausat där? nyfiken på vilket länk du spelade upp där, för min datorn klarar inte alls av detta.(utan gpu)

har du installerat / gjort något speciellt ?

Trädvy Permalänk
Datavetare
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av Disney:

klippet är inte pausat där? nyfiken på vilket länk du spelade upp där, för min datorn klarar inte alls av detta.(utan gpu)

har du installerat / gjort något speciellt ?

Det är inte pausat, men notera att jag kör med Edge. Inte helt säker på att Chrome använder QuickSync, om den gör det så ska du se att videoavkodningsmätaren ska ha >0 % last.

Om jag inte missminner mig är det detta klipp jag körde där

Edit: kör jag samma klipp på Firefox under Ubuntu, där QuickSync tyvärr inte används, är CPU-delen väsentligt mer lastad men ändå långt ifrån att slå i taket. I detta fall är datorn en Dell Latitude med i7-8665U (CPU-last 17 %, men notera att Linux sätter 100 % till att alla CPU-trådar är lastad medan Windows sätter 100 % till att en CPU tråd är lastad fullt ut)

Care About Your Craft: Why spend your life developing software unless you care about doing it well? - The Pragmatic Programmer

Trädvy Permalänk
Medlem
Plats
Göteborg
Registrerad
Maj 2002
Skrivet av Yoshman:

Det är inte pausat, men notera att jag kör med Edge. Inte helt säker på att Chrome använder QuickSync, om den gör det så ska du se att videoavkodningsmätaren ska ha >0 % last.

Det ser ju pausat ut eftersom man kan se "Play Knappen" på videon, den visas ju bara när videon inte är igång. Medans den spelar så ser man ist paus symbolen.

Intel Core i9-9900K @5100Mhz core, 4900Mhz Uncore // Corsair Hydro H100i RGB Platinum // Corsair Vengence RGB PRO DDR4 3200MHz 32GB // Gigabyte GeForce RTX 2060 Super Windforce OC 8g // Gigabyte Z390 Aorus Pro // PSU: Corsair RM750W v2 // Chassi: Lian Li PC-O11 Dynamic // Keyboard: Corsair K70 RGB MK2 Low Profile // Mouse: Corsair Dark Core RGB with the MM1000 QI mousepad //

Trädvy Permalänk
Datavetare
Plats
Stockholm
Registrerad
Jun 2011
Skrivet av knaz:

Det ser ju pausat ut eftersom man kan se "Play Knappen" på videon, den visas ju bara när videon inte är igång. Medans den spelar så ser man ist paus symbolen.

Det kan jag hålla med om, ser märkligt ut

Fast om videon inte spelade skulle GPU-avkodningsdelen aldrig kunna ha en last då den inte används för annat än just avkoda film.

Edit:
Det står faktiskt "avkodning 0 %" så undrar om det blev ett klick, är ju 3s mellanrum från man klickar "ta skärmdump" till att den tas i "klipp&skissa" programet.

Så du fick mig att tvivla på min egen mätning, gjorde två till. CPU-frekvens hoppar lite fram och tillbaka men det är generellt väldigt låg CPU-last och fläktarna står still.

Samma video uppspelad med Firefox, notera att "Video Decode" nu är 0 % samtidigt som CPU är långt mer belastad.

Dock orkar en i7-6650U avkoda filen ändå, det på en 2736x1824 skärm.

Care About Your Craft: Why spend your life developing software unless you care about doing it well? - The Pragmatic Programmer

Trädvy Permalänk
Medlem
Plats
Luleå
Registrerad
Feb 2002
Skrivet av Yoshman:

Det kan jag hålla med om, ser märkligt ut

Fast om videon inte spelade skulle GPU-avkodningsdelen aldrig kunna ha en last då den inte används för annat än just avkoda film.

Edit:
Det står faktiskt "avkodning 0 %" så undrar om det blev ett klick, är ju 3s mellanrum från man klickar "ta skärmdump" till att den tas i "klipp&skissa" programet.

Så du fick mig att tvivla på min egen mätning, gjorde två till. CPU-frekvens hoppar lite fram och tillbaka men det är generellt väldigt låg CPU-last och fläktarna står still.
https://i.imgur.com/nls1LSO.png
https://i.imgur.com/6mz0lxj.png

Samma video uppspelad med Firefox, notera att "Video Decode" nu är 0 % samtidigt som CPU är långt mer belastad.
https://i.imgur.com/B0j8wnN.jpg
Dock orkar en i7-6650U avkoda filen ändå, det på en 2736x1824 skärm.

kör windows 10, 8086k + titan XP + Chrome =>

har två till datorer, men hur vet man att vi får samma "kvalitet" / Hz / pixlar?
på tv datorn har jag 4k projektor, dock såg jag ingen skillnad när jag drog bilden från min 1440p till 1080p skärm. dubbla skärmar kan ju belastat mitt test?

ps. hur stabilt är youtube egentligen?

edit:
testade edge = 20-40% & laggar tom

edit