Vill du vara del av diskussionerna i forumet, ställa frågor eller hjälpa andra? Registrera dig här!

Försöker få till anslutning mellan Windows och Linux genom SSH

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008

Försöker få till anslutning mellan Windows och Linux genom SSH

Försökt med nästan allt, gått igen flera tutorials för få fungerande SSh koppling.

Linux servern (Ubuntu 20.04) är placerad utanför lan.

Vi har öppnat massa portar och sett till så SSH är installerat. Får bara upp att windows inte hittar någon anslutning.

Något gör man fel, men frågan är vad. Är lite för dåligt insatt känner jag runt nätverk. Men antar jag måste på något vis lägga till datorn som ska ansluta till Linux ?

Även testat både lägga in regler och stänga av brandväggen (bara för testa).

Tittat på dessa
https://johan.driessen.se/posts/Setting-up-an-SSH-tunnel-to-a...
https://phoenixnap.com/kb/ssh-to-connect-to-remote-server-lin...
http://ubuntuhandbook.org/index.php/2013/08/connect-to-ubuntu...

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Registrerad
Mar 2014

Står datorn med ubuntu bakom en router? Har du isåfall öppnat portarna i denna router?

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av Hejss:

Står datorn med ubuntu bakom en router? Har du isåfall öppnat portarna i denna router?

ja, 22,3389 upt och tpc

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008

När jag kör sudo service ssh status, så i loggen så fick jag tydligen tidigare Did not receive identification string from "mitt ip jag försökte ansluta med"

Men får inte upp något nytt där nu.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Registrerad
Mar 2014

Kolla på ubuntumaskinen att du kan ssh:a localhost för att verifiera att tjänsten är igång, om det funkar låter det som att någon regel hindrar dig från att ansluta

Kolla även detta svar https://superuser.com/a/1084108

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av Hejss:

Kolla på ubuntumaskinen att du kan ssh:a localhost för att verifiera att tjänsten är igång, om det funkar låter det som att någon regel hindrar dig från att ansluta

ja det fungerar.

Gav inte så mycket för mig, kan inte i routern ge mer än lokala ip adresser, men ska testa vidare med brandväggen.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
Ankeborg
Registrerad
Feb 2002

>ssh -vvv iptillanfraburken

Med vvv får du ut mer info så du kan se vad som händer när du försöker ansluta.

RedHat <3 CentOS <3 OpenSuse <3 FreeBSD

Trädvy Permalänk
Medlem
Registrerad
Jan 2003

Finns det ett publikt IP på routern där Linux-servern står? Är ju rätt vanligt med CG-NAT idag.

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av DuckMuck:

>ssh -vvv iptillanfraburken

Med vvv får du ut mer info så du kan se vad som händer när du försöker ansluta.

Från linux? För det är windows som ska ansluta till linux servern (kan ju starta en dist för att testa).

Skrivet av breakman:

Finns det ett publikt IP på routern där Linux-servern står? Är ju rätt vanligt med CG-NAT idag.

Ja, den står på privat internetabb, inte i riktig serverhall.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
Linköping
Registrerad
Jun 2007
Skrivet av Broken-arrow:

Ja, den står på privat internetabb, inte i riktig serverhall.

Att du har ett privat abonnemang säger ingenting om CG-NAT används eller ej. Ett sätt att testa är att jämföra vad routern som datorn du försöker ansluta till är ansluten till säger att den har för IP och vad t.ex. whatsmyip säger från samma dator, är de olika så har du ej en publik IP utan sitter bakom CG-NAT.

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av perost:

Att du har ett privat abonnemang säger ingenting om CG-NAT används eller ej. Ett sätt att testa är att jämföra vad routern som datorn du försöker ansluta till är ansluten till säger att den har för IP och vad t.ex. whatsmyip säger från samma dator, är de olika så har du ej en publik IP utan sitter bakom CG-NAT.

Har inte riktigt koll, vad ipser hittar på. Vi har en test spelserver och där funkar IP hyfsat fast är annan dator med windows 7 på samma nät som linux datorn och bakom samma router(lite svårt att få kontakt alltid, kan vara spelservern en omstart så får man kontakt igen).

Men hur löser man det om det ligger bakom en CG-NAT?

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
Sundets Pärla?
Registrerad
Okt 2007

@Broken-arrow:

Vid CG-NAt:

Kontakta din ISP och begär publik IP.

Har man Bahnhof som ISP så skall det vara möjligt att få public IP om man går till dhcp.bahnhof.se . Har Bahnhof men i mitt nät är CG NAT inte standard.

Bara för att klargöra: Är windowsmaskinen och linuxmaskinen bakom samma router eller är de bakom varsin router?

Celeron 300A @ 450MHz

Trädvy Permalänk
Medlem
Registrerad
Aug 2016

Du får gå till din ISP/internetleverantör och begära publik IP-adress - ibland kan det göras på en hemsida och IP blir då låst till en MAC-adress - oftast din routers och då är det bara nätet på insidan på din router som kan prata ut på routerns IP-adress och vidare ut. Ofta är det bara en adress som ingår i abonnemanget

Den givna ipadressen (som kan var helt annat än innan) så kolla med tex. nämnda 'whatsmyip' och sedan kan du prova med nmap ifall dina önskade portar är öppnade.

typisk CG-NAT är om man kör programmet 'nmap' mot adressen i fråga (som du ser med 'whatsmyip' provad strax innan) är att det är noll portar öppna oavsett vad du ställt in din router med och allmänt informationsfattigt - det är halt som teflon och inget man kan fastna på sas.

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av mayo:

@Broken-arrow:

Vid CG-NAt:

Kontakta din ISP och begär publik IP.

Har man Bahnhof som ISP så skall det vara möjligt att få public IP om man går till dhcp.bahnhof.se . Har Bahnhof men i mitt nät är CG NAT inte standard.

Bara för att klargöra: Är windowsmaskinen och linuxmaskinen bakom samma router eller är de bakom varsin router?

ja och jag försöker med annan windows dator på annat ips nät ansluta till linux maskinen, windows datorn bakom samma router som linuxmaskinen går att ansluta till (används då andra portar än vad SSH använder).

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
Umeå
Registrerad
Feb 2010

Ett första steg är då att kolla om du ens har CG-NAT. Logga in i din router och kolla vilken IP-adress den får från din leverantör, kolla därefter på typ whatsmyip.com från en dator bakom routern om det är samma IP som du just såg.

Lian Li PC-O11 Dynamic | Asus ROG STRIX Z370-F | Intel Core i7 8700k | 32GB@3000MHz | MSI RTX 2080 Ti Gaming X Trio | MX100 512GB & Samsung QVO 1TB | RM750x v2

Trädvy Permalänk
Medlem
Registrerad
Mar 2018
Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jun 2011
Skrivet av Broken-arrow:

Har inte riktigt koll, vad ipser hittar på. Vi har en test spelserver och där funkar IP hyfsat fast är annan dator med windows 7 på samma nät som linux datorn och bakom samma router(lite svårt att få kontakt alltid, kan vara spelservern en omstart så får man kontakt igen).

Men hur löser man det om det ligger bakom en CG-NAT?

Om det funkar att ansluta till spelservern, så kanske det är så att du försöker ssh:a till spelservern också. Alltså att routern skickar all trafik till spelservern?
Isf är det i routern där linuxmaskinen och spelservern står du behöver konfigurera

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av macmann1:

Ett första steg är då att kolla om du ens har CG-NAT. Logga in i din router och kolla vilken IP-adress den får från din leverantör, kolla därefter på typ whatsmyip.com från en dator bakom routern om det är samma IP som du just såg.

Nej inget CG-NAT, när jag kollar routern och hemsidan (whatsmyip.com).

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av Hothep:

Om det funkar att ansluta till spelservern, så kanske det är så att du försöker ssh:a till spelservern också. Alltså att routern skickar all trafik till spelservern?
Isf är det i routern där linuxmaskinen och spelservern står du behöver konfigurera

Selservern är avstängd, den varit igång när vi ska testa saker endast (en Minecraft server), på vanlig windows 7 dator.

Linux datorn har det öppnas portar till den datorn, kan ju kolla så rätt lokalt ip används.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008

Vi hade fått lite buggar med linux (när vi fick upp terminalen gick det inte komma ur) och gjorde ominstallation.

Verkar funka nu, men på windows datorn med fjärranslutning får jag protokollfel upptäcktes hos klienten .

Testade på linux ubantu (virtuellt då) står The authenticity "host ip" can´t established. ECDSA key fingerprint is "långt nummer" sen frågar den om du verkligen vill ansluta.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008

Okej går att få respons från Linuxdatorn nu, men fått annat problem att den inte tar användarnamn och lösenord (säger det är invalid i logen). Användare skapad i linux Ubuntu på den datorn.

Har inte helt koll hur man kör ssh kommandot i terminalen. Men kört ssh "användarnamnet på konto jag har på andra datorn"@"ip på den datorn" (är på maskin som ligger utanför lan, alltså på annan IP som jag försöker ansluta till denna ssh host).

Fixat detta i settings
PermitRootLogin yes
PasswordAuthentication yes
UseLogin yes
RSAAuthentication no
PubkeyAuthentication no

Windows funkar det inte att ansluta, något protokollfel. Har PuTTY.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
Uppsala
Registrerad
Jun 2011

om du precis har ändrat din ssh-conf så måste du starta om tjänsten. (systemctl restart ssh)
Sen vill jag bara säga att det kommer vara folk som försöker ta sig in på din server inom kort så hoppas du har ett "bra lösenord"

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av Hothep:

om du precis har ändrat din ssh-conf så måste du starta om tjänsten. (systemctl restart ssh)
Sen vill jag bara säga att det kommer vara folk som försöker ta sig in på din server inom kort så hoppas du har ett "bra lösenord"

Nja halvbra, är någon okänd IP som försökt redan. Var snarare så linux döljer det riktiga namnet (står inte under user och hjälper inte ens ändra det). utan den gör namnet med små bokstäver, så den som ansluter måste ha rätt namn och lösenord annars funkar det inte

Vi får se om vi kan använda annan port ansluta till routern och sen vidare till rätt port (lär dock behöva någon mer avancerad router än vad man brukar ha hemma). Sen sätta brandväggen att bara ta emot vissa ip.

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av Broken-arrow:

Nja halvbra, är någon okänd IP som försökt redan. Var snarare så linux döljer det riktiga namnet (står inte under user och hjälper inte ens ändra det). utan den gör namnet med små bokstäver, så den som ansluter måste ha rätt namn och lösenord annars funkar det inte

Vi får se om vi kan använda annan port ansluta till routern och sen vidare till rätt port (lär dock behöva någon mer avancerad router än vad man brukar ha hemma). Sen sätta brandväggen att bara ta emot vissa ip.

Det är nog bäst att byta från standardporten 22 för SSH, är aldrig rekommenderat att köra på standardportar när det handlar om fjärrsystem kopplade mot Internet. Det gäller även för 3389 (RDP).
Du kan göra den ändringen i routern många gånger. t.ex. incoming port 12345 i Router -> ip.address.på.server via port 22. -Om nätverket där servern står är klassat som "säkert".

Annars kan det vara bäst att även byta port direkt på servern via:

sudo nano /etc/ssh/sshd_config

Editera raden som säger:

Port 22

och ändra till t.ex.

Port 12345

Tryck Ctrl+x, följt av "y" för att bekräfta att spara filen och sedan Enter för confirm overwrite.

Sedan bör du starta om SSH tjänsten likt någon redan hade nämnt i tråden:

systemctl restart ssh

För att därefter ansluta till en server som ej använder standardporten för SSH via kommandorad får man nu istället köra kommandot med -p parametern:

ssh -p 12345 anvandarnamn@ip.address.på.server

Där -p 12345 specar vilken annan port som skall användas för SSH.

Kan även rekommendera att installera och använda UFW (Uncomplicated FireWall) på Ubuntu som lokal brandvägg:

sudo apt install ufw -y

Därefter lägger du till regler för varje tjänst t.ex:

sudo ufw allow 22/tcp - (För standard SSH-port)

alternativt:

sudo ufw allow 12345/tcp - (Om du ändrat standard porten på servern för SSH)

sudo ufw allow 80/tcp
sudo ufw allow 443/tcp
etc...

Du kan även speca port-ranges enkelt via UFW:

sudo ufw allow 7100:7200/tcp -medför att port 7100 t.o.m. port 7200 tillåter anslutningar.

-Och därefter kör du:

sudo ufw enable
för att aktivera den lokala brandväggen. (du kan alltså confa regler osv. utan att att för den sakens skull behöva aktivera brandväggen, så se till att kolla så att allt annat fungerar fullt ut innan du aktiverar brandväggen, får du problem efter det så vet du att det var brandväggen som ställde till det och därmed bör du köra nedan kommando)

sudo ufw disable

för att stänga av den lokala brandväggen om det mot förmodan inte skulle fungera, kom ihåg att disable kommandot mest troligt måste utföras lokalt på servern, då brandväggen inte kommer att godkänna din fjärrsession om den är felkonfigurerad.

Är inte helsåld på settingen PermitRootLogin yes om jag skall vara ärlig.
Det låter väl mycket Windows-tänk där att man skall vara admin överallt och även logga in som det remote...
Normalt sett bör du logga in med non-standard user konto och sedan använda sudo eller sudo su kommando för att få root-rättigheter, tillfälligt.
Detta är ett bättre sätt då ett root konto alltid existerar på Linux-system, ungefär som ett Administratör-konto alltid finns på en Windows maskin som standard, det är således det första kontot som nät-bots försöker logga in via, därmed bättre om det inte tillåts alls, då måste bots även gissa rätt port+användarnamn(med sudo-rättigheter)+password.)

För att skapa en ny användare i Ubuntu kan du köra kommandot:

sudo useradd newuser

Fyll i uppgifterna som följer på skärmen.

Då skapas en ny användare: newuser
newuser har inga sudo-rättigheter som standard utan kan enbart logga in på systemet men har inte några administrativa inställningar eller häftigare rättigheter.

För att de ditt nyskapade newuser konto sudo-rättigheter kan du köra nedan kommando:

sudo usermod -a -G sudo newuser

Ovan kommando lägger till användaren newuser till -G (group) sudo.

Vill du se om det skett failade SSH-inloggningar mot ditt Linux-system kan du köra kommandot:

grep sshd.\*Failed /var/log/auth.log | less

Annars, det klart säkrare alternativet är givetvis att inte använda sig av några lösenord alls utan istället enbart köra med SSH-keys, dessa är makabert långa i jämförelse med traditionella lösenord och i.o.m. att SSH är krypterat end-to-end är det ingen större risk att nycklarna kommer på vift när man sätter upp lösningen:

https://www.tecmint.com/ssh-passwordless-login-using-ssh-keygen-in-5-easy-steps/

En klar fördel att använda sig av SSH-keys är att du kan köra script och kommandon remote via SSH som om du satt uppkopplad direkt mot systemet (då inloggningen sker automatiskt baserat på din SSH-key) som då utförs direkt utan att du behöver sitta och fylla i lösenordsprompter eller inkludera lösenord i script-filer. Så det är rätt smutt, fast kanske överkurs i ditt fall.

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Plats
sweden
Registrerad
Dec 2008
Skrivet av krigelkorren:

Det är nog bäst att byta från standardporten 22 för SSH, är aldrig rekommenderat att köra på standardportar när det handlar om fjärrsystem kopplade mot Internet. Det gäller även för 3389 (RDP).
Du kan göra den ändringen i routern många gånger. t.ex. incoming port 12345 i Router -> ip.address.på.server via port 22. -Om nätverket där servern står är klassat som "säkert".

Annars kan det vara bäst att även byta port direkt på servern via:

sudo nano /etc/ssh/sshd_config

Editera raden som säger:

Port 22

och ändra till t.ex.

Port 12345

Tryck Ctrl+x, följt av "y" för att bekräfta att spara filen och sedan Enter för confirm overwrite.

Sedan bör du starta om SSH tjänsten likt någon redan hade nämnt i tråden:

systemctl restart ssh

För att därefter ansluta till en server som ej använder standardporten för SSH via kommandorad får man nu istället köra kommandot med -p parametern:

ssh -p 12345 anvandarnamn@ip.address.på.server

Där -p 12345 specar vilken annan port som skall användas för SSH.

Kan även rekommendera att installera och använda UFW (Uncomplicated FireWall) på Ubuntu som lokal brandvägg:

sudo apt install ufw -y

Därefter lägger du till regler för varje tjänst t.ex:

sudo ufw allow 22/tcp - (För standard SSH-port)

alternativt:

sudo ufw allow 12345/tcp - (Om du ändrat standard porten på servern för SSH)

sudo ufw allow 80/tcp
sudo ufw allow 443/tcp
etc...

Du kan även speca port-ranges enkelt via UFW:

sudo ufw allow 7100:7200/tcp -medför att port 7100 t.o.m. port 7200 tillåter anslutningar.

-Och därefter kör du:

sudo ufw enable
för att aktivera den lokala brandväggen. (du kan alltså confa regler osv. utan att att för den sakens skull behöva aktivera brandväggen, så se till att kolla så att allt annat fungerar fullt ut innan du aktiverar brandväggen, får du problem efter det så vet du att det var brandväggen som ställde till det och därmed bör du köra nedan kommando)

sudo ufw disable

för att stänga av den lokala brandväggen om det mot förmodan inte skulle fungera, kom ihåg att disable kommandot mest troligt måste utföras lokalt på servern, då brandväggen inte kommer att godkänna din fjärrsession om den är felkonfigurerad.

Är inte helsåld på settingen PermitRootLogin yes om jag skall vara ärlig.
Det låter väl mycket Windows-tänk där att man skall vara admin överallt och även logga in som det remote...
Normalt sett bör du logga in med non-standard user konto och sedan använda sudo eller sudo su kommando för att få root-rättigheter, tillfälligt.
Detta är ett bättre sätt då ett root konto alltid existerar på Linux-system, ungefär som ett Administratör-konto alltid finns på en Windows maskin som standard, det är således det första kontot som nät-bots försöker logga in via, därmed bättre om det inte tillåts alls, då måste bots även gissa rätt port+användarnamn(med sudo-rättigheter)+password.)

För att skapa en ny användare i Ubuntu kan du köra kommandot:

sudo useradd newuser

Fyll i uppgifterna som följer på skärmen.

Då skapas en ny användare: newuser
newuser har inga sudo-rättigheter som standard utan kan enbart logga in på systemet men har inte några administrativa inställningar eller häftigare rättigheter.

För att de ditt nyskapade newuser konto sudo-rättigheter kan du köra nedan kommando:

sudo usermod -a -G sudo newuser

Ovan kommando lägger till användaren newuser till -G (group) sudo.

Vill du se om det skett failade SSH-inloggningar mot ditt Linux-system kan du köra kommandot:

grep sshd.\*Failed /var/log/auth.log | less

Annars, det klart säkrare alternativet är givetvis att inte använda sig av några lösenord alls utan istället enbart köra med SSH-keys, dessa är makabert långa i jämförelse med traditionella lösenord och i.o.m. att SSH är krypterat end-to-end är det ingen större risk att nycklarna kommer på vift när man sätter upp lösningen:

https://www.tecmint.com/ssh-passwordless-login-using-ssh-keygen-in-5-easy-steps/

En klar fördel att använda sig av SSH-keys är att du kan köra script och kommandon remote via SSH som om du satt uppkopplad direkt mot systemet (då inloggningen sker automatiskt baserat på din SSH-key) som då utförs direkt utan att du behöver sitta och fylla i lösenordsprompter eller inkludera lösenord i script-filer. Så det är rätt smutt, fast kanske överkurs i ditt fall.

Jo vi ska försöka hamra ut allt Tar ju nästan en heldag bara för få remotdesktop funka Vist är det bra med begränsningar, men när allt hamnar under root eller sudo blir det lite väl överdrivet

Kan ju hoppas man slipper pilla för mycket i detta sen, när allt fungerar. När man ska skriva kommandon och vet knappt om det fungerat eller att dom ens registrerat gör det rätt svårt att veta om man gjort linux mindre säkert än windows

Min spel rigg:FD Define R4|VX 550W|i5 2500K|Corsair LP 4GBX2|Mammabräda P67 Extreme4|GTX 670 windforce|23tum u2312hm
Min gamla/HTPC:AMD 6000+|Ram 2GbX2|Radeon HD5770| XFX 450/nu XFX 550
Mitt bygge: ByggloggFri frakt INET:Fraktfritt sweclockers vid köp över 500kr

#Gilla inlägg som är bra & Använd citera/@"namn" vid snabbt svar