Teamviewer krashar på min server

Trädvy Permalänk
Medlem
Registrerad
Okt 2009

Teamviewer krashar på min server

Tjena har nyligen skaffat mig en egen server som jag hostar Minecraft, Plex osv.

Men då jag innan kört Windows 7 pga att den datorn jag hade som server användes till att betala räkningar på av en som ville ha Windows ca ett år utan några problem och varit 24/7 stabilt men nu när jag skaffat egen server så kör jag såklart Linux då det verkar vara ett givet val inom serverbruk enligt de flesta.

Jag har alltid fjärrtstyrt min server via Teamviewer, men på Linux (Lubuntu som jag kör) så krashar det, vet ej vad som händer då jag inte har någon skärm eller något till serverdatorn samt den står ca 2.5 mil bort.

Först fungerade det ca 2 veckor utan problem. Men nu i helgen fick jag åka dit serverdatorn står och hålla in avstängningsknappen och starta om den så fungerade det igen. Teamviewer har jag ställt in att starta när datorn startar.

Det står bara att Teamviewer not running on partner computer.

Har tänkt använda SSH (fjärrstyrning av terminalen?), och genom det starta Teamviewer när det väljer att stänga av sig själv.

Eller finns det någon skript liknande man kan skriva så servern känner av när Teamviewer inte är igång och startar det automatiskt?

Mvh Jesper

Intel I7 4770K @ Stock Hyper 212 Evo | 16 Gb ram 2400 Mhz | SSD: Samsung 850 Evo 500 Gb | Asus GTX 980 Strix

Trädvy Permalänk
Medlem
Registrerad
Nov 2011

Om du kör Teamviewer som en service bör det vara en rätt enkel match att knåpa ihop ett script som regelbundet kollar om servicen är igång och annars startar den. Det scriptet bör bara vara att köra under crontab.

Annars är det väl inte så betungande att bara SSH:a in och starta servicen själv när det behövs.

AMD Ryzen 7 1700X 3.8 GHz 20MB | ASUS PRIME X370-PRO | MSI GeForce GTX 1080 Gaming X 8GB | G.Skill 16GB DDR4 3200 MHz CL14 Flare X | Corsair RM650x 650W

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av juniorjesper:

Tjena har nyligen skaffat mig en egen server som jag hostar Minecraft, Plex osv.

Men då jag innan kört Windows 7 pga att den datorn jag hade som server användes till att betala räkningar på av en som ville ha Windows ca ett år utan några problem och varit 24/7 stabilt men nu när jag skaffat egen server så kör jag såklart Linux då det verkar vara ett givet val inom serverbruk enligt de flesta.

Jag har alltid fjärrtstyrt min server via Teamviewer, men på Linux (Lubuntu som jag kör) så krashar det, vet ej vad som händer då jag inte har någon skärm eller något till serverdatorn samt den står ca 2.5 mil bort.

Först fungerade det ca 2 veckor utan problem. Men nu i helgen fick jag åka dit serverdatorn står och hålla in avstängningsknappen och starta om den så fungerade det igen. Teamviewer har jag ställt in att starta när datorn startar.

Det står bara att Teamviewer not running on partner computer.

Har tänkt använda SSH (fjärrstyrning av terminalen?), och genom det starta Teamviewer när det väljer att stänga av sig själv.

Eller finns det någon skript liknande man kan skriva så servern känner av när Teamviewer inte är igång och startar det automatiskt?

Mvh Jesper

Vilken version av Lubuntu kör servern? (Om du vill köra den som server längre än 9 månader bör det vara någon av LTS versionerna såsom 16.04 LTS eller 18.04 LTS, någon annan version är inte rekommenderat då supporten snabbt går ut. 14.04 LTS sjunger på sista versen nu.)

Det senaste året har jag upplevt att Teamviewer beter sig aningens skakigt på Ubuntu, ofta om man startar teamviewer mjukvaran direkt (på servern i ditt fall) står det "Not Ready. Please check your connection" -teamviewer-klienten kopplar alltså inte upp sig mot teamviewers-servernät.
Detta ser du givetvis inte om du sitter remote men jag kan tänka mig att det resulterar i felmeddelandet som du stöter på "Teamviewer not running on partner computer."
Själv orkade jag inte grotta i det då jag sällan använder mig av Teamviewer, så för att lösa problemet snabbt installerade jag bara om programmet varje gång det strulade via terminalen: sudo dpkg -i teamviewer_13.1.8286_amd64.deb

Det finns lite olika förslag på forum som ev. kan avhjälpa problemet permanent på servern:
https://community.teamviewer.com/t5/TeamViewer-12/Not-ready-Please-check-your-connection-after-upgrade-to-v12/m-p/8802#M4444

sudo apt install libnss-resolve -om du kör 64-bits Lubuntu
sudo apt install libnss-resolve:i386 -om du kör 32-bits Lubuntu

Alternativt kan du lägga till Googles DNS servrar i din nätverkskonfiguration på servern. (här kan det dock spela roll vilken version av Lubuntu du använder då man i.o.m. 18.04 bytt ut nätverkshanteraren mot en .yaml version)

Please try if setting Google Public DNS servers work on your case.

Primary 8.8.8.8
Secondary 8.8.4.4

Then restart Teamviewer by running the following command.

sudo teamviewer daemon restart

En brasklapp: Förlita dig inte på 3:e partstjänster såsom Teamviewer som enda åtkomstalternativ när det kommer till Linux, testningen och supporten är rudimentär som bäst, man kan inte jämföra det mot Windows-klienten där man lägger ner väsentligt mycket mer kraft på stabilitet och funktion.
I Linuxvärlden brukar jag hålla mig till "Hope for the best, plan for the worst" när jag använder mig av 3:e parts...

Så du bör absolut ha openssh-server tillgängligt på servern så att du kan, dels starta om teamviewer-tjänsten/installera om teamviewer, men även utföra viktiga uppdateringar samt undvika att åka fysiskt till platsen för att starta om själva burken, det låter fruktansvärt ineffektivt!

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Registrerad
Okt 2009
Skrivet av noMad17:

Om du kör Teamviewer som en service bör det vara en rätt enkel match att knåpa ihop ett script som regelbundet kollar om servicen är igång och annars startar den. Det scriptet bör bara vara att köra under crontab.

Annars är det väl inte så betungande att bara SSH:a in och starta servicen själv när det behövs.

Ja det går att göra så ja, men det är nog lite ovanför mina kunskaper 😋

Skrivet av krigelkorren:

Vilken version av Lubuntu kör servern? (Om du vill köra den som server längre än 9 månader bör det vara någon av LTS versionerna såsom 16.04 LTS eller 18.04 LTS, någon annan version är inte rekommenderat då supporten snabbt går ut. 14.04 LTS sjunger på sista versen nu.)

Det senaste året har jag upplevt att Teamviewer beter sig aningens skakigt på Ubuntu, ofta om man startar teamviewer mjukvaran direkt (på servern i ditt fall) står det "Not Ready. Please check your connection" -teamviewer-klienten kopplar alltså inte upp sig mot teamviewers-servernät.
Detta ser du givetvis inte om du sitter remote men jag kan tänka mig att det resulterar i felmeddelandet som du stöter på "Teamviewer not running on partner computer."
Själv orkade jag inte grotta i det då jag sällan använder mig av Teamviewer, så för att lösa problemet snabbt installerade jag bara om programmet varje gång det strulade via terminalen: sudo dpkg -i teamviewer_13.1.8286_amd64.deb

Det finns lite olika förslag på forum som ev. kan avhjälpa problemet permanent på servern:
https://community.teamviewer.com/t5/TeamViewer-12/Not-ready-Please-check-your-connection-after-upgrade-to-v12/m-p/8802#M4444

sudo apt install libnss-resolve -om du kör 64-bits Lubuntu
sudo apt install libnss-resolve:i386 -om du kör 32-bits Lubuntu

Alternativt kan du lägga till Googles DNS servrar i din nätverkskonfiguration på servern. (här kan det dock spela roll vilken version av Lubuntu du använder då man i.o.m. 18.04 bytt ut nätverkshanteraren mot en .yaml version)

Please try if setting Google Public DNS servers work on your case.

Primary 8.8.8.8
Secondary 8.8.4.4

Then restart Teamviewer by running the following command.

sudo teamviewer daemon restart

En brasklapp: Förlita dig inte på 3:e partstjänster såsom Teamviewer som enda åtkomstalternativ när det kommer till Linux, testningen och supporten är rudimentär som bäst, man kan inte jämföra det mot Windows-klienten där man lägger ner väsentligt mycket mer kraft på stabilitet och funktion.
I Linuxvärlden brukar jag hålla mig till "Hope for the best, plan for the worst" när jag använder mig av 3:e parts...

Så du bör absolut ha openssh-server tillgängligt på servern så att du kan, dels starta om teamviewer-tjänsten/installera om teamviewer, men även utföra viktiga uppdateringar samt undvika att åka fysiskt till platsen för att starta om själva burken, det låter fruktansvärt ineffektivt!

Tackar för långt svar 😁

Har för mig jag kör på 16.04 LTS, kan ej kolla nu.

Blev ist att jag kör ssh, dels roligt med terminalen som jag försöker lära mig samt så kunde jag starta TeamViewer genom det.

Men jag får inte till det, kört en massa olika kommandon t.ex

sudo teamviewer daemon testat
sudo teamviewer daemon stop
sudo teamviewer daemon start

Etc men inget har hjälpt.

Sen igår märkte jag helt plötsligt hur Plex slutat fungera, det står "direkt anslutningar ej tillgänglig" men det går ej att ansluta.

Men om jag kör t.ex ping google.se eller någon annan hemsida eller ip jag vet fungerar, så blir det bara att den försöker pinga 10.0.0.1. t.ex pinging Google.se ip 10.0.0.1 etc.

Apt-get update funkar inte eller nånting. T.ex apt-get update fastnar på första, och försöker ansluta till 10.0.0.1.

På ifconfig verkar allt stämma, router är 192.168.1.1 osv. Kan det vara nå DNS problem?

Det konstiga är att servern verkar inte ha tillgång till internet, men Minecraft servern och hemsidan med kartan över Minecraftvärlden fungerar utan problem.

Intel I7 4770K @ Stock Hyper 212 Evo | 16 Gb ram 2400 Mhz | SSD: Samsung 850 Evo 500 Gb | Asus GTX 980 Strix

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av juniorjesper:

Ja det går att göra så ja, men det är nog lite ovanför mina kunskaper 😋

Tackar för långt svar 😁

Har för mig jag kör på 16.04 LTS, kan ej kolla nu.

Blev ist att jag kör ssh, dels roligt med terminalen som jag försöker lära mig samt så kunde jag starta TeamViewer genom det.

Men jag får inte till det, kört en massa olika kommandon t.ex

sudo teamviewer daemon testat
sudo teamviewer daemon stop
sudo teamviewer daemon start

Etc men inget har hjälpt.

Sen igår märkte jag helt plötsligt hur Plex slutat fungera, det står "direkt anslutningar ej tillgänglig" men det går ej att ansluta.

Men om jag kör t.ex ping google.se eller någon annan hemsida eller ip jag vet fungerar, så blir det bara att den försöker pinga 10.0.0.1. t.ex pinging Google.se ip 10.0.0.1 etc.

Apt-get update funkar inte eller nånting. T.ex apt-get update fastnar på första, och försöker ansluta till 10.0.0.1.

På ifconfig verkar allt stämma, router är 192.168.1.1 osv. Kan det vara nå DNS problem?

Det konstiga är att servern verkar inte ha tillgång till internet, men Minecraft servern och hemsidan med kartan över Minecraftvärlden fungerar utan problem.

Om du har SSH till burken nu och vill ta reda på vilken release av (L)ubuntu du kör kan du köra nedan kommando i terminalen när du loggat på burken:

lsb_release -a

Ah, jag var kanske aningens lat där, refererade egentligen till vad som stod på sidan som länken pekade mot.
Tror det är nedan kommando man behöver köra nu för tiden, för att starta om teamviewer daemon servicen på ett Ubuntu system:

sudo service teamviewerd restart

Ändrade du DNS inställningarna som refererade till också? Om det slutade fungera efter det bör du nog ändra tillbaka.

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Registrerad
Okt 2009
Skrivet av krigelkorren:

Om du har SSH till burken nu och vill ta reda på vilken release av (L)ubuntu du kör kan du köra nedan kommando i terminalen när du loggat på burken:

lsb_release -a

Ah, jag var kanske aningens lat där, refererade egentligen till vad som stod på sidan som länken pekade mot.
Tror det är nedan kommando man behöver köra nu för tiden, för att starta om teamviewer daemon servicen på ett Ubuntu system:

sudo service teamviewerd restart

Ändrade du DNS inställningarna som refererade till också? Om det slutade fungera efter det bör du nog ändra tillbaka.

Det kommer upp när jag skriver lsb_release -a

server@server:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 16.04.4 LTS Release: 16.04 Codename: xenial

Nä har inte ändrat någonting, helt plötsligt bara så tror datorn att allt är 10.0.0.1.

Printscreen när jag t.ex prövade pinga Google.se

När jag skriver Sudo apt-get update

Har ingen aning om varför det blivit så här, helt av sig själv?

Minecraft servern funkar utan problem, både hemsidan till Minecraft samt spelservern. Inget annat verkar fungera.

Plex står det "Unable to connect to "Server" securely."

Vet inte om jag vågar starta om den heller via SSH? Kanske slutar fungera helt?

Intel I7 4770K @ Stock Hyper 212 Evo | 16 Gb ram 2400 Mhz | SSD: Samsung 850 Evo 500 Gb | Asus GTX 980 Strix

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av juniorjesper:

Det kommer upp när jag skriver lsb_release -a

server@server:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 16.04.4 LTS Release: 16.04 Codename: xenial

Nä har inte ändrat någonting, helt plötsligt bara så tror datorn att allt är 10.0.0.1.

Printscreen när jag t.ex prövade pinga Google.se

https://i.imgur.com/e1LC6EU.png

När jag skriver Sudo apt-get update

https://i.imgur.com/jtRw6af.png

Har ingen aning om varför det blivit så här, helt av sig själv?

Minecraft servern funkar utan problem, både hemsidan till Minecraft samt spelservern. Inget annat verkar fungera.

Plex står det "Unable to connect to "Server" securely."

Vet inte om jag vågar starta om den heller via SSH? Kanske slutar fungera helt?

Hmm, spännande.

Verkar som att någon nätverksinställning löpt amok...

Vad får du om du gör en ping mot localhost?

ping 127.0.0.1

Du skulle även kunna prova med att pinga googles DNS-server via IP-adressen istället för dns-namnet, då det kan vara DNS som strular.
ping 8.8.8.8

Nedan borde ge dig DNS serverns adress för din servers nät samt IP samt info om adressen google.com
nslookup www.google.com

Exempel på svaret jag får när jag kör ovan kommando:
danne@desktop:~$ nslookup www.google.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: www.google.com
Address: 216.58.207.228
Name: www.google.com
Address: 2a00:1450:400f:80c::2004

Du gör nog rätt i att inte starta om den förrän du tagit en titt på nätverksinställningarna så att dem är rätt, då du troligtvis kör med en fast IP-adress på servern?

Du borde kunna se nätverksinställningarna i terminalen om du kör nedan kommando: (beror på om Lubuntu har någon specialare som hanterar nätverket men generellt brukar det vara interfaces-filen som hanterar det.)
cat /etc/network/interfaces

Om du sedan vill ändra något värde kan du köra nedan kommando för att öppna filen med texteditorn 'nano' i editerbart läge:
sudo nano /etc/network/interfaces

När du editerat klart kan du spara och stänga filen med kommandot Ctrl+x välj "y" och bekräfta med [Enter] -om du vill spara, alt. väljer du "n" och bekräftar med [Enter] för att INTE spara några ändringar gjorda till filen.

Till sist... paranoja-frågan:
Kör du SSH på standardporten (Port 22) och direkt exponerat mot nätet?
-Gör helst aldrig det då det finns massor av bots och port-scanners som jobbar dygnet med att knäcka lösenord för sådana.
Standard porten är ofta en "big no-no" för alla typer av inloggningstjänster över nätet.
Isåfall kan det absolut vara värt att ta en titt på om du har en massa failed ssh-logon attempts mot din server från suspekta konton och adresser.

Nedan kommando listar alla loggade 'failed' inloggningsförsök gjorda mot ssh-servern:
sudo cat /var/log/auth.log | grep 'sshd.*Invalid'

Nedan kommando listar alla lyckade försök där man loggat in mot ssh-servern:
sudo cat /var/log/auth.log | grep 'sshd.*opened'

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Registrerad
Okt 2009
Skrivet av krigelkorren:

Hmm, spännande.

Verkar som att någon nätverksinställning löpt amok...

Vad får du om du gör en ping mot localhost?

ping 127.0.0.1

Du skulle även kunna prova med att pinga googles DNS-server via IP-adressen istället för dns-namnet, då det kan vara DNS som strular.
ping 8.8.8.8

Nedan borde ge dig DNS serverns adress för din servers nät samt IP samt info om adressen google.com
nslookup www.google.com

Exempel på svaret jag får när jag kör ovan kommando:
danne@desktop:~$ nslookup www.google.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: www.google.com
Address: 216.58.207.228
Name: www.google.com
Address: 2a00:1450:400f:80c::2004

Du gör nog rätt i att inte starta om den förrän du tagit en titt på nätverksinställningarna så att dem är rätt, då du troligtvis kör med en fast IP-adress på servern?

Du borde kunna se nätverksinställningarna i terminalen om du kör nedan kommando: (beror på om Lubuntu har någon specialare som hanterar nätverket men generellt brukar det vara interfaces-filen som hanterar det.)
cat /etc/network/interfaces

Om du sedan vill ändra något värde kan du köra nedan kommando för att öppna filen med texteditorn 'nano' i editerbart läge:
sudo nano /etc/network/interfaces

När du editerat klart kan du spara och stänga filen med kommandot Ctrl+x välj "y" och bekräfta med [Enter] -om du vill spara, alt. väljer du "n" och bekräftar med [Enter] för att INTE spara några ändringar gjorda till filen.

Till sist... paranoja-frågan:
Kör du SSH på standardporten (Port 22) och direkt exponerat mot nätet?
-Gör helst aldrig det då det finns massor av bots och port-scanners som jobbar dygnet med att knäcka lösenord för sådana.
Standard porten är ofta en "big no-no" för alla typer av inloggningstjänster över nätet.
Isåfall kan det absolut vara värt att ta en titt på om du har en massa failed ssh-logon attempts mot din server från suspekta konton och adresser.

Nedan kommando listar alla loggade 'failed' inloggningsförsök gjorda mot ssh-servern:
sudo cat /var/log/auth.log | grep 'sshd.*Invalid'

Nedan kommando listar alla lyckade försök där man loggat in mot ssh-servern:
sudo cat /var/log/auth.log | grep 'sshd.*opened'

Tjena Jäklar vad mycket du skrivit, tack för du försöker hjälpa!

Ping mot localhost fungerar utan problem samt ping 8.8.8.8.

När jag kör nslookup www.google.com

Du gör nog rätt i att inte starta om den förrän du tagit en titt på nätverksinställningarna så att dem är rätt, då du troligtvis kör med en fast IP-adress på servern? Tror inte jag kör med fast IP-adress, jag bara stoppade i nätverkssladden och lan ip har varit 192.168.1.138 hela tiden Man kanske borde ändra det?

När jag prövade cat /etc/network/interfaces så fick jag detta som svar, ingen aning om det är något som inte stämmer?

Tackar för tipset om porten samt se misslyckade inloggningsförsök!

Intel I7 4770K @ Stock Hyper 212 Evo | 16 Gb ram 2400 Mhz | SSD: Samsung 850 Evo 500 Gb | Asus GTX 980 Strix

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av juniorjesper:

Tjena Jäklar vad mycket du skrivit, tack för du försöker hjälpa!

Ping mot localhost fungerar utan problem samt ping 8.8.8.8.

https://i.imgur.com/XN9tekR.png

När jag kör nslookup www.google.com

https://i.imgur.com/qtkUqQ6.png

Du gör nog rätt i att inte starta om den förrän du tagit en titt på nätverksinställningarna så att dem är rätt, då du troligtvis kör med en fast IP-adress på servern? Tror inte jag kör med fast IP-adress, jag bara stoppade i nätverkssladden och lan ip har varit 192.168.1.138 hela tiden Man kanske borde ändra det?

När jag prövade cat /etc/network/interfaces så fick jag detta som svar, ingen aning om det är något som inte stämmer?

https://i.imgur.com/WokAv50.png

Tackar för tipset om porten samt se misslyckade inloggningsförsök!

Verkar som att det är DNS som spökar i ditt fall. Då ping mot IP-adress fungerar men ping mot DNS returnerar "localhost" dvs. servern anropar sig själv. -Tog en till koll på dina screenshots och 10.0.0.1 är ju troligtvis DNS:en som felar då du inte får något pingsvar när du kör kommandot "ping google.se"

Ansluter du mot servern via IP-adress? Då kan det vara anledningen till att det fungerar, -samma för Minecraft-servern?
Troligtvis kan dessa tjänster fortfarande nås via IP men inte via DNS-namn såsom ex. www.minecraftserver.se
Det är troligtvis också därför som kommandon likt sudo apt update && sudo apt upgrade inte fungerar då de resolvar DNS-namn primärt likt www.ubuntu.com osv.

Du verkar köra med DHCP, dvs. automatiskt tilldelad IP-adress, beroende på hur nätet är konfigurerat dit servern är uppkopplad mot skulle jag rekommendera en statisk (fast) ip-adress om din server skall vara nåbar 24/7.

På nslookup-svaret ser det ut som att datorn använder localhost (127.0.0.1) som DNS vilket enligt mina erfaranheter inte brukar vara någon bra lösning. Normalt sett tilldelar nätverket IP-adress samt förmedlar gateway/DNS-tjänstens adresser. -Glöm detta, vet ej vad jag rökt på när jag skrev det...

Vet inte om nedan kommando funkar för just din distribution av Ubuntu (Lubuntu) men har jag har ful-restartat dns-tjänsten ibland med kommandot:

sudo /etc/init.d/dns-clean start

Alternativt kan det vara såpass enkelt som att du kan ange googles publika DNS server 8.8.8.8 som DNS för din server samt starta om DNS-tjänsten/servern så kanske DNS-uppslag fungerar igen.

Edit: Jag kan köra igång en virtuell Lubuntu 16.04 hemma när jag slutat jobbet senare idag för att ta reda på lite mer kring hur man bäst hanterar problemet. Alt. anger en DNS för systemet. Var åratal sedan jag körde Lubuntu 16.04 så jag har inte full koll på vilka verktyg de använder normalt sett.

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007

Har testat på en virtuell Lubuntu 16.04 nu, filen /etc/network/interfaces verkar inte göra ett smack i Lubuntu då man istället använder sig av NetworkManager som är en annan nätverkshanterare. Så glöm den.

Du skulle däremot kunna prova att starta om NetworkManager-tjänsten för att se om det gör någon skillnad:

sudo service network-manager restart

Omstarten av NetworkManager sker på någon sekund så du bör märka effekten direkt, -om det löser något vill säga.

Annars om du vill ändra inställningar för NetworkManager via terminalen måste man istället köra nedan kommando för att få upp filen i editerbart läge:

sudo nano /etc/NetworkManager/system-connections/Wired\ connection\ 1

Det är i denna fil man kan göra ex. nedan inställning i sektionen för [ipv4] för att kringgå den automatiska och troligtvis felande DNS:en i nätet (10.0.0.1)

[ipv4]
dns=8.8.8.8;
dns-search=
ignore-auto-dns=true
method=auto

När du editerat klart kan du spara och stänga filen med kommandot Ctrl+x välj "y" och bekräfta med [Enter] -om du vill spara, alt. väljer du "n" och bekräftar med [Enter] för att INTE spara några ändringar gjorda till filen.

Det kan vara värt ett försök, men du måste troligtvis starta om NetworkManager med nedan kommando efter att du sparat ändringen för att de nya inställningarna skall börja gälla.

sudo service network-manager restart

-Märkte dock att NetworkManager ser ut att skapa en ny connection-config, så någon verklig effekt verkar ändringen inte ha förrän man startar om själva servern... så tyvärr kan jag inte utesluta att en omstart skulle kunna kräva ett fysiskt besök hos servern om nätverkskontakten inte kommer upp igen.

sudo reboot

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Registrerad
Okt 2009
Skrivet av krigelkorren:

Har testat på en virtuell Lubuntu 16.04 nu, filen /etc/network/interfaces verkar inte göra ett smack i Lubuntu då man istället använder sig av NetworkManager som är en annan nätverkshanterare. Så glöm den.

Du skulle däremot kunna prova att starta om NetworkManager-tjänsten för att se om det gör någon skillnad:

sudo service network-manager restart

Omstarten av NetworkManager sker på någon sekund så du bör märka effekten direkt, -om det löser något vill säga.

Annars om du vill ändra inställningar för NetworkManager via terminalen måste man istället köra nedan kommando för att få upp filen i editerbart läge:

sudo nano /etc/NetworkManager/system-connections/Wired\ connection\ 1

Det är i denna fil man kan göra ex. nedan inställning i sektionen för [ipv4] för att kringgå den automatiska och troligtvis felande DNS:en i nätet (10.0.0.1)

[ipv4]
dns=8.8.8.8;
dns-search=
ignore-auto-dns=true
method=auto

När du editerat klart kan du spara och stänga filen med kommandot Ctrl+x välj "y" och bekräfta med [Enter] -om du vill spara, alt. väljer du "n" och bekräftar med [Enter] för att INTE spara några ändringar gjorda till filen.

Det kan vara värt ett försök, men du måste troligtvis starta om NetworkManager med nedan kommando efter att du sparat ändringen för att de nya inställningarna skall börja gälla.

sudo service network-manager restart

-Märkte dock att NetworkManager ser ut att skapa en ny connection-config, så någon verklig effekt verkar ändringen inte ha förrän man startar om själva servern... så tyvärr kan jag inte utesluta att en omstart skulle kunna kräva ett fysiskt besök hos servern om nätverkskontakten inte kommer upp igen.

sudo reboot

Alltså tackar så hemskt mycket!!

sudo service network-manager restart funkade direkt

Får se om det funkar nu och framöver annars får jag nog göra som du beskrev sen:)

Tackar!

Intel I7 4770K @ Stock Hyper 212 Evo | 16 Gb ram 2400 Mhz | SSD: Samsung 850 Evo 500 Gb | Asus GTX 980 Strix

Trädvy Permalänk
Medlem
Plats
root
Registrerad
Jan 2004

@juniorjesper
testa och lägg Cloudflare dns'er istället för googles

1.1.1.1 och 1.0.0.1

De är bättre i flera aspekter än vad googles är

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av juniorjesper:

Alltså tackar så hemskt mycket!!

sudo service network-manager restart funkade direkt

Får se om det funkar nu och framöver annars får jag nog göra som du beskrev sen:)

Tackar!

Trevligt!
Lycka till med servern och glöm inte att köra uppdateringarna emellanåt på den!

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS

Trädvy Permalänk
Medlem
Registrerad
Okt 2009
Skrivet av krigelkorren:

Trevligt!
Lycka till med servern och glöm inte att köra uppdateringarna emellanåt på den!

Tack Nerå ska göra det (Y)
Alltså då är det väl bara att köra apt-get update och apt-get upgrade?

Intel I7 4770K @ Stock Hyper 212 Evo | 16 Gb ram 2400 Mhz | SSD: Samsung 850 Evo 500 Gb | Asus GTX 980 Strix

Trädvy Permalänk
Medlem
Plats
gbg
Registrerad
Nov 2007
Skrivet av juniorjesper:

Tack Nerå ska göra det (Y)
Alltså då är det väl bara att köra apt-get update och apt-get upgrade?

Ja i princip kan man sammanfatta det så, Linux OS brukar var hyfsat underhållsfritt förutsatt att man kör uppdateringarna och startar om någon gång när man installerat en kernel uppdatering (Linux image).

Brukar själv använda mig av nedan kommando för generella uppdateringar, när jag vill ha det så underhållsfritt som möjligt, men ändå ha manuell kontroll över när jag vill göra uppdateringarna:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove -y && sudo apt autoclean -y

sudo apt update gör alltså en repository uppdatering -uppdaterar indexet över alla tillgängliga paket och referenser. ("&&" kommandot anger att du vill utföra ännu ett kommando sekventiellt efter att det första kört klart.)

sudo apt upgrade -y utför ev. uppgraderingar (patchar, säkerhetsuppdateringar) av redan installerade paket/programvaror (-y -flaggan efter ett kommando signalerar till systemet att den automatiskt skall svara "yes" på frågan om du vill fortsätta med det som kommandot är avsett för, i detta fall om den skall fortsätta med uppgraderingen (yes/no) -annars kommer den att stanna där och väntar på input från användaren)

sudo apt autoremove -y gör en rensning av utgångna, ej längre relaterade paketberoenden.

sudo apt autoclean -y gör en rensning av den lokalt nedladdade paket-cachen och tar bort ev. onödiga nedladdade paket som är utdaterade och bara tar upp diskyta.

Finns mängder av varianter man kan laborera med om man har lust, t.ex. kan man byta ut "sudo apt upgrade" mot "sudo apt dist-upgrade" som har skillnaden att den alltid uppgraderar paketen till senast tillgängliga version med allt vad det innebär.
Men för mig funkar ovan kommandon bra i den ordningen.

Tower: ace Battle IV | CPU AMD Phenom II X2 BE unlocked 4cores@3,2GHz | RAM 8GB DDR2@800MHz | MB ASUS M4A785-M | GFK AMD Radeon HD 6850 1GB | HDD Kingston SSD Now 60GB (/) Seagate 2TB(/home) | OS Ubuntu 16.04 LTS