displayport på skärm fungerar på gamla datorn men inte nya.

Permalänk
Medlem

displayport på skärm fungerar på gamla datorn men inte nya.

Tjena! ganska ny skärm som har slutat fungerat på nya datorn, hdmi fungerar bra men kan inte ha hög uppdateringfrekvens på den så skulle vilja ha helst på displayport istället men den fungerar inte med nya datorn, har testat olika display sladdar men funkar ej

Den fungerade bra när jag först fick skärmen men har nu slutar helt med displayport, fungerar dock på mina gamla dator så jag antar att det måste vara något med min nya dator. Några tips?

Skärm = https://www.komplett.se/product/1158205?noredirect=true

Dator = https://www.elgiganten.se/product/gaming/gaming-pc/stationar-...

Permalänk
Forumledare

@Oboyknarkaren: Vad för du för fel när du försöker koppla in skärmen på den nya datorn?

Kopplar du in i rätt uttag, dvs i grafikkortet och inte i moderkortets uttag?

Har du försökt att ändra den aktiva ingången manuellt på skärmen?

Permalänk
Bildexpert 📺

Vanligaste tre missarna är att man måste (1) växla i skärmen till rätt ingång (2) ansluta till datorns grafikkort och inte moderkortet samt (3) DP-kabeln är för dålig så att den inte orkar höga frekvenser.

Man kanske får 60 Hz att fungera över DP med den gamla datorn. Här märker 3070-GPU:n av via handskakningen att det är en 165 Hz-kapabel G-Sync-skärm och försöker därför köra högsta möjliga bandbredd på signalen. Fast kabeln orkar inte med.

Ett steg i felsökningen är att ansluta till en annan skärm och se hur Window och grafikkort reagerar eller inte reagerar på DP-anslutningen. Kan ofta fungera att ansluta till samma skärm via HDMI och se samma sak.

Syns skärmen och känns igen men ingen bild kommer kan man sänka frekvensen till 60 Hz. Kommer bilden på 60, men inte på 165, 144 eller 120 Hz brukar det vara tecken på dålig kabel.

Syns inte skärmen alls i Windows via DP så kan man felsöka något med GPU:n. Vi vet att skärmens DP fungerar i alla fall.

Permalänk
Medlem
Skrivet av NordhNet:

@Oboyknarkaren: Vad för du för fel när du försöker koppla in skärmen på den nya datorn?

Kopplar du in i rätt uttag, dvs i grafikkortet och inte i moderkortets uttag?

Har du försökt att ändra den aktiva ingången manuellt på skärmen?

när jag byter från hdmi till displayport på skärmens inställningar så står det "no signal" det konstiga är också att mina andra skärm har hdmi till display adapter och den funkar till datorn.

Permalänk
Medlem
Skrivet av Laxpudding:

Vanligaste tre missarna är att man måste (1) växla i skärmen till rätt ingång (2) ansluta till datorns grafikkort och inte moderkortet samt (3) DP-kabeln är för dålig så att den inte orkar höga frekvenser.

Man kanske får 60 Hz att fungera över DP med den gamla datorn. Här märker 3070-GPU:n av via handskakningen att det är en 165 Hz-kapabel G-Sync-skärm och försöker därför köra högsta möjliga bandbredd på signalen. Fast kabeln orkar inte med.

Ett steg i felsökningen är att ansluta till en annan skärm och se hur Window och grafikkort reagerar eller inte reagerar på DP-anslutningen. Kan ofta fungera att ansluta till samma skärm via HDMI och se samma sak.

Syns skärmen och känns igen men ingen bild kommer kan man sänka frekvensen till 60 Hz. Kommer bilden på 60, men inte på 165, 144 eller 120 Hz brukar det vara tecken på dålig kabel.

Syns inte skärmen alls i Windows via DP så kan man felsöka något med GPU:n. Vi vet att skärmens DP fungerar i alla fall.

Jag har testat olika kablar men det blir samma fel, jag har också en annan skärm som har hdm men har en hdmi till displayport adapter för att jag har tre displayports och en hdmi. så det är lite konstigt att den andra skärmen fungerar som har en display adapter. provade ockås sänka Hz men det funkade inte, Jag skulle anta att det är något fel med gpu:n men som sagt så funkar det på min andra skärm.

Permalänk
Bildexpert 📺

Jag tror menar Displayport-till-HDMI-adapter, att du kör Displayport-ut-från-grafikkortet till HDMI-in-i-skärmen, eller hur? Ordningen blandas ofta ihop eftersom HDMI-till-Displayport är en helt annan och faktiskt rätt sällsynt pryl.

Det vill säga att du använder två Displayport på ditt grafikkort samt har en ledig Displayport och en ledig HDMI på grafikkortet, är det rätt fattat?

Testa med de andra DP-anslutningarna på grafikkortet. Kan vara så att du inte kan använda just dessa två DP samtidigt ifall du har en passiv omvandlare i ena av dem. Finns en del oväntade begränsningar på en del grafikkort som inte är tydligt dokumenterade utan upptäcks i just sådana här fall.

Kan också pröva att bara köra DP till nya skärmen och koppla ur allt annat.

Ifall du har HDMI ledigt på grafikkortet och HDMI in i extra skärmen så är tumregeln att köra med rätt kabel från början. Alla adaptrar och omvandlare man sätter dit ökar komplexiteten och risken för att något ska krångla.

Permalänk
Medlem
Skrivet av Laxpudding:

Jag tror menar Displayport-till-HDMI-adapter, att du kör Displayport-ut-från-grafikkortet till HDMI-in-i-skärmen, eller hur? Ordningen blandas ofta ihop eftersom HDMI-till-Displayport är en helt annan och faktiskt rätt sällsynt pryl.

Det vill säga att du använder två Displayport på ditt grafikkort samt har en ledig Displayport och en ledig HDMI på grafikkortet, är det rätt fattat?

Testa med de andra DP-anslutningarna på grafikkortet. Kan vara så att du inte kan använda just dessa två DP samtidigt ifall du har en passiv omvandlare i ena av dem. Finns en del oväntade begränsningar på en del grafikkort som inte är tydligt dokumenterade utan upptäcks i just sådana här fall.

Kan också pröva att bara köra DP till nya skärmen och koppla ur allt annat.

Ifall du har HDMI ledigt på grafikkortet och HDMI in i extra skärmen så är tumregeln att köra med rätt kabel från början. Alla adaptrar och omvandlare man sätter dit ökar komplexiteten och risken för att något ska krångla.

Löste problemet, Gick in på nvidias kontrollpanel och gick till ställ in flera bildskärmar och sen klickade på den skärm som inte var markerad och nu fungerar allt igen. lite konstigt dock har inte hållit på med dessa inställningar förut så vet inte varför bara en skärm var markerad när det fungerade förut.

Det vara också antagligen därför jag kunde stoppa in nya skärmen i display porten och sen när jag stoppade i den gamla i hdmi i moderkortet så fungerade bara den gamla, men så fort jag drog ut den gamla hdmi så fungerade den nya igen.

Permalänk
Medlem
Skrivet av Oboyknarkaren:

Löste problemet, Gick in på nvidias kontrollpanel och gick till ställ in flera bildskärmar och sen klickade på den skärm som inte var markerad och nu fungerar allt igen. lite konstigt dock har inte hållit på med dessa inställningar förut så vet inte varför bara en skärm var markerad när det fungerade förut.

Det vara också antagligen därför jag kunde stoppa in nya skärmen i display porten och sen när jag stoppade i den gamla i hdmi i moderkortet så fungerade bara den gamla, men så fort jag drog ut den gamla hdmi så fungerade den nya igen.

Har dock hafft ett problem när skärmen flickrar av och på, några lösningar för den ?

Permalänk
Bildexpert 📺
Skrivet av Oboyknarkaren:

Har dock hafft ett problem när skärmen flickrar av och på, några lösningar för den ?

Vilken skärm? Den nya som du kör med DP-kabel? Då är det tecken på dålig kabel och felsökningen är samma beskrivet ovan. Om det slutar blinka av/på när du kör 60 Hz frekves är det ett tydligt tecken på DP-kabeln du har är för dålig.

Generellt är detta tecken på dåliga kablar, men också glapp någonstans. Använder du olika former av omvandlare/adaptrar ökar risken för den typen av problem.

Permalänk
Bildexpert 📺
Skrivet av Oboyknarkaren:

Det vara också antagligen därför jag kunde stoppa in nya skärmen i display porten och sen när jag stoppade i den gamla i hdmi i moderkortet så fungerade bara den gamla, men så fort jag drog ut den gamla hdmi så fungerade den nya igen.

Du har ett modernt grafikkort med tre DP och 1 HDMI. Koppla allt via grafikkortet och risken för problem minskar ytterligare.

Permalänk
Medlem
Skrivet av Laxpudding:

Vilken skärm? Den nya som du kör med DP-kabel? Då är det tecken på dålig kabel och felsökningen är samma beskrivet ovan. Om det slutar blinka av/på när du kör 60 Hz frekves är det ett tydligt tecken på DP-kabeln du har är för dålig.

Generellt är detta tecken på dåliga kablar, men också glapp någonstans. Använder du olika former av omvandlare/adaptrar ökar risken för den typen av problem.

kör med 144hz och ibland bara stängs den av och på typ. altsså att den blir svart och sen kommer ikonen upp i högra hörnet

Alltså den nya stora skärmen som ibland randomly sätts av och på

Permalänk
Bildexpert 📺
Skrivet av Oboyknarkaren:

kör med 144hz och ibland bara stängs den av och på typ. altsså att den blir svart och sen kommer ikonen upp i högra hörnet

Alltså den nya stora skärmen som ibland randomly sätts av och på

Precis som jag skrev: tecken på dålig kabel. Sänkt till 60 Hz. Fungerar det utan problem då? Sannolikt kabeln.

Permalänk
Medlem
Skrivet av Laxpudding:

Precis som jag skrev: tecken på dålig kabel. Sänkt till 60 Hz. Fungerar det utan problem då? Sannolikt kabeln.

hmm, ska försöka testa sänka till 60 ett tag, men problemet uppstår randomly så vet it hur jag ska veta att det funkar, antar kanske att jag måste prova flera dagar, Har denna kabel just nu

https://www.webhallen.com/se/product/295498-Deltaco-DisplayPo...

Vet du någon kabel som är "felsäker" som är bra för min skärm ?.

Permalänk
Bildexpert 📺
Skrivet av Oboyknarkaren:

hmm, ska försöka testa sänka till 60 ett tag, men problemet uppstår randomly så vet it hur jag ska veta att det funkar, antar kanske att jag måste prova flera dagar, Har denna kabel just nu

https://www.webhallen.com/se/product/295498-Deltaco-DisplayPo...

Vet du någon kabel som är "felsäker" som är bra för min skärm ?.

Kabeln du har är DP8K-märkt vilket är så säkert det kan bli eftersom den ska vara byggd enligt VESA-krav för sådant som bandbredd.

Kan annars finnas mer som gör att bilden periodiskt tappas. Svaren kan också finnas i mjukvara/datorn i övrigt så observera ifall det finns sammanhang. En "klassiker" är man får drop outs och sedan låsningar vid intensivt spelande som beror på överhettning men också att PSU:n inte håller riktigt.

Kan vara så enkelt att slipper drop outs om du drar ut och sätter i kabeln igen. Det kanske slutar om du inte använder den där DP-till-HDMI-adaptern för att något med den får grafikkortet att genomföra någon intern återställning där den synkar om bildsignalen.

Permalänk
Medlem
Skrivet av Laxpudding:

Kabeln du har är DP8K-märkt vilket är så säkert det kan bli eftersom den ska vara byggd enligt VESA-krav för sådant som bandbredd.

Kan annars finnas mer som gör att bilden periodiskt tappas. Svaren kan också finnas i mjukvara/datorn i övrigt så observera ifall det finns sammanhang. En "klassiker" är man får drop outs och sedan låsningar vid intensivt spelande som beror på överhettning men också att PSU:n inte håller riktigt.

Kan vara så enkelt att slipper drop outs om du drar ut och sätter i kabeln igen. Det kanske slutar om du inte använder den där DP-till-HDMI-adaptern för att något med den får grafikkortet att genomföra någon intern återställning där den synkar om bildsignalen.

Ok, ska försöka lista ut vad det kan vara för något, känns kanske som att det kan vara för att den blir för varm, men som sagt så är det random och kan vara när jag inte har något spel igång. Tack för hjälpen, btw vet du något sätt om datorn loggar sånna här problem någonstans ? så man kan see vad som orsakar problemet ? om inte så tack ändå.

Permalänk
Bildexpert 📺
Skrivet av Oboyknarkaren:

Ok, ska försöka lista ut vad det kan vara för något, känns kanske som att det kan vara för att den blir för varm, men som sagt så är det random och kan vara när jag inte har något spel igång. Tack för hjälpen, btw vet du något sätt om datorn loggar sånna här problem någonstans ? så man kan see vad som orsakar problemet ? om inte så tack ändå.

Finns inga självklart system för att logga detta, men det finns programvaror för logga sådant som temperatur i GPU och processer där säkert HP har något vettigt som följer med.